1. Nimm jetzt an unserem Uhans - 3. ADVENT - Gewinnspiel teil - Alle Informationen findest Du hier!

abnormales magnetischhes feld

Dieses Thema im Forum "HTC Legend Forum" wurde erstellt von elLoko, 05.04.2011.

  1. elLoko, 05.04.2011 #1
    elLoko

    elLoko Threadstarter Junior Mitglied

    Beiträge:
    31
    Erhaltene Danke:
    0
    Registriert seit:
    03.04.2011
    erst einmal ein hallo an alle! (mein 1. Eintrag)

    hab seit kurzem ein legend und leider ein dickes Problem. die gps-signale werden meist nur sehr schwach empfangen. oft werden mit dem App compass bis zu 15 Satelliten angezeigt, aber keins gefixt. hab alles mögliche getestet: zu Fuß, mim Fahrrad, im auto und Bus. sehr selten mit Erfolg.

    dann fiel mir auf, dass bei jedem!!! Aufruf von compass die Meldung "abnormales magnetisches feld" Feld erscheint. ich muss also immer kalibrieren. die Stärke ist dabei um die 500 statt, wie nachm kalibrieren, etwa 40. das selbe ist such beim App gps status zu sehen. weiterhin ist mir aufgefallen, dass beim leichten berühren der "menu"-taste, die Feldstärke um bis zu 10 punkten zunimmt, je fester ich drauf drücke. egal ob mit nem Finger oder nem Plastikstift. das alles passiert nur auf dieser taste.

    der HTC-support hat bisher mich nur genervt.

    deswegen an euch: kennt einer dieses Problem? kann man das gerät entmagnetisieren? ;)
     
  2. Philipp1110, 05.04.2011 #2
    Philipp1110

    Philipp1110 Erfahrener Benutzer

    Beiträge:
    249
    Erhaltene Danke:
    46
    Registriert seit:
    19.06.2010
    Hallo elLoko,
    ich kann die zwar keine Lösung präsentieren, aber ich kann dich insofern beruhigen, dass ich beim Starten der Kompass App ebenfalls jedesmal die Meldung zur Magnetfeldstörung bekomme, weshalb ich das inzwischen für "normal" halte. Das mit der Menütaste hab ich so noch nicht ausprobiert, ich befürchte allerdings, dass dieses Verhalten bei mir nicht oder nur sehr schwach auftritt, sonst wäre es mir wohl irgendwann einmal aufgefallen.

    Wegen dem fehlenden GPS-Fix: Es wäre einmal wichtig zu wissen, ob du ein Custom-ROM geflasht hast, denn gerade beim GPS haben viele ROMs Probleme. Falls das nicht der Fall ist, weiß ich leider auch nicht weiter. (Nachdem was du geschrieben hast, hast du es ja auch unter freien Himmel probiert.)
    Hattest du denn schoneinmal einen GPS-Fix? Es kann nämlich durchaus einige Minuten dauern, bis das Legend einen gefunden hat, falls du längere Zeit kein GPS mehr verwendet hast. Schalte doch einfach mal GPS ein, starte Google Maps und lass das Handy ein paar Minuten (bestenfalls draußen oder sehr nah am Fenster) liegen.
     
    elLoko bedankt sich.
  3. elLoko, 05.04.2011 #3
    elLoko

    elLoko Threadstarter Junior Mitglied

    Beiträge:
    31
    Erhaltene Danke:
    0
    Registriert seit:
    03.04.2011
    Hallo Philipp,
    erst einmal Danke, für die Antwort (bin ich zu höflich :),

    schade, dass mit dem "immer abnormales feld", weil dachte, dass das evtl. das Problem mit dem GPS hervorruft.
    Habe das Gerät gebraucht gekauft. Kann ich irgendwie feststellen, ob es geflasht/gerootet wurde? Ich jedenfalls hab es noch nicht getan. Vor habe ich das auf jeden Fall. Welchen ROM würdest Du denn empfehlen, also welcher macht keine Probleme mit dem GPS?
    Einen Fix krieg ich schon hin und wieder hin. Und ich habe das Gefühl, dass es besser und schneller klappt, kurz nachdem ich das Handy kalibriert habe.
     
  4. Philipp1110, 05.04.2011 #4
    Philipp1110

    Philipp1110 Erfahrener Benutzer

    Beiträge:
    249
    Erhaltene Danke:
    46
    Registriert seit:
    19.06.2010
    Ich habe ja nicht völlig ausgeschlossen, dass das abnormale Feld und der schlechte GPS-Fix zusammenhängen. Ich meine nur, es sei unwarscheinlich. Aber möglich ist alles...

    Wenn des Gerät einmal gerootet und mit einer Custom-ROM ausgestattet war, hat das keine Auswirkungen auf die jetzige GPS-Funktionalität. Aber nachdem du ja scheinbar die Original HTC-Rom wieder drauf hast, und das Legend jetzt nicht mehr gerootet ist, kann man ein Problem durch die aktuelle ROM ausschließen.

    Ich nutze momentan Cyanogenmod 7 RC4. RC = Release Candidate, das bedeutet, die ROM ist fast fertig entwickelt. Bis zur endgültigen Final dürfte es nicht mehr lange dauern.
    Mit CM7 habe ich keine Probleme mit GPS und auch irgendwelche andere Bugs konnte ich keine finden.
    Zum Rooten nutzt du am besten die Anleitung hier im Legend-Forum. Dort gibt es auch einen Thread zur Cyanogenmod-ROM. CM7 basiert schon auf Android 2.3 (Gingerbread) und läuft auf dem Legend völlig rund und perfekt. Es gibt auch noch blay0s b0.7, die basiert allerdings noch auf Froyo. Das ist zwar kein Nachteil, aber sozusagen schon wieder "veraltet".
     
    elLoko bedankt sich.
  5. elLoko, 05.04.2011 #5
    elLoko

    elLoko Threadstarter Junior Mitglied

    Beiträge:
    31
    Erhaltene Danke:
    0
    Registriert seit:
    03.04.2011
    ah, cool, super! danke, android 2.3.3 wäre net schlecht. jetzt sehe ich auch deine signatur. werde ich mal testen.

    ich werde dann mal hier posten, ob sich etwas verändert/verbessert hat.
     
  6. Philipp1110, 05.04.2011 #6
    Philipp1110

    Philipp1110 Erfahrener Benutzer

    Beiträge:
    249
    Erhaltene Danke:
    46
    Registriert seit:
    19.06.2010
    Ok, danke. Möglicherweise lösen sich mit der neuen ROM die GPS Probleme ganz von selbst. Probier es mal aus, kann praktisch eigentlich nichts schief gehen.
    Und die ROM solltest du am besten über den ROM-Manager aus dem Market (kostenlose Version reicht) installieren. Geht einfach und schnell und du hast gleich die Google-Apps mit dabei.
     
  7. elLoko, 05.04.2011 #7
    elLoko

    elLoko Threadstarter Junior Mitglied

    Beiträge:
    31
    Erhaltene Danke:
    0
    Registriert seit:
    03.04.2011
    hört sich gut an. bin noch arbeiten und jetzt ziemlich heiss drauf.
     
  8. elLoko, 05.04.2011 #8
    elLoko

    elLoko Threadstarter Junior Mitglied

    Beiträge:
    31
    Erhaltene Danke:
    0
    Registriert seit:
    03.04.2011
    mist, faq4mobiles ist down. versuchs morgen nochmal.
     
  9. elLoko, 06.04.2011 #9
    elLoko

    elLoko Threadstarter Junior Mitglied

    Beiträge:
    31
    Erhaltene Danke:
    0
    Registriert seit:
    03.04.2011
    habe weiter getestet (noch nicht gerootet, faq4mobiles ist wieder on):
    das magnetische feld hat auf jeden fall was mit dem gps-empfang zu tun. wird ein "abnormales magnetisches feld" angezeigt, also bei mir etwa 500µ, dann werden z.b. 4 Satelliten angezeigt, und keines gefixt (nicht innerhalb der getesten 5min). kalibrier ich das handy, ohne das app zu verlassen, auf 40µ, dann werden plötzlich 8 satelliten angezeigt und innerhalb einer minute fast alle auch gefixt.

    wenn sich vielleicht noch einer melden könnte, bei dem das magnetische feld so gut wie nie "abnormal" wird, wäre das sehr aufschlussreich. danke schonmal... oder sich das nach nem rooten zum positiven geändert hat.
     
  10. elLoko, 06.04.2011 #10
    elLoko

    elLoko Threadstarter Junior Mitglied

    Beiträge:
    31
    Erhaltene Danke:
    0
    Registriert seit:
    03.04.2011
    noch ne frage zum CyanogenMod 7 (vielleicht direkt an Phillip):
    habe gelesen, dass dies kein ap2sd+ hat. ist ja eigentlich ne ganz colle sache, seine sd zu partionieren und einen teil als speichererweiterung zu nutzen.

    die frage also: hat CyanogebMod 7 (RC4) ap2sd+-Unterstützung?
     
  11. pimpifax, 07.04.2011 #11
    pimpifax

    pimpifax Fortgeschrittenes Mitglied

    Beiträge:
    255
    Erhaltene Danke:
    16
    Registriert seit:
    02.06.2010
    Welche App namens Compass meinst du...? Link?
     
  12. elLoko, 07.04.2011 #12
    elLoko

    elLoko Threadstarter Junior Mitglied

    Beiträge:
    31
    Erhaltene Danke:
    0
    Registriert seit:
    03.04.2011
    Sorry, meine den von catch.com

    market://details?id=com.apksoftware.compass
     
  13. Philipp1110, 07.04.2011 #13
    Philipp1110

    Philipp1110 Erfahrener Benutzer

    Beiträge:
    249
    Erhaltene Danke:
    46
    Registriert seit:
    19.06.2010
    @elLoko: Ja, CM7 unterstützt App2SD. Du kannst die Apps, wie unter Froyo auch, einfach in der Anwendungsverwaltung "Auf SD-Karte verschieben".
    Im ROMManager hast du zusätzlich dann noch die Möglichkeit, deine SD-Karte zu partitionieren.
     
  14. elLoko, 09.04.2011 #14
    elLoko

    elLoko Threadstarter Junior Mitglied

    Beiträge:
    31
    Erhaltene Danke:
    0
    Registriert seit:
    03.04.2011
    versuche heute den ganzen tag schon das cm7 rc4 auf mein handy zu bekommen. bisher bin ich zumindest soweit gekommen, dass ich es rooten konnte. leider startet der rom-manager die installation nicht. weder über den pc runtergeladenes rom, noch direkt über den rom-manager selbst. es kommt die frage nach dem backup und dem löschen der daten und des cache, dann die sicherheitsfrage, aber dann kommt nur wieder das menü. mist...versuche es weiter.

    wenn jemand nen tipp hat, würds mich sehr freuen.

    momentan ist android 2.1 drauf. was noch auffällt: wenn ich über den fastboot gehe und dann recovery wähle, kommt das bild mit dem roten dreickeck und ausrufezeichen.
     
  15. elLoko, 09.04.2011 #15
    elLoko

    elLoko Threadstarter Junior Mitglied

    Beiträge:
    31
    Erhaltene Danke:
    0
    Registriert seit:
    03.04.2011
    das beste an der ganzen sache: mein problem mit dem abnormalen magnetischen feld hat sich von allein gelöst. es läuft perfekt, gps sogar auf der couch.
     

Diese Seite empfehlen