1. Nimm jetzt an unserem Uhans - 3. ADVENT - Gewinnspiel teil - Alle Informationen findest Du hier!

ADB findet Galaxy unter Linux nicht

Dieses Thema im Forum "Samsung Galaxy (I7500) Forum" wurde erstellt von Scogit, 01.07.2010.

  1. Scogit, 01.07.2010 #1
    Scogit

    Scogit Threadstarter Android-Hilfe.de Mitglied

    Beiträge:
    69
    Erhaltene Danke:
    2
    Registriert seit:
    16.08.2009
    Phone:
    Samsung Galaxy
    Servus,

    hat jemand derzeit das Android SDK für Linux installiert bei dem das tool adb das Galaxy findet? Wenn ja wäre ich für eine kurze Hilfestellung dankbar.

    Entsprechende Udev Regel ist für das Galaxy angelegt:
    Code:
    SUBSYSTEM=="usb", SYSFS{idVendor}=="04e8", MODE="0666"
     
  2. mx82, 01.07.2010 #2
    mx82

    mx82 Junior Mitglied

    Beiträge:
    41
    Erhaltene Danke:
    0
    Registriert seit:
    21.02.2010
    Phone:
    HTC Desire
    funktioniert bei mir unter Ubuntu 64-Bit einwandfrei, mit 32-Bit gabs überhaupt keine Probs. Einfach nur den SDK runterladen, entpacken, mit der Konsole in den Unterordner tools gehen und ./adb mit den entsprechenden Befehlen aufrufen.
    Hier noch ein hilfreicher Link: Android Screenshots mit dem SDK in Ubuntu machen ? nodch.de
    Guck dir auch deren Verlinkung 'ähnliche Artikel' an.

    MfG Max
     
  3. Chrissss, 01.07.2010 #3
    Chrissss

    Chrissss Android-Hilfe.de Mitglied

    Beiträge:
    90
    Erhaltene Danke:
    2
    Registriert seit:
    18.07.2009
    Phone:
    HTC Desire
    Zur Not auch mal adb mit root-rechten, also sudo, starten.
     
  4. Sin-H, 01.07.2010 #4
    Sin-H

    Sin-H Fortgeschrittenes Mitglied

    Beiträge:
    253
    Erhaltene Danke:
    28
    Registriert seit:
    09.02.2010
  5. Scogit, 01.07.2010 #5
    Scogit

    Scogit Threadstarter Android-Hilfe.de Mitglied

    Beiträge:
    69
    Erhaltene Danke:
    2
    Registriert seit:
    16.08.2009
    Phone:
    Samsung Galaxy
    Sehr komisch ich habs unter sowohl unter 32 als auch 64bit versucht allerdings hab ich das Galaxo Rom (nicht die aktuelle Version) auf meinen Galaxy vielleicht hängt das damit zusammen.

    Die Udev Regel greift auf jeden Fall wenn ich per Udev noch einen Symlink erstellen lasse wird dieser auch angelegt mit den richtigen Rechten sobald das Galaxy angeschlossen ist.

    btw. ich hatte das vor einiger Zeit schon mal mit einer anderen Galaxo Version und gepatchten adb am laufen... aber irgendwie hilft das gepatchte adb nicht mehr
     
  6. Sin-H, 01.07.2010 #6
    Sin-H

    Sin-H Fortgeschrittenes Mitglied

    Beiträge:
    253
    Erhaltene Danke:
    28
    Registriert seit:
    09.02.2010
    Ich hab doch auch galaxo drauf... Also mit 1.6.3.x hat es immer funktioniert, egal ob .1, .2 oder .3.

    Muss doch gehen, drakaz ist auch Ubuntu user.
     
  7. Scogit, 01.07.2010 #7
    Scogit

    Scogit Threadstarter Android-Hilfe.de Mitglied

    Beiträge:
    69
    Erhaltene Danke:
    2
    Registriert seit:
    16.08.2009
    Phone:
    Samsung Galaxy
    Hat sich grad erledigt hatte auf meinen Desktop Rechner mit Arch Linux noch das vorletzte sdk mit den aktuellen sdk und adb als root gestartet (trotz Udev?) funktionierts ... jetzt muss ich nur noch rausfinden warum es auf den 32bit System nicht funktioniert denn da ist definitiv das aktuellste sdk drauf weil vor ner Woche erst installiert.
     

Diese Seite empfehlen