1. Nimm jetzt an unserem Uhans - 3. ADVENT - Gewinnspiel teil - Alle Informationen findest Du hier!

ADB: Gerät wird nicht erkannt

Dieses Thema im Forum "T-Mobile G1 Forum" wurde erstellt von Aavion, 17.11.2009.

  1. Aavion, 17.11.2009 #1
    Aavion

    Aavion Threadstarter Neuer Benutzer

    Beiträge:
    16
    Erhaltene Danke:
    0
    Registriert seit:
    12.11.2009
    Überschrift ist Thema:
    Mein G2 Touch lässt sich wunderbar über USB steuern via ADB, doch mein G1 bekomm ich einfach nicht rein.

    Das Gerät war defekt und so habe ich ein Ersatzgerät bekommen. Seit dem existiert Fastboot nicht mehr, sondern nur noch ein reiner hBoot-Bootloader, ohne Optionen, irgendetwas zu machen. Auch die Recovery-Console ist gesperrt, ich gelange nicht über die gewohnte Tastenkombinationen in diesen rein. Zudem wird das Gerät nicht mehr via USB erkannt, dass ich mit ADB drauf komm, obwohl Treiber installiert ist und USB-Debugging eingeschaltet ist.

    Was ist da schief gelaufen? o_O

    Auch kann ich das Gerät nicht auf Cupcake, geschweige denn auf Donut upgraden, ich bekomme während das Gerät neustartet lediglich ein Warnschild angezeigt. Über OTA sagt der mir, keine Updates verfügbar, daher habe ich das Manual-Installation-Kit von Google geladen (KILA_EU-Version).

    Außerdem erkennt das Gerät den Y-Audio-Adapter nicht, der Sound kommt weiterhin über die Lautsprecher, besagter Adapter läuft beim G2 einwandfrei.

    Soll ich das Gerät wieder Reklamieren, oder seht ihr eine Möglichkeit, die gewohnte Umgebung wiederherzustellen?

    Ich bin Ratlos, Danke.

    LG Aavion
     
  2. StefanG1, 17.11.2009 #2
    StefanG1

    StefanG1 Android-Lexikon

    Beiträge:
    1,494
    Erhaltene Danke:
    115
    Registriert seit:
    03.05.2009
    Phone:
    HTC Desire
    Ersatzgerät -> = Original Bootloader, kein Cyanogen Recovery

    Öhm ist doch logisch, das sind alles Sachen, die im Originalzustand so sind? Das Recovery Image müsstest du erst flashen.

    Wann du die OTA-Version bekommst, kannst du nicht beeinflussen.

    Wenn du die richtige Version auf der SD als update.zip gespeichert hast mit HOME+Power starten und dann ALT+S drücken, dann sollte das klappen.

    Was mit deinem Treiber ist, weiß ich nicht, dazu fehlen Infos wie WELCHEN Treiber du nutzen möchtest, und welches OS du nutzt etc.

    PS: Das gelbe Dreieck ist das Recovery.

    #Stefan
     
  3. Aavion, 17.11.2009 #3
    Aavion

    Aavion Threadstarter Neuer Benutzer

    Beiträge:
    16
    Erhaltene Danke:
    0
    Registriert seit:
    12.11.2009
    Ich hatte auf meinem G1 kein Custom-Rom im Einsatz...
    Der G1 Bootloader hatte Fastboot und im Hintergrund waren auch skatende Androiden, beim neuen Gerät nicht der Fall, sondern nur ein schwarzer Hintergrund, wo oben die üblichen Details stehen, darunter dann [Serial0], das wars...
    Ich hatte nix geflasht xD man kommt beim g1 auch so ins recovery rein, jedoch nur dieses äffe blaue, aber man kommt rein!
    Tja.. wenn das gehen würde... Ich boote mit Power+Home, das Warnschild kommt, ich drücke ALT+L und was passiert? Das Gerät geht einfach aus. Lässt sich nur nach erneutem Einlegen des Akkus neustarten.
    Und naja, wenn ich das Manual-Installation-Kit KILA_EU benutze, welches ein Kumpel mir aus den ZIP-Files erstellt hat, welches man ohne Update-Zip und den ganzen Quatsch, wie als wenn es OTA kommt, installieren kann (was ich auch bestätigen kann, hat ja früher auch geklappt), kommt beim neustarten lediglich das Warnschild, von wo aus ich nix mehr machen kann.
    Den normalen ADB-Treiber von Google, welcher schon installiert war und mit dem alten Gerät einwandfrei funktioniert hat.
    ich weiß ;-)
     
  4. StefanG1, 18.11.2009 #4
    StefanG1

    StefanG1 Android-Lexikon

    Beiträge:
    1,494
    Erhaltene Danke:
    115
    Registriert seit:
    03.05.2009
    Phone:
    HTC Desire
    Irgendwie alles sehr widersprüchlich.
    Also nochmal:

    Woher hattest du denn dein Handy überhaupt? Das was du schreibst hört sich irgendwie nach ADP an, anstatt G1....


    Naja okay AAAAAALSOOOO.... zum Treiber:
    Lad dir das neue SDK herunter, deinstalliere vorher den Treiber komplett und installiere den neuen aus dem neusten SDK. Das Gerät muss in der Systemsteuerung als Android Development Bridge oder irgendwas in der Art erkannt werden.

    Erst sagst du du kommst nicht ins Recovery, dann doch? Also wenn du rein kommst, lad dir das Originale Update irgendwo herunter und speicher es auf die SD, dann drückst du Home+Power beim Booten und dann beim Dreieck ALT+S.
    Wenn es dir ein Kumpel erstellt hat, hat der es entweder falsch gesigned, bzw darfst du sowieso keine nicht von Google gesigneten Zips flashen.

    So habs mal relativ kurz gehalten, dass es voran geht :).

    #Stefan
     
  5. Aavion, 18.11.2009 #5
    Aavion

    Aavion Threadstarter Neuer Benutzer

    Beiträge:
    16
    Erhaltene Danke:
    0
    Registriert seit:
    12.11.2009
    T-Mobile G1 mit Branding, war defekt (Display kaputt), ließ sich vorher jedoch wunderbar Bedienen und es ließ sich alles oben beschriebene wunderbar durchführen. Hatte die original-Firmware drauf, also nix geflasht oder sonst etwas unternommen.
    Wegen dem Display habe ich es dann in den HandyCheck gegeben bei T-Mobile und habe am nächsten Tag dann ein Ersatzgerät bekommen (Man bekommt bei T-Mobile immer ein bereits repariertes Gerät zurück, damit man nicht wochenlang auf das eigene Warten muss). Anscheinend hatte der Vorbesitzer das Teil so verhunzt.. -.- Und den Leuten in der Reparatur scheint dies nicht aufgefallen zu sein.. Naja..

    Das Gerät wird lediglich als USB-Massenspeichergerät erkannt, obwohl USB-Debugging aktiviert ist. Treiberneuinstallation über SDK ist des öfteren pasiert...
    Beim alten Gerät kam ich rein, beim neuen hängt sich das Handy beim Dreieck auf, sobald ich dann irgendetwas drücke schaltet es einfach ab.
    Ich hätte es ja via Update.zip gemacht, aber aufgrund des o.g. Problems war dies leider nicht möglich, daher habe ich mir von nem Kumpel nen Script geben lassen, dass die Updates wie das OTA installiert, also im laufenden Betrieb mit Abfrage. Die Updates selber wurden nicht geändert, daher anständig gesigned.


    lg aavion
     
  6. Denowa, 18.11.2009 #6
    Denowa

    Denowa Android-Guru

    Beiträge:
    2,872
    Erhaltene Danke:
    565
    Registriert seit:
    21.08.2009
    Phone:
    OnePlus One, OnePlus Two, ZTE Axon 7
    Wearable:
    Pebble
    Ich denke "da" steht die Antwort drin, Du hast ein defektes Gerät, sprich nicht repariert, als Austausch bekommen. Ansonsten kann ich mir die Häufung von Fehler, Abstürzen usw. nicht erklären. :cool:
     
  7. StefanG1, 18.11.2009 #7
    StefanG1

    StefanG1 Android-Lexikon

    Beiträge:
    1,494
    Erhaltene Danke:
    115
    Registriert seit:
    03.05.2009
    Phone:
    HTC Desire
    Welches OS nutzt du denn?

    Zum ADB-Problem könnte dir: http://forum.xda-developers.com/showthread.php?t=502010 helfen. Aber erst brauchst du den korrekten Treiber, als Massenspeichergerät hilft es dir nichts, es muss als Android Composite ADB Interface erkannt werden.
    Du darfst es auch nicht über die Benachrichtigungszeite die Daten bereitsstellen lassen.

    Für mich sieht das einfach so aus, als hättest du mit den Flashversuchen dein Recovery zerschossen. Also wenn du den Treiber korrekt installiert bekommst könntest du das originale Recovery neu flashen und dann dein Original-ROM Donut flashen.

    Achja was mir noch dazu einfällt: Welches Version hast du denn auf dem Handy? Wenn du noch 1.0 hast, was eigentlich nicht sein kann, weil du ja den USB Debugging Punkt im Menü hast, welchen es da noch nicht gab, glaube ich, aber oben schreibst du, dass du auch kein 1.5 flashen kannst, also was hast du denn im Moment für eine Version?
    Achso - worums eigentlich bei dem Gedanken ging, sind die SDK's abwärtskompatibel?
     
    Zuletzt bearbeitet: 18.11.2009

Diese Seite empfehlen