1. Nimm jetzt an unserem Uhans - 3. ADVENT - Gewinnspiel teil - Alle Informationen findest Du hier!

Android 3.0 Tablet Version Tagesschau-App [Gelöst/Solved]

Dieses Thema im Forum "Root / Hacking / Modding für HANNspree HANNSpad (SN10T1)" wurde erstellt von marcero, 08.01.2012.

  1. marcero, 08.01.2012 #1
    marcero

    marcero Threadstarter Fortgeschrittenes Mitglied

    Beiträge:
    401
    Erhaltene Danke:
    139
    Registriert seit:
    06.09.2011
    Hi,

    hab heute bei der Benutzung von fards ICS alpha gemerkt, dass es ja inzwischen eine Tablet Version der Tagesschau Android App gibt.
    Bin jetzt aber wieder zurück zu Android 3.0 Flashback gegangen und wenn ich dort die tagesschau App herunterlade, bekomme ich immer die Smartphone Version.
    Gibt es eine Möglichkeit Anpassungen vorzunehmen, damit der Market mir die Apps als Table Apps zur Verfügung stellt?
    Hat da jemand Erfahrung mit, hab irgendwo gelesen dass die App schon ab Android 3.0 zur Verfügung stehen soll. Falls es erst ab 3.2 geht, hat das ja mit Flashback eh keinen Sinn.
    Suche daher jemanden der mir sagen kann, welche Änderungen in der build.prop mir helfen können, oder welche Market Version ich brauche.

    Vielen Dank
     
    Zuletzt bearbeitet: 09.01.2012
  2. 4dro1d, 08.01.2012 #2
    4dro1d

    4dro1d Android-Guru

    Beiträge:
    2,966
    Erhaltene Danke:
    1,406
    Registriert seit:
    02.08.2011
    Simkou und Freakandr0id haben sich bedankt.
  3. marcero, 09.01.2012 #3
    marcero

    marcero Threadstarter Fortgeschrittenes Mitglied

    Beiträge:
    401
    Erhaltene Danke:
    139
    Registriert seit:
    06.09.2011
    Hab einfach mal die build.prop kopiert und eingefügt.
    Wie zu erwarten war, stürzt der Market jetzt mit nem FC ab :flapper:

    Aber auf alle Fälle vielen Dank für das APK, das läuft auch auf fb 10.1 hervorragend und sieht deutlich besser aus als die Smartphone-Version :)
     
  4. marcero, 09.01.2012 #4
    marcero

    marcero Threadstarter Fortgeschrittenes Mitglied

    Beiträge:
    401
    Erhaltene Danke:
    139
    Registriert seit:
    06.09.2011
    So einfacher workaround, in build.prop die sdk version von 11 auf 12 ändern.
    bisher keine inkomp. gefunden und tagesschau ist in tab version verfügbar.
     
    Zuletzt bearbeitet: 09.01.2012
    marc---O bedankt sich.
  5. Freakandr0id, 12.01.2012 #5
    Freakandr0id

    Freakandr0id Fortgeschrittenes Mitglied

    Beiträge:
    289
    Erhaltene Danke:
    57
    Registriert seit:
    22.06.2011
    Hallo marcero,

    das ändern in der build.prop der sdk version von 11 auf 12 löst das Problem der FehlerMeldung zum parsen des Paketes und ermöglicht die installation der app.
    Die TabletVersion sieht ja absolut geil aus!!! Aber ich habe jetzt leider folgendes Problem: aller paar Minuten stürzt die komplette app ab und man landet auf dem homescreen...!? Das passiert bei mir in unregelmäßigen Abständen und ich konnte bis jetzt auch noch keinen Zusammenhang erkennen. Manchmal kann ich 1-2 Artikel lesen und manchmal muß ich die app für einen Artikel 3x neu starten :-( ist das bei dir auch so??? Und wenn ja hast du eine lösung dafür gefunden?


    Danke schon mal

    Freakandr0id



    Tapatalk'ed with my I9000
     
  6. 4dro1d, 12.01.2012 #6
    4dro1d

    4dro1d Android-Guru

    Beiträge:
    2,966
    Erhaltene Danke:
    1,406
    Registriert seit:
    02.08.2011
    Welches ROM hast du denn ?
     
  7. Freakandr0id, 12.01.2012 #7
    Freakandr0id

    Freakandr0id Fortgeschrittenes Mitglied

    Beiträge:
    289
    Erhaltene Danke:
    57
    Registriert seit:
    22.06.2011
    Oh sorry wie noobisch von mir...! Deine Frage ist natürlich mehr als berechtigt! Ich nutze flashback 10 easy und den geilsten Kernel der Welt von rotation!

    Tapatalk'ed with my I9000
     
  8. marcero, 12.01.2012 #8
    marcero

    marcero Threadstarter Fortgeschrittenes Mitglied

    Beiträge:
    401
    Erhaltene Danke:
    139
    Registriert seit:
    06.09.2011
    Bisher hatte ich das nicht, aber wenn die tagesschau app Funktionen aus sdk 12 nutzt, die fb nicht hat, stürzt die app halt ab, wenn die aufgerufen werden.
    Ich weiß leider nicht welche sdk version zu welcher Android Version gehört.

    Sent from my gTablet using Tapatalk
     
    Freakandr0id bedankt sich.
  9. Freakandr0id, 12.01.2012 #9
    Freakandr0id

    Freakandr0id Fortgeschrittenes Mitglied

    Beiträge:
    289
    Erhaltene Danke:
    57
    Registriert seit:
    22.06.2011
    Ja aber du hast doch selbst geschrieben das du die app auch unter FB 10.1 nutzt!?!? Oder habe ich da etwas falsch verstanden???
     
  10. marcero, 12.01.2012 #10
    marcero

    marcero Threadstarter Fortgeschrittenes Mitglied

    Beiträge:
    401
    Erhaltene Danke:
    139
    Registriert seit:
    06.09.2011
    So hab was dazu gefunden:

    Android API Levels | Android Developers

    Da flashback auf 3.0.1 basiert, ist sdk 11 für Flashback die richtige Konfiguration.
    Wenn nun aber die Tagesschau Tablet App Funktionen enthält die es nur im SDK 12 gibt, dann lässt es sich in Flashback nicht installieren.
    Wird nun aber in der build.prop SDK=12 eingestellt wird, man quasi vortäuscht man hätte Android 3.1+, obwohl Flashback es nicht ist, dann bekommt man die App über den Market und kann sie auch so installieren.
    Ruft man aber in der apk ne Funktion auf, die nur für SDK 12 vorgesehen ist, die es aber in FB dann nicht gibt, stürzt die App an der Stelle einfach ab.

    Das beruht jetzt nur auf dem, so wie ich es mir vorstelle, wie es ist und muss nicht unbedingt der Realität entsprechen.

    Falls du übrigens im fingerprint sagst, du hättest ne andere Android Version, z.B. 3.2 dann stürzt immer der Market ab, weil er anscheinend Market Updates lädt, die nicht zum SDK passen. Bei der Tagesschau App wird aber anscheinend nur der SDK Versions Wert aus der build.prop abgefragt.

    Ich nutze FB 10.1 (ohne easy) und Hybridkernel v3 von antibyte und bei mir ist die App bisher noch nie abgestürzt. Kann also eventuell auch andere Ursachen haben.
     
    Appqueen und Freakandr0id haben sich bedankt.
  11. Freakandr0id, 13.01.2012 #11
    Freakandr0id

    Freakandr0id Fortgeschrittenes Mitglied

    Beiträge:
    289
    Erhaltene Danke:
    57
    Registriert seit:
    22.06.2011
    @marcero

    Ich könnte kotzen! Die app hat standig FC's :cursing:
    Welche app-version hast du bei dir am laufen? Hast du die installiert die 4droid hier zum download verlinkt hat oder eine andere die du selbst runter geladen hast???? Falls du eine andere hast würdest du sie für mich mal uploaden??? Bitte!!!

    Danke Freakandr0id
     
  12. marcero, 13.01.2012 #12
    marcero

    marcero Threadstarter Fortgeschrittenes Mitglied

    Beiträge:
    401
    Erhaltene Danke:
    139
    Registriert seit:
    06.09.2011
    Hab meine aus dem Market geladen.
     
  13. Freakandr0id, 13.01.2012 #13
    Freakandr0id

    Freakandr0id Fortgeschrittenes Mitglied

    Beiträge:
    289
    Erhaltene Danke:
    57
    Registriert seit:
    22.06.2011
    Und lädst sie mir mal bitte hoch???
     
  14. marcero, 14.01.2012 #14
    marcero

    marcero Threadstarter Fortgeschrittenes Mitglied

    Beiträge:
    401
    Erhaltene Danke:
    139
    Registriert seit:
    06.09.2011
    :thumbup:
     

    Anhänge:

    Freakandr0id bedankt sich.
  15. cantax, 04.02.2012 #15
    cantax

    cantax Fortgeschrittenes Mitglied

    Beiträge:
    409
    Erhaltene Danke:
    78
    Registriert seit:
    02.11.2011
    Ich grad den Thread nochmal aus, weil ich ein Problem mit der sdk Version 12 fesstgestellt habe.
    Ich habe von 11 auf 12 gestellt um die tagesschau app zu installieren. Aber daraufhin lief Flashplayer nicht mehr. Ich habe den aktuellen Flashplayer und die alte Opera Version.
    Dann wieder von 12 auf 11 gestellt, rebootet und Flashplayer funktioniert wieder einwandfrei.
    Ich hoffe ich kann anderen damit mühsames Fehlersuchen ersparen.
     
  16. marcero, 04.02.2012 #16
    marcero

    marcero Threadstarter Fortgeschrittenes Mitglied

    Beiträge:
    401
    Erhaltene Danke:
    139
    Registriert seit:
    06.09.2011
    Hehe, ich hab sdk auf 12 und flashplayer geht, dafür krieg ich inzwischen trotzdem immer die handy version der tagesschau app ausm market. Die hier von mir hochgeladene tablet version geht zum Glück noch. :)
     
    Zuletzt bearbeitet: 04.02.2012
  17. cantax, 04.02.2012 #17
    cantax

    cantax Fortgeschrittenes Mitglied

    Beiträge:
    409
    Erhaltene Danke:
    78
    Registriert seit:
    02.11.2011
    Wenn ich die Tagesschau App aus dem Market installiere kriege ich auch nur die Handy Version.
    Schön, dass Flash bei dir keine Probleme macht. Vielleicht nur ein Einzelfall. Oder aber es liegt daran, dass ich Flashplayer installiert hab bevor ich die sdk Version von 11 auf 12 gestellt habe.
     
  18. marcero, 04.02.2012 #18
    marcero

    marcero Threadstarter Fortgeschrittenes Mitglied

    Beiträge:
    401
    Erhaltene Danke:
    139
    Registriert seit:
    06.09.2011
    Ich hab auch die neueste Opera Version.
     

Diese Seite empfehlen