1. Nimm jetzt an unserem Uhans - 3. ADVENT - Gewinnspiel teil - Alle Informationen findest Du hier!

Anfängerfrage: import Packages

Dieses Thema im Forum "Android App Entwicklung" wurde erstellt von Logan, 03.01.2010.

  1. Logan, 03.01.2010 #1
    Logan

    Logan Threadstarter Neuer Benutzer

    Beiträge:
    2
    Erhaltene Danke:
    0
    Registriert seit:
    03.01.2010
    Hi,

    ich bin gerade dabei mich in Android einzuarbeiten. Habe leider kein Vorwissen was Java betrifft, daher werde ich es wohl an manchen Stellen doppelt schwer haben. Aber nun ja.

    Leider ist jedes Buch was ich bisher in der Hand gehalten habe irgendwie mit Fehlern versehen.

    Ich bekomme im Moment eine Fehlermeldung, dass in der folgenden Zeile:
    PHP:
    Intent geoIntent = new Intent(android.content.Intent.ACTION_VIEWUri.parse("geo:0,0?q=" address));
    ein Fehler beim ist.

    Hier die Fehlermeldung:
    PHP:
    cannot find symbol
    symbol
    variable Uri
    Nutze Textmate mit dem Android Bundle. Diese Fehlermeldung hatte ich schon bei anderen Dingen, und hängt mit einem fehlenden Package zusammen. Aber egal welches Package ich importiere, die Meldung bleibt. Daher bin ich gerade recht ratlos. Die Lösung ist wahrscheinlich super einfach, wäre aber um kurze Hilfe dankbar.
     
  2. Logan, 03.01.2010 #2
    Logan

    Logan Threadstarter Neuer Benutzer

    Beiträge:
    2
    Erhaltene Danke:
    0
    Registriert seit:
    03.01.2010
    Vergesst es. Hab den Fehler gefunden.
     
  3. herrlado, 03.01.2010 #3
    herrlado

    herrlado Fortgeschrittenes Mitglied

    Beiträge:
    390
    Erhaltene Danke:
    25
    Registriert seit:
    26.10.2009
    Uri in der Methodenaufruf ist weder eine Variable noch eine Klasse.
    Korrekt muss es URI lauten und muss importiert werden.

    Statt textmate lade dir eclipse und android plugin herunter. So kommst du schneller vorwärts.


    Gruß,
    Lado

     

Diese Seite empfehlen