1. Nimm jetzt an unserem 2. ADVENT-Gewinnspiel teil - Alle Informationen findest Du hier!

Anleitung: Root

Dieses Thema im Forum "Root / Hacking / Modding für HTC Legend" wurde erstellt von Doug, 26.08.2010.

  1. Doug, 26.08.2010 #1
    Doug

    Doug Threadstarter Fortgeschrittenes Mitglied

    Beiträge:
    407
    Erhaltene Danke:
    118
    Registriert seit:
    19.11.2009
    Moin,

    da mir momentan aus privaten/beruflichen Gründen die Zeit fehlt um euch eine eigene Step-by-Step Anleitung zu schreiben; hier mal ein paar deutsche Anleitungen mit denen ich, erfolgreich, gearbeitet habe:

    Achtung: Laut einiger User funktionieren die folgenden Schritte nur unter WindowsXP einwandfrei!

    1. Goldcard erstellen (Danke an Maces):
    http://www.android-hilfe.de/507802-post11.html

    2. SDK installieren:
    Android SDK installieren

    3. Downgrade:
    HTC Legend - Rom Downgrade

    4. Root:
    Anleitung zum Root beim HTC Legend
    (Download Mirror: r4-legend-root.zip http://www.megaupload.com/?d=XBAOCSWZ

    Die benötigten Dateien findet man in den Anleitungen selbst als Downloads.

    5. Anschließend aus dem Market die App "ROM Manager" installieren, darin dann die .zip Datei vom CustomROM von der SD Karte auswählen und warten, fertig :)


    Abschließend bleibt noch zu sagen, dass es auch bei mir nicht auf Anhieb funktioniert hat.
    Habe einen Schritt beim rooten übersehen. Das ganze endete in einer Bootschleife beim hochfahren des Legend - wo mir ganz schön heiß wurde ;).
    Daher rate ich euch: aufmerksam die Anleitungen lesen und JEDEN Schritt genau befolgen ;)

    Vielleicht hilft es ja jemand.

    Falls jemand Probleme während des gesamten Vorgangs haben sollte, kann er hier posten.
    Aber bitte nicht nach dem Muster "Hallo, das klappt nicht, kann mir jemand helfen????" sondern bitte eine genaue Beschreibung der schon durchgeführten Schritte und wann und wo genau es welches Problem gibt, vielleicht können wir dann helfen.

    Berichtet auch mal ob es geklappt hat :)

    Grüße,
    Doug

    PS: Android-Hilfe.de und meine Wenigkeit übernehmen selbstverständlich keinerlei Haftung o.ä. für ggf. entstehende Schäden o.ä. Wer Root erlangen will, tut dies auf eigene Gefahr und akzeptiert den Verlust der Garantie!

    Für eventuelle Schäden haftet ausschließlich der anwendende Nutzer. Root und alle daraus entstehenden Vor- und Nachteile sollten dem User bewusst sein, bevor er das System modifiziert.
     
    Zuletzt bearbeitet: 10.05.2011
    lala2011, linchen4000, lomycess und 14 andere haben sich bedankt.
  2. Maces, 27.08.2010 #2
    Maces

    Maces Fortgeschrittenes Mitglied

    Beiträge:
    366
    Erhaltene Danke:
    91
    Registriert seit:
    20.04.2010
    Phone:
    Samsung Galaxy A5 2016, LG G2, HTC One X ...
    Hi Doug, ich habe da ein Problem beim Downgrade. Ich habe schon vor ein paar Tagen den Downgrade versucht durchzuführen aber es kam leider nicht dazu, da wenn ich die Ruu.exe ausführe nach dem durchlauf des Installshieldes die Installation einfach beendet wird. (Das Programm schließt sich)
    Damals hatte ich das Downgrade soweit durchgeführt das ich den crwxrwxrwx befehl gesehen habe.

    Gestern Abend also auf ein Neues.
    SDK deinstalliert, neu installiert, USB_driver bearbeiten fürs HTC Legend, (Wurde nicht gefunden, also HTC Snyc wieder installiert und anschließend die ADB Treiber bearbeiten in der Win.inf im ../USB_Driver. Dann habe ich den Treiber manuell neu installiert [Geräte-Manger -> andere Treiber wählen "../USB_Driver"])

    So weit so gut. ADB und Treiber dürften jetzt ja funktionieren.

    Dann habe ich die Crackin.bat ausgeführt. Nach 2 bzw. 3 Reboots meines Legends:" Multiple Devices or System detectet"

    Nach dem gefühlten 100. Versuch hat er es Teilweise schon beim ersten Reboot angezeigt.

    Dann habe ich mir gedacht:" Ok vllt ist der crwxrwxrwx befehl noch in der /dev/mtd/mtd0 eingetragen!" Schließlich hat er das bei meinem Versuch letzte Woche angezeigt. (Ok ich habe ein paar mal neu gestartet in der Zwischenzeit aber ich habe noch ein wenig Gottvertrauen) ;)

    Also wieder die RUU.exe ausgeführt und wieder bricht die Installation nach dem Installshield ab und beendet sich.

    Dann habe ich die Ruu.exe nocheinmal von einer anderen Quelle geladen.
    Leider das selbe Spiel, der Installshieldmanager läuft durch ... fenster geschlossen.

    Ich werde mal versuchen heute noch Ubuntu zu installieren und/oder es über einen Win7 Rechner zu machen, sonst habe ich echt keine Idee mehr.

    Software: 2.1 update 1
    Bootloader: 43.0001
    Dazu dieser Thread der XDA-Devs
    Stock 2.05.405.2 still shows HBOOT of 43.0001 - xda-developers

    Mhh ich schätze das hier ein gaaanz besonderes Problem auf mich wartet, wenn es über Linux und Win7 nicht klappt.
     
    Zuletzt bearbeitet: 27.08.2010
  3. Doug, 27.08.2010 #3
    Doug

    Doug Threadstarter Fortgeschrittenes Mitglied

    Beiträge:
    407
    Erhaltene Danke:
    118
    Registriert seit:
    19.11.2009
    Puh, gute Frage Maces :D

    Wie du schon sagtest, würde ich das ganze auch erstmal an einem anderen Rechner probieren. Vorzugsweise mit Windows XP.

    Habe auf meinem Mac XP unter Bootcamp laufen, damit war das Downgrade kein Problem, klappte direkt mit dem ersten Anlauf.

    Unter Windows 7 und Vista muss man die .exe glaub ich explizit als Admin ausführen damit es funktioniert.

    Ich drück die Daumen ;)

    PS:
    Komisch, ich musste keinen Treiber manuell installieren o.ä.
    Bei mir lief alles von selbst.

    Hier übrigens der Link zu der RUU die ich für das Downgrade genutzt habe:
    http://shipped-roms.com/shipped/Leg...6.35.04_7.05.35.26L_release_126592_signed.exe
    Vielleicht bringt es dir ja was..:confused:

    Ach ja,
    Software: 2.1 update 1
    Bootloader: 43.0001
    Hatte/habe ich auch, kein Hindernis gewesen :)
     
  4. Frostbeule2k, 27.08.2010 #4
    Frostbeule2k

    Frostbeule2k Erfahrener Benutzer

    Beiträge:
    217
    Erhaltene Danke:
    32
    Registriert seit:
    04.03.2010
    Phone:
    OnePlus X
    Hallo,

    ich hatte/habe bei mir auch den selben Stand wie Doug.
    Das Downgrade hat bei mir auch erst mit einem Windows XP funktioniert. Win 7 hat nicht funktioniert. Bei mir hatte er auch unter Win XP den Treiber angemault; ich habe dann den des HTC Hero´s verwendet (http://www.pocketpc.ch/attachments/...2230-htc-hero-treiber-fehlen-hero-treiber.zip). Den Treiber habe ich auch für das Rooten verwendet.
    Laut der englischen Anleitung welche ich befolgt habe startet sich das Gerät insgesamt 5x neu und man soll jegliche Fehlermeldungen ignorieren.

    Was hast du dann nach dieser Fehlermeldung gemacht!?

    Nur zur richtigkeit; der "Befehl" ist kein Befehl sondern die Berechtigung auf /dev/mtd/mtd0

    Beendet sich ohne Fehlermeldung? Steht vielleicht im Systemlog hierzu etwas!?

    Gruß Frostbeule2k
     
  5. Doug, 27.08.2010 #5
    Doug

    Doug Threadstarter Fortgeschrittenes Mitglied

    Beiträge:
    407
    Erhaltene Danke:
    118
    Registriert seit:
    19.11.2009
    So, also bei mir hat sich die ganze Geschichte mehr als gelohnt.
    Endlich 2.2, endlich kein HTC Sense mehr, endlich nicht mehr von HTC abhängig was Updates angeht etc.

    Habs zwar schon in einem anderen Thread gepostet, aber hier mal mein 2.2 Legend@root als kleine Ermutigung für euch (so schön kann es ohne Sense sein :D):
     

    Anhänge:

  6. Frostbeule2k, 28.08.2010 #6
    Frostbeule2k

    Frostbeule2k Erfahrener Benutzer

    Beiträge:
    217
    Erhaltene Danke:
    32
    Registriert seit:
    04.03.2010
    Phone:
    OnePlus X
    Das ist doch die Flip Clock von HTC Sense, oder!? Wo bekomme ich die her!?
     
  7. Doug, 28.08.2010 #7
    Doug

    Doug Threadstarter Fortgeschrittenes Mitglied

    Beiträge:
    407
    Erhaltene Danke:
    118
    Registriert seit:
    19.11.2009
    Nennt sich Fancy Widget :)
     
    Frostbeule2k bedankt sich.
  8. Philipp1110, 28.08.2010 #8
    Philipp1110

    Philipp1110 Erfahrener Benutzer

    Beiträge:
    249
    Erhaltene Danke:
    46
    Registriert seit:
    19.06.2010
    Fancy Widget ist allerdings leider nicht mehr im Market erhältlich. Ich habe HIER mal einen Link gepostet von Version 1.3 (die ist in Deutsch verfügbar). :thumbup:
     
  9. chika, 01.09.2010 #9
    chika

    chika Fortgeschrittenes Mitglied

    Beiträge:
    340
    Erhaltene Danke:
    85
    Registriert seit:
    01.09.2010
    hallo
    habe mich nun auch mal an das rooten gewagt.hat auch alles bis zum root selber geklappt.nun hänge ich aber bei step2 fest.wenn er sagt "Pushing update file to device sdcard-this mey a few minutes..."läuft sr sofort durch und das schwarze display mit rotem dreieck bleibt.ich komme also nicht in den recovery-modus.
    nach erfolgreichem step1 trenne ich das handy vom rechner,starte es neu um sdcard zu formatieren(könnte das der fehler sein?),handy dann wieder ausschalten,dann in den fastboot und auf recovery,angestöpselt,in die kosole den step2 befehl eingegeben und dann rennt er durch und es passiert nix.
    mein legend ist debranded und hatte v 2.05 drauf,jetzt 1.31
    edit:hab es nochmal mit einer zweiten sdcard probiert.also nach step1 goldcard raus und andere sdcard rein,ohne neustart.leider das gleiche ergebnis.
     
    Zuletzt bearbeitet: 01.09.2010
  10. Frostbeule2k, 03.09.2010 #10
    Frostbeule2k

    Frostbeule2k Erfahrener Benutzer

    Beiträge:
    217
    Erhaltene Danke:
    32
    Registriert seit:
    04.03.2010
    Phone:
    OnePlus X
    Hi Chika,

    wenn du das Gerät in den Recoverymodus versetzten willst musst du bei dem Modus bei welchem du das rote Dreieck siehst nicht die step-2.bat starten sondern die recovery-windows.bat.

    Gruß

    @ Doug: Du könntest deinem Post vielleicht noch hinzufügen das das rooten etc. nur unter Windows XP einwandfrei läuft.
     
    chika bedankt sich.
  11. chika, 03.09.2010 #11
    chika

    chika Fortgeschrittenes Mitglied

    Beiträge:
    340
    Erhaltene Danke:
    85
    Registriert seit:
    01.09.2010
    habs denn jetzt auch hinbekommen.der knackpunkt war wohl WinXP.was noch zu erwähnen wäre,hatte erst htc-sync
    v3....drauf,was auch nicht funktionierte.mit den usb-treibern von v2...funktionierte es auf anhieb.
     
  12. pchanbo, 06.09.2010 #12
    pchanbo

    pchanbo Neuer Benutzer

    Beiträge:
    13
    Erhaltene Danke:
    2
    Registriert seit:
    05.09.2010
    ich sehe nach step2

    ein grünes recovery menü. paar sachen zum klicken sind zu sehen. leider passiert nix. über vol+ und power komme ich in ein zweites recovery menü. dieses ist blau und mit weniger möglichkeiten.
    bin ich da richtig?
     
  13. chika, 06.09.2010 #13
    chika

    chika Fortgeschrittenes Mitglied

    Beiträge:
    340
    Erhaltene Danke:
    85
    Registriert seit:
    01.09.2010
    halte dich an die anleitung von #1.navigieren kannst du mit dem trackball.
     
  14. speedgummi, 11.09.2010 #14
    speedgummi

    speedgummi Neuer Benutzer

    Beiträge:
    1
    Erhaltene Danke:
    0
    Registriert seit:
    10.09.2010
    mir gehts genauso wie pchanbo. nach step2 erscheint das recovery menü in grüner Schrift, in diesem kann ich jedoch nur mit dem trackball navigieren! die tasten reagieren vorerst nicht, erst wenn ich vol+ und power gleichzeitig drücke erscheint ein neues recovery menü in blauer Schrift, hier sind aber viel weniger Optionen als bei dem grünen. wenn ich in diesem menü den trackball berühre springt er wieder ins grüne menü zurück. war das bei euch auch so? was muss ich machen damit das rootedupdate.zip geflasht wird?
    Bitte um Hilfe ich weiss nicht mehr was ich machen soll.
    Habs in Windows XP und Win7 probiert.
     
    Zuletzt bearbeitet: 11.09.2010
  15. pchanbo, 11.09.2010 #15
    pchanbo

    pchanbo Neuer Benutzer

    Beiträge:
    13
    Erhaltene Danke:
    2
    Registriert seit:
    05.09.2010
    wie chicka geschrieben hat:

    plötzlich funzt in dem teil des ganzen der trakball unten am legend und du kannst damit die sachen ansteuern und kommst weiter :rolleyes2:
     
  16. mop

    mop Android-Hilfe.de Mitglied

    Beiträge:
    147
    Erhaltene Danke:
    16
    Registriert seit:
    12.08.2009
    Phone:
    Sony Ericsson Xperia Arc S
    Hi,

    ich frag lieber mal nach bevor ich mich dran mach.
    Ich hab leider nur W7 und kein XP, also würde ich das ganze über die virtuelle Konsole im XP-Mode machen.
    Was meint ihr, das müsste eigentlich gehen, oder?

    Danke

    Edit:
    DIE LÖSUNG FÜR WINDOWS 7 und alle die nicht extra XP installieren möchten

    Hier

    Hier wird es gut erklärt!
     
    Zuletzt bearbeitet: 16.09.2010
  17. mop

    mop Android-Hilfe.de Mitglied

    Beiträge:
    147
    Erhaltene Danke:
    16
    Registriert seit:
    12.08.2009
    Phone:
    Sony Ericsson Xperia Arc S
    Hallo ,

    ich habe leider schon wieder ein Problem und zwar Folgendes:

    Ich hatte auf meinem Legend ebenfalls Azure1.01 geflasht, allerdings hat mir das alles nicht so gefallen. Darum wollt ich wieder mein ursprüngliches System zurüch.
    Also habe ich wieder Firmware 1.31.405.4 installiert was auch alles geklappt hat.
    Jetzt allerdings wollte ich ein Update OTA machen um wieder die aktuellste Version zu bekommen, jedoch sagt mir das Handy das es auf dem aktuellsten Stand ist, was ja aber nicht stimmt.

    Hab die Firmware inzwischen 3mal neu Aufgespielt ohne Erfolg.

    Hat mir jemand einen Rat was ich jetzt machen könnte?

    Danke
     
  18. chika, 18.09.2010 #18
    chika

    chika Fortgeschrittenes Mitglied

    Beiträge:
    340
    Erhaltene Danke:
    85
    Registriert seit:
    01.09.2010
    ich denke mal sie werden es zurückgezogen haben.aber du kannst ja mal dieses rom (Mdj Droid L0.3) ausprobieren.ist noch mit sense und ich finde es sehr gelungen.
    ansonsten mal im netz nach der inoffiziellen 2.03 suchen.die hat,glaub ich, auch noch nicht den sms-bug.

    mfg chika
     
  19. squall40, 20.09.2010 #19
    squall40

    squall40 Junior Mitglied

    Beiträge:
    34
    Erhaltene Danke:
    0
    Registriert seit:
    24.08.2010
    hiho !

    will mein legend gern debranden aber um die schritte vom debranden durch zu gehen muss ich es erst downgraden.....

    nun hab ich hier folgendes problem

    man soll ja nachdem man das legend 5mal rebooten lassen hat, die gold card einlegen und auf sync gehen und dann die ruu.exe starten.

    das problem ist, das mien legend das htc sync auf meinem rechner nicht mehr findet obwohl er es vor dem goldcardflash immer getan hat. demzufolge kann ich die ruu.exe nicht starten bzw es kommt folgender fehler

    [​IMG]

    Uploaded with ImageShack.us


    benutze windows xp....

    kann mir vllt jemand helfen ?
     
  20. Frostbeule2k, 20.09.2010 #20
    Frostbeule2k

    Frostbeule2k Erfahrener Benutzer

    Beiträge:
    217
    Erhaltene Danke:
    32
    Registriert seit:
    04.03.2010
    Phone:
    OnePlus X
    Hallo,

    deine Fehlermeldung kommt von Windows und hat in erster Linie nichts mit deinem Legend zu tun. Es scheint als ob bereits eine Installation durchgeführt wird bzw. das der InstallShield bereits läuft. Hast du das ganze ein zweites mal probiert und ggf. einen reboot des Rechners durchgeführt!?
    Wenn du die Goldcard eingelegt hast, musst du nicht syncen, du musst nur das Legend mit dem PC verbinden.
     

Diese Seite empfehlen