1. Nimm jetzt an unserem Uhans - 3. ADVENT - Gewinnspiel teil - Alle Informationen findest Du hier!

App Problem: vpnc

Dieses Thema im Forum "Samsung Galaxy (I7500) Forum" wurde erstellt von Jay1982, 06.09.2009.

  1. Jay1982, 06.09.2009 #1
    Jay1982

    Jay1982 Threadstarter Android-Experte

    Beiträge:
    666
    Erhaltene Danke:
    71
    Registriert seit:
    17.07.2009
    Da ich langsam aber sicher verzweifel, hoffe ich das mir jemand weiter helfen kann.

    Und zwar hab ich Probleme mit dieser App: Cyrket - VPN Connections - root only.

    Hintergrund ist, dass ich, um auf den Exchange Server in der Arbeit zuzugreifen, mich erstmal per VPN verbinden muss (ipsec, cisco hardware).

    Meine Versuche mit dem Galaxo Rom waren leider ernüchternd. Bekam immer nur "Connection Failed" (Version 0.6 ausm Market, sowie Version 0.9 von der Homepage). Wenn ich das tun.ko File manuell per insmod eingebunden habe (wie hier beschrieben: LoadingTheTunModule - get-a-robot-vpnc - How to load the tun kernel module. - Project Hosting on Google Code) und die Verbindung aufbauen wollte, ging mein Galaxy komplett aus.

    Hat irgendwer diese App erfolgreich laufen? Bzw. besteht überhaupt die Möglichkeit, mit der kommenden H8 Firmware + root über drakaz recovery, das Ding ohne weitere großartige Änderungen zum laufen zu kriegen (Custom Roms würde ich mir gerne sparen)?
     
  2. leromarinvit, 07.09.2009 #2
    leromarinvit

    leromarinvit Erfahrener Benutzer

    Beiträge:
    202
    Erhaltene Danke:
    13
    Registriert seit:
    08.07.2009
    Also prinzipell gehts. Ein bisschen Handarbeit ist aber notwendig:

    • du brauchst ein passendes tun.ko für deinen Kernel. Ich habe für den Kernel vom 1. Update (IG8) mal eines compiled und hier hochgeladen, das funktioniert vermutlich immer noch. Wenn nicht, musst du es halt selbst compilen: http://www.android-hilfe.de/rom-ers...e-kompilieren-erster-versuch-3.html#post60163
    • VPN Connections verwendet ein Script, um die eigentliche Arbeit zu machen. Offenbar gibts auf den HTC-Geräten eine besser ausgestattete Standard-Shell oder so; jedenfalls geht davon auf dem Galaxy die Hälfte nicht. Wenn du busybox installierst (z.B. aus einem der Recovery-Images, die kann man hiermit extrahieren) und die erste Zeile von /data/data/org.codeandroid.vpnc_frontend/files/vpnc-script entsprechend änderst (/system/bin/sh -> /system/bin/busybox sh), dann funktionierts
     
  3. Jay1982, 07.09.2009 #3
    Jay1982

    Jay1982 Threadstarter Android-Experte

    Beiträge:
    666
    Erhaltene Danke:
    71
    Registriert seit:
    17.07.2009
    Hab schon gedacht ich bin der einzige der VPN braucht *g*
    Vielen Dank erstmal, ich werd das heute mal probieren. Die tun.ko hatte ich in meiner Verzweiflung schon von dort genommen, war wohl wenigstens schonmal der erste richtige Schritt *g*

    Noch eine Frage hätte ich, da ich mich bisher bei Linux immer vom Kernel ferngehalten habe: Muss ich den insmod Befehl dann jedesmal ausführen? Oder lädt vpnc selbiges dann automatisch nach (so hatte ich nämlich die Beschreibung auf der Homepage verstanden)?
     
  4. Jay1982, 07.09.2009 #4
    Jay1982

    Jay1982 Threadstarter Android-Experte

    Beiträge:
    666
    Erhaltene Danke:
    71
    Registriert seit:
    17.07.2009
    So brauch doch nochmal deine Hilfe... Dein Unpack-img Link geht leider nicht mehr, aber hab mir Busybox einfach von hier besorgt: Place Ghantoos Running Debian on a Samsung Galaxy under Android

    Wollte das Ganze dann mit adb push draufballern, aber geht irgendwie nicht... Überall ist die Rede vom Recovery Mode, da hab ich die V3 vom hdblog drauf, aber wenn ich den starte bekomm ich keine Device Verbindung... Und wenns normal hochfährt isses ja read-only...
    Von daher kann ich auch keine shell starten um den Ordner mit mkdir zu erstellen...
     
  5. leromarinvit, 07.09.2009 #5
    leromarinvit

    leromarinvit Erfahrener Benutzer

    Beiträge:
    202
    Erhaltene Danke:
    13
    Registriert seit:
    08.07.2009
    Hm, die haben offenbar irgendeinen Link-Schutz oder so, der aus irgendeinem Grund 404 liefert. Warum auch immer. Der Link stammt jedenfalls von hier und geht dort auch noch: HOWTO: Unpack, Edit, and Re-Pack Boot Images - Android Wiki

    Damit adb push geht, musst du /system als rw remounten. Das geht entweder mit "adb remount", wenn du einen Kernel mit entsprechend modifizierter Ramdisk hast (z.B. den von hdblog). Wenn nicht, einfach adb shell starten und dort "mount -o remount,rw /dev/block/mtdblock1 /system" eingeben. Dann sollte push funktionieren.

    Warum du im Recovery nicht reinkommst weiß ich nicht; ich hatte das auch irgendwann, aber das war grad nach einem Hard Reset und ist wieder verschwunden, nachdem ich im normalen System USB Debugging aktiviert hab. Muss aber nicht unbedingt zusammenhängen...
     
  6. Jay1982, 07.09.2009 #6
    Jay1982

    Jay1982 Threadstarter Android-Experte

    Beiträge:
    666
    Erhaltene Danke:
    71
    Registriert seit:
    17.07.2009
    Hm...

    Also entweder bin ich doof oder sonstwas:

    C:\android-sdk-windows-1.5_r3\tools>adb shell
    $ mount -o remount,rw /dev/block/mtdblock1 /system
    mount -o remount,rw /dev/block/mtdblock1 /system
    mount: Operation not permitted

    Also das ganze wenns Handy ganz normal läuft + Debugging Modus oder?

    Edit:
    Also in den Recovery Modus komm ich schon rein (also die V3 von drakaz), aber dort steht dann in adb das das Device offline wär...

    Edit 2:
    Argh Sorry ^^ adb server neu starten hilft *g* push ging jetzt thx erstmal
     
    Zuletzt bearbeitet: 07.09.2009
  7. leromarinvit, 07.09.2009 #7
    leromarinvit

    leromarinvit Erfahrener Benutzer

    Beiträge:
    202
    Erhaltene Danke:
    13
    Registriert seit:
    08.07.2009
    Das geht natürlich alles nur als root, also vorher noch ein su. :)

    @recovery: genau so hab ich das auch gemeint

    EDIT: ok, wenns jetzt geht dann passt ja alles
     
  8. Jay1982, 07.09.2009 #8
    Jay1982

    Jay1982 Threadstarter Android-Experte

    Beiträge:
    666
    Erhaltene Danke:
    71
    Registriert seit:
    17.07.2009
    Hm... Also ich bin im Recovery, adb push ging (busybox ist auch in /tmp angekommen), aber:
    C:\android-sdk-windows-1.5_r3\tools>adb shell
    / # su
    su
    su: permission denied

    Das muss ich jetzt nicht verstehen oder???
     
  9. leromarinvit, 07.09.2009 #9
    leromarinvit

    leromarinvit Erfahrener Benutzer

    Beiträge:
    202
    Erhaltene Danke:
    13
    Registriert seit:
    08.07.2009
    Im Recovery brauchst du kein su, da bist du schon root. Das ist nur im normalen System notwendig, aber natürlich musst du das su vorher installieren. Das geht aber nur als root, also entweder ausm Recovery oder mit gepatchtem Kernel (Ramdisk).

    Das Drakaz-Recvoery hat doch so eine "enable su" Option oder so, vielleicht funktioniert die ja. Hab ich noch nie probiert.

    Aber du kannst das alles auch ausm Recovery heraus machen:
    Code:
    mount /system
    cp /tmp/busybox /system/bin
    mount /dev/block/mmcblk0p1 /data
    vi /data/data/org.codeandroid.vpnc_frontend/files/vpnc-script
    
    Alternativ, wenn du dich mit vi nicht auskennst, einfach pull, aufm PC bearbeiten, push zurück. Aber aufpassen, dass die Zeilenenden im Unix-Stil bleiben, also nicht das normale Windows-Notepad verwenden!
     
  10. Jay1982, 07.09.2009 #10
    Jay1982

    Jay1982 Threadstarter Android-Experte

    Beiträge:
    666
    Erhaltene Danke:
    71
    Registriert seit:
    17.07.2009
    Ok thx hat alles funktioniert, nur bringt VPNC immer noch ne Fehlermeldung und stürzt ab...
     
  11. leromarinvit, 07.09.2009 #11
    leromarinvit

    leromarinvit Erfahrener Benutzer

    Beiträge:
    202
    Erhaltene Danke:
    13
    Registriert seit:
    08.07.2009
    Hast du tun.ko vorher manuell geladen oder lässt du das VPNC machen? Bei meinem kurzen Test gestern hab ichs nicht geschafft, eine Fehlermeldung oder einen Absturz zu verursachen - es ist einfach nicht gegangen, wenn ichs nicht manuell geladen hab. Ein Absturz deutet aber darauf hin, dass tun.ko nicht zum Kernel kompatibel ist. Wundert micht aber, weil AFAIK hat sich nicht wirklich geändert hat bei den bisherigen Updates; das tun.ko aus dem OpenVPN-Thread hab ich auch aus generischen 2.6.27 Sourcen compiled, das war vor der Veröffentlichung der richtigen. Bei mir hat das immer funktioniert; jetzt hab ich aber einen selbst kompilierten Kernel und daher auch ein anderes tun.ko Modul.

    Hat die Fehlermeldung einen brauchbaren Inhalt oder ist die von der Sorte "Geht nicht, Pech gehabt"? Kannst du den Inhalt von /data/data/org.codeandroid.vpnc_frontend/files/last_connection.log (oder so ähnlich...) posten?
     
  12. Jay1982, 07.09.2009 #12
    Jay1982

    Jay1982 Threadstarter Android-Experte

    Beiträge:
    666
    Erhaltene Danke:
    71
    Registriert seit:
    17.07.2009
    Sorry net gesehen beim F5 drücken, dass es schon auf Seite 2 weitergeht *g*

    Also, deine tun.ko aus dem einen Openvpn Thread manuell per Conenctbot und "insmod" geladen vorher:

    Von den Daten her stimmts... Auf jeden Fall stürzt VPNC nicht mehr beim Versuch zu connecten ab... Bringt jetzt nur wie im Log ersichtlich "Connection failed"
     
  13. leromarinvit, 07.09.2009 #13
    leromarinvit

    leromarinvit Erfahrener Benutzer

    Beiträge:
    202
    Erhaltene Danke:
    13
    Registriert seit:
    08.07.2009
    Seltsam. Bei mir hats funktioniert... Hat das insmod geklappt, was sagt denn lsmod? Ansonsten, irgendwas interessantes im Kernel Log (dmesg)?

    Edit: busybox funktioniert? Sprich, hast du ein chmod 755 /system/bin/busybox gemacht nach dem push? Ist bei Windows notwendig.
     
    Zuletzt bearbeitet: 07.09.2009
  14. Jay1982, 08.09.2009 #14
    Jay1982

    Jay1982 Threadstarter Android-Experte

    Beiträge:
    666
    Erhaltene Danke:
    71
    Registriert seit:
    17.07.2009
    insmod funktioniert ohne Fehler und tun wird als activ bei lsmod angezeigt...

    hab heute auch nochmal den chmod auf die busybox gemacht, das sagts android log (hab ich mir mit sendlog geschickt)

     
  15. leromarinvit, 08.09.2009 #15
    leromarinvit

    leromarinvit Erfahrener Benutzer

    Beiträge:
    202
    Erhaltene Danke:
    13
    Registriert seit:
    08.07.2009
    Was passiert denn, wenn du /data/data/org.codeandroid.vpnc_frontend/files/vpnc manuell auf der Konsole startest, entweder über adb oder mit ConnectBot? (natürlich als root, also vorher su) Dort soilte man die Verbindungsdaten manuell eingeben können, wäre interessant ob vpnc dann weiter kommt.
     
  16. Jay1982, 08.09.2009 #16
    Jay1982

    Jay1982 Threadstarter Android-Experte

    Beiträge:
    666
    Erhaltene Danke:
    71
    Registriert seit:
    17.07.2009
    Argh ich will ne Hardware Tastatur *g*

    Also manueller Aufruf bring die Eingabe der Daten und danach dann:

    Edith sagt:
    Sehe auch unter netcfg nen tun0 Device mit Status "down"
     
  17. leromarinvit, 08.09.2009 #17
    leromarinvit

    leromarinvit Erfahrener Benutzer

    Beiträge:
    202
    Erhaltene Danke:
    13
    Registriert seit:
    08.07.2009
    Sorry, das Script hat einen non-standard path.

    Das hier funktioniert bei mir; wenns bei dir nicht geht, sollte zumindest eine brauchbare Fehlermeldung rauskommen:
    Code:
    insmod tun.ko
    mkdir /dev/net/tun
    ln -s ../tun /dev/net/tun
    /data/data/*vpn*/files/vpnc --script /data/data/*vpn*/files/vpnc-script
     
  18. Jay1982, 08.09.2009 #18
    Jay1982

    Jay1982 Threadstarter Android-Experte

    Beiträge:
    666
    Erhaltene Danke:
    71
    Registriert seit:
    17.07.2009
    Per Connectbot und su kann er das mkdir schon nicht machen: No such file or directory
     
  19. leromarinvit, 08.09.2009 #19
    leromarinvit

    leromarinvit Erfahrener Benutzer

    Beiträge:
    202
    Erhaltene Danke:
    13
    Registriert seit:
    08.07.2009
    äh, das hätte /dev/net heißen sollen...

    und wenn du vpnc schon mal gestartet hast seit dem letzten reboot, ist es auch nicht notwendig.
     
  20. Jay1982, 08.09.2009 #20
    Jay1982

    Jay1982 Threadstarter Android-Experte

    Beiträge:
    666
    Erhaltene Danke:
    71
    Registriert seit:
    17.07.2009
    Beim ln kommt "Link failed File exists"
     

Diese Seite empfehlen