1. Nimm jetzt an unserem Uhans - 3. ADVENT - Gewinnspiel teil - Alle Informationen findest Du hier!

Apps nach Installation von 1.6 nicht auffindbar

Dieses Thema im Forum "Root / Hacking / Modding für Samsung Galaxy" wurde erstellt von suchard, 23.02.2010.

  1. suchard, 23.02.2010 #1
    suchard

    suchard Threadstarter Junior Mitglied

    Beiträge:
    31
    Erhaltene Danke:
    2
    Registriert seit:
    25.08.2009
    Ich habe es schon mal im Thread bzgl. der neuen Firmware 1.6 versucht, dort ist es wohl aber zu unübersichtlich, daher versuch ich es mal mit einem eigenen Thema:

    Ich hab ein Problem, vermutlich sehe ich den Wald vor lauter Bäumen nicht:
    Habe nun auch die 1.6 mit ODIN installiert.
    Auch diverse Apps installiert, alles wunderbar.
    Nur kann ich auf der SD-Karte (intern) die installierten Apps mit ihren Ordnern nicht mehr finden. Bei 1.5 hatte ich dort z.B. einen Ordner "COPILOT", oder "missed_call".
    Die gesamten installierten Apps finde ich nun aber nicht mehr. Sie laufen aber. Habe schon hier und im Web gesucht aber nichts dazu gefunden.
    Die Standard *.apk's (Apps, welche mit Firmware installiert werden) finde ich, nur eben nicht die der nachträglich über den Market installierten Apps und deren ggf. nötigen Ordner.
    Wo finde ich die Apps. Muss ich bei 1.6 root installieren, oder wo liegt mein Fehler???
    Wer kann einem Dummie helfen?
     
  2. marwei27, 23.02.2010 #2
    marwei27

    marwei27 Erfahrener Benutzer

    Beiträge:
    208
    Erhaltene Danke:
    9
    Registriert seit:
    09.08.2009
    ich bin fast der meinung das es auch auf /system/data/app
    oder nur /data/app liegt
     
  3. suchard, 23.02.2010 #3
    suchard

    suchard Threadstarter Junior Mitglied

    Beiträge:
    31
    Erhaltene Danke:
    2
    Registriert seit:
    25.08.2009
    Zunächst einmal Danke, aber:

    /system/data/app gibt es bei mir nicht.
    Nur /system/app, und da sind nur die Apps, welche mit der Firmware gekommen sind, vorhanden.

    Der /data - Ordner ist komplett leer
    :confused:


    Edit:
    Es scheint tatsächlich so, dass die später installierten Apps nach:
    /data/apps
    installiert werden.

    Nur warum bekomme ich den Inhalt des Ordners /data z.B. mit Astro oder AndExplorer nicht angezeigt?
     
    Zuletzt bearbeitet: 23.02.2010
  4. marwei27, 23.02.2010 #4
    marwei27

    marwei27 Erfahrener Benutzer

    Beiträge:
    208
    Erhaltene Danke:
    9
    Registriert seit:
    09.08.2009
    hatte bei mir auch nich geklappt.
    versuch ma mit connectbot oder so zu remounten mit schreibrechte.

    ich hab auch so meine probleme mit connectbot und astro.
     
    suchard bedankt sich.
  5. suchard, 23.02.2010 #5
    suchard

    suchard Threadstarter Junior Mitglied

    Beiträge:
    31
    Erhaltene Danke:
    2
    Registriert seit:
    25.08.2009


    Danke für den Tipp, aber das Tool geht mir zu sehr ins Eingemachte, das scheint mir zu kompliziert.:(
     
  6. Thyrion, 24.02.2010 #6
    Thyrion

    Thyrion Ehrenmitglied

    Beiträge:
    11,849
    Erhaltene Danke:
    2,452
    Registriert seit:
    21.07.2009
    Phone:
    Nexus 5X
    @suchard: Die Apps wurden auch mit 1.5 bereits in diesen Ordner (/data/app) installiert. Nur die Daten die die Anwendungen selbst geschrieben haben, landeten in einem Ordner auf der SD-Karte (wenn sie nicht in der internen Datenbank gespeichert wurden).
     
  7. suchard, 24.02.2010 #7
    suchard

    suchard Threadstarter Junior Mitglied

    Beiträge:
    31
    Erhaltene Danke:
    2
    Registriert seit:
    25.08.2009

    Hallo Thyrion,

    vielen Dank, habe ich auch festgestellt.
    Nur warum ist dieser Ordner für mich seit 1.6 nicht sichtbar?
    /data ist vorhanden, wird aber komplett leer angezeigt???

    Bin für weitere Hinweise dankbar, ist das nur bei mir so?

    Grüße
     
  8. Thyrion, 24.02.2010 #8
    Thyrion

    Thyrion Ehrenmitglied

    Beiträge:
    11,849
    Erhaltene Danke:
    2,452
    Registriert seit:
    21.07.2009
    Phone:
    Nexus 5X
    Dir fehlt nur die Berechtigung den Inhalt zu sehen - auch das war bei 1.5 schon so.

    Beispiel: Ich habe mit ConnectBot eine lokale Konsole aufgemacht und in den Ordner gewechselt. "ls" zeigt mir dann an, dass ich nicht ausreichende Rechte habe, um auf den Inhalt zuzugreifen. Wechsel ich dann zur Root-Konsole ("su"), dann sehe ich den Inhalt.

    Ich denke mal, das hängt auch damit zusammen, welche Rechte eine Anwendung von vorneherein anfordert. AppManager lesen ja auch die Dateien aus dem Ordner.
     
    suchard bedankt sich.
  9. suchard, 24.02.2010 #9
    suchard

    suchard Threadstarter Junior Mitglied

    Beiträge:
    31
    Erhaltene Danke:
    2
    Registriert seit:
    25.08.2009

    Danke Dir!
    Nur merkwürdig, dass ich bei 1.5 ohne weiteres zutun das Verzeichnis einsehen konnte. Bleibt nur die Möglichkeit das eine installierte App hier ggf. die Rechte "bereitstellte"!?!
     
  10. marwei27, 24.02.2010 #10
    marwei27

    marwei27 Erfahrener Benutzer

    Beiträge:
    208
    Erhaltene Danke:
    9
    Registriert seit:
    09.08.2009
    Wenn du als su (superuser) angemeldet bist kannst du die rechte vergeben

    mit
    Code:
    ls -l
    erhälst du eine übersicht

    zum ändern der rechte gibst du
    Code:
    chmod
    ein
    beispiel:
    Code:
    chmod 644 /system/app/***.apk
    das wäre zum beispiel die standardvergabe der rechte für das system

    wie die rechtevergabe bei /data/ ist, kann ich dir grad nich sagen

    auf http://pmhahn.de/linux/permission/index.html gibs ne supi anleitung:D
     
    Zuletzt bearbeitet: 24.02.2010
    suchard bedankt sich.

Diese Seite empfehlen