1. Nimm jetzt an unserem 2. ADVENT-Gewinnspiel teil - Alle Informationen findest Du hier!

Automatische CPU Taktung = Defy hängt minutenlang,CPU auf Max und alles rennt ?

Dieses Thema im Forum "Motorola Defy Forum" wurde erstellt von kabby, 03.05.2011.

  1. kabby, 03.05.2011 #1
    kabby

    kabby Threadstarter Android-Experte

    Beiträge:
    587
    Erhaltene Danke:
    176
    Registriert seit:
    12.01.2011
    Hi zusammen,

    also ich hab mich bemüht um die forensuche aber nichts gefunden (sollt es dazu was geben bitte einfach verschieben )

    Und zwar hab ich n problem mit meinem defy was Games betrifft wie NFS Shift oder TurboFLy 3D.

    Lasse ich Vsel und andere CPU tools runter sollte sich das Defy ja alleine hochtakten...
    Bei NFS Shift und TurboFly3D stockt es dann aber erheblichst bis zur unspielbarkeit weil echt nichts mehr geht.

    Auch nach beenden des games kaggt das handy totalst ab, nichts reagiert, es braucht echt minuten bis sich was tut.
    Auch taskmanager genuzt um alles zu beenden - nichts zu machen das handy schneckt sich einen ab.

    nach 10minuten gings dann wieder.

    EInstellungen - Akku Manager - Leistungsmodus is eingestellt (macht ja eigentlich auch nichts aus)


    Sooo, wenn ich dann mit vsel oder SetCPU Performance modus (also auf 800Mhz oder mehr) Stelle laufen auf einmal die games spielbar.

    USB Debugging ein oder aus macht keinen unterschied.

    3.4.2.-117 hab ich drauf.


    Woran liegts problem ?
    wär n bissken doof wenns echt nur dann geht wenn ich mit den besagten tools die cpu erstmal zwischen die beine treten müsste.


    es grüsst, der kabby :)
     
  2. Dodge, 03.05.2011 #2
    Dodge

    Dodge Android-Guru

    Beiträge:
    2,125
    Erhaltene Danke:
    444
    Registriert seit:
    03.06.2010
    Lass bei FroYo trotzdem den USB-Debugmodus an.

    Meiner lief mit 1Ghz (vsel60) absolut flüssig, NfS Shift hab ich durch^^

    Eingestellt mit SetVsel, auf 75%, mittlerer Takt war 700Mhz (48vsel).

    Hochtakten tut es eben nur nach dem threshold-wert, der erreicht wird.

    Leistungsmodus bedeutet, das es so schnell wie möglich hochtaktet. (Schneller wie ondemand)
     
  3. kabby, 03.05.2011 #3
    kabby

    kabby Threadstarter Android-Experte

    Beiträge:
    587
    Erhaltene Danke:
    176
    Registriert seit:
    12.01.2011
    macht's ja nicht von alleine.

    is ja die sache die n bissl wurmt.

    warum gehts nicht ohne fremde hilfe ?

    *edit*

    nun ist es trotz 800mhz setting ganz abgeschmiert -.-
    das ist einfach abfi***end nervig
    bishin zum neustart grad abgeschissen
     
  4. Krassu$, 03.05.2011 #4
    Krassu$

    Krassu$ Android-Hilfe.de Mitglied

    Beiträge:
    93
    Erhaltene Danke:
    10
    Registriert seit:
    14.04.2011
    Phone:
    Motorola Defy
    wie kann man denn auf eine bestimmte taktung stellen? das ist imo mit den genannten tools garnicht möglich.

    auf welchen wert hast du up_threshold eingestellt? (der schieberegler in SetVsel)? damit kann man alles durcheinander bringen, default ist 86% und damit sollte das defy brav hin und her schalten.
     
  5. kabby, 03.05.2011 #5
    kabby

    kabby Threadstarter Android-Experte

    Beiträge:
    587
    Erhaltene Danke:
    176
    Registriert seit:
    12.01.2011
    was erzählst du da?

    es geht nicht aufs mhz genaue takten sondern das er in dem bereich arbeitet.
    sicher wenn du 1200mhz eingibst wird er da laufen.

    die tools zeigen nicht nur bunte zahlen an.


    btw, auf 800mhz rennt alles.
    bei 600 zickt er noch rum.

    *edit*

    das defy sollte auch ohne jegliches tool brav hin und her schalten ;)
     
    Zuletzt bearbeitet: 03.05.2011
  6. Krassu$, 03.05.2011 #6
    Krassu$

    Krassu$ Android-Hilfe.de Mitglied

    Beiträge:
    93
    Erhaltene Danke:
    10
    Registriert seit:
    14.04.2011
    Phone:
    Motorola Defy
    Die Tools ändern nur Werte die es auch ohne sie gibt, das Defy schaltet mit oder ohne Tools hoch, entsprechend der Einstellungen. Wenn dir deine verstellten Settings nich passen, dann drück doch in SetVsel einfach auf "Set defaults" und deinstalliere die App.
     
  7. obiwan, 03.05.2011 #7
    obiwan

    obiwan Ehrenmitglied

    Beiträge:
    3,970
    Erhaltene Danke:
    1,231
    Registriert seit:
    16.12.2009
    Es sinkt für Sie heute, das Niveau!
    Eine bitte an euch beide, versetzt euch mal in die Lage eines android/defy-neulings der zum ersten mal in diesem forum ist und das hier liest. Und auch für alle anderen ist so ein ton nicht schön.

    </kritik>
     
    Dodge bedankt sich.
  8. Krassu$, 03.05.2011 #8
    Krassu$

    Krassu$ Android-Hilfe.de Mitglied

    Beiträge:
    93
    Erhaltene Danke:
    10
    Registriert seit:
    14.04.2011
    Phone:
    Motorola Defy
    Ah, wenn ich das so lese bin ich gern ahnungslos, hier rennt alles wie geschmiert:)

    Viel Spaß noch beim Rebooten!
     
  9. vetzki, 03.05.2011 #9
    vetzki

    vetzki Android-Ikone

    Beiträge:
    5,942
    Erhaltene Danke:
    1,492
    Registriert seit:
    21.11.2010

    Um mal ein bischen sachlich zu bleiben:
    2. So wie ich es verstanden habe meint er ohne setvsel o.ä., also mit standardtakt 33/300 48/600 58/800 treshold: 86

    3. Gibt ja diverse Programme die das können im Market, z.b osmonitor ohne das an der taktung was verändert wird

    4. Defaultsettings, hab ich jedenfalls so verstanden

    Kann kabby aber leider bei seinem Problem nicht wirklich helfen, vll. liegts an dem speicherbug der 2.2 erst ROMs (s. entspr. Thread) evtl. mit sysctl Free Kbytes auf 4096 setzen


    Gesendet mit der Android-Hilfe.de-App
     
  10. kabby, 03.05.2011 #10
    kabby

    kabby Threadstarter Android-Experte

    Beiträge:
    587
    Erhaltene Danke:
    176
    Registriert seit:
    12.01.2011
    3 seitenlang und immer wieder erwähne ich, es soll ohne setvsel und co laufen....

    mal jemand der sich dem problem annimmt.

    @ Vetzki,

    werd das gleich mal probieren, danke :)

    @ krassus, mit setcpu auf 800 ;)
    nicht mit setvsel, aber ich habs ja erst 15mal erwähnt ?
    ebenso oft wurds überlesen
     
  11. Krassu$, 03.05.2011 #11
    Krassu$

    Krassu$ Android-Hilfe.de Mitglied

    Beiträge:
    93
    Erhaltene Danke:
    10
    Registriert seit:
    14.04.2011
    Phone:
    Motorola Defy
    Wieso Spaßbremse, ich finde ihn sehr unterhaltsam:wubwub:

    Vielleicht kommen wir dem Problem ja näher wenn er uns verrät wie er "ohne die tools" sieht auf welchem Takt das Defy gerade arbeitet, ggf. ist das ja das Problem:winki:
     
  12. Dodge, 03.05.2011 #12
    Dodge

    Dodge Android-Guru

    Beiträge:
    2,125
    Erhaltene Danke:
    444
    Registriert seit:
    03.06.2010
    ist es auch nicht, da es die Taktraten (Beim Defy die dreierlei Hauptwerte [300,600,800]) aus dem Kernel ausließt.

    Da wir aber durch unseren liiiiiiiebsten Hersteller einen Riegel vorgeschoben bekommen haben - [​IMG] Bootloader - können wir
    die mod. Taktraten nicht im Kernel hinterlegen, wodurch SetCPU seine Grundaufgabe - Das Übertakten - nicht ausführen kann.


    btw. kabby ftw! :D
     
    Zuletzt bearbeitet: 03.05.2011
  13. kabby, 03.05.2011 #13
    kabby

    kabby Threadstarter Android-Experte

    Beiträge:
    587
    Erhaltene Danke:
    176
    Registriert seit:
    12.01.2011
    right, aber mann kann mit setcpu zumindest die cpu auf ihre ~800mhz laufen lassen.
    auch wenns nicht zu empfehlen ist.

    aber mal zum thema bitte :(

    wieso machts defy sich nicht selber und taktet hoch wenn ich zocke ?
    das geht mir total auf den .....
    das hat zu spuren und fertig.
    will da nicht erst mit setvsel drohen damit das läuft - mein pc takte ich auch ... scheisse okay der is eh OC also kann ich den vergleich knicken....

    mein notebook z.b., das trudelt bei umme 600mhz rum bei normal use, fang ich an zu zocken - TM Nations o.ä. brauch ich bumms und dann steckt auch son kleiner dicker im notebook zwecks stromversorgung.
    dann kachelt das teil aber hoch und gibt sich seiner urgewalt hin und ich kann zocken.

    das schafft sogar mein Pentium M ohne jegliche tools (kannste auch undervolten und underclocken bis zum erbrechen... auf wunsch wirds n "Biest" )
     
  14. Krassu$, 03.05.2011 #14
    Krassu$

    Krassu$ Android-Hilfe.de Mitglied

    Beiträge:
    93
    Erhaltene Danke:
    10
    Registriert seit:
    14.04.2011
    Phone:
    Motorola Defy
    Aha. Es kann seinen Takt eigentlich nich ändern, aber es führt dazu dass sein Problem verschwindet und sein Takt für ihn offenbar geändert angezeigt wird.

    Wenn da mal keine Magie im Spiel ist:)

    Ich wäre immernoch an den Ausgaben von SetVsel nach dem Boot interessiert-.-
     
  15. Dodge, 03.05.2011 #15
    Dodge

    Dodge Android-Guru

    Beiträge:
    2,125
    Erhaltene Danke:
    444
    Registriert seit:
    03.06.2010
    Das ist echt blöd..

    Mal umgeflasht?
    FullWipe brauch ich - glaub ich nicht erwähnen ;)
    Wie bist du zu dem Standpunkt gekommen? Im System gepfuscht (auch wenn ich dir vertraue, dass du weißt, was du tust)
     
  16. kabby, 03.05.2011 #16
    kabby

    kabby Threadstarter Android-Experte

    Beiträge:
    587
    Erhaltene Danke:
    176
    Registriert seit:
    12.01.2011
    @ Dogde, ne also klar fullwipe flash etc der ganze krempel und stanni statusleiste.
    also nichts rumgepfuscht nichtmal root o.ä.

    *edit*
    ähm ne nichts rumgepfuscht - ganz ehrlich, wär ja sonst klar wo das problem zu 99% liegen würd :D
    *edit*

    das dann mit root probiert, debug on/off probiert...

    beim gamen laggt es total ishin zum kompletten aufhänger und bei 2 von 5 versuchen sogar reboot (akkutemp 27°)

    p.s.:hast n liebesbrief auf deinem profil :D

    @ krassus

    ändert er ja nicht bzw setcpu machts ja nichts anderes die setvsel.
    wenn du bei setvsel 800 oder von mir aus 1200 @ 64 einstellst, performance klickst geht der stromvrbrauch ja auch dezent hoch (dezent :D )

    mich wurmt es das es sich ohne jegliches zutun halt nicht hochtaktet...
     
    Dodge bedankt sich.
  17. fighterchris, 03.05.2011 #17
    fighterchris

    fighterchris Ehrenmitglied

    Beiträge:
    7,270
    Erhaltene Danke:
    1,487
    Registriert seit:
    16.08.2010
    Phone:
    LG G2
    Seit ihr nun hier Fertig mit euren Anfeindungen und Beleidigungen ??

    Falls ich oder einer der MOD Kollegen nochmals was in der Art lese ,wird der Thread ohne weiteres geschlossen.


    Die beiden Streithähne bekommen noch ne PN von mir


    Und nun bitte Zurück zum eigentlichen Thema des Threads
     
    Talahthas bedankt sich.
  18. obiwan, 03.05.2011 #18
    obiwan

    obiwan Ehrenmitglied

    Beiträge:
    3,970
    Erhaltene Danke:
    1,231
    Registriert seit:
    16.12.2009
    @kabby
    Mein AMD x4 zeigt unter Linux, 32er Kernel(hat froyo ja auch), ein ähnliches verhalten(wenn man von der mehrkern-CPU mal absieht). Allerdings nur auf ondemand. Jedoch nur bei bestimmten Anwendungen/Prozessen. Merkwürdig das du der einzige bist mit diesem Problem.
     
  19. stulle, 03.05.2011 #19
    stulle

    stulle Fortgeschrittenes Mitglied

    Beiträge:
    382
    Erhaltene Danke:
    107
    Registriert seit:
    06.11.2010
    Was Vetzki in Post #9 geschrieben hat klingt gut.

    Bei mir ist googlemaps (UK-Froyo 117) häufiger eingefroren. Mit dem App SystemPanel konnte ich sehen, dass die CPU auf 300 MHz getaktet war und kontinuierlich mit 100% Auslastung lief. Das Handy war in diesem Zustand kaum zu benutzen.

    Probier das mal bitte mit sysctl und min_free_kbytes=4096 aus. Würde mich echt interessieren, ob sich Dein Fehler damit beheben lässt. Mein googlemaps läuft seit dieser Änderung problemlos.
     
    Zuletzt bearbeitet: 03.05.2011
    Dodge und kabby haben sich bedankt.
  20. kabby, 03.05.2011 #20
    kabby

    kabby Threadstarter Android-Experte

    Beiträge:
    587
    Erhaltene Danke:
    176
    Registriert seit:
    12.01.2011
    es hilft und das ganz klar !

    danke :)

    nun hab ich ja direkt die frage - wieso machts defy das nicht alleine ?
     

Diese Seite empfehlen