1. Nimm jetzt an unserem Uhans - 3. ADVENT - Gewinnspiel teil - Alle Informationen findest Du hier!

Back to 2.1.36 -> Kameraproblem

Dieses Thema im Forum "Motorola Milestone Forum" wurde erstellt von AlfredENeumann, 22.03.2011.

  1. AlfredENeumann, 22.03.2011 #1
    AlfredENeumann

    AlfredENeumann Threadstarter Android-Lexikon

    Beiträge:
    1,197
    Erhaltene Danke:
    167
    Registriert seit:
    06.12.2009
    Phone:
    Huawei P8
    Nachdem Ich gestern mein o2 Froyo zerschossen habe bin ich wieder auf das 2.1 (Update 1) zurück.
    Jetzt hab ich aber diesen blöden Kamera-Bug, das der autofokus nicht richtig funktioniert.
    Der sollte doch eigentlich mit diesem Update behoben worden sein.
    Wie bekomme ich den am elegantesten jetzt weg?
    Reicht das wenn ich eine neue Kamera-app drauf ballere (und wenn ja wo bekomme ich die her?).
    Google mir hier nämlich schon seit ner Stunde die Finger wund.
     
    Zuletzt bearbeitet: 22.03.2011
  2. AlfredENeumann, 22.03.2011 #2
    AlfredENeumann

    AlfredENeumann Threadstarter Android-Lexikon

    Beiträge:
    1,197
    Erhaltene Danke:
    167
    Registriert seit:
    06.12.2009
    Phone:
    Huawei P8
    Hab jetzt nach langem suchen eine CameraMoto.APK gefunden die halbwegs brauchbare Bilder schiest, aber der Barcodescanner will immer noch nicht.
    Ich krich hier noch zuviel
     
  3. todd13, 06.04.2011 #3
    todd13

    todd13 Neuer Benutzer

    Beiträge:
    8
    Erhaltene Danke:
    0
    Registriert seit:
    06.04.2011
    Bei mir ist es noch schlimmer: Vor dem Update hatte der Autofocus ab und zu Aussetzer, seit dem Update hat er nicht einmal mehr funktioniert.
    Hat jemand ähnliche Erfahrungen gesammelt?
    Thx und Grüße, todd13
     
  4. Gregor901, 06.04.2011 #4
    Gregor901

    Gregor901 Android-Guru

    Beiträge:
    3,212
    Erhaltene Danke:
    1,953
    Registriert seit:
    11.12.2009
    Versuch mal die hier im Anhang. Stammt aus dem 2.2.1-APAC, aber sollte auch mit 2.1 laufen. Wenn nicht ---> Info

    Datei gehört in /system/apps. Permissions: 644 (nicht vergessen).
     

    Anhänge:

    todd13 bedankt sich.
  5. todd13, 07.04.2011 #5
    todd13

    todd13 Neuer Benutzer

    Beiträge:
    8
    Erhaltene Danke:
    0
    Registriert seit:
    06.04.2011
    Hallo Gregor,

    verrat mir bitte noch wie ich die Rechte auf 644 setzen kann? Danke!

    VG, todd
     
  6. TheSpiritof69, 07.04.2011 #6
    TheSpiritof69

    TheSpiritof69 Android-Guru

    Beiträge:
    2,392
    Erhaltene Danke:
    763
    Registriert seit:
    30.03.2010
    Phone:
    Nexus 5
    Terminal, su, chmod 644 /system/apps/CameraMoto.apk

    Eventuell vor chmod noch mount -o remount,rw /system
     
  7. todd13, 10.04.2011 #7
    todd13

    todd13 Neuer Benutzer

    Beiträge:
    8
    Erhaltene Danke:
    0
    Registriert seit:
    06.04.2011
    Hallo TheSpiritof69,

    zunächst mal Danke für Deine Antwort. Leider weiss ich nicht wie ich sie umsetzen soll. Gibt es eine ausführliche Anleitung für dieses Vorgehen?

    Danke und Grüße, todd13
     
  8. Gregor901, 10.04.2011 #8
    Gregor901

    Gregor901 Android-Guru

    Beiträge:
    3,212
    Erhaltene Danke:
    1,953
    Registriert seit:
    11.12.2009
    1.) Die o.a. Datei auf die SD-Card kopieren.
    2.) Phone starten und die Datei von der SD-Card mittels ROOT-EXPLORER (im Market) per Copy-Befehl in das Phone-Verzeichnis /system/apps/ reintun.
    3.) Die eben reinkopierte Camera.apk mit ROOTexplorer anwählen
    4.) Langer Druck und eine Auswahl öffnet sich.
    5.) Auf "Permissions" scrollen und auswählen
    6.) Folgende Haken setzen:

    x x -
    x - -
    x - -

    (das ist 644)

    Fertig und Reboot.
     
  9. todd13, 16.04.2011 #9
    todd13

    todd13 Neuer Benutzer

    Beiträge:
    8
    Erhaltene Danke:
    0
    Registriert seit:
    06.04.2011
    Hallo Gregor,

    danke erst mal!

    Leider habe ich folgende Probleme:

    1. Das Verzeichnis heißt bei meinem 2.2 Sytem/app nicht .../apps, ist aber vermutlich egal
    2. Ich kann mit dem Programm die Rechte nicht verändern, da "CameraMoto.apk permissions can not be changed because the file system is read only"

    Irgendwelche Vorschläge?

    Grüße, todd13
     
  10. TheSpiritof69, 16.04.2011 #10
    TheSpiritof69

    TheSpiritof69 Android-Guru

    Beiträge:
    2,392
    Erhaltene Danke:
    763
    Registriert seit:
    30.03.2010
    Phone:
    Nexus 5
    Im Root-Explorer oben "Remount R/W" anklicken
     
  11. todd13, 17.04.2011 #11
    todd13

    todd13 Neuer Benutzer

    Beiträge:
    8
    Erhaltene Danke:
    0
    Registriert seit:
    06.04.2011
    Hallo TheSpiritof69,

    danke für den Tip. Somit konnte ich auch prompt der Permissions einsehen/ändern. So weit so gut.

    Leider hat das an dem ursprünglichen Problem nichts geändert: Der Stein fokussiert einfach nicht mehr. Wenn ich die Kamera nahe genug an das Objekt halte wird der Rahmen grün, aber in jedem anderen Abstand bleibt er einfach rot:cursing:

    Gibt es noch weitere Ideen?

    Danke für jeden Tip!

    VG Todd13
     
  12. Gregor901, 17.04.2011 #12
    Gregor901

    Gregor901 Android-Guru

    Beiträge:
    3,212
    Erhaltene Danke:
    1,953
    Registriert seit:
    11.12.2009
    Reboot gemacht ??
     
  13. motoroller, 17.04.2011 #13
    motoroller

    motoroller Android-Experte

    Beiträge:
    740
    Erhaltene Danke:
    99
    Registriert seit:
    20.04.2010
    Phone:
    OnePlus One
    Hast Du vielleicht den Makromodus aktiviert?
     
  14. todd13, 19.04.2011 #14
    todd13

    todd13 Neuer Benutzer

    Beiträge:
    8
    Erhaltene Danke:
    0
    Registriert seit:
    06.04.2011
    Hallo Motoroller,

    ich wollte schon mit Schamesröte im Gesicht sagen dass ich soooo ein Hirsch bin, ABER
    Makro war nicht eingestellt.

    Was mir aufgefallen ist: Der Stein fiepst garnicht mehr so wie früher wenn die Kamera aktiv war...

    Irgendwelche weiteren Vorschläge?

    Danke an Alle und Grüße,

    todd13
     
  15. motoroller, 19.04.2011 #15
    motoroller

    motoroller Android-Experte

    Beiträge:
    740
    Erhaltene Danke:
    99
    Registriert seit:
    20.04.2010
    Phone:
    OnePlus One
    Tjoa, dann hab ich momentan keine Idee mehr...

    Wenn das unter Stock 2.1.36 nicht mehr geht, dann würde ich fast auf nen HW-Defekt tippen und das Teil zu Datrepair schicken, so lange Du noch Garantie hast. Wenn Du das direkt machst, hast Du Dein Steinchen innerhalb einer Woche wieder (obwohl ist ja Ostern).
     
  16. todd13, 22.04.2011 #16
    todd13

    todd13 Neuer Benutzer

    Beiträge:
    8
    Erhaltene Danke:
    0
    Registriert seit:
    06.04.2011
    Hab noch mal ein Reset gemacht (auf Werkszustand zurückgesetzt), hat aber nichts gebracht:angry:

    Werde den Stein morgen zur Kundendienst bringen. In dem Zusammenhang: Wie kann man den Stein "entrouten"?

    Danke und insbesondere an alle die mir bei dem Kamera Problem geholfen haben!

    VG, todd13
     
  17. -FuFu-, 23.04.2011 #17
    -FuFu-

    -FuFu- Android-Urgestein

    Beiträge:
    8,406
    Erhaltene Danke:
    3,148
    Registriert seit:
    17.03.2010
    Phone:
    Motorola Moto E 2.Gen
  18. todd13, 23.05.2011 #18
    todd13

    todd13 Neuer Benutzer

    Beiträge:
    8
    Erhaltene Danke:
    0
    Registriert seit:
    06.04.2011
    Hallo Zusammen,

    an dieser Stelle möchte ich mich für die viele Hilfe bedanken. Ich habe meinen Stein eingeschickt. Eine Woche später war er wieder da und hatte ein neues Kameramodul.

    Thx!
     

Diese Seite empfehlen