1. Nimm jetzt an unserem Uhans - 3. ADVENT - Gewinnspiel teil - Alle Informationen findest Du hier!

Backup mit nvflash

Dieses Thema im Forum "Toshiba AC100 Forum" wurde erstellt von Conzi, 19.06.2011.

  1. Conzi, 19.06.2011 #1
    Conzi

    Conzi Threadstarter Android-Hilfe.de Mitglied

    Beiträge:
    58
    Erhaltene Danke:
    24
    Registriert seit:
    29.04.2011
    Phone:
    Sony Ericsson Xperia X10 Mini
    Hallo,

    ich greife das das Thema "Vollsicherung mit nvflash" mal neu auf und packe es der Übersichtlichkeit halber in einen eigenen Thread. Diese Kurzanleitung enthält eine Beschreibung für Windows und eine für Linux. Die benötigten Tools und Skripte habe ich jeweils zum Download angehängt. Alle Schritte sind getestet und funktionieren bei mir. Ich übernehme natürlich keinerlei Garanie, dass es bei Euch auch klappt! Feedback ist erwünscht ;-)

    *** Linux ***
    Ich verwende Ubuntu 11.04 und musste keine vorbereitenden Schritte durchführen. Das AC100 wurde problemlos und sofort von nvflash erkannt. Einzig 7z (p7zip-full) muss installiert werden.
    • Backupskript und -tools herunterladen und in /tmp speichern
    • Das AC100 mit CTRL-ESC-POWER in den Flash-Modus versetzen
    • mit STRG-ALT-T eine Konsole öffnen
    • in der Konsole wie folgt 7z installieren (nur falls noch nicht geschehen!), in den Ordner /tmp wechseln, das Archiv entpacken und das Backup durchführen...
      Code:
      martin@bigtux:~$ [B]sudo apt-get install p7zip-full[/B]
      martin@bigtux:~$ [B]cd /tmp[/B]
      martin@bigtux:/tmp$ [B]7z x ac100_full_backup.linux.7z.zip [/B]
      martin@bigtux:/tmp$ [B]cd ac100_full_backup/[/B]
      martin@bigtux:/tmp/ac100_full_backup$ [B]./ac100_full_backup.sh[/B]
      
    Nun befindet sich (wenn keine Fehler aufgetreten sind) im Ordner /tmp/ac100_full_backup/Zeitstempel_ac100_full_backup eine komplette Sicherung aller Partitionen. Man kann das Backup überprüfen indem man die Dateigrößen mit denen in der Datei partitiontable.txt vergleicht und/oder die Partitionen loop mountet - siehe unten. Das loop mounten funktioniert nicht mit allen Partitionen!

    Hinweis: Es kann sein, dass nvflash bei der Partition 14 folgendes meldet:
    receiving file: part14.img, expected size: -106430464 bytes
    / 1598554112/-106430464 bytes receiveddata receive failure NvError 0x120000
    command failure: read failed
    Anscheinend kommt nvflash nicht mit der 5.5GB großen Datenpartition klar und lässt irgendeine Variable überlaufen. Das Backup ist aber trotzdem i.O. Man kann die einzelnen Partitionen überprüfen, indem man diese - wie bereits erwähnt - als loop mountet:
    Code:
    martin@bigtux: /tmp/ac100_full_backup$ [B]mkdir /mnt/loop/[/B]
    martin@bigtux: /tmp/ac100_full_backup$ [B]sudo mount -o loop /tmp/ac100_full_backup/[I]Zeitstempel[/I]_ac100_full_backup/14_UDB_raw.img /mnt/loop[/B]
    
    Jetzt kann man mal mit einem Dateimanager oder die Konsole reinschauen oder Änderungen vornehmen ;-) Anschließend aushängen nicht vergessen!
    Code:
    martin@bigtux: /tmp/ac100_full_backup$ [B]sudo umount /mnt/loop[/B]
    

    *** Windows ***
    Es gibt Berichte, dass der USB-Treiber für das AC100 unter Windows 7 64bit nicht installiert werden kann. Windows 7 32bit wurde als funktionierend gemeldet. Ich habe alle Schritte auf Windows XP durchgeführt....

    • Backupskript und -tools herunterladen und in C:\tmp speichern. Dieser Ordner muss evtl noch angelegt werden.
    • Archiv entpacken. Es sollte im Ordner C:\tmp\ac100_full_backup landen
    • Das AC100 mit CTRL-ESC-POWER in den Flash-Modus versetzen
    • Das Backup durch Aufrufen der ac100_full_backup.bat starten.

    Das Backup befindet sich (wenn keine Fehler aufgetreten sind) im Ordner C:\tmp\ac100_full_backup\backup - dieser Ordner sollte mit einem Zeitstempel versehen und umbenannt (z.B. 20110619_full_backup) werden. Man kann das Backup überprüfen indem man die Dateigrößen mit denen in der Datei partitiontable.txt vergleicht.

    Hinweis: Bei Problemen mit der Partition 14 -> siehe "Linux"
     

    Anhänge:

    Zuletzt bearbeitet: 27.11.2011
    crankrider, viruzMJ, hargar und 3 andere haben sich bedankt.
  2. matula, 19.06.2011 #2
    matula

    matula Android-Experte

    Beiträge:
    895
    Erhaltene Danke:
    127
    Registriert seit:
    31.07.2009
    Phone:
    LG G2
    Tablet:
    Samsung Galaxy Note 8.0
    super, vielen Dank
    ...und gepinnt
     
    netbook21 bedankt sich.
  3. Eddie8, 07.07.2011 #3
    Eddie8

    Eddie8 Fortgeschrittenes Mitglied

    Beiträge:
    278
    Erhaltene Danke:
    38
    Registriert seit:
    22.03.2009
    Phone:
    Sony Xperia Z5
    Tablet:
    Samsung Galaxy Note 8.0
    Das Backup ist ein volles Backup, samt Original-OS, oder?
    D.h. wenn ich vom Custom Rom auf das Toshiba-eigene Zurückwechseln will, geht das mit dem Backup, richtig?
    Wenn ja, wie spiele ich das Backup denn dann wieder ein?

    Gruß & vielen Dank für die einfache Anleitung!
    Eddie8
     
    netbook21 bedankt sich.
  4. netbook21, 17.07.2011 #4
    netbook21

    netbook21 Neuer Benutzer

    Beiträge:
    20
    Erhaltene Danke:
    0
    Registriert seit:
    17.07.2011
    Hallo Leute,
    habe alle Anweisungen befolgt und es hat alles auf anhieb funktioniert.
    Sogar unter Win7pro 64bit.
    Ich wollte einfach nur DANKE sagen.

    Vielleicht ein Hinweis zu den USB-Treibern: beim Treiberverzeichnis nicht auf amd64 gehen, sondern im Ordner davor bleiben und dann auf Suchen gehen, dann funkts.


    Grüße.
     
  5. petet0n76, 26.07.2011 #5
    petet0n76

    petet0n76 Neuer Benutzer

    Beiträge:
    4
    Erhaltene Danke:
    0
    Registriert seit:
    22.07.2011
    Hallo zusammen,

    hat jemand von Euch schonmal ein Toshiba AC100 (116 Class, 8GB SSD/512MB/UMTS/WLAN) nach Installation Custom Rom 4b wieder auf den org. Werkszustand (Toshiba/Froyo 2.2) zurückgeflasht ? Oder war´s für alle Formumsteilnehmer bis jetzt eine glückliche Einbahnstrasse ?

    Gruss,
    Pete
     
  6. netbook21, 02.08.2011 #6
    netbook21

    netbook21 Neuer Benutzer

    Beiträge:
    20
    Erhaltene Danke:
    0
    Registriert seit:
    17.07.2011
    Hallo,
    also ich habe heute versucht das Original wieder einzuspielen, da es von Toshiba ein eigenes Update gibt.
    Hat nach Anpassung der Flash-Datei auch alles bestens funktioniert.
    Es ist wirklich wieder alles so wie bei der Sicherung.
    Das Toshiba-Update funktioniert leider auch nicht, ich bekomme immer eine Fehlermeldung, das beim kopieren ein Fehler aufgetreten sei.
    Werde nun also wieder auf 4b flashen und hoffen, dass dann alles wieder funkt.

    Gruß netbook21
     
    Zuletzt bearbeitet: 02.08.2011
  7. petet0n76, 11.08.2011 #7
    petet0n76

    petet0n76 Neuer Benutzer

    Beiträge:
    4
    Erhaltene Danke:
    0
    Registriert seit:
    22.07.2011
    Hi,

    @Netbook21: Kannst Du bitte Deine modifizierte CMD-Datei für das Restore des org. Toshiba Android 2.2 posten ? Hatte Conzi`s Backup Script verwendet um Android 2.2 Toshiba zu sichern, 4b installiert (soweit okay) und wollte auf das org. Toshiba 2.2 zurückgehen um mir das aktuelle Toshiba 2.2.5.003 Update vom 29.07.2011 anzusehen.

    Danke !

    Gruss
    Pete
     
  8. netbook21, 11.08.2011 #8
    netbook21

    netbook21 Neuer Benutzer

    Beiträge:
    20
    Erhaltene Danke:
    0
    Registriert seit:
    17.07.2011
    Hallo Pete,
    Ich poste Dir das Scrip per PN.
    Das Restore hat einwandfrei funktioniert.
    Du musst nur die Ordner anpassen.
    Leider habe ich das Update mit dem neuen Toshiba nicht hinbekommen.
    Vielleicht klappt es aber ja bei Dir.
    Viel Erfolg.

    Gruß
    Netbook21
     
  9. X-HawkEye-X, 11.08.2011 #9
    X-HawkEye-X

    X-HawkEye-X Erfahrener Benutzer

    Beiträge:
    159
    Erhaltene Danke:
    9
    Registriert seit:
    08.02.2011
    Tablet:
    Asus Memo Pad HD7
    Warum das Script nur per PN? Will auch haben :)
     
  10. netbook21, 12.08.2011 #10
    netbook21

    netbook21 Neuer Benutzer

    Beiträge:
    20
    Erhaltene Danke:
    0
    Registriert seit:
    17.07.2011
    OK,OK, wenn man so nett gebeten wird.

    Das Verzeichnis für die originalen Daten muss auf AC100 geändert werden oder Ihr passt das Script an.
    Das Script, wie bei der 4b in das Verzeichniss vor den Android-Dateien.

    Sollte dann problemlos ablaufen.

    Wenn jemand das Update mit der Toshiba-Version hinbekommt, hätte ich gerne ein Image davon.

    Gruß
    netbook21
     

    Anhänge:

  11. petet0n76, 12.08.2011 #11
    petet0n76

    petet0n76 Neuer Benutzer

    Beiträge:
    4
    Erhaltene Danke:
    0
    Registriert seit:
    22.07.2011
    Hi,
    @netbook21: Vielen Dank erstmal für das Posten des Scripts, habe ich grade mal ausprobiert und bin erfolgreich *gescheitert*.

    Meine Sicherungsdateien:
    // BEGIN
    12.08.2011 11:07 <DIR> .
    12.08.2011 11:07 <DIR> ..
    17.06.2011 17:09 3.145.728 10_MSC_raw.img
    17.06.2011 17:09 3.145.728 11_EM1_raw.img
    17.06.2011 17:09 3.145.728 12_UDA_raw.img
    17.06.2011 17:09 3.145.728 13_EM2_raw.img
    17.06.2011 17:09 3.145.728 14_EM2_raw.img
    17.06.2011 17:09 3.145.728 2_BCT_raw.img
    17.06.2011 17:09 3.145.728 3_PT_raw.img
    17.06.2011 17:09 3.145.728 4_EBT_raw.img
    17.06.2011 17:09 3.145.728 5_SOS_raw.img
    17.06.2011 17:09 3.145.728 6_LNX_raw.img
    17.06.2011 17:09 3.145.728 7_MBR_raw.img
    17.06.2011 17:09 3.145.728 8_APP_raw.img
    17.06.2011 17:09 3.145.728 9_CAC_raw.img
    12.08.2011 11:07 0 out.txt
    17.06.2011 17:09 1.294 partitiontable.txt
    // END

    Fehlermeldung:
    //BEGIN
    ...
    bootloader downloaded successfully
    Nvflash started
    [resume mode]
    sending file: AC100\2_BCT_raw.img
    / 3145728/3145728 bytes sent
    AC100\2_BCT_raw.img sent successfully
    Nvflash started
    [resume mode]
    sending file: AC100\3_PT_raw.img
    / 524288/524288 bytes sent
    AC100\3_PT_raw.img sent successfully
    Nvflash started
    [resume mode]
    sending file: AC100\4_EBT_raw.img
    / 2097152/2097152 bytes sent
    AC100\4_EBT_raw.img sent successfully
    Nvflash started
    [resume mode]
    AC100\5_SOS_raw.img is too small for writing 5242880 bytes
    command failure: writedeviceraw failed
    Nvflash started
    [resume mode]
    failed executing command 31 NvError 0x120002
    command failure: writedeviceraw failed (bad data)
    //END

    Sieht also so aus als ob die 5_SOS_raw.img irgendwie nicht okay ist, die Paritionsgrössen sind ja kostant. Irgendwie kommt mir das Backup auch insofern seltsam vor da es ja nur aus einer Menge von 3 MB grossen Files besteht...ein komplettes Android mit allem Zip&Zapp stelle ich mir grösser vor.

    Irgendeine Idee oder eine Chance funktionierende Backup-Files von einem AC100 3G (116er) zu bekommen ? Hilfe herzlich erbeten !

    Flashe mal auf 4b zurück...grummel !

    Gruss
    Pete
     
  12. netbook21, 12.08.2011 #12
    netbook21

    netbook21 Neuer Benutzer

    Beiträge:
    20
    Erhaltene Danke:
    0
    Registriert seit:
    17.07.2011
    Hallo Pete,
    ja- da ist beim Backup der originalen Daten etwas schief gelaufen.
    Steht aber in der Anleitung zum Backup drin, dass man darauf achten soll das alle Dateien unteschiedlich groß sein müssen.
    Vielleicht sollte man das noch einmal deutlicher hervorheben.

    Ich kann Dir das Backup von mir zukommen lassen.

    Das dauert aber etwas, da ich es erst einspielen muss, cleanen (persönliche daten raus), neu erstellen und dann auf 2 DVD brennen und Dir per Post zusenden. Das Image ist 7,5 GB groß.

    Leider kann ich das natürlich auch nicht kostenfrei machen.

    Also, bei Interesse wieder melden.

    Gruß
    netbook21
     
  13. petet0n76, 14.08.2011 #13
    petet0n76

    petet0n76 Neuer Benutzer

    Beiträge:
    4
    Erhaltene Danke:
    0
    Registriert seit:
    22.07.2011
    Hi netbook21,
    danke für das Angebot,komme gerne darauf zurück. Kannst Du die Dateien ggf. auch per FTP auf einen von mir bereitgestellten FTP Server hochladen ? Wenn das zu umständlich ist akzeptiere ich auch einen Obulus für DVD Erstellung und Versand. Danke jedenfalls, melde mich gegen Ende des Monats nochmal deswegen.

    Gruss
    Pete
     
  14. pogodancer, 03.11.2011 #14
    pogodancer

    pogodancer Android-Experte

    Beiträge:
    822
    Erhaltene Danke:
    151
    Registriert seit:
    19.02.2011
    Hi,
    habe das Conzi-Backup probiert, aber das klappt bei meinem AC100-10v nicht. Nach Ausführung werden zwar sämtliche .img-Dateien im Ordner Backup erstellt, lediglich das .img mit der Nr. 14 mit der Bezeichnung "14_UDB_raw.img" scheint nie zu enden. Nach ca. 20 Minuten für das .img Nr. 14 allein wird eine Datei mit einer Größe von 5,8 GB erstellt und es erscheint eine Fehlermeldung im Ausführen-Fenster, daß die zu erhaltenen Daten für das 14er-img nicht korrekt waren.
    An was kann es liegen, daß es bei mir nicht klappt ?
     
  15. Conzi, 03.11.2011 #15
    Conzi

    Conzi Threadstarter Android-Hilfe.de Mitglied

    Beiträge:
    58
    Erhaltene Danke:
    24
    Registriert seit:
    29.04.2011
    Phone:
    Sony Ericsson Xperia X10 Mini
    Hi Pogodancer,

    wahrscheinlich ist das Backup sehrwohl erfolgreich gewesen. Auf das Problem mit Partition 14 weise ich in der Anleitung bereits hin:

    Hinweis: Es kann sein, dass nvflash bei der Partition 14 folgendes meldet:
    receiving file: part14.img, expected size: -106430464 bytes
    / 1598554112/-106430464 bytes receiveddata receive failure NvError 0x120000
    command failure: read failed
    Anscheinend kommt nvflash nicht mit der 5.5GB großen Datenpartition klar und lässt irgendeine Variable überlaufen. Das Backup ist aber trotzdem i.O.

    Ein paar Zeilen später wird auch erklärt, wie Du die die part14.img als loop mounten und überprüfen kannst, ob sie in Ordnung ist.

    Grüße,
    Conzi
     
  16. pogodancer, 03.11.2011 #16
    pogodancer

    pogodancer Android-Experte

    Beiträge:
    822
    Erhaltene Danke:
    151
    Registriert seit:
    19.02.2011
    Hi Conzi,
    danke für Deine blitzschnelle Antwort.
    Asche über mein Haupt, Du hast es richtigerweise in Deiner Anleitung geschrieben. Leider hab ich dem Linux-Teil keine Beachtung geschenkt, da ich mit Win arbeite und Linux nicht verstehe. Sorry, tut mir wirklich leid.

    Andere Frage: Brauche ich das img Nr. 14 überhaupt, denn in den CustomRoms sind ja auch nur die img von 2 bis 3 enthalten ? Scheinbar ist die Nr. 14 ja der interne Datenspeicher, der mir für eine Wiederherstellung nicht so wichtig wäre. Hauptsache das Betriebssystem läßt sich in der Original-Version wiederherstellen.
     
  17. pogodancer, 03.11.2011 #17
    pogodancer

    pogodancer Android-Experte

    Beiträge:
    822
    Erhaltene Danke:
    151
    Registriert seit:
    19.02.2011
    Hi Conzi,
    noch ein kurzer Nachtrag. Hatte trotz VERMEINTLICH gescheiterter Backups gestern Android2.2 v4b von Silver Alx eingespielt und ausgiebig getestet. Läuft cool und absolut stabil. Und der Launcher Pro erzielt für meinen Geschmack eine gute Übersichtlichkeit für das System auf dem Netbook.

    Aber zurück zu dem, was ich eigentlich melden wollte: Wollte gerade anfangen, die Honeycomb-Version aufzuspielen, als ich noch sah, daß in den Download-Dateien auch eine "backup.cmd" enthalten ist, deren Ausführung vor dem Flash empfohlen wird. Diese habe ich ausgeführt, und sie war nach ca. 10 Minuten successfully mit der img Nr. 13 beendet. Kein weiteres Backup wurde angestossen, sondern: All Done! Dont forget to reboot ...

    Kann ich somit davon ausgehen, daß ich die 5,8 GB-Monster-Dateien von meinen vorherigen Backup-Läufen löschen kann, sofern sich darauf keine wichtigen persönlichen Dateien (Texte, Bilder, Musik, Video) befinden ? Kann ich eine Systemwiederherstellung auch ohne die img Nr. 14 vornehmen ?
     
  18. Conzi, 03.11.2011 #18
    Conzi

    Conzi Threadstarter Android-Hilfe.de Mitglied

    Beiträge:
    58
    Erhaltene Danke:
    24
    Registriert seit:
    29.04.2011
    Phone:
    Sony Ericsson Xperia X10 Mini
    Lt. diesem Link ( Partition Layout - Hacking the Toshiba AC100 ) sind die Partitionen 12 und 14 für die Userdaten da und sind daher (wahrscheinlich) für eine Systemwiederherstellung nicht erforderlich. Du solltest allerdings nach einer Wiederherstellung einen kompletten Reset durchführen und das Gerät auf die Werkseinstellungen zurücksetzen, da u.U. die Userdaten nicht zur OS-Version passen....

    Grüße,
    Conzi
     
  19. pogodancer, 03.11.2011 #19
    pogodancer

    pogodancer Android-Experte

    Beiträge:
    822
    Erhaltene Danke:
    151
    Registriert seit:
    19.02.2011
    Hi Conzi,
    danke für Deine Antwort. Nachdem ich grad fleißig rum-geflasht hab, bin ich von Honeycomb wieder zurück auf die CR-Android2.2, da die Honeycomb zwar vom Betriebssystem der Hammer ist, aber das Image hat noch zu viele Bugs. Android3 fürs AC100 ist bisher noch nicht so ausgeklügelt wie die Version2.2 von Silver-Alx's (speziell die angepassten Loader für die unterschiedlichen AC100-Versionen). Hab aber bisher immer wieder neu installiert und nicht restored. Wenn ich noch ein bisschen Zeit habe, werde ich mal die jetzige Installation sichern und ein Restore durchführen, um zu prüfen, ob das auch bei mir klappt. Solange das System noch läuft, wäre das die Hauptsache. Persönliche Dateien auf img.14 wären mir egal, weil das mit SD-Karte gleich wieder eingespielt ist. Könnte ich das Toshi eigentlich tot flashen, wenn ich beim Restore nur die img. bis 13 habe und nicht bis 14, wie es vielleicht in Deinem Script vorgesehen ist ? Habe leider von Programmierung und Skripts etc. nicht den geringsten Schimmer.
     
  20. Conzi, 04.11.2011 #20
    Conzi

    Conzi Threadstarter Android-Hilfe.de Mitglied

    Beiträge:
    58
    Erhaltene Danke:
    24
    Registriert seit:
    29.04.2011
    Phone:
    Sony Ericsson Xperia X10 Mini
    Hallo,

    "totflashen" wegen der fehlenden part14 im technischen Sinne halte ich für unwahrscheinlich. Du kannst in meinem Skript die Zeile, in der die 14 geflasht wird, einfach mit einem REM (Windows) bzw. # (Linux) auskommentieren.
    Was allerdings sein kann ist, dass irgendwelche in der Sicherung enthaltenen Programme dann nicht mehr funktionieren und den Systemstart blockieren. Es wird allgemein empfohlen, nach dem Wiederherstellen einen (Factory-Reset) durchzuführen. Dabei wird die 14 bereinigt/gelöscht...

    Grüße
    Conzi
     

Diese Seite empfehlen