1. Nimm jetzt an unserem Uhans - 3. ADVENT - Gewinnspiel teil - Alle Informationen findest Du hier!

Backward Compatibilty, wie geht das?

Dieses Thema im Forum "Android App Entwicklung" wurde erstellt von DieGoldeneMitte, 22.06.2012.

  1. DieGoldeneMitte, 22.06.2012 #1
    DieGoldeneMitte

    DieGoldeneMitte Threadstarter Android-Lexikon

    Beiträge:
    1,230
    Erhaltene Danke:
    256
    Registriert seit:
    05.02.2010
    Phone:
    Nexus 5X
    Tablet:
    Nexus 7 (2013)
    Hallo,

    ich habe eine App für Honeycomb entwickelt und festgestellt, dass ich von der API11 eigentlich nur einen Aufruf brauche:
    View.setSystemUIVisibility(int)

    Da dachte ich mir: Das muss doch auch unter Gingerbread ans Laufen zu kriegen sein, schließlich gibt es die Android Support Library. Aber ich verstehe nicht, was ich tun muss, um das bestehende Programm dort ans laufen zu kriegen. Wenn ich v4 in den Buildpath aufnehme und das target entsprechend setze, fliegt mir alles mögliche um die Ohren (vor allem die Layouts). Ich müsste also dann gegen 1.6 entwickeln - und das will ich nun auch wieder nicht :D (und wie ich in dem 1.6er view die v11 api aufrufe habe ich aus der doku heraus auch nicht verstanden)

    Was muss ich tun, um die App unter v7 (oder meintwegen auch v9) ans Laufen zu bekommen? Es gibt zwar ein v7 im support dir des SDKs, aber da ist keine support jar zu finden. Fehlt da vielleicht bei mir was?
     

Diese Seite empfehlen