1. Nimm jetzt an unserem Uhans - 3. ADVENT - Gewinnspiel teil - Alle Informationen findest Du hier!

Bekannte WLAN-Netzwerke werden ständig deaktiviert, wenn länger nicht verbunden

Dieses Thema im Forum "Motorola Milestone 2 Forum" wurde erstellt von Zoli1972, 07.04.2012.

  1. Zoli1972, 07.04.2012 #1
    Zoli1972

    Zoli1972 Threadstarter Junior Mitglied

    Beiträge:
    43
    Erhaltene Danke:
    3
    Registriert seit:
    19.06.2011
    Hi,

    Habe das Problem, daß sich mein Milestone 2 nicht mit einem WLAN-Netzwerk verbindet, mit dem es eine längere Zeit (können auch schon 12 Stunden zuviel sein) nicht mehr verbunden war. Das betroffene Netz wird dann in
    "Einstellungen"->
    "WLAN-Einstellungen"->
    "Netzwerke verwalten"
    als "deaktiviert" angezeigt. Offensichtlich deaktiviert Android alle WLAN-Netze, mit denen es längere Zeit nicht verbunden wird. Würde mich mal interessieren, wieso das System dies tut? Für mich erscheint dies völlig unsinnig. Ich will ja, daß sich das Handy, wenn es in Reichweite bekannter Netze kommt, automatisch wieder verbindet. Das WLAN ist jedenfalls dauerhaft auf "AN" gestellt, somit scannt es wohl, so nehme ich jedenfalls an, permanent die Umgebung.

    Vorweg:
    Bitte schlagt mir nicht vor, ein Tool zu installieren, daß nach der GPS-Position oder nach einer GSM-Funkzelle in der Nähe der WLAN-Netze sucht, und dann WLAN aktiviert. Das funktioniert nicht, und ich möchte das auch nicht, zumal, was GPS angeht dieser ger größte Akkufresser im Handy ist.

    Wäre super, wenn jemand helfen könnte. Das Handy ist gerootet, und hat die original 2.3.4 Software drauf.

    Zoli
     
  2. lulli, 08.04.2012 #2
    lulli

    lulli Android-Lexikon

    Beiträge:
    900
    Erhaltene Danke:
    191
    Registriert seit:
    06.10.2011
    passiert dir das nur in einem wlan oder in mehreren?
    wenn nur in einem, wuerd ich eher auf den router tippen als auf den stein.

    Gruß lulli
     
  3. Zoli1972, 08.04.2012 #3
    Zoli1972

    Zoli1972 Threadstarter Junior Mitglied

    Beiträge:
    43
    Erhaltene Danke:
    3
    Registriert seit:
    19.06.2011
    Nein, passiert bei allen Router-Modellen, mit denen ich je verbunden war. Sobald das Netzwerk nicht mehr in Reichweite ist, erscheint es als "deaktiviert", und wird auch nie wieder aktiviert, es sei denn, ich mach das manuell. Sehr blöd das Ganze. Ich hab jedenfalls das Motorola mit Routern folgender Hersteller schon mal verbunden gehabt:

    Fritz-Boxen (z.B. 7141, 7170)
    T-Home-Speedports der 900er und 700er-Serie (ich weiß, sind auch FritzBoxen)
    Netgear
    Linksys
    Dlink
    AQuip

    Alle werdern deaktiviert. Siehe Screenshots. (bitte nicht wundern, daß die Farbe der WLAN-Verbindung orange ist, ist eigentlich blau, aber das Screenshot-Tool hat das irgendwie orange eingefärbt :unsure:)
     

    Anhänge:

  4. lulli, 09.04.2012 #4
    lulli

    lulli Android-Lexikon

    Beiträge:
    900
    Erhaltene Danke:
    191
    Registriert seit:
    06.10.2011
    also normalerweise wird man doch vom system beim ersten verbinden gefragt ob man immer automatisch verbinden moechte, wenn in reichweite.
    kommt diese abfrage bei dir ueberhaupt?

    was fuer ein rom ist das, mit dem du da zugange bist?
    ist das von anfang an so gewesen?

    Gruß lulli
     
  5. Zoli1972, 09.04.2012 #5
    Zoli1972

    Zoli1972 Threadstarter Junior Mitglied

    Beiträge:
    43
    Erhaltene Danke:
    3
    Registriert seit:
    19.06.2011
    Werde ich leider nicht.

    Hatte vorher Froyo, jetzt Gingerbread 2.3.4 original von Motorola (siehe Signatur).

    Ja.

    Ich habe mal von Apps (spezielle Connectionmanager) gelesen, die alle Zugangspunkte wieder auf "aktiv" stellen können. Noch besser wäre aber ein permanenter Hack im Handy, der die Zugangspunkte gar nicht erst soweit kommen läßt, daß sie vom System deaktiviert werden. Gerootet ist das Gerät jedenfalls schon.

    Zoli
     
  6. lulli, 10.04.2012 #6
    lulli

    lulli Android-Lexikon

    Beiträge:
    900
    Erhaltene Danke:
    191
    Registriert seit:
    06.10.2011
    factory reset wird wohl nix bringen, wenn das von anfang an so war.
    willst das teil nicht einfach mal zu datrepair senden, garantie hast ja sicher noch?
    vorher aber unrooten....

    Gruß lulli
     
  7. Zoli1972, 10.04.2012 #7
    Zoli1972

    Zoli1972 Threadstarter Junior Mitglied

    Beiträge:
    43
    Erhaltene Danke:
    3
    Registriert seit:
    19.06.2011
    Was ist denn Datrepair?

    Garantie hab ich noch, und mit dem Gedanken, es einzuschicken, habe ich schon oft gespielt. Plattgemacht hab ich das Ding auch schon mal, kurz nach dem Upgrade auf Froyo, weil ich es mit BloatFreezer gebrickt hatte. Sicherungen hab ich auch, dank Titanium.

    Werde es nochmal sichern, unrooten, wipen, sobald ich meine 32GB Speicherkarte hab, und dann (ohne die Karte ;-) ) zur Reperatur schicken. Wie sind denn die Erfahrungen eigentlich bezüglich Reperatur? Bekomme ich das gleiche Handy wieder, oder bekomme ich ein Tauschgerät? Die Oberschale hat auf jeden Fall schon kleine Schrammen / Kratzer / andere Gebrauchsspuren.

    Zoli
     
  8. seba1980, 11.04.2012 #8
    seba1980

    seba1980 Android-Hilfe.de Mitglied

    Beiträge:
    67
    Erhaltene Danke:
    7
    Registriert seit:
    04.01.2011
    Hallo Zoli1972,

    zu Deinen Fragen. Datrepair ist der Dienstleister, der für Moto die Garantieabwicklung durchführt (Link) In der Regel bekommst Du dein Gerät wieder (außer es ist irreparabel), also Du wirst Dich wohl mit deinen Kratzern anfreunden müssen - sofern Du sie nicht gegen Entgeld entfernen lässt. Bisher war ich mit den ausgeführten Reparaturen sowohl von der Ausführung her, als auch von der Reparaturzeit sehr zufrieden(mein MS2 war mittlerweile drei Mal da, wegen des Tastaturproblems, was nach anscheinend nach der Nutzung anderer Tastaturmatten wirklich behoben ist!!!).

    Gruß seba1980
     
  9. Zoli1972, 31.12.2012 #9
    Zoli1972

    Zoli1972 Threadstarter Junior Mitglied

    Beiträge:
    43
    Erhaltene Danke:
    3
    Registriert seit:
    19.06.2011
    Hallo,

    Jetzt wollte ich doch nochmal nachhaken: Gibt es denn wirklich keine einzige App, die diese deaktivierten WLANs in einem frei definierbaren Intervall wieder aktiviert?

    Mein Handy ist gerootet, deshalb hier auch noch die Frage, wo (in welcher Config-Datei) steht denn die Information, daß ein bestimmtes Netz deaktiviert ist? Vielleicht kann ich das auch irgendwie editieren (lassen)?

    Zoli
     

Diese Seite empfehlen