1. Nimm jetzt an unserem Uhans - 3. ADVENT - Gewinnspiel teil - Alle Informationen findest Du hier!

Bildschirmauflösung

Dieses Thema im Forum "Motorola Xoom Forum" wurde erstellt von Googorola, 13.09.2011.

  1. Googorola, 13.09.2011 #1
    Googorola

    Googorola Threadstarter Neuer Benutzer

    Beiträge:
    11
    Erhaltene Danke:
    0
    Registriert seit:
    13.09.2011
    Hallo,

    ich kann mir irgendwie nicht helfen... Wenn ich mein Xoom über HDMI an einen Beamer anschließe bekomme ich keine 1280er Auflösung im Browser! Liegt das an den Browsereinstellungen? Kann ich da irgendwo dran drehen!?

    Bin für jeden Hinweis dankbar!
     
  2. Googorola, 13.09.2011 #2
    Googorola

    Googorola Threadstarter Neuer Benutzer

    Beiträge:
    11
    Erhaltene Danke:
    0
    Registriert seit:
    13.09.2011
    übrigens sieht auch im direkten Vergleich mit einem Ipad2 dieselbe Internetseite im Browser bei mir "nur" nach 1024x768 aus! :confused2:
     
  3. oohlen, 14.09.2011 #3
    oohlen

    oohlen Fortgeschrittenes Mitglied

    Beiträge:
    302
    Erhaltene Danke:
    32
    Registriert seit:
    13.08.2009
    Das sollte eigentlich am Beamer liegen, dort kannst du das Format doch einstellen...
     
  4. Lupus, 14.09.2011 #4
    Lupus

    Lupus Android-Experte

    Beiträge:
    473
    Erhaltene Danke:
    139
    Registriert seit:
    12.09.2009
    Wahrscheinlich ist 1024*768 die maximale Auflösung beim Beamer, sofern du keinen HD Beamer hast.
     
  5. Googorola, 14.09.2011 #5
    Googorola

    Googorola Threadstarter Neuer Benutzer

    Beiträge:
    11
    Erhaltene Danke:
    0
    Registriert seit:
    13.09.2011
    Der Beamer macht WXGA, also 1280x800. Mit einem Laptop über HDMI funktioniert das auch...
    Aber vergesst mal den Beamer. Wenn ich eine Internetseite im Xoom-Display mit dem Ipad2 vergleiche habe ich eine identische Auflösung!? Auch am Laptop mit 1280x800 Pixeln sehe ich im Browser mehr als im Xoom-Display. Kann doch eigentlich nicht sein!?
     
    Zuletzt bearbeitet: 14.09.2011
  6. oohlen, 15.09.2011 #6
    oohlen

    oohlen Fortgeschrittenes Mitglied

    Beiträge:
    302
    Erhaltene Danke:
    32
    Registriert seit:
    13.08.2009
    Okay, es kann nicht am Gerät liegen welches du anschliesst... ansonsten würden nicht beide Tablets das gleiche ergebniss erzielen, dass das xoom den rand unten abschneidet ist klar oder? tut er das bei dir auch? hast du es mal an einem anderen Beamer ausprobiert? Bei mir wird alles anständig in 1280 angezeigt...
     
  7. Googorola, 15.09.2011 #7
    Googorola

    Googorola Threadstarter Neuer Benutzer

    Beiträge:
    11
    Erhaltene Danke:
    0
    Registriert seit:
    13.09.2011
    das unten was abgeschnitten wird ist klar. Macht es bei mir auch...

    So sieht das Browserfenster im Xoom-Display aus:
    [​IMG]

    und so auf dem Laptop mit der Einstellung 1024x768:
    [​IMG]

    so sollten 1280x768 Pixel in der vollen Breite aussehen:
    [​IMG]


    Irgendwas ist da doch faul... :confused2:
     

    Anhänge:

  8. Lupus, 15.09.2011 #8
    Lupus

    Lupus Android-Experte

    Beiträge:
    473
    Erhaltene Danke:
    139
    Registriert seit:
    12.09.2009
    Nun Auflösung alleine ist ja nicht alles, da kommen noch Faktoren wie DPI, Schriftgröße, Density ins Spiel. Wenn du in Windows die Schrift größer machst, hast du im Browser automatisch auch weniger "Sicht" auf die Seite in Firefox.

    Ich weiß jetzt nicht ob man bei Honeycomb problemlos die Density zB mit LCD Density ändern kann. Das müsstest du dann halt testen, vorher am besten ein Nandroid Backup erstellen.
     
    Googorola bedankt sich.
  9. pixelflicker, 17.09.2011 #9
    pixelflicker

    pixelflicker Junior Mitglied

    Beiträge:
    32
    Erhaltene Danke:
    2
    Registriert seit:
    19.06.2010
    Der Android Browser funktioniert anders als ein Browser an einem PC. Er ist nicht direkt auf die Auflösung festgelegt, sondern verwendet eine Virtuelle Auflösung um die Website darzustellen. Diese Virtuelle Auflösung liegt bei etwa 980px. Die verwendet jedes Android System um die Seite aufzubauen, daher sieht dort jede Seite so aus als wäre sie auf einem 1024er Display dargestellt.
    Man kann die Seite dann ja auch stufenlos Zoomen.

    Ob man das im Browser anders einstellen kann weiß ich nicht. Geht vielleicht mit alternativen Browsern.

    Aber warum stört dich das eigentlich? Geht irgendeine Website nicht bei dieser Darstellungsbreite?
     
    Googorola bedankt sich.
  10. Googorola, 19.09.2011 #10
    Googorola

    Googorola Threadstarter Neuer Benutzer

    Beiträge:
    11
    Erhaltene Danke:
    0
    Registriert seit:
    13.09.2011
    Ich habe bei einer eigenen Webseite die Darstellung auf eine Breite von 1280px optimiert. Das war in dem Zusammenhang wohl ein Fehler, obwohl ich es im Sinne der "HD-Revolution" für verkehrt halte, nicht auch den Standard für ein Webdesign auf 1280x768px festlegen zu können.

    Auf meinem Laptop arbeite ich mit 1600px Breite bei 13" Diagonale. Da sollten 1280px bei 10" kein Problem sein. Gut, da arbeite ich auch noch mit der Maus, aber wenn man überlegt, in welcher Auflösung wir zum Teil auf einem Smartphone-Display rumtatschen...

    Zoomen funktioniert jedenfalls nur in die andere Richtung. Im Standartbrowser gibt es unter den erweiterten Einstellungen zwar die Möglichkeit die Textgröße zu ändern, allerdings verschiebt sich dadurch natürlich das gesamte Design. Was die Einstellung "Standard-Zoom" (Nah-Mittel-Weit) bewirken soll ist mir nicht klar, hilft aber auch nicht weiter!

    An Alternativen Browsern habe ich mittlerweile weder im Firefox noch im Dolphin eine passende Einstellmöglichkeit gefunden.
    Ich werde das Xoom wohl rooten müssen, um mit LCD Density vielleicht etwas erreichen zu können. :sad:
     
  11. Cheyenne, 19.09.2011 #11
    Cheyenne

    Cheyenne Android-Experte

    Beiträge:
    674
    Erhaltene Danke:
    180
    Registriert seit:
    01.07.2010
    Phone:
    LG G3 (D855)
    Probier mal den Maxthon Browser, der läuft bei mir sehr gut und hat vllt. die richtige Auflösung/Darstellung fűr dich. Er unterstützt auch Vollbild. Einfach mal testen...

    Gesendet mit der Android-Hilfe.de-App
     
  12. pixelflicker, 19.09.2011 #12
    pixelflicker

    pixelflicker Junior Mitglied

    Beiträge:
    32
    Erhaltene Danke:
    2
    Registriert seit:
    19.06.2010
    Nun normalerweise müssten 1000px für eine Website locker aussreichen, es ist eh besser, wenn man diese etwas übersichtlicher gestaltet.

    Bisher habe ich noch nie gehört, dass jemand empfiehlt eine Website auf eine so große Bildschirmauflösung anzupassen, zumal die Geräte immer kleiner werden (12" Notebooks werden auch immer beliebter). Daher würde ich dir eher empfehlen deine Website anzupassen als am Gerät rumzuspielen, bei einem Smartphone hast du ja dann das Selbe Problem, sogar noch verstärkt.
     
  13. Googorola, 19.09.2011 #13
    Googorola

    Googorola Threadstarter Neuer Benutzer

    Beiträge:
    11
    Erhaltene Danke:
    0
    Registriert seit:
    13.09.2011
    Für die Darstellung auf dem Smartphone sind viele Webseiten dann aber extra angepasst. D.h. es gibt ein zweites Layout der Seite für mobile Browser. Wenn ich an der Seite aber auch arbeiten muss (wie z.b. in der Wikipedia), dann mache ich das normalerweise nicht am Handy und auch nur selten am Tablet. Dagegen wird kaum jemand an seinem Desktop-Rechner noch mit einem XGA-Display arbeiten... Die Tablets und Netbooks liegen jetzt irgendwie dazwischen :unsure: WXGA-Darstellung auch im Browser wäre da aus meiner Sicht ein guter Kompromiss!

    Gerade wenn man das Xoom (z.b. für eine Präsentation) an ein größeres Display oder einen HD-Beamer anschließen möchte finde ich es unsinnig, die Auflösung "künstlich" zu reduzieren.

    Den Maxthon Browser werde ich mal noch ausprobieren...
     
  14. pixelflicker, 19.09.2011 #14
    pixelflicker

    pixelflicker Junior Mitglied

    Beiträge:
    32
    Erhaltene Danke:
    2
    Registriert seit:
    19.06.2010
    Ich denke das wir sich auch bald ändern. Android ist halt kein Desktop-System und daher sind die Philosophien da andere. Ich könnte mir aber gut vorstellen, dass das in anderen Browsern einstellbar sein wird. Ob der Standard-Browser da in nächter Zeit eine Änderung macht bezweifle ich. Ich denke der Anteil der Websites, die eine so große Breite (unflexibel) anbieten dürfte sich im Einstelligen Prozenbereich bewegen, wenn überhaupt. Es spricht eher gegen die Website, wenn sie so unflexibel und starr ist.

    Es wird ja nicht die Auflösung reduziert, sondern lediglich der Seitenaufbau auf eine bestimmte Auflösung ausgerichtet. Da der Tablet-Browser keinen festen Viewport hat muss man das halt irgendwo festlegen und da so gut wie alle Websites mit einer Auflösung knapp unter 1000px auskommen ist das die Beste Wahl. Eine höhere würde nur zu ungenutzten Raum führen.

    Du kannst ja auch ein alternatives Layout anbieten, wie es viele andere Seiten machen.
     
  15. jannux, 20.09.2011 #15
    jannux

    jannux Android-Experte

    Beiträge:
    678
    Erhaltene Danke:
    84
    Registriert seit:
    22.09.2009
    Phone:
    auf Suche
    Tablet:
    Sony Xperia Tablet Z3 Compact
    Vielleicht hilft Dir Folgendes:

    Man kann in den Einstellungen die Option "use wide viewport" ausschalten.
    Dafür bitte in der Adresszeile des Browsers "about:debug" eingeben und mit enter bestätigen. Augenscheinlich passiert erstmal nichts, aber wenn Du jetzt oben links das Menu aufklappst und "Einstellungen" wählst, hast Du einen zusätzlichen Reiter "Debugging" und dort kann man die Option deaktivieren. Dort kann man übrigens auch den User Agent auf Desktop stellen.

    Leider scheint die Einstellung nicht immer permanent zu sein, nach einem Neustart kann das wieder weg sein.

    Vielen Dank an "JR Raphael" unter
    How to make Android's Honeycomb browser load desktop -- not mobile -- Web sites - Computerworld Blogs

    Um die zusätzlichen Einträge wieder los zu werden, nochmals "about:debug" eingeben und bestätigen.

    Gruß Jan
     
    Zuletzt bearbeitet: 20.09.2011
    Googorola, das_ICH und ahoibrausepulver haben sich bedankt.
  16. ahoibrausepulver, 20.09.2011 #16
    ahoibrausepulver

    ahoibrausepulver Erfahrener Benutzer

    Beiträge:
    158
    Erhaltene Danke:
    16
    Registriert seit:
    13.09.2011
    Jannux, mein Held!

    Danke für den Hinweis!
    So klappt dann auch der facebook Chat und so einiges mehr...
     
  17. jannux, 20.09.2011 #17
    jannux

    jannux Android-Experte

    Beiträge:
    678
    Erhaltene Danke:
    84
    Registriert seit:
    22.09.2009
    Phone:
    auf Suche
    Tablet:
    Sony Xperia Tablet Z3 Compact
    Ich spiele gerade damit ein wenig rum. Wenn man den debug modus wieder ausschaltet gehen manche Einstellungen wieder verloren (die mit dem viewport zum Beispiel), der user agent bleibt auf Desktop.

    Gleichzeitig habe ich festgestellt, dass im debug Modus das Zoomen mit Doppelklick nicht funktioniert.

    Ich finde aber, dass das surf feeling ohne den breiten viewport erheblich schöner ist und zum vergrößern reicht mir "pinch to zoom"

    Gruß Jan
     
    Zuletzt bearbeitet: 21.09.2011
  18. Googorola, 22.09.2011 #18
    Googorola

    Googorola Threadstarter Neuer Benutzer

    Beiträge:
    11
    Erhaltene Danke:
    0
    Registriert seit:
    13.09.2011
    Prima! So funktioniert es :thumbup: Auf einer großen Leinwand sieht das so doch gleich viel besser aus!
    Surfen auf dem Xoom-Display finde ich so auch schöner und die Links treffe ich auch mit meinen Wurstfingern noch ganz gut ;-) Pinch to Zoom funktioniert allerdings nicht mehr ganz so gut. Ohne den wide viewport verschiebt sich da alles...
    Jetzt fehlt nur noch, dass ich auch im Antroid-Browser (hat der eigentlich einen Namen?) eine Vollbildansicht wie bei Maxthon oder Dolphin hinbekomme. Dann hätte ich auch in der Höhe noch ein paar Pixel gewonnen ;)
     
  19. pixelflicker, 22.09.2011 #19
    pixelflicker

    pixelflicker Junior Mitglied

    Beiträge:
    32
    Erhaltene Danke:
    2
    Registriert seit:
    19.06.2010
    Vollbild ist einfach, dazu musst du nur in den Einstellungen unter Labs die Option Schnellsteuerelemente aktivieren. Dann kannst du das Menü von der rechten Seite reingehen. Ist aber etwas Gewöhnungsbedürftig.
     
    Googorola bedankt sich.

Diese Seite empfehlen