1. Nimm jetzt an unserem Uhans - 3. ADVENT - Gewinnspiel teil - Alle Informationen findest Du hier!

Boot Partition hat den Geist aufgegeben

Dieses Thema im Forum "Huawei Ideos X3 (U8510) Forum" wurde erstellt von Gubbl, 05.07.2012.

  1. Gubbl, 05.07.2012 #1
    Gubbl

    Gubbl Threadstarter Neuer Benutzer

    Beiträge:
    13
    Erhaltene Danke:
    0
    Registriert seit:
    05.07.2012
    Schönen guten Abend.
    Ich habe schon einiges hier im Forum anonym gelesen, aber jetzt konnte mir leider kein Beitrag mehr weiter helfen. Erstmal tolle Arbeit von euch :thumbsup:

    Soo, aber jetzt hab ich seit gestern ein Problem. Wir haben hier 2 mal das X3 und ich wollte auf Android 2.3.5 updaten. Beim Ersten hat das auch ohne Probleme geklappt... dann kam das 2. dran... gleich nach dem Start kam "Update failed" :( und ab da hab ich alles probiert... hab mit adb und fastboot gearbeitet, versucht vom anderen Handy ein Backup zu machen und aufzuspielen, das Image aus dem Forum benutzt... und dann habe ich rausgefunden, dass die boot partition nichtmehr beschrieben werden kann... gelöscht wird sie, aber sobalds ans beschreiben geht, kommt die fehlermeldung, dass der Speicher nicht beschrieben werden kann :(

    Auch nach fast 10 Stunden gestern und heute nach der Arbeit konnte ich das Problem nicht lösen und wende mich in großer Hoffnung an euch, dass vielleicht noch jemand eine Idee haben könnte.

    Über eventuelle Antworten würde ich mich sehr freuen:blushing:

    Schöne Grüße
    Gubbl
     
  2. Silverblade, 06.07.2012 #2
    Silverblade

    Silverblade Android-Lexikon

    Beiträge:
    910
    Erhaltene Danke:
    112
    Registriert seit:
    02.01.2012
    Phone:
    Samsung Galaxy Note 2
    Tablet:
    Odys Next
  3. Gubbl, 06.07.2012 #3
    Gubbl

    Gubbl Threadstarter Neuer Benutzer

    Beiträge:
    13
    Erhaltene Danke:
    0
    Registriert seit:
    05.07.2012
    Ich habe jetzt auch noch die Partitionsoffsets verschoben und ziemlich alles probiert, was in dem Post drin stand... leider auch kein Erfolg :( Kann es sein, dass die Flashzellen des Geräts kaputt sind?
     
  4. Time_Bandit, 06.07.2012 #4
    Time_Bandit

    Time_Bandit Android-Lexikon

    Beiträge:
    1,239
    Erhaltene Danke:
    246
    Registriert seit:
    07.10.2011
    Phone:
    Huawei P8 Lite
    Offizielles Update von hier?

    Auch möglich das sich beim Download ein Fehler eingeschlichen hat. Ebenso beim kopieren auf die SD!

    Das die Speicherzellen defekt sind, ist eher unwahrscheinlich.
     
  5. Ryuk, 06.07.2012 #5
    Ryuk

    Ryuk Android-Lexikon

    Beiträge:
    1,010
    Erhaltene Danke:
    207
    Registriert seit:
    19.09.2011
    mal über cwm versucht die boot-partition zu formatieren?
     
  6. ElTonno, 06.07.2012 #6
    ElTonno

    ElTonno Android-Lexikon

    Beiträge:
    1,828
    Erhaltene Danke:
    331
    Registriert seit:
    20.09.2011
    fastboot erase boot -> geht?
    fastboot flash boot boot.img -> geht nicht?
     
  7. Gubbl, 06.07.2012 #7
    Gubbl

    Gubbl Threadstarter Neuer Benutzer

    Beiträge:
    13
    Erhaltene Danke:
    0
    Registriert seit:
    05.07.2012
    Das Offizielle Update von der Huawei Seite hab ich runtergeladen und auf dem 2. Smartphone hats auch geklappt mitm Update.

    Über CWM kann ich die boot Partition formatieren.


    Genau
     
    Zuletzt bearbeitet: 06.07.2012
  8. Ryuk, 06.07.2012 #8
    Ryuk

    Ryuk Android-Lexikon

    Beiträge:
    1,010
    Erhaltene Danke:
    207
    Registriert seit:
    19.09.2011
    und nach dem formatieren tut sich auch nix beim beschreiben?
     
  9. ElTonno, 06.07.2012 #9
    ElTonno

    ElTonno Android-Lexikon

    Beiträge:
    1,828
    Erhaltene Danke:
    331
    Registriert seit:
    20.09.2011
    Noch nie probiert, aber vielleicht kann man ja selber die boot rw mounten:
    Code:
    mount -o rw,remount -t yaffs2 /dev/block/mtdblock0
    
     
  10. Gubbl, 06.07.2012 #10
    Gubbl

    Gubbl Threadstarter Neuer Benutzer

    Beiträge:
    13
    Erhaltene Danke:
    0
    Registriert seit:
    05.07.2012
    Nein, dann versucht er zu beschreiben und es kommt die Fehlermeldung: FAILED (remote: flash write falure)

    Und was mache ich dann, wenn ich es gemounted haben sollte?
     
  11. ElTonno, 06.07.2012 #11
    ElTonno

    ElTonno Android-Lexikon

    Beiträge:
    1,828
    Erhaltene Danke:
    331
    Registriert seit:
    20.09.2011
    fastboot flash boot boot.img
     
    Zuletzt bearbeitet: 06.07.2012
  12. Gubbl, 06.07.2012 #12
    Gubbl

    Gubbl Threadstarter Neuer Benutzer

    Beiträge:
    13
    Erhaltene Danke:
    0
    Registriert seit:
    05.07.2012
    sending 'boot' (5120 KB)... OKAY [ 1.280s]
    writing 'boot'... FAILED (remote: flash write failure)
    finished. total time: 2.210s
     
  13. KatyB, 06.07.2012 #13
    KatyB

    KatyB Ehrenmitglied

    Beiträge:
    7,858
    Erhaltene Danke:
    1,888
    Registriert seit:
    06.09.2011
    Phone:
    BQ Aquaris M5
    @Ryuk: Du hattest doch das Problem selbst mal:
    http://www.android-hilfe.de/root-ha...t-oc-kernel-fuer-stock-rom-4.html#post2285301

    Ich kann mich erinnern, dass manche das Problem auch noch hatten. Finde die Beiträge momentan nicht. Keine Ahnung was da weitergeholfen hatte (Evtl. anderer PC, USB-Kabel, USB-Port, Treiber für das Android Device)

    Wenn man danach googelt, findet man übrigens massenweise Beiträge. Evtl. die boot-Partition mal testweise mit Nullen überschreiben vlt. bringts ja was. ^.-
    http://forum.openetna.com/index.php?topic=202.0

    Wahrscheinlicher ist eher, dass die boot.img defekt ist. Nochmals downloaden und wenn vorhanden die MD5-Prüfsummen vergleichen. (Hatte ich übrigens schonmal vorgeschlagen, bei jedem Download die zum Überprüfen anzugeben. Gerade beim flashen nervig, wenn Dateien beschädigt sind.)
     
    Zuletzt bearbeitet: 06.07.2012
  14. Ryuk, 06.07.2012 #14
    Ryuk

    Ryuk Android-Lexikon

    Beiträge:
    1,010
    Erhaltene Danke:
    207
    Registriert seit:
    19.09.2011
    bei mir wars so, dass die boot.img zu groß war...sieht aber hier nicht danach aus, zumal das upgrade ja bei dem anderen fehlerfrei ablief...
    vllt. ist der speicher ja doch defekt, bad blocks oder so...
     
  15. Gubbl, 06.07.2012 #15
    Gubbl

    Gubbl Threadstarter Neuer Benutzer

    Beiträge:
    13
    Erhaltene Danke:
    0
    Registriert seit:
    05.07.2012
    Das mit den Nullen überschreiben habe ich leider auch schon gestestet und es hat nicht zum gewünschten Erfolg geführt :(

    Ich habe schon das Originalimage, ein modifiziertes von dem Partitionierungslink und sogar das von dem bereits geupdateten Ideos benutzt und der Fehler tritt bei allen auf.

    Habe auch gerade einen anderen USB Port und sogar einen anderen Computer ausprobiert, aber das Gerät weigert sich hartnäckig. Allerdings wenn ich das Backup zurück spiele, dann funktioniert es... aber auch nur bei einem einzigen Backup. Und das originale vom Partitionierungslink funktioniert auch.

    Edit:
    Gestern hab ichs irgendwie geschafft, dass er beim Flashen jeden einzelnen Block angezeigt hat, den er gerade bearbeitet hat und es lief ca. ein dutzend Blöcke lang gut und dann kam einer mit nem Fehler.
     
    Zuletzt bearbeitet: 06.07.2012
  16. ElTonno, 06.07.2012 #16
    ElTonno

    ElTonno Android-Lexikon

    Beiträge:
    1,828
    Erhaltene Danke:
    331
    Registriert seit:
    20.09.2011
    Vielleicht hilft der Post
     
  17. KatyB, 06.07.2012 #17
    KatyB

    KatyB Ehrenmitglied

    Beiträge:
    7,858
    Erhaltene Danke:
    1,888
    Registriert seit:
    06.09.2011
    Phone:
    BQ Aquaris M5
    Deswegen flashe ich eine neue boot.img einfach per fastboot immer über die andere. Wenns nicht klappt habe ich immer noch die vorherige. So wie du das gemacht hast, ist der Nachteil dass du durch fastboot erase usw. die funktionierende gelöscht hast und jetzt keine neue mehr draufbekommst. :/
     
  18. Gubbl, 06.07.2012 #18
    Gubbl

    Gubbl Threadstarter Neuer Benutzer

    Beiträge:
    13
    Erhaltene Danke:
    0
    Registriert seit:
    05.07.2012
    Also die Partitionen miteinander tauschen geht, aber normal booten kann man so ja nicht, oder? aber wieso kann ich denn dann kein boot Image auf die Partition schreiben? Und wieso zeigt er beim Update immer beim Entpacken nach kurzer Zeit "Update Failed"
    an? Normal scheint das Gerät nicht zu sein:unsure: Mysteriös:sad:
     
    Zuletzt bearbeitet: 06.07.2012
  19. Gubbl, 07.07.2012 #19
    Gubbl

    Gubbl Threadstarter Neuer Benutzer

    Beiträge:
    13
    Erhaltene Danke:
    0
    Registriert seit:
    05.07.2012
    Soo... jetzt hab ichs geschafft, dass die Bootpartition wieder beschrieben werden kann, es hat geklappt wie im folgenden Post: http://www.android-hilfe.de/1916926-post129.html

    Aber jetzt heißts bei der Systepartition, dass diese zu groß wär. Ich verzweifel an de Ding...:mad:
     
  20. Gubbl, 07.07.2012 #20
    Gubbl

    Gubbl Threadstarter Neuer Benutzer

    Beiträge:
    13
    Erhaltene Danke:
    0
    Registriert seit:
    05.07.2012
    Jetzt hab ich nach 3 Tagenendlich wieder in funktionierendes Handy :) Ich habe jetzt Supertoast drauf gemacht und musste das neue Partitionslayout benutzen, aber hauptsache das Gerät läuft wieder :) allerdings kommt beim Playstore immer eine "Serverfehler" Meldung. Forensuche und Internet hat mir leider nicht weiterhelfen können:blushing:
     

Diese Seite empfehlen