1. Nimm jetzt an unserem Uhans - 3. ADVENT - Gewinnspiel teil - Alle Informationen findest Du hier!

Bootschleife!!!

Dieses Thema im Forum "Root / Hacking / Modding für Motorola Milestone" wurde erstellt von kabald, 13.08.2010.

  1. kabald, 13.08.2010 #1
    kabald

    kabald Threadstarter Android-Experte

    Beiträge:
    462
    Erhaltene Danke:
    88
    Registriert seit:
    16.12.2009
    Phone:
    Motorola Milestone
    Ich habe heute meine ersten Versuche in Richtung Root und Co. gewagt und die Rechnung ist jetzt ein Stein mit einer Bootschleife...

    Was habe ich gemacht? Ich wollte meine Infoleiste einfärben und habe mir hier aus dem Forum die BlackBar framework-res. und die dazu anderen Dateien runtergeladen.
    Mit der App "Root Explorer" habe ich dann die Originale framework-res.apk mit BlackBar framework-res überschrieben. Seitdem häng sich mein Stein im Boot Vorgang auf.

    Ich habe einen 2.1 Bugfix update Stein mit Root. Natürlich habe ich auch eine Sicherung der Originalen framework-res Datei... aber leider habe ich keinen Plan, was ich jetzt machen muss, damit mein Stein kein Friedhofsstein wird...
     
  2. emx_o, 13.08.2010 #2
    emx_o

    emx_o Fortgeschrittenes Mitglied

    Beiträge:
    339
    Erhaltene Danke:
    39
    Registriert seit:
    09.04.2010
    Phone:
    HTC Desire HD
    hört sich danach an als hättest du die rechte (permissions) der framework-res.apk nicht auf 644 geändert, wie es überall schön beschrieben wird
     
  3. kabald, 13.08.2010 #3
    kabald

    kabald Threadstarter Android-Experte

    Beiträge:
    462
    Erhaltene Danke:
    88
    Registriert seit:
    16.12.2009
    Phone:
    Motorola Milestone
    Danke für die Antwort... und jetzt??? Wie komme ich mit meinem PC auf meinen Stein um den Fehler rückgängig zu machen?
     
  4. emx_o, 13.08.2010 #4
    emx_o

    emx_o Fortgeschrittenes Mitglied

    Beiträge:
    339
    Erhaltene Danke:
    39
    Registriert seit:
    09.04.2010
    Phone:
    HTC Desire HD
    entweder du hast dir n nandroid backup gemacht (einfachste lösung - sollte man vor solchen eingriffen immer tun) oder du kommst zufällig noch irgendwie per adb shell aufs handy (auch recht schön) oder du flashst komplett neu (ekelhaft)

    wie der ganze spaß funktioniert (falls du keine der ersten beiden lösungen parat hast) erfährst du im how-to forum
     
  5. kabald, 13.08.2010 #5
    kabald

    kabald Threadstarter Android-Experte

    Beiträge:
    462
    Erhaltene Danke:
    88
    Registriert seit:
    16.12.2009
    Phone:
    Motorola Milestone
    Danke!

    Beim installieren von ADB meckert der rum: Failed to fetch URL https://dl-ssl.google.com/android/repository/repository.xml, reason: HTTPS SSL error. You might want to force download through HTTP in the settings.

    was läuft da falsch?
    ein nandroid backup hab ich nicht.
     
  6. emx_o, 13.08.2010 #6
    emx_o

    emx_o Fortgeschrittenes Mitglied

    Beiträge:
    339
    Erhaltene Danke:
    39
    Registriert seit:
    09.04.2010
    Phone:
    HTC Desire HD
    irgendwo in dem sdk gibts unter settings ne option "force https://..." - aktivier das :)
     
  7. -FuFu-, 13.08.2010 #7
    -FuFu-

    -FuFu- Android-Urgestein

    Beiträge:
    8,406
    Erhaltene Danke:
    3,148
    Registriert seit:
    17.03.2010
    Phone:
    Motorola Moto E 2.Gen
    man muß da nix installieren...
    aber um per adb auf den stein zu kommen muß man die OpenRecovery oder ADBRecovery auf dem Stein haben....

    gehört zu der grundausrüstung würd ich behaupten wenn man sowas macht, denn beim austauschen der framework-res.apk per rootexplorer kommt es oft zu problemen, das der stein rebootet bevor die datei komplett kopiert ist...

    und wenn du nicht per adb an den stein kommst, hilft nur flashen einer service sbf per rsd lite, so bleiben deine daten und apps wenigstens erhalten
     
  8. kabald, 14.08.2010 #8
    kabald

    kabald Threadstarter Android-Experte

    Beiträge:
    462
    Erhaltene Danke:
    88
    Registriert seit:
    16.12.2009
    Phone:
    Motorola Milestone
    Danke für eure Antworten. Ihr helft mir sehr... kann mir jedoch wer sagen... ob ich eine SHOLS_U2_02.36.0 oder eine SHOLS_U2_02.34.0 brauche?
     
    Zuletzt bearbeitet: 14.08.2010
  9. pogobi, 14.08.2010 #9
    pogobi

    pogobi Fortgeschrittenes Mitglied

    Beiträge:
    356
    Erhaltene Danke:
    121
    Registriert seit:
    10.01.2010
    Die SHOLS_02.36 ist halt die neuere Version mit Bugfixes. Nimm die ;)
     
  10. kabald, 14.08.2010 #10
    kabald

    kabald Threadstarter Android-Experte

    Beiträge:
    462
    Erhaltene Danke:
    88
    Registriert seit:
    16.12.2009
    Phone:
    Motorola Milestone
  11. segelfreund, 14.08.2010 #11
    segelfreund

    segelfreund Ehrenmitglied

    Beiträge:
    12,099
    Erhaltene Danke:
    1,554
    Registriert seit:
    12.01.2010
    Versuche mal die sbf umzubennen.
    Hatte ich auch schon oft, das hat meist geholfen.
     
  12. licht77, 14.08.2010 #12
    licht77

    licht77 Erfahrener Benutzer

    Beiträge:
    178
    Erhaltene Danke:
    17
    Registriert seit:
    23.04.2010
  13. kabald, 14.08.2010 #13
    kabald

    kabald Threadstarter Android-Experte

    Beiträge:
    462
    Erhaltene Danke:
    88
    Registriert seit:
    16.12.2009
    Phone:
    Motorola Milestone
    Oh man Leute :D ich hab ein neues Problem.
    Also hab die Datei jetzt umbenannt. kann auch auswählen und auf Start drücke. Aber dann kommt die Fehlermeldung: Failed flashing process. Error processing flash file. (0X700F), phone connected.

    Ich weiß, hier (http://www.android-hilfe.de/anleitu...how-fehlerbehebung-bei-brick-neu-flashen.html) wurde auch beschrieben wie man das umgeht.
    Aber bei meiner CMD Konsole sagt der immer, dass es kein Programme (x86) (ja ich habe w7 64bit) gibt. So dann habe ich bei RSD Lite in den Kompalibitätseinstellungen den Haken bei "Als Administrator ausführen" gesetzt. nichts hilft. Was mache ich jetzt?
     
  14. segelfreund, 14.08.2010 #14
    segelfreund

    segelfreund Ehrenmitglied

    Beiträge:
    12,099
    Erhaltene Danke:
    1,554
    Registriert seit:
    12.01.2010
    HAst Du den 64bit Treiber installiert?

    Ich habe unter 64bit keine Probleme.
     
  15. kabald, 14.08.2010 #15
    kabald

    kabald Threadstarter Android-Experte

    Beiträge:
    462
    Erhaltene Danke:
    88
    Registriert seit:
    16.12.2009
    Phone:
    Motorola Milestone
    Ja Klar :D
    Kannst du mir vllt. die Befehle schreiben, die du eingeben würdest, um rsd lite auszuführen. Weil das komische ist, dass der in der Konsole, wenn ich C:\Programme (x86) eingebe mir als Fehler ausgibt: Der Befehl "C:\Programme" ist entweder falsch geschrieben oder konnte nicht gefunden werden.
    Also das _(x86) juckt den gar nicht.

    Also ich wäre dir sehr verbunden... wenn du mir mal den Befehl hier schreiben würdest... den du in der CMD Konsole eingeben würdest.
     
  16. segelfreund, 14.08.2010 #16
    segelfreund

    segelfreund Ehrenmitglied

    Beiträge:
    12,099
    Erhaltene Danke:
    1,554
    Registriert seit:
    12.01.2010
    Ich gebe keine Befehle ein.
    Ich öffne einfach die Verknüpfung! :p:D
     
  17. kabald, 14.08.2010 #17
    kabald

    kabald Threadstarter Android-Experte

    Beiträge:
    462
    Erhaltene Danke:
    88
    Registriert seit:
    16.12.2009
    Phone:
    Motorola Milestone
    Ja toll... und was soll ich jetzt machen? :o
    & by the way... ich bin computer administrator. wieso funzt das nich???
     
  18. -FuFu-, 14.08.2010 #18
    -FuFu-

    -FuFu- Android-Urgestein

    Beiträge:
    8,406
    Erhaltene Danke:
    3,148
    Registriert seit:
    17.03.2010
    Phone:
    Motorola Moto E 2.Gen
    2 möglichkeiten, du erstellst dir eine verknüpfung und führst diese als Admin aus, oder du machst die Sicherheits-Konten-Steuerung oder wie das heißt aus, meldest dich als Administrator an und versuchst es dann...

    mehr kann ich nicht sagen, da ich xp 32bit hab :D

    ab und an hilft auch einfach ein reboot ;)
     
  19. kabald, 14.08.2010 #19
    kabald

    kabald Threadstarter Android-Experte

    Beiträge:
    462
    Erhaltene Danke:
    88
    Registriert seit:
    16.12.2009
    Phone:
    Motorola Milestone
    So egal... ich hab`s jetzt mit meinem netbook gemacht und da hat alles geklappt.
    Danke an alle, die mir geholfen haben!
     
  20. licht77, 15.08.2010 #20
    licht77

    licht77 Erfahrener Benutzer

    Beiträge:
    178
    Erhaltene Danke:
    17
    Registriert seit:
    23.04.2010
    Woa und das in einem Linux/Android Forum... anderswo würde man für sowas öffentlich im Stadion gekreuzigt :)
     

Diese Seite empfehlen