1. Nimm jetzt an unserem 2. ADVENT-Gewinnspiel teil - Alle Informationen findest Du hier!

CarMode beendet sich nicht

Dieses Thema im Forum "Samsung Galaxy S (I9000) Forum" wurde erstellt von Socke, 28.04.2011.

  1. Socke, 28.04.2011 #1
    Socke

    Socke Threadstarter Neuer Benutzer

    Beiträge:
    17
    Erhaltene Danke:
    1
    Registriert seit:
    15.11.2010
    Hallo,

    ich habe die original Samsung KFZ-Halterung und die Samsung App 'Auto Privat' installiert.

    Der Normallfall sollte sein:
    Galaxy in die Halterung --> Galaxy geht in CarMode und die App startet,
    Galaxy aus der Halterung --> Galaxy beendet CarMode und die App

    Manchmal geht das Galaxy nicht direkt in den CarMode bzw. startet die App nicht beim Einsetzen in die Halterung, doch das ist das kleinere Problem...

    Hatte jetzt schon zweimal das Problem dass sich beim Herausnehmen des Galaxys der CarMode nicht beendet, auch nicht wenn ich die App manuell (über den Exit-Button) beende.
    Das macht sich dann dadurch bemerkbar dass sich sowohl die Homescreens als auch das Menü horizontal drehen je nach Neigung des Galaxys (habe den original Launcher) bzw. dass immer der Lautsprecher angeht wenn ich einen Anruf annehme.

    Diesen Zustand kann ich lediglich durch einen kompletten Neustart des Galaxys beheben.

    Auch die App 'Car Mode' aus dem Android Market hat keinen Einfluss auf diesen Zustand.

    Hat jemand eine Idee?
     
    Turner bedankt sich.
  2. DrMole, 28.04.2011 #2
    DrMole

    DrMole Android-Ikone

    Beiträge:
    4,941
    Erhaltene Danke:
    1,463
    Registriert seit:
    06.08.2010
    Hallo
    Welche Firmware hast du?
     
  3. Socke, 28.04.2011 #3
    Socke

    Socke Threadstarter Neuer Benutzer

    Beiträge:
    17
    Erhaltene Danke:
    1
    Registriert seit:
    15.11.2010
    Oh sorry, habe ich ganz vergessen 2.2.1 FROYO.XXJQ3
     
    Zuletzt von einem Moderator bearbeitet: 28.04.2011
  4. ModIt, 28.04.2011 #4
    ModIt

    ModIt Fortgeschrittenes Mitglied

    Beiträge:
    416
    Erhaltene Danke:
    12
    Registriert seit:
    13.12.2010
    Kann man die App auch außerhalb vom Samsung Store beziehen?
    Hab den garnicht drauf...
     
  5. Turner, 26.05.2011 #5
    Turner

    Turner Neuer Benutzer

    Beiträge:
    5
    Erhaltene Danke:
    0
    Registriert seit:
    26.05.2011
    Ich habe ein ganz ähnliches Problem:

    Nach dem Einbau der Samsung KFZ Halterung und der zugehörigen Samsung Car Home bzw. Auto Privat App und der Dock Sound App ist zunächst einmal gar nix über den USB-Anschluss der Halterung übertragen worden. Egal ob ich den Lautsprecher der Car Home App an- oder ausgeschaltet habe. Da hatte ich noch JPO drauf.

    Einmal hat's kurz über die Autolautsprecher gezuckt, was ich mir aber auch nicht erklären kann.

    Heute morgen habe ich auf JPY geflasht, wonach Audio über USB im Auto auch nicht funktionierte. Nach x Versuchen, bei denen ich immer wieder die Dock Sound App aktiviert habe, das Telefon eingesetzt und wieder rausgenommen habe und nach und nach alle "Car Apps" auch die von Samsung bis auf die Dock Sound App deinstalliert habe, sprang es scheinbar in diesen Car Mode (Home-Bildschirm im Landscape-Format) und der Sound ging über die Auto-Lautsprecher. Wenn ich das Telefon aus der Schale nahm, wechselte der Sound auf den Telefon-Lautsprecher.

    Soweit sogut, die Freude war erstmal groß und es scheint so, als müsste ich nach dem Einsetzen in die Ladeschale zunächst einmal die Dock Sound App aktivieren, dann den Schlitten mit dem USB-Stecker ins Telefon schieben, was dann wieder den Car Mode aktiviert hat.

    Nach dem x-ten mal herausnehmen des Telefons aus der Halterung lief das Telefon allerdings im Car Mode weiter und der Telefon-interne Lautsprecher blieb inaktiv. Abhilfe schaffte auch hier nur der Neustart des Telefons.

    Meine bescheidene Meinung als jemand der das Samsung erst seit kurzem hat: stark verbesserungswürdiges Produktdesign und Qualitätsmanagement. Aber das hilft nicht weiter, hat statt dessen jemand Erfahrung bzw. Verbesserungsvorschläge für dieses Problem? Ich bin für alles offen, andere Apps etc...

    Bild vom Telefon im Car Mode ohne Halterung:

    SDC11081.jpg
     
  6. gokpog, 26.05.2011 #6
    gokpog

    gokpog Android-Ikone

    Beiträge:
    5,954
    Erhaltene Danke:
    1,386
    Registriert seit:
    12.11.2009
    Geht es dir nur ums Audio über USB? Wenn du die Car Home/Desk Home Apps nicht brauchst, dann installier dir nur schnell den Galaxy Dock Sound Redirector und schmeiss die Samsung Apps wieser runter.
     
  7. Turner, 26.05.2011 #7
    Turner

    Turner Neuer Benutzer

    Beiträge:
    5
    Erhaltene Danke:
    0
    Registriert seit:
    26.05.2011
    Den Galaxy Dock Sound Redirector habe ich noch als einzige "Car" App drauf. Den Redirector habe den in meinem Posting als "Dock Sound App" bezeichnet.

    Und genau der Galaxy Dock Sound Redirector scheint wohl nicht zuverlässig beendet zu werden. Oder ist der "CarMode" eine Funktion des Android? Keine Ahnung, das Samsung ist für mich Neuland.

    Edit: Sollte der Dock Sound Redirector eigentlich automatisch den USB Anschluss beim Einsetzen in die KFZ-Halterung auf Audio-Wiedergabe schalten, oder ist das wirklich so, dass man die jedes Mal aktivieren muss?
     
  8. casakorte, 26.05.2011 #8
    casakorte

    casakorte Android-Lexikon

    Beiträge:
    1,417
    Erhaltene Danke:
    389
    Registriert seit:
    17.12.2010
    Hallo Turner,
    das Bild was Du da angehängt hast ist aber nicht der Car Modus...
    ich weiß ja nicht, was Du da alles drauf hast, aber ich habe auch die JQ3 in Verbindung mit dem Galaxy Doch redirector und der Google Car App, und bei mir geht alles wunderbar.
    Gruß,
    Dirk
     
  9. Turner, 26.05.2011 #9
    Turner

    Turner Neuer Benutzer

    Beiträge:
    5
    Erhaltene Danke:
    0
    Registriert seit:
    26.05.2011
    Okay, das ist mal sehr interessant! Alle anderen "Car Irgendwas" Apps, die ich mal geladen hatte, waren zum Zeitpunkt der Aufnahme nicht mehr installiert.

    Installiert in der Richtung waren:

    - CarHome Ultra
    - Custom Car Home
    - Samsung Car Home (aus dem Samsung Market)

    Kann es sein, dass diese Ausrichtung wie auf dem Foto ein Überbleibsel der zuvor installierten Apps ist? Kurz nachdem der Sound das erste mal konstant über die Autoanlage übertragen wurde, ist bei mir ein Icon ähnlich des "Auto Widget" oder "Car Dashboard" in der Statusleiste aufgetaucht. An den Namen kann ich mich leider nicht mehr erinnern. Seither sehe ich das nicht mehr, noch kann ich mich erinnern mir eine der beiden Apps runtergeladen zu haben.

    Die Google Car App scheint für mein Galaxy nicht zur Verfügung zu stehen. Und wie sieht denn der CarMode aus?
     
  10. casakorte, 26.05.2011 #10
    casakorte

    casakorte Android-Lexikon

    Beiträge:
    1,417
    Erhaltene Danke:
    389
    Registriert seit:
    17.12.2010
    hmmm...wenn ich wüsste wie man das mit dem screeneshots macht würde ichs dir zeigen...*schäm*:wubwub:
    Also: ich habe bei mir folgendes aus dem market geladen: Auto widget pro, gibts aber auch als free Version, Galaxy Dock sound redirector...das ist schon alles. Dieses Auto widget hiess früher mal Google Car home, so steht es bei dem Auto widget geschrieben...
    PS: Wenn Du mir erklären kannst wie ich das mit dem Screenshot hinkriege bekommst Du eins von mir:)
    Dirk

    EDITH: Vergiss den Screenshot, ich hab ihn ,muss ihn nur noch hier reinfrickeln...

    Hier also die App...

    Sent from my GT-I9000 using Tapatalk


    SORRY fürs Doppelposting, wusste nicht wie ich den Screenshot hier anders reinkriegen sollte...

    So sieht bei mir der carmode aus...Ich hab ihn aus dem Market geladen und ein bischen angepasst...
    Wenn ich das SGS in das CarDock stecke, dann geht es bei mir automatisch an, wenn ich es rausnehme, wieder aus...

    Sent from my GT-I9000 using Tapatalk


    Hmmm...was ich jetzt aber noch nicht verstehe Turner: Die Halterung hat doch den USB Anschluss zum aufladen und den Klinkenanschluss für Audio...was hast Du denn wie ans Autoradio angeschlossen, das würde mich mal interessieren...ich hatte bis vor einer Woche auch noch 2.2...da ging auch nichts übers Radio, das geht erst seit 2.2.1...
     

    Anhänge:

    Zuletzt von einem Moderator bearbeitet: 26.05.2011
    Turner bedankt sich.
  11. Turner, 27.05.2011 #11
    Turner

    Turner Neuer Benutzer

    Beiträge:
    5
    Erhaltene Danke:
    0
    Registriert seit:
    26.05.2011
    Moin,

    danke für den Tip mit der Auto Widget App, die probiere ich mal aus.

    Wegen des Anschlusses habe ich mich ungenau ausgedrückt. USB-Stromversorgung vom Zigarettenanzünder und Audiokabel vom Radio gehen in die Samsung ECS-V968, also ganz normal nach Bedienungsanleitung. Entweder geht der Sound über USB erst mit 2.2.1, das ich erst seit gestern morgen installiert habe, oder ich habe mich davor nur dumm angestellt.


    Zu meinem letzten Posting:

    Das Icon, das bei mir, wie weiter oben erwähnt, in der Statusleiste auftaucht, nennt sich "Automodus". Weder Namen noch Icon kann ich mit einer bei mir installierten App in Verbindung bringen.

    SDC11082.jpg

    Das Icon taucht nur dann auf, wenn ich das Telefon in die KFZ-Halterung stecke und den Schlitten mit der USB-Halterung ins Telefon schiebe. Dann kommt eine Meldung wie "Audio Routed to Dock", der "Automodus" startet, anschließend schließe ich den Redirector und der Homescreen sieht, wenn ich Glück habe, so aus:

    SDC11083.jpg

    Manchmal allerdings muss ich den USB-Schlitten der Halterung mehrmals wieder raus- und reinschieben, da der "Automodus" nicht startet. Teilweise braucht es vier oder fünf Versuche bis sich das gewollte Ergebniss einstellt.

    Zunächst kommt die Meldung "Audio Routed to Dock", ohne dass das der Automodus startet oder der Bildschirm sich dreht:

    SDC11084.jpg


    Dann kommt das Pop-Up "Audio Routed Normal" und alles ist wie gehabt:

    SDC11085.jpg


    Ich vermute, dass die PINs des USB-Anschlusses codiert sind und die ganze Konstruktion so viel Spiel hat, dass manchmal dort kein Kontakt hergestellt wird.

    Manchmal lässt sich nämlich auf Grund der scheinbar recht großen Spiels der Halterung der USB-Stecker des Schlittens nicht einschieben, sondern bleibt am Rand der Telefon-Schale hängen (siehe Einkerbungen am Gehäuse hinter USB-Anschluss, letztes Foto).

    SDC11087-2.jpg

    Und ganz kurios, einmal wollte sich das Telefon mit Kies verbinden, als ich den Schlitten sehr langsam eingeschoben hatte.
     
    Zuletzt bearbeitet: 27.05.2011
  12. casakorte, 31.05.2011 #12
    casakorte

    casakorte Android-Lexikon

    Beiträge:
    1,417
    Erhaltene Danke:
    389
    Registriert seit:
    17.12.2010
    Hej Turner,
    das mit der Musik geht definitiv erst seit 2.2.1...vorher kam Musik nur aus dem SGS. Ich vermute mal, daß Dein Problem an dem Galaxy Sound Director liegt...schmeiss den mal runter und probiere es nur mit der Google Car App...
    Die sollte dann, sobald Du Dein SGS in die Halterung schiebst, von alleine starten und erst wieder beenden, wenn Du das SGS rausnimmst...Alternativ könntest Du aber auch mal den Custom Car Holder aus dem Market probieren, oder eben die Samsung Car App...
     
  13. Turner, 31.05.2011 #13
    Turner

    Turner Neuer Benutzer

    Beiträge:
    5
    Erhaltene Danke:
    0
    Registriert seit:
    26.05.2011
    Ich habe es auf Deinen Tip heute nochmal mit der Samsung Car Home App und dem Car Widget Free versucht, nachdem ich den Galaxy Sound Director deinstalliert habe.

    Das Verhalten ist immer noch das selbe wie nur mit dem Sound Director. Sprich, nach dem Einschieben in die Halterung taucht zunächst das Automodus-Icon kurz in der Statusleiste auf, es piept einmal und dann verschwindet es wieder. Irgendwann, es kann gleich beim ersten Mal oder auch erst nach dem zehnten Versuch sein, startet tatsächlich der Automodus und der Sound geht dauerhaft auf die Fahrzeuglautsprecher. Das ganze unabhängig davon, ob ich z. B. die Samsung App oder das Widget gestartet wurde oder nicht.

    Weil dieses Verhalten scheinbar ohne Regel ist, gehe ich von einem fehlerhaften PIN am USB-Anschluss aus. Ich habe gelesen, dass der Automodus, genauso wie dieser Quermodus für die Tischhalterung, von einem separaten, nur dafür vorgesehenen PIN im USB-Stecker der KFZ-Halterung bzw. im USB-Anschluss des Telefons initiiert wird. Und dort scheint es leider solche Fertigungstoleranzen zu geben (zumindest bei mir), die dazu führen, dass es nicht jedes Mal Kontakt gibt.

    Scheinbar ist's an der Zeit den Samsung Support wegen dieses Problems in Anspruch zu nehmen.
     
  14. casakorte, 31.05.2011 #14
    casakorte

    casakorte Android-Lexikon

    Beiträge:
    1,417
    Erhaltene Danke:
    389
    Registriert seit:
    17.12.2010
    Ich denke nicht daß es ein Fall für den Support ist...mein USB Anschluss sieht genauso aus wie bei Dir, auch mit deisen, wie Du es nennst, optischen Toleranzen, und alles klappt fehlerlos...hmmm...es muss da noch was anderes geben...was passiert denn wenn Du die Car apps runterschmeisst und nur den Director drauf hast?
     

Diese Seite empfehlen