1. Nimm jetzt an unserem Uhans - 3. ADVENT - Gewinnspiel teil - Alle Informationen findest Du hier!

CM7 + SIP-Phone-Betrieb + FritzBox = Problem

Dieses Thema im Forum "Root / Hacking / Modding für ZTE Blade / OSF / Lutea" wurde erstellt von TylerD, 28.05.2011.

  1. TylerD, 28.05.2011 #1
    TylerD

    TylerD Threadstarter Android-Hilfe.de Mitglied

    Beiträge:
    61
    Erhaltene Danke:
    9
    Registriert seit:
    05.04.2011
    Hallo,

    ich habe heute testweise versucht, mein Lutea als mobiles Telefon-Hörer für meine FritzBox (Fon Wlan 7270) zu konfigurieren, also als einfaches VOIP-Phone. Das OS ist aktuelles CM7-N85 mit der integrierten VOIP-Funktion.

    Die Registrierung funktioniert einwandfrei, Blade kriegt eine interne Kurzwahl und Mapping auf externe Nummer. Ich kann anrufen und kann angerufen werden... aber nach Annahme des Gesprächs passieren merkwürdige Dinge:

    1. man hört gar nichts auf beiden Seiten. Nach etwa zehn Sekunden wird in der Statusbar der Verlust des Netzsignals (GSM!) gemeldet und nach ein Paar Sekunden wieder aufgebaut. WiFI-Signal bleibt währenddessen konstant ok. Das Gespräch bricht ab, Dialer geht zu, aber das Hörer-Symbol in der Statusbar bleibt hängen und der Vibrationshinweis (alle 45s, ist so eingestellt) kommt auch regelmässig. Sprich, das Telefon verhält sich so, als wäre der Anruf noch aktiv, obwohl ich nicht mehr drauf zugreifen kann. Dieser Zustand bleibt, auch wenn man zwischendurch telefoniert. Nur ein Reboot hilft.
    2. das Gespräch funktioniert, aber nur in eine Richtung. Man hört die Gegenseite, aber nicht den Sprecher am Blade-Telefon.
    3. man hört gar nichts, aber das Gespräch lässt sich normal beenden.
    Testweise habe ich auch SipDroid versucht und kriege fast immer Variante 2). Mit dem nativen Client kriege ich 2) bei Anrufen von Blade zu Festnetz/Voip-Gegenseite, 1) bei Anrufen zu anderen Dect-Hörern im gleichen Netz und 3) bei Anrufen von Außerhalb zum Blade.

    Und jetzt die Preisfrage: worin liegt die Ursache? Ich bin mir fast sicher, dass an dieser FritzBox schon mal Android-Phones mit SipDroid verwendet wurden, es müsste also gehen.
     
  2. FelixL, 29.05.2011 #2
    FelixL

    FelixL Ehrenmitglied

    Beiträge:
    4,855
    Erhaltene Danke:
    754
    Registriert seit:
    26.11.2009
    Phone:
    Wileyfox Swift, HTC One M8
    Hast du die Fritz-App selbst mal probiert? Die lief bei mir.
     
  3. TylerD, 29.05.2011 #3
    TylerD

    TylerD Threadstarter Android-Hilfe.de Mitglied

    Beiträge:
    61
    Erhaltene Danke:
    9
    Registriert seit:
    05.04.2011
    Hab's gerade ausprobiert, die Labor-Version. Ergebnis: Gespräch über interne Kennung klappt gut. Anruf einer externen Nummer führt zum o.g. einseitigen Gespräch, als wäre Blades Mikro kaputt. Immerhin gibt es keine komischen Aufhänger im scheinbaren Telefonie-Modus.

    Irgendwo ist da noch der Wurm drin. Könnte vielleicht doch ein CM7-Bug sein, laut Changelogs bauen sie gerade am Audio-Routing im Zusammenhang mit SIP.
     
  4. FelixL, 29.05.2011 #4
    FelixL

    FelixL Ehrenmitglied

    Beiträge:
    4,855
    Erhaltene Danke:
    754
    Registriert seit:
    26.11.2009
    Phone:
    Wileyfox Swift, HTC One M8
    Ja, warte am besten mal die nächste Nightly ab und probier es dann noch mal.
     
  5. TylerD, 03.06.2011 #5
    TylerD

    TylerD Threadstarter Android-Hilfe.de Mitglied

    Beiträge:
    61
    Erhaltene Danke:
    9
    Registriert seit:
    05.04.2011
    Hab mir den aktuellen Git-Stand mal gebaut und drauf geflasht. Ergebnis: keine Verbesserung. Immerhin scheint Proximity-Sensor im Dialer (mit Auto-Helligkeit) jetzt zu gehen. Aber: wenn das Telefon im o.g. schein-telefonierenden Zustand landet, dann geht die Beleuchtung gar nicht mehr an.

    Ich kann mich dann noch per ADB einloggen und sehe dann aud_mgr im D-State (deutet IMHO auf IO-Hängern oder kaputte Kernel-Treibern). Und ich kann auf diese Weise noch rebooten, ohne Akku ziehen zu müssen.

    Also nach wie vor ein Trauerspiel.
     

Diese Seite empfehlen