1. Nimm jetzt an unserem Uhans - 3. ADVENT - Gewinnspiel teil - Alle Informationen findest Du hier!

Datein werden automatisch gelöscht

Dieses Thema im Forum "Samsung Galaxy Ace (S5830) Forum" wurde erstellt von InFrontOfMe, 07.10.2011.

  1. InFrontOfMe, 07.10.2011 #1
    InFrontOfMe

    InFrontOfMe Threadstarter Android-Hilfe.de Mitglied

    Beiträge:
    134
    Erhaltene Danke:
    5
    Registriert seit:
    07.10.2011
    Moin Leute!

    Ich habe folgendes Problem. Ich hatte mir Bilder aus dem Internet runtergeladen und habe sie dann aus dem download Ordner geholt und sie woanders reingepackt.

    Soweit so gut.

    Nun wollte ich verhindern das sie in der Galleri angezeigt werden und kopierte ne nomedia von nem anderen Ordner in diesen rein.
    Und plötzlich waren die reinkopierten Bilder weg. Nicht nur aus der Galerie sondern sogar von der SD Karte selber.
    Der Fehler ist sogar wiederholbar.

    Wisst ihr warum?

    Mit freundlichen Grüßen

    PS: Mein Handy ist ein Samsung Galaxy Ace.
     
  2. ChaosWare, 07.10.2011 #2
    ChaosWare

    ChaosWare Android-Experte

    Beiträge:
    457
    Erhaltene Danke:
    120
    Registriert seit:
    05.05.2011
    Ja, denn alle Dateien die mit in einem Verzeichnis mit einer .nomedia liegen werden beim Medienscan ausgelassen -> also auch nicht angezeigt (Esseiden du hast ein FileManager mit root berechtigung). Du solltest sie aber auf dem PC sehen können :)

    Gruß, Chris
     
  3. m.odem, 07.10.2011 #3
    m.odem

    m.odem Fortgeschrittenes Mitglied

    Beiträge:
    268
    Erhaltene Danke:
    42
    Registriert seit:
    07.07.2011
    @InFrontOfMe: Passiert das auch, wenn du die .nomedia nicht von nem anderen Ordner kopierst, sondern neu erstellst?

    @ChaosWare:
    Nur zu meinem Verständnis: Unter "Eigene Dateien" sind die Dateien im jeweiligen Verzeichnis aber trotzdem sichtbar?
     
  4. InFrontOfMe, 10.10.2011 #4
    InFrontOfMe

    InFrontOfMe Threadstarter Android-Hilfe.de Mitglied

    Beiträge:
    134
    Erhaltene Danke:
    5
    Registriert seit:
    07.10.2011
    Sry das ich jetzt erst antworte.

    Mit ner extra erstellten nomedia habe ich das nicht getestet. Wird sich aber wohl gleich bleiben. Nomedia bleibt halt ne nomedia.

    Bezüglich der Sache mit, die Sachen werden nicht gelöscht sondern nur versteckt. Aka MediaScanner.
    Verstehe ich das denn so richtig das der Scanner sie einfach nur nicht im HandyFileManager anzeigt? Ausser man hat nen FileManager mit Root Rechten?
    Das würde doch aber auch heissen wenn man die nomedia löschte, die Bilder alle wieder auftauchen sollten?

    Hatte vor diesem Handy nen Xperia X8. Leider nur mit 1.6 drauf. Da gab es keinen Scanner und er hat die Dateien trotz nomedia angezeigt.
    Alledings nur im FileManager.

    Gruss Chris

    Ja so heisse ich auch :)

    Edit: Also mit ner rüberkopierten nomedia verschwinden die Dateien und nach dem löschen von nomedia tauchen sie nicht wieder auf.
    Auch nicht auf dem Pc.
     
    Zuletzt bearbeitet: 10.10.2011
  5. m.odem, 10.10.2011 #5
    m.odem

    m.odem Fortgeschrittenes Mitglied

    Beiträge:
    268
    Erhaltene Danke:
    42
    Registriert seit:
    07.07.2011
    Das ist eben die Frage...??? Mach doch mal, zu verlieren hast du ja nix - außer dass die Dateien eh gelöscht werden könnten ;)

    Also bei mir versteckt die .nomedia die Dateien lediglich in der Gallery - nicht wenn ich sie über "Eigene Dateien" aufrufe! Und ich habe kein Root. (Und am PC werden die Dateien ebenfalls alle angezeigt.)
     
  6. InFrontOfMe, 10.10.2011 #6
    InFrontOfMe

    InFrontOfMe Threadstarter Android-Hilfe.de Mitglied

    Beiträge:
    134
    Erhaltene Danke:
    5
    Registriert seit:
    07.10.2011
    So habe das jetzt nochmal getestet.
    Erst Bild runtergeladen. Dann an den Pc ran. Dann ne nomedia erstellt und in den Ordner gepackt. Dann wieder vom Pc abgezogen und nachgeschaut.

    Die einzige Datei im Download Ordner war die nomedia. Dann wieder ran an den Pc zum kucken aber auch dort war die Datei weg bzw. nicht mehr zu sehen.

    Anscheinend nach wurde sie gelöscht.

    Sent from my GT-S5830
     
  7. m.odem, 10.10.2011 #7
    m.odem

    m.odem Fortgeschrittenes Mitglied

    Beiträge:
    268
    Erhaltene Danke:
    42
    Registriert seit:
    07.07.2011
    Hab das grad mal so gemacht wie du - bei mir ist die Datei da.

    Durch die .nomedia wird sie in der Gallery nicht angezeigt. Im Ace unter "Eigene Dateien" wird sie angezeigt und wenn ich das Handy am PC anschließe, dann auch dort. (Logisch, die .nomedia blendet die Datei ja nicht am PC aus!)

    Ist die Speicherkarte evtl. defekt? (Ansonsten drück ich dir die Daumen, dass die "Spezialisten" noch nen Tipp haben ;))
     
  8. InFrontOfMe, 10.10.2011 #8
    InFrontOfMe

    InFrontOfMe Threadstarter Android-Hilfe.de Mitglied

    Beiträge:
    134
    Erhaltene Danke:
    5
    Registriert seit:
    07.10.2011
    Also meine Speicherkarte ist die, die beim Lieferumfang dabei war.

    Ich habe gerade festgestellt das alle ORDNER die mit einem Punkt anfangen
    (.Ordnername) nicht angezeigt werden wenn man bei Eigene Dateien bzw. My Files in die Settings geht und den Hacken bei versteckte Dateien anzeigen rausnimmt.

    Am Pc werden sie dann aber wieder gezeigt und die die Bilder die im Punkt Ordner sind werden nicht in der Gallerie gezeigt.
    Einziger Nachteil das Bild greift auf keine Thumb Datei zurück und das öffnen übers Handy dauert dann lange.

    Ist ja irgendwie interessant das ganze.

    Mit freundlichen Grüssen.
     
  9. InFrontOfMe, 18.10.2011 #9
    InFrontOfMe

    InFrontOfMe Threadstarter Android-Hilfe.de Mitglied

    Beiträge:
    134
    Erhaltene Danke:
    5
    Registriert seit:
    07.10.2011
    Besser spät als nie.

    Das Problem mit der nomedia bei den Bildern ist zwar nicht behoben aber ich komme gut mit den Punktordnern zurecht.

    Downloaden, in den Punkt Ordnern rein und sie sind versteckt. Sichtbar machen und den Ordner umbennen, egal wie hauptsache der Punkt ist weg und schon laden alle Bilder so schnell wie sie sollen.

    Wenn man fertig ist, Ordner umbennen (also Punkt wieder vorsetzen) und schon verschwinden sie wieder aus der Gallerie.

    Somit ist das Problem ansich nicht behoben, wurde aber elegant umgangen.
    Danke für die Hilfe.

    Thread kann geschlossen werden.
     

Diese Seite empfehlen