1. Nimm jetzt an unserem 2. ADVENT-Gewinnspiel teil - Alle Informationen findest Du hier!

Defy Bluetooth Tethering unter Linux?

Dieses Thema im Forum "Motorola Defy Forum" wurde erstellt von ktwo, 20.04.2011.

  1. ktwo, 20.04.2011 #1
    ktwo

    ktwo Threadstarter Android-Hilfe.de Mitglied

    Beiträge:
    104
    Erhaltene Danke:
    16
    Registriert seit:
    14.04.2011
    Hi,
    das DEFY hat ja bekanntlich (als eines der wenigen Android Smartphone) einen Bluetooth Tethering modus standardmäßig (also ohne root und wifi-tehter etc.) über ein DUN profil.

    über windows xp, 7 geht es problemlos mit *99# als einwahlnummer und web/web als PW

    unter linux (ubuntu) geht es aber nicht, hat jemand eventuell schon getestet? Eine idee woran es leigen könnte? das Pairing klappt einwandfrei
     
  2. TeaAge, 20.04.2011 #2
    TeaAge

    TeaAge Fortgeschrittenes Mitglied

    Beiträge:
    295
    Erhaltene Danke:
    63
    Registriert seit:
    29.12.2010
    Phone:
    Motorola Defy
  3. ktwo, 20.04.2011 #3
    ktwo

    ktwo Threadstarter Android-Hilfe.de Mitglied

    Beiträge:
    104
    Erhaltene Danke:
    16
    Registriert seit:
    14.04.2011
    Thx schon mal für den thread, USB-teher ist aber doch etwas anderes wie BT was die vorgehensweise angeht - bzw. USB-tether geht eh ohne große probleme, egal mit welchem OS

    ich schaffe mit BT-Tether ( unter XP) mit dem defy locker 8 stunden daueronline sein (natürlich nicht auf voll last) bis der akku endgültig leer ist (mit einigen reconnects dazwischen, weil es anscheinend probleme aht manchmal)

    nun wäre halt bei wlan die frage, das frisst doch deutlich mehr strom oder nicht?
    ob wlan oder bt wäre mir an sich egal, oder kann man das wlan so weit drosseln, dass es nicht mehr strom zieht wie bt
     
  4. TeaAge, 20.04.2011 #4
    TeaAge

    TeaAge Fortgeschrittenes Mitglied

    Beiträge:
    295
    Erhaltene Danke:
    63
    Registriert seit:
    29.12.2010
    Phone:
    Motorola Defy
    Ach sorry, hast natürlich völlig recht. Weiß auch nicht was mich jetzt geritten hat.
    Ja, Hotspot frisst schon gut Saft, wahrscheinlich auch mehr als BT (ohne das jetzt wirklich getestet zu haben).

    Gruß
     
  5. Maxpo, 20.04.2011 #5
    Maxpo

    Maxpo Neuer Benutzer

    Beiträge:
    17
    Erhaltene Danke:
    6
    Registriert seit:
    17.02.2011
    Liegt meines erachtens an Ubuntu.
    Bei mir hat unter 10.10 auf die schnelle nicht mal das Pairing funktioniert.

    Werde mir das später mal anschauen wenn ich zu Hause bin.

    Grüße
     
  6. schenkelklopfer, 27.06.2011 #6
    schenkelklopfer

    schenkelklopfer Fortgeschrittenes Mitglied

    Beiträge:
    313
    Erhaltene Danke:
    16
    Registriert seit:
    29.10.2009
    Phone:
    Ulefone Power
    Tablet:
    Amazon Fire (2015)
    Sonstige:
    AFTVStick
    bei mir läufts super
    ubuntu 11.04

    bluetooth aufm handy an.
    (ich hab nicht mal die Internethotspot Verbindung angemacht aufm defy, nur bluetooth)
    dann paaren (ging bei mir ohne Probleme)
    dann:
    auf das Verbunden MB525 klicken, und Network Access Point anmachen.
    schon bin ich verbunden. (ich schreib darüber gerade...)

    ich hoffe das hilft euch weiter!
     
  7. ktwo, 27.06.2011 #7
    ktwo

    ktwo Threadstarter Android-Hilfe.de Mitglied

    Beiträge:
    104
    Erhaltene Danke:
    16
    Registriert seit:
    14.04.2011
    Hi wärst du bitte so nett und machst 1-2 screenshots von deiner ansicht im networkmanager (oder einstellungen) ? das paaren an sich langt bei mir nicht. Benutzt du stock froyo? oder ein anderes rom / pdanet installiert?

    nur das wir uns richtig verstehen: stock froyo + bluetooth + ubuntu

    du bist absolut sicher dass wlan aus ist und die verbindung auch vom handy kommt? xD

    Unter windows 7 muss ich ebenfalls eine dun-verbindung aufbauen (manuell). PAN / NAP scheint es iwie nicht zu geben
     
  8. schenkelklopfer, 27.06.2011 #8
    schenkelklopfer

    schenkelklopfer Fortgeschrittenes Mitglied

    Beiträge:
    313
    Erhaltene Danke:
    16
    Registriert seit:
    29.10.2009
    Phone:
    Ulefone Power
    Tablet:
    Amazon Fire (2015)
    Sonstige:
    AFTVStick
    ja, nur bluetooth ist am handy an, kein wlan.
    100%
    standard ubuntu 11.04
    standard froyo rom (vodafone inkl.)

    screenshots kann ich später nachreichen...
    (Einstellungen waren automatisch eingestellt sind aber wie folgt:
    MB 525 --> Einwahl Netzwerk (DUN) -->
    dann kommt auf dem Handy: internetfreigabe von Notebook "xyz"
    haken bei immer erlauben gemacht und OK

    anschliessend auf dem notebook doppelklick auf das bluetooth symbol.
    dann rechtsklick auf mein handy symbol und auf "Network Access Point" klicken
    wichtig, das problem hatte ich auch:
    nicht über dialupnetwork ... wenn das aktiv ist, mach einen disconnect.
    läuft wunderbar
     
    Zuletzt bearbeitet: 27.06.2011
  9. schenkelklopfer, 28.06.2011 #9
    schenkelklopfer

    schenkelklopfer Fortgeschrittenes Mitglied

    Beiträge:
    313
    Erhaltene Danke:
    16
    Registriert seit:
    29.10.2009
    Phone:
    Ulefone Power
    Tablet:
    Amazon Fire (2015)
    Sonstige:
    AFTVStick
    kommst du damit klar, oder brauchst du noch hilfe?
     
  10. cae

    cae Neuer Benutzer

    Beiträge:
    2
    Erhaltene Danke:
    0
    Registriert seit:
    15.05.2013
    Vorneweg: Mir ist bewusst, dass der letzte Post hier im Thread zwei Jahre alt ist.

    Ich habe mich kuerzlich mit demselben Problem herumgeschlagen. Insbesondere ging es mir darum, auf das kaputte NetworkManager-Geraffel zu verzichten. Das funktioniert auch einwandfrei, und damit kuenftige Besucher nicht dumm sterben, ist hier das Skript, welches ich zu diesem Zweck geschrieben habe:
    Code:
    #!/bin/sh
    # MIT License, author <cae@debianforum.de> 2013-05-14
    #
    # script designed to enable bluetooth tethering from a Motorola Defy (but may
    # work for similar devices)
    #
    # 1) install the packages rfkill, bluez, wvdial and ppp (or similar, you need
    #    rfkill, bluetooth-agent, hciconfig, hcitool, wvdial, pppd)
    # 2) on the Android 2.2 configuration: wireless and networks/mobile network/
    #    internet tethering -> enable. Switch bluetooth on.
    # 3) put/append the wvdial.conf (this file, line 55+) to /etc/wvdial.conf
    # 4) config this script and start it; pair (check phone), start tethering
    #    (check phone), profit.
    # hint: once paired, you can skip pairing by calling with --nopair
    #
    set -e #-x
    
    # get MAC via # hcitool scan # (while phone is 'visible')
    modem_mac=CA:FE:DE:AD:BE:EF;
    # get device name via # hcitool dev # (it's the local bluetooth dev)
    modem_dev=hci0;
    # get channel via # sdptool search DUN # (while phone is 'visible')
    network_channel=1;
    # custom name for your local bluetooth device
    own_name='mybluetoothdev';
    
    trap ' \
    rfcomm release '"$modem_dev"'; \
    hciconfig '"$modem_dev"' down; \
    rfkill block bluetooth; \
    ' EXIT; # FIXME: reset pairing here?
    trap '' INT; # to enable cancelling wvdial with ^C
    
    rfkill unblock bluetooth;
    hciconfig "$modem_dev" up;
    hciconfig "$modem_dev" name "$own_name";
    
    if [ x--nopair != "x$1" ]; then # FIXME: recognize if you're already paired
        rnd="$(tr -cd 0-9 </dev/urandom | head -c 4)";
        bluetooth-agent "$rnd" &
        kill=$!;
        echo "## accept pairing handshake and press enter (you are probably "\
    "already paired)...";
        read fnord; # blocking here
        kill "$kill";
    fi
    
    rfcomm bind "$modem_dev" "$modem_mac" "$network_channel";
    
    echo "## accept tethering request on phone...";
    wvdial defy; # -> /etc/wvdial.conf (see below)
    
    exit $?;
    
    ; /etc/wvdial.conf
    [Dialer defy]
    Modem = /dev/rfcomm0
    Baud = 115200
    Init1 = ATZ
    Init2 =
    Init3 =
    Init4 =
    Init5 =
    Init6 =
    Init7 =
    Init8 =
    Init9 =
    Phone = *99#
    Phone1 =
    Phone2 =
    Phone3 =
    Phone4 =
    Dial Prefix =
    Dial Attempts = 10
    Dial Command = ATDT
    Ask Password = off
    Password = dummydummythisis
    Username = totallyirrelevant
    Auto Reconnect = on
    Abort on Busy = off
    Carrier Check = on
    ;Check Def Route = on
    Abort on No Dialtone = on
    Stupid Mode = on
    Idle Seconds = 0
    Auto DNS = on
    ; /etc/wvdial.conf END
    (falls es hier einen Pastebin gibt (den ich nicht finden konnte), moege der Mod des Tages bitte das Skript verschieben.)

    Das Skript ist imho weitgehend selbsterklaerend; vielleicht ist das Verhalten von wvdial zunaechst ungewohnt: wvdial startet, aktiviert das Modem und setzt Netzwerkeinstellungen und scheint dann nix mehr zu tun. Das ist korrekt, in diesem Zustand haelt es die Verbindung offen, sobald man den Prozess per Strg+C abbricht, wird diese beendet.

    Gruss,

    cae
     

Diese Seite empfehlen