1. Nimm jetzt an unserem 2. ADVENT-Gewinnspiel teil - Alle Informationen findest Du hier!

Desire HD: 100% CPU-Last durch "init linux prozess"

Dieses Thema im Forum "HTC Desire HD Forum" wurde erstellt von Killerkai, 31.10.2010.

  1. Killerkai, 31.10.2010 #1
    Killerkai

    Killerkai Threadstarter Junior Mitglied

    Beiträge:
    30
    Erhaltene Danke:
    1
    Registriert seit:
    25.10.2010
    Hallo, bin nicht sicher ob es eine Eigenart des DHD ist oder ob es Froyo allgemein betrifft.
    Gelegentlich wird mein gerät träge und warm. Im Taskmanager (App) stelle ich dann fest, das der Prozess init Linux process die CPU voll auslastet. Es hilft nur ein kompletter neustart..
    Im netz habe ich keine Lösung dazu gefunden, aber ich bin wohl nicht der einzige.
    Hat einer von euch schon so ein Problem gehabt?
    Ich verzweifel hier noch. Es tritt scheinbar oft nach dem abziehen des ladegerätes auf.
    Ist ein o2 gerät, nicht gerootet und ohne taskkiller o.ä.

    Bitte helft mir!!
     
  2. segelfreund, 31.10.2010 #2
    segelfreund

    segelfreund Ehrenmitglied

    Beiträge:
    12,099
    Erhaltene Danke:
    1,554
    Registriert seit:
    12.01.2010
    Oh das wäre sehr schade wenn das so wäre.
    Ich habe ein ähnliches Problem beim MS. Dachte aber es liegt an der noch nicht offiziellen Froyo Version.

    Probiere mal ob es weg ist wenn Du beim Abziehvorgang den bildschirm ab hast.

    Sent from my Milestone using Tapatalk
     
  3. GeorgFoc, 31.10.2010 #3
    GeorgFoc

    GeorgFoc Erfahrener Benutzer

    Beiträge:
    210
    Erhaltene Danke:
    16
    Registriert seit:
    02.09.2009
    Also ich kenne das Problem nicht. Was für einen Taskmanager hast du. Allgemein sollte man die Finger, von Taskkiller lassen.

    Lass das Handy doch mal machen.
     
  4. Killerkai, 31.10.2010 #4
    Killerkai

    Killerkai Threadstarter Junior Mitglied

    Beiträge:
    30
    Erhaltene Danke:
    1
    Registriert seit:
    25.10.2010
    Hi, den taskmanager habe ich nur installiert um herauszubekommen warum das gerät plötzlich warm wird und alles ruckelt.. hab da so einen watchdog taskkiller installiert, der meldet wenn ein task über einen längeren Zeitraum mehr als 50% last verursacht.
    Ansonsten Kille ich gar nichts. Das hd hat ja genug Power.
    Allerdings lässt sich der besagte init Prozess ja auch nicht killen.
    Neustart ist nötig..
    Ich verzweifel hier!!
     
  5. ulbi, 31.10.2010 #5
    ulbi

    ulbi Erfahrener Benutzer

    Beiträge:
    154
    Erhaltene Danke:
    7
    Registriert seit:
    18.08.2009
    Ich hab auch ein Desire HD von o2 und hab teilweise das gleiche Problem. Geht nur neustarten. Hab auch schon das Handy zurück gesetzt. Kommt aber nach einer Weile wieder.
     
  6. djbommel, 01.11.2010 #6
    djbommel

    djbommel Fortgeschrittenes Mitglied

    Beiträge:
    387
    Erhaltene Danke:
    21
    Registriert seit:
    23.09.2009
    Phone:
    Nexus S
    Hmmm,


    das hört sich stark nach dem USB Bug an.:angry: Wenn das Teil am Kabel war, einfach mal restarten und weiterhin beobachten.


    Bommel
     
  7. Herr Lehmann, 01.11.2010 #7
    Herr Lehmann

    Herr Lehmann Android-Hilfe.de Mitglied

    Beiträge:
    48
    Erhaltene Danke:
    3
    Registriert seit:
    25.10.2010
    Kannst Du den USB-Bug mal näher beschreiben? Wo ist der denn bereits aufgetreten und was konnte man dagegen tun?

    THX
     
  8. Killerkai, 01.11.2010 #8
    Killerkai

    Killerkai Threadstarter Junior Mitglied

    Beiträge:
    30
    Erhaltene Danke:
    1
    Registriert seit:
    25.10.2010
    Hmm, ja- das könnte mit usb zu tun haben. Immerhin wird ja die usb Buchse zum laden benutzt. Nach dem restart ist alles ok.. bis dann irgendwann der Fehler wieder da ist.
    Gibt es genaueres zu dem "usb-Bug"?
     
  9. segelfreund, 01.11.2010 #9
    segelfreund

    segelfreund Ehrenmitglied

    Beiträge:
    12,099
    Erhaltene Danke:
    1,554
    Registriert seit:
    12.01.2010
    Nun das ganze gab es oder gibt es beim MS auch.

    Und zwar kam dieser Fehler nach dem laden.
    Wurde das Gerät danach neu gestartet war wieder alles i.O.
    Bis zum nächsten Ladevorgang.

    Teilweise hat es geholfen das Display beim abziehen anzuhaben, teilweise nicht.
     
  10. djbommel, 01.11.2010 #10
    djbommel

    djbommel Fortgeschrittenes Mitglied

    Beiträge:
    387
    Erhaltene Danke:
    21
    Registriert seit:
    23.09.2009
    Phone:
    Nexus S
    Hmm,

    obwohl mich dann schon der "init process" wundert. Da ich glaube, dass das dann was anders ist.:confused:


    Bommel
     
  11. directmail, 06.11.2010 #11
    directmail

    directmail Neuer Benutzer

    Beiträge:
    3
    Erhaltene Danke:
    1
    Registriert seit:
    06.11.2010
    Ich habe das gleiche Problem - der /init Prozess hat immer eine hohe CPU-Auslastung von 80-100%. Keine Ahnung was der Auslöser ist aber das Problem kann man nur per Neustart beheben. Da der Akku dadurch schnell leer wird kann man das Handy fast nicht mehr benutzen...

    Das Problem gab es auch auf anderen Handys und scheint an Froyo 2.2 zu liegen. Manchmal läuft das Handy für 2-3 Tage problemlos aber der Init Bug kommt nach einer Weile immer wieder. Der Bug scheint häufiger als gedacht vorzukommen...

    Mehr info hier:
    /INIT process Desire HD lag problems. - xda-developers
     
    Zuletzt bearbeitet: 06.11.2010
    schilfrohr1 bedankt sich.
  12. apsis, 06.11.2010 #12
    apsis

    apsis Android-Hilfe.de Mitglied

    Beiträge:
    139
    Erhaltene Danke:
    50
    Registriert seit:
    22.10.2010
    Hört sich echt merkwürdig an, ich hab sowas zum Glück noch nicht festgestellt. Beim überfliegen des Threads bei den XDA's bin ich darauf gestoßen:
    Hört sich zumindest irgendwo logisch an, daher wäre es vllt. interessant wenn die Betroffenen Personen mal aufführen wie sie :
    - die Synchronisation der Konten eingestellt haben
    - das Problem über diesen Weg reproduzierbar ist (dauerhaft synchronisieren verweigern - wird dann synchronisiert, taucht der Fehler auf)
     
  13. directmail, 06.11.2010 #13
    directmail

    directmail Neuer Benutzer

    Beiträge:
    3
    Erhaltene Danke:
    1
    Registriert seit:
    06.11.2010
    Nachdem ich folgenden Artikel gelesen habe
    Issue 3453 - android - Android gets slow after about a week, system_service takes more and more CPU (HTC Android) - Project Hosting on Google Code

    habe ich auch gedacht, dass es wahrscheinlich an Google Locations oder ähnliches liegen könnte aber andere Benutzer die das gleiche Problem haben, haben Google Maps oder Latitude noch nie benutzt. Ich denke aber auch, dass das Problem irgendwie mit der Synchonisation der Konton zusammenhängt. Ich habe bemerkt, dass der HTC Kalender immer 100% CPU Auslastung beim synchronisieren hat und habe danach (aber nicht immer) den init bug bemerkt. Da der init bug so willkürlich auftaucht, ist es schwierig eine Ursache zu finden...
     
  14. directmail, 06.11.2010 #14
    directmail

    directmail Neuer Benutzer

    Beiträge:
    3
    Erhaltene Danke:
    1
    Registriert seit:
    06.11.2010
    Angeblich hat ein Benutzer bemerkt, dass die 100% cpu-auslastung des init prozesses gestoppt werden kann wenn man "USB debugging mode" aktiviert. Gibt es genauere informationen zum USB Bug oder einen link?
     
  15. djbommel, 10.11.2010 #15
    djbommel

    djbommel Fortgeschrittenes Mitglied

    Beiträge:
    387
    Erhaltene Danke:
    21
    Registriert seit:
    23.09.2009
    Phone:
    Nexus S
    AlexManner und schilfrohr1 haben sich bedankt.
  16. emx_o, 10.11.2010 #16
    emx_o

    emx_o Fortgeschrittenes Mitglied

    Beiträge:
    339
    Erhaltene Danke:
    39
    Registriert seit:
    09.04.2010
    Phone:
    HTC Desire HD
    das problem hat sich mit dem usb debugging mode auch bei mir erledigt
     
  17. name_th, 11.11.2010 #17
    name_th

    name_th Android-Hilfe.de Mitglied

    Beiträge:
    75
    Erhaltene Danke:
    34
    Registriert seit:
    20.10.2010
    Naja, gefixed würde ich das aber nicht nennen :D Eher ein Workaround bis zum eigentlichen Fix ;)
     
  18. Herr K., 11.11.2010 #18
    Herr K.

    Herr K. Android-Hilfe.de Mitglied

    Beiträge:
    68
    Erhaltene Danke:
    1
    Registriert seit:
    05.11.2010
    Der Workaround hat es aber in sich. Bemerkbar bei mir in Geschwindigkeit und insbesondere in der Akkulaufzeit.

    grüße
     
  19. djbommel, 11.11.2010 #19
    djbommel

    djbommel Fortgeschrittenes Mitglied

    Beiträge:
    387
    Erhaltene Danke:
    21
    Registriert seit:
    23.09.2009
    Phone:
    Nexus S
    Bommel ´o Brian würde sagen "Temp Fix"
     
    Zuletzt bearbeitet: 11.11.2010
  20. schilfrohr1, 11.11.2010 #20
    schilfrohr1

    schilfrohr1 Erfahrener Benutzer

    Beiträge:
    157
    Erhaltene Danke:
    12
    Registriert seit:
    29.09.2010
    Frage:
    ganz klar ist mir die Bedeutung von "usb-debugging" als androider Neuling nicht. Fehlererkennung von selbstentwickelten Apps am PC?

    Kann der Modus "usb-debugging" auch Schaden anrichten (zB bei Anschluss an einen Mac)? Gibt es überhaupt irgendeinen Nachteil an dieser Einstellung?

    Und: warum verlängert sich die Akku-Laufzeit? Und in welchem Ausmaß?

    Super Infos übrigens!!! Wie immer in dieser Community!! Ich musste ebenfalls häufiger neustarten, war aber für mich nichts neues, ich bin davon ausgegangen, das´müsste halt so sein.. bin gespannt, wie es jetzt weiter geht.
    S.
     

Diese Seite empfehlen