Desire nach Update zerflasht!

Dieses Thema im Forum "Root / Hacking / Modding für HTC Desire" wurde erstellt von MrFreezeman, 13.09.2011.

  1. MrFreezeman, 13.09.2011 #1
    MrFreezeman

    MrFreezeman Threadstarter Neuer Benutzer

    Beiträge:
    16
    Erhaltene Danke:
    0
    Registriert seit:
    13.09.2011
    Hallo Leute, hab ein riesen Problem, und das wird komplex :-S

    Angefangen hat alles damit, dass ich Gingerbread mit Sense 3.0 auf meinem Desire haben wollte.
    Eigentlich kenne ich mich damit gar nicht schlecht aus. Hab S-OFF gemacht, Goldcardtool erstellt und angewendet, neuen hboot mit Bravo CM7 r2 geflasht, und dann das ROM hier geflasht. Alles wunderbar, lief gut...
    Allerdings lief das ROM doch etwas zach auf dem Desire, weshalb ich mich entschied, doch wieder auf das gute alte ORIGINAL Froyo zu wechseln. Dummerweise (wohl) wollte ich das ungebrandete originale ROM installieren (habe ein gebrandetes T-Mobile Handy mit SLCD), nämlich aus der Anleitung hier: HTC Desire Root rückängig machen, S-OFF entfernen, Rebranden Irgendwann brach aber das Update ab, und seitdem, wenn ich das Desire einschalte kommt nur noch ein schwarzer Bildschirm, mit dem HTC Logo in der Mitte und vier Anführungszeichen (in Dreiecken) an den Ecken.
    Mehr geht nicht. Ich komme weder in das Recovery, noch in den hboot hinein. Kann also rein gar nichts machen. Wenn ich allerdings das USB Kabel nach Anstecken wieder herausziehe, dann wechselt der Bildschirm und zeigt mir folgendes an:

    -----------------------
    AlphaRev CM7 r2
    BRAVO PVT4 SHIP S-OF
    HBOOT-6-93-1002
    MCROP-051d
    TOUCH PANEL-SYNT0101
    Radio-5.11.05.27
    Aug 10 2010,17:52:18

    RUU
    ------------------------

    Und mehr lässt sich da auch nicht machen. Hat hier IRGENDJEMAND einen Rat? Ist das Desire komplett bricked? Oder lässt sich da noch was machen? Ich habe schon versucht ein originales RUU zu flashen (das für T-Mobile dann), aber ich bekomme über USB keine Verbindung mehr zu der .exe am PC, obwohl eigentlich alles verbindungstechnisch soweit passt...!?

    BITTE HELFT MIR IHR EXPERTEN!!!! :-( :-S
     
  2. Melatroid, 13.09.2011 #2
    Melatroid

    Melatroid Neuer Benutzer

    Beiträge:
    22
    Erhaltene Danke:
    0
    Registriert seit:
    09.11.2009
    Phone:
    HTC Desire
    Ohhh..... du hättest auf jedenfall mal nicht das Original Flashen dürfen


    Zu deinem Problem:
    Hört sich nach Brick an. Hast du ADB auf dem PC und mal versucht damit auf das Gerät zuzugreifen? Wenn nicht lade dir die ADB Shell runter und guck nach ob dein Gerät erkannt wird, dann kannst du es mit viel Glück nachträglich Rebricken.

    Meld dich.
     
  3. 2WildFire, 14.09.2011 #3
    2WildFire

    2WildFire Android-Guru

    Beiträge:
    3,000
    Erhaltene Danke:
    469
    Registriert seit:
    26.10.2010
    Du solltest erstmal wieder den downgrade hboot flashen, versuch das mal evtl mit dem Androidflasher.
    Dann nochmal mit der T-mob RUU versuchen.
     
  4. MrFreezeman, 14.09.2011 #4
    MrFreezeman

    MrFreezeman Threadstarter Neuer Benutzer

    Beiträge:
    16
    Erhaltene Danke:
    0
    Registriert seit:
    13.09.2011
    Danke für eure Hilfe, aber das geht ja eben nicht. Habs mit der adb schon versucht, aber mit "adb devices" findet er kein Gerät. Auch mit dem Android Flasher funktioniert das nicht, weil er über USB kein device findet.
    Irgendwie ging das mal, dass ich sogar die RUU neu installieren konnte, bzw. den Installationsprozess neu anstarten konnte, aber mittlerweile findet keine Flash-Apllikation mehr dieses Desire via USB.

    Weiß einer weiter? Kompletter brick?
     
  5. Thyrion, 14.09.2011 #5
    Thyrion

    Thyrion Ehrenmitglied

    Beiträge:
    11,845
    Erhaltene Danke:
    2,450
    Registriert seit:
    21.07.2009
    Phone:
    Nexus 5X
    Im Hboot-Modus verwendet man auch kein ADB, sondern Fastboot.

    Und deine RUUs schlagen fehl, weil du noch den geänderten HBOOT hast.

    Also eigentlich wie 2WildFire schon schrieb:
    - Den Downgrade HBOOT von AlphaRev 1.8 laden
    - fastboot flash hboot bravo_downgrade.img
    - Danach T-Mobile RUU ausführen: Shipped ROMs

    Solltest du gar keine USB-Verbindung mehr hinbekommen (und einen Kartenleser zur Hand haben), kannst du auch jeweils auf die PB99img ausweichen. Diese dann als "PB99IMG.zip" auf die SD-Karte legen und im HBOOT-Modus starten.

    T-Mob PB99IMG
     
  6. MrFreezeman, 14.09.2011 #6
    MrFreezeman

    MrFreezeman Threadstarter Neuer Benutzer

    Beiträge:
    16
    Erhaltene Danke:
    0
    Registriert seit:
    13.09.2011
    Ja, aber genau da liegt der Hund begraben, weil ich weder über adb noch über fastboot ein device finde (das Kommando gibts ja für beide Befehle: "adb devices" und "fastboot devices"). Das flashen hab ich bereits versucht.

    Die zip-Datei vom downgrad-hboot hab ich schon auf die SD-Karte gebracht (mit anderem Handy), aber das bringt ja auch nix, weil ich nicht in den HBOOT-Modus (mit Leiser-Taste und POWER) komme. Daher kann ich auch nichts flashen... :-S :-(

    Noch nen Tipp, oder hab ich noch was nicht verstanden? Anbei auch die cmd-Resultate mit fastboot und adb
     

    Anhänge:

    • cmd.jpg
      cmd.jpg
      Dateigröße:
      29 KB
      Aufrufe:
      126
  7. Melatroid, 14.09.2011 #7
    Melatroid

    Melatroid Neuer Benutzer

    Beiträge:
    22
    Erhaltene Danke:
    0
    Registriert seit:
    09.11.2009
    Phone:
    HTC Desire
    Hast du es mit Fastboot mal probiert? Mach mal en kleines Video wie du das gerät anmachst und was passiert

    Gesendet mit der Android-Hilfe.de-App
     
  8. MrFreezeman, 14.09.2011 #8
    MrFreezeman

    MrFreezeman Threadstarter Neuer Benutzer

    Beiträge:
    16
    Erhaltene Danke:
    0
    Registriert seit:
    13.09.2011
    Ich hab jetzt keine gute Kamera da...
    Aber vom Ablauf:

    1.) bravo_downgrade.img (von alpharev) in das Verzeichnis kopieren, in dem die adb-tools zu finden sind
    2.) Handy mit der Power-Taste starten
    3.) Es erscheint auf dem Handy das HTC Logo in der Mitte und die vier Dreiecke in den Ecken, mit jeweils einem Ausrufezeichen darin (Siehe Anhang ganz oben)
    4.) Eingabe in die CMD: "fastboot devices"
    5.) Es kommt: " "
    --> nichts! :-D
    ------> Er findet wohl kein device
    6.) gebe ich ein: "adb devices" kommt, dass er einen Port öffnet und die Liste anhängt (mehr aber nicht!? Anhang?)
    7.) Gebe ich "fastboot flash hboot bravo_downgrade.img" ein, dann sagt er "error: cannot load "bravo_downgrade.img"
    8.) Auf dem Handy passiert nix (nie) und ich komm auch mit keinen Tastenkombinationen weiter

    JEMAND HILFE?
     
  9. Melatroid, 14.09.2011 #9
    Melatroid

    Melatroid Neuer Benutzer

    Beiträge:
    22
    Erhaltene Danke:
    0
    Registriert seit:
    09.11.2009
    Phone:
    HTC Desire
    Startest du das gerät auch mit VOL DOWN + Power?

    Gesendet mit der Android-Hilfe.de-App
     
  10. MrFreezeman, 14.09.2011 #10
    MrFreezeman

    MrFreezeman Threadstarter Neuer Benutzer

    Beiträge:
    16
    Erhaltene Danke:
    0
    Registriert seit:
    13.09.2011
    Macht keinen Unterschied... man landet beim selben Bild...
     
  11. Melatroid, 14.09.2011 #11
    Melatroid

    Melatroid Neuer Benutzer

    Beiträge:
    22
    Erhaltene Danke:
    0
    Registriert seit:
    09.11.2009
    Phone:
    HTC Desire
    Tut mir leid aber an dieser Stelle ist mein chinesisch zu Ende :(

    Gesendet mit der Android-Hilfe.de-App
     
  12. Thyrion, 14.09.2011 #12
    Thyrion

    Thyrion Ehrenmitglied

    Beiträge:
    11,845
    Erhaltene Danke:
    2,450
    Registriert seit:
    21.07.2009
    Phone:
    Nexus 5X
    Zu 7) Wenn du sie schon in das Verzeichnis der Tools kopierst (siehe 1) - warum auch immer), dann solltest du bevor du den Befehl machst dich auch in diesem Verzeichnis befinden.

    Da es aber wohl im HBOOT-Modus (also der Modus, wenn dort die ganzen Infos stehen, den du weiter oben ja schon irgendwie hinbekommen hast) nicht von deinem System gefunden wird (Treiber richtig installiert?) - versuch das ganze mal als PB99img.zip (gibt's auch auf der Alpharev-Seite): Zip-Datei herunterladen, als "PB99IMG.zip" auf die SD-Karte kopieren, Gerät im HBOOT-Modus starten/einschalten/versetzen.

    Mit der RUU verfährst du dann ähnlich: http://www.android-hilfe.de/anleitu...card-ruu-exe-rooten-recovery-allgemeines.html
     
  13. Melatroid, 14.09.2011 #13
    Melatroid

    Melatroid Neuer Benutzer

    Beiträge:
    22
    Erhaltene Danke:
    0
    Registriert seit:
    09.11.2009
    Phone:
    HTC Desire
    Das hab ich allerdings auch nicht verstande. Wenn du im hboot Modus sein solltest müsstest eig mit VOL UP VOL DOWN iwas machen können !

    Deswegen mach ein kurz clip auf yt damit dir überhaupt jemand sagen kann was Sache ist.

    Gesendet mit der Android-Hilfe.de-App
     
  14. MrFreezeman, 14.09.2011 #14
    MrFreezeman

    MrFreezeman Threadstarter Neuer Benutzer

    Beiträge:
    16
    Erhaltene Danke:
    0
    Registriert seit:
    13.09.2011
    Wow, moment habs immerhin jetzt geschafft mit den tools "fastboot" etwas zu machen. Der Treiber auf dem PC war irgendwie abgeschmiert. Kam im Geräte-Manager

    "Dieses Hardwaregerät kann nicht gestartet werden, da dessen Konfigurationsinformationen (in der Registrierung) unvollständig oder beschädigt sind. (Code 19)"

    Aber nachdem ich die Treiber deinstalliert und dann nochmal neu installiert hatte, wurde das Gerät nach anstecken an USB wieder als "My HTC" korrekt erkannt, und siehe da, beim Befehl "fastboot devices" kam wieder mein HTC zum Vorschein :)

    Nun gilt es nur die RUU zu flashen... wie mach ich das denn mit der RUU, die mir vorhin verlinkt wurde? Das ist ja ne .img. Wie flashe ich die?
     
  15. 2WildFire, 15.09.2011 #15
    2WildFire

    2WildFire Android-Guru

    Beiträge:
    3,000
    Erhaltene Danke:
    469
    Registriert seit:
    26.10.2010
    Hat Thyrion doch schon geschrieben^^
     
  16. Thyrion, 15.09.2011 #16
    Thyrion

    Thyrion Ehrenmitglied

    Beiträge:
    11,845
    Erhaltene Danke:
    2,450
    Registriert seit:
    21.07.2009
    Phone:
    Nexus 5X
    Moment...

    Eine RUU ist keine img-Datei. Eine RUU ist normalerweise eine exe-Datei (oder wenn sie gepackt wurde eine ZIP, dann bitte auspacken ;) ) Du kannst aber aus einer RUU(.exe) eine PB99img.zip machen (wie das geht, steht in der verlinkten Anleitung). Mit der RUU würde ich aber erst arbeiten, wenn dein HBOOT/Bootloader entsprechend vorbereitet wurde. Hast du den HBOOT nun neu geflasht?

    Ich hatte einmal den Downgrade-HBOOT als img verlinkt (und einmal auf die PB99img.zip-Variante verwiesen).

    Was genau meinst du nun mit "Nun gilt es nur die RUU zu flashen... wie mach ich das denn mit der RUU, die mir vorhin verlinkt wurde? Das ist ja ne .img. Wie flashe ich die? "?


    Eine img-Datei flasht du per Fastboot.
    Eine RUU führst du am PC aus.
    Eine PB99img.zip kopierst du auf die SD-Karte und startest das Handy im HBOOT-Modus.
    Andere zip-Dateien werden über das Recovery geflasht.
     
  17. MrFreezeman, 15.09.2011 #17
    MrFreezeman

    MrFreezeman Threadstarter Neuer Benutzer

    Beiträge:
    16
    Erhaltene Danke:
    0
    Registriert seit:
    13.09.2011
    Mhm, also den hboot hatte ich bereits geflasht, mittels fastboot und dem bravo_downgrade.img von alpharev.
    Hatte wohl funktioniert, allerdings kommt immer noch der Screen mit den Ausrufezeichen in den Ecken. Gleiches Bild.
    Allerdings schaffe ich es manchmal, wenn ich mit dem Android Flasher ein neues Recovery oder Radio flashe, auf den hboot zuzugreifen, allerdings auch nicht immer, nur sporadisch. Keine Ahnung an was das liegt.

    Vor allem,... der originale hboot sollte doch jetzt geflasht sein, warum kommt dan immer noch der Warnungs-Screen mit den Ausrufezeichen???
     
  18. MrFreezeman, 15.09.2011 #18
    MrFreezeman

    MrFreezeman Threadstarter Neuer Benutzer

    Beiträge:
    16
    Erhaltene Danke:
    0
    Registriert seit:
    13.09.2011
    Vielleicht nochmal vorher nachhaken, zum hboot flashen.

    Ich nehme den Android Flasher 1.8.0. hboot angehakt, und von alpharev den bravo_downgrade.img ausgewählt.

    Hier der Debug Log von Android Flasher:
    --------------------------------------------------------------
    FEHLER: Der Prozess "fastboot.exe" wurde nicht gefunden.
    cd data\
    cd data\
    taskkill /F /IM adb.exe
    taskkill /F /IM fastboot.exe
    adb.exe reboot bootloader
    * daemon not running. starting it now on port 5037 *
    * daemon started successfully *
    error: device not found
    fastboot.exe flash hboot hboot.img
    sending 'hboot' (512 KB)...
    OKAY [ 0.089s]
    writing 'hboot'...
    (bootloader) signature checking...
    FAILED (remote: 12 signature verify fail)
    finished. total time: 0.143s
    fastboot.exe reboot-bootloader
    rebooting into bootloader...
    OKAY [ 0.092s]
    finished. total time: 0.092s
    fastboot.exe erase cache
    < waiting for device >
    erasing 'cache'...
    OKAY [ 0.489s]
    finished. total time: 0.489s
    Del hboot.img
    fastboot.exe reboot
    rebooting...
    finished. total time: 0.092s
    ----------------------------------------------------

    Irgendwas komisch hier? Hat das nun funktioniert? Es erscheint nämlich immer noch der Screen mit den vier Ausrufezeichen und ich kann
    immer noch nichts machen von dort aus...!?
     
  19. Schnello, 15.09.2011 #19
    Schnello

    Schnello Android-Guru

    Beiträge:
    3,816
    Erhaltene Danke:
    618
    Registriert seit:
    03.09.2010
    Phone:
    Samsung Galaxy S5 (G900)
    Der Screen mit den 4! hat aber nichts mit dem Hoot zu tun. Beide sind unabhängig.

    Sollte nicht erfolgreich gewesen sein.

    HTC Sync noch neben bei laufen?
    Was sagt denn der Verbindungs Check? (Glaube den gibt es in dem Tool)

    ich persönlich ziehe den Fastboot Commander vor. Teste den mal.
     
    Zuletzt bearbeitet: 15.09.2011
  20. MrFreezeman, 15.09.2011 #20
    MrFreezeman

    MrFreezeman Threadstarter Neuer Benutzer

    Beiträge:
    16
    Erhaltene Danke:
    0
    Registriert seit:
    13.09.2011
    Also Verbindungscheck ist positiv, habs auch mit dem Fastboot Commander probiert, aber der endet auch mit dem Signaturfehler:

    ###Calling fastboot with: flash radio C:\Users\ABGVIRGENL\Desktop\PB99IMG_Froyo_TMO_UK_2.12.110.4_R_Radio_32.49.00.32U_5.11.05.27_release_157560_signed\radio.img###
    sending 'radio' (26112 KB)... OKAY [ 3.782s]
    writing 'radio'... INFOsignature checking...
    FAILED (remote: 12 signature verify fail)
    finished. total time: 6.496s
    ********************************

    Was ist das für ein Fehler, wenn "remote: 12 signature verify fail" kommt?
     

Diese Seite empfehlen