1. Nimm jetzt an unserem 2. ADVENT-Gewinnspiel teil - Alle Informationen findest Du hier!

Desire Z Unroot + S-On + Probleme

Dieses Thema im Forum "Root / Hacking / Modding für HTC Desire Z" wurde erstellt von battlecake, 17.01.2012.

  1. battlecake, 17.01.2012 #1
    battlecake

    battlecake Threadstarter Neuer Benutzer

    Beiträge:
    11
    Erhaltene Danke:
    0
    Registriert seit:
    06.03.2011
    Hi,
    ich bin derzeit dabei mein Desire Z wieder auf Werkszustand zu bringen, aufgrund eines Garantieschadens.
    Nun stellten sich mir einige Probleme in den Weg
    - Welche CID war original?
    - Welche Methode ist die richtige?
    - Welche die beste?

    Die erste Frage ist mir beantwortet, offensichtlich war es ein ungebrandetes Handy, also ist die richtige CID ja folglich htc__102.
    Nun komme ich zum naechsten Problem. Nach einigem rumfragen und fehlenden Antworten hab ich einfach mal die xda-developers Wikimethode befolgt, mit gfree.
    Leider bekomme ich dabei einen fehler (angehängter Screenshot)

    Was sagt mir dieser Fehler? Meine Linuxkenntnisse reichen zwar fuer vieles, aber da bin ich ueberfragt.
    Ich sehe nur, dass irgendeine Datei nicht gefunden werden kann.

    Ich hoffe, ihr koennt mir da helfen.

    Beste grueße
     

    Anhänge:

  2. Nimrod, 17.01.2012 #2
    Nimrod

    Nimrod Android-Guru

    Beiträge:
    2,858
    Erhaltene Danke:
    587
    Registriert seit:
    02.01.2011
    Phone:
    LG G3
    Tablet:
    Nexus 7 (2012)
    Scheint doch funktioniert zu haben, oder? Lies die CID mal aus, steht glaube im Bootloader, und per adb müsste das auch gehen,
    Code:
    adb shell
    getprop ro.cid
    Wenn ich mich nicht irre.

    Lies dich mal in den Thread ein, falls du das noch nicht getan haben solltest:
    http://www.android-hilfe.de/root-ha...ire-z/85428-sammelthread-unroot-desire-z.html

    Übrigens gehört dein Beitrag auch dort rein, oder zumindest ins root Forum!
     
  3. battlecake, 17.01.2012 #3
    battlecake

    battlecake Threadstarter Neuer Benutzer

    Beiträge:
    11
    Erhaltene Danke:
    0
    Registriert seit:
    06.03.2011
    Hi, also erstmal danke fuer die freundliche Antwort.
    Das mit dem Unterforum ist 'ne peinliche Sache... Ich hab es leider erst danach gesehen...
    Den Sammelthread hatte ich mir gestern zum großteil angeschaut, leider fand ich es im großen und ganzen mehr verwirrend, als helfend.(Bis ich das Unterforum gesehen hatte, war mir so, als waer der Thread in einem anderen Forum gewesen)
    Ich will mich dafuer erstmal entschuldigen!

    Also es ist noch auf S-On, daher meine Annahme, dass es fehlschlug (oder muss ich es danach erst neuflashen, damit S-On uebernommen wird? )
    Die CID stand nicht im Bootloader, auch in der CM-Recoverykonsole hatte ich keinen passenden Punkt gefunden.

    bei getprop ro.cid spuckt er mir die htc__102 aus
    Im Bootmanager steht jedoch eben noch S-Off

    Ich werde das ganze nochmal in den Sammelthread schreiben, ansonsten waer's auch ganz nett, wenn man den Thread in's Unterforum verschieben koennte.

    Gruß
     
  4. Nimrod, 17.01.2012 #4
    Nimrod

    Nimrod Android-Guru

    Beiträge:
    2,858
    Erhaltene Danke:
    587
    Registriert seit:
    02.01.2011
    Phone:
    LG G3
    Tablet:
    Nexus 7 (2012)
    na dann stimmt die CID ja schonmal. Hat ja nicht direkt was mit S-ON und S-OFF zu tun.
    Gib mal durch, was alles in deinem Bootloader steht (also die ersten paar Zeilen ganz oben).
     
  5. battlecake, 17.01.2012 #5
    battlecake

    battlecake Threadstarter Neuer Benutzer

    Beiträge:
    11
    Erhaltene Danke:
    0
    Registriert seit:
    06.03.2011
    VISION PVT SHIP S-OFF
    HBOOT-0.85.0005
    MICROP-0425
    RADIO-26.03.02.26_M
    eMMC-boot
    Oct 11 2010, 20:10:38

    Hatte gerade mal das How-To hier ausprobiert (auch erst eben gesehen :crying: )
    Ich scheitere aber beim Schritt 3, mit fre3vo. Er muss die ADB-Shell verlassen, was er aber nicht tut. Es wird "Potential exploit area found at address *******" ausgeben und danach "Payload verification failed." nun fuehrt er den Scan fort, bis ich schließlich wieder in der Shell lande.
    Hab ich das nun falsch verstanden? Dort steht zwar, von Gingerbread auf Froyo + S-On, aber taugt die Anleitung ueberhaupt etwas fuer gemoddete Systeme?
     
  6. sealsnipe, 17.01.2012 #6
    sealsnipe

    sealsnipe Android-Hilfe.de Mitglied

    Beiträge:
    93
    Erhaltene Danke:
    19
    Registriert seit:
    31.12.2011
    Phone:
    HTC Desire Z
    OK.
    1) Hat dein gfree die notwendigen rechte? wie man nen chmod ausliest kein plan, aber du kannst gfree die rechte ja einfach ma geben (per adb eingeben, das $-Zeichen weglassen)
    Code:
    $ adb shell chmod 777 /data/local/tmp/gfree
    Danach versuchste es nochmal mit:
    Code:
    $ adb shell
    # /data/local/tmp/gfree -s on 
    Jedoch bitte im Dateipfad (/data/local/tmp/gfree) das angeben wo dein gfree grade liegt. habe oben was gelesen von ./gfree also eher für dich sowas wie # ./gfree -s on oder so. schau mal was er dann macht.


    2) Wenn du S-On nicht durch gfree bekommst, dann versuchs doch mit deiner partition7 backup!? die sollte (bei mir tut sie das) im hauptordner deiner SD liegen ("part7backup-blahblah.bin") zusammen mit dem part17 backup...
     
  7. battlecake, 17.01.2012 #7
    battlecake

    battlecake Threadstarter Neuer Benutzer

    Beiträge:
    11
    Erhaltene Danke:
    0
    Registriert seit:
    06.03.2011
    Hab's per root ausgefuehrt (zuvor su eingegeben) und zuvor chmod 777 gesetzt
    Ich hab deshalb ./gfree geschrieben, da ich im Verzeichnis war, in dem gfree liegt (das ./ gibt an, dass die datei im derzeitigem Verzeichnis ist, da nur 'gfree' wie ein vorhandener Befehl gehandelt werden wuerde.)
    Es tut also das selbige, wie mit komplettem Dateipfad.

    Zu 2. bis gestern war mir das part7 backup unbekannt. Ich weiß nicht, ob ich ueberhaupt eines gemacht hatte, durch die angewendete Methode oder ob ich je eines hatte. Zumindest jetzt liegt keines im Hauptordner, auch in meinem Backup liegt keine solche Datei.

    Gruß
     
  8. sealsnipe, 17.01.2012 #8
    sealsnipe

    sealsnipe Android-Hilfe.de Mitglied

    Beiträge:
    93
    Erhaltene Danke:
    19
    Registriert seit:
    31.12.2011
    Phone:
    HTC Desire Z
    Interessant. Die Partition 7 Backup wird normal automatisch erstellt.
    Ich werf ma einfach was noob-mäßiges in den Raum: Kann man die Partition7 vielleicht von wem anders einfach drauf haun? ;)
     
  9. battlecake, 04.10.2012 #9
    battlecake

    battlecake Threadstarter Neuer Benutzer

    Beiträge:
    11
    Erhaltene Danke:
    0
    Registriert seit:
    06.03.2011
    Ich weiß, dass es etwas her ist, als ich den Thread oeffnete, allerdings weiß ich nun, was das Problem war und vielleicht interessiert es den ein oder anderen.
    Leider Gottes muss ich gestehen, dass es Fehler meiner eigenen Dummheit war :mad:
    Ich hatte den Teil voellig uebersehen, in dem gezeigt wird, dass man die Stock Rom vorher schon installieren muss... Ich hatte immer gedacht, das kaeme zum Schluss. Darum der Fehler ...
    Stock Rom -> gleiche Vorgehensweise -> Erfolg.
    Danke dennoch fuer eure Hilfe, auch wenn sie eher sinnlos gefordert wurde... :bored:
     
  10. Felix_928, 18.10.2012 #10
    Felix_928

    Felix_928 Neuer Benutzer

    Beiträge:
    3
    Erhaltene Danke:
    0
    Registriert seit:
    17.10.2012
    Hallo, ich hab das grade alles so gemacht wie überall beschrieben wird. Hat soweit auch alles gut geklappt, ich bekomme auch die Rückmeldung bei gfree_verify @secu_flag:1
    Allerdings steht in der obersten Zeile vom HBoot immernoch VISION PVT ENG S-OFF
    Was mache ich falsch?

    Der ursprüngliche Beitrag 17.10.2012 von 23:28 Uhr wurde 18.10.2012 um 00:01 Uhr ergänzt:

    Habs selber gelöst... Ich hab nach dem ganzen Prozedere einfach mal ein Update auf 1.34 gefahren und siehe da: S-ON! keine Ahnung wieso aber egal
     
  11. Nimrod, 18.10.2012 #11
    Nimrod

    Nimrod Android-Guru

    Beiträge:
    2,858
    Erhaltene Danke:
    587
    Registriert seit:
    02.01.2011
    Phone:
    LG G3
    Tablet:
    Nexus 7 (2012)
    Weil du das Eng-hboot (Engineering-Hboot) hattest, was dir sogenanntes Fake S-OFF gibt.
    Mit der RUU wurde auch der originale Bootloader wieder geflasht.
    Nur zur Information. ;)

    Gesendet von meinem Evo 3D GSM
     
  12. battlecake, 19.10.2012 #12
    battlecake

    battlecake Threadstarter Neuer Benutzer

    Beiträge:
    11
    Erhaltene Danke:
    0
    Registriert seit:
    06.03.2011
    Es ist quasi das, was ich falsch gemacht hatte... Man muss zuerst das originale RUU draufflashen
     
  13. fr0g, 27.12.2012 #13
    fr0g

    fr0g Junior Mitglied

    Beiträge:
    38
    Erhaltene Danke:
    12
    Registriert seit:
    28.10.2011
    Hallo und frohe weihnachten noch im nachhinein.

    genau das selbe Problem wie der TE habe ich auch... habe meine frage auch schon im sammelthread gestellt und bin soeben auf diesen thread hier gestoßen.
    Habe mir jetzt gedacht die frage hier nochmal zu stellen, da genau mein problem hier geschildert wird.

    B2T: Ich bin genau wie der TE davon ausgegangen das man das handy rooten muss->s-on->shipped rom
    Als ich das hier las dachte ich schon mir wäre geholfen. Ich habe sofort RUU_Vision_HTC_WWE_1.34.405.5_Radio_12.28b.60.140e_26.03.02.26_M_release_155556_signed
    runtergeladen und auf mein Desire Z gespielt. Dann noch gfree mithilfe von adb aufs handy...jedoch bekomme ich immernoch den error..

    Ich glaube ich hab irgendwas dummes simples übersehen..aber ich finde es nicht. Vielleicht kann ja einer von den "profis" nochmal nen blick über mein problem werfen

    Vielen dank schonmal!
     
  14. battlecake, 27.12.2012 #14
    battlecake

    battlecake Threadstarter Neuer Benutzer

    Beiträge:
    11
    Erhaltene Danke:
    0
    Registriert seit:
    06.03.2011
    Welche Anleitung befolgst du denn?
     
  15. fr0g, 27.12.2012 #15
    fr0g

    fr0g Junior Mitglied

    Beiträge:
    38
    Erhaltene Danke:
    12
    Registriert seit:
    28.10.2011
    Hallo. Danke erstmal für die schnelle antwort!

    ich benutze die Anleitung aus dem xda-forum: HTC Vision - XDA-Developers

    ganz unten stehen die schritte zum unrooten.
    Eine Frage hätte ich aber noch an dich: Hast du deine mainversion (von der im xda-forum die rede ist) gedowngradet?

    Ich muss das ganze mit gfree machen, da ich leider keine backupdatei mehr finde.
     
  16. battlecake, 27.12.2012 #16
    battlecake

    battlecake Threadstarter Neuer Benutzer

    Beiträge:
    11
    Erhaltene Danke:
    0
    Registriert seit:
    06.03.2011
    Ich hatte auch kein part 7 backup mehr und musste es deshalb auch ohne machen.
    Was genau fuer ein Fehler kommt denn da? Wo haengt es?
     
  17. fr0g, 27.12.2012 #17
    fr0g

    fr0g Junior Mitglied

    Beiträge:
    38
    Erhaltene Danke:
    12
    Registriert seit:
    28.10.2011
    Ich hänge genau an dem Punkt wo es bei dir auch nicht mehr weiter ging. Bei mir steht das selbe bei adb wie auf dem screenshot im ersten post.

    Hast du denn deine mainversion geändert bevor du mit gfree versucht hast s-on zu erhalten?
     
  18. battlecake, 27.12.2012 #18
    battlecake

    battlecake Threadstarter Neuer Benutzer

    Beiträge:
    11
    Erhaltene Danke:
    0
    Registriert seit:
    06.03.2011
    Der Witz ist, dass ich selbst nicht mehr genau weiß, was ich gemacht habe.
    Die kleine Geschichte dazu laeuft etwa wie folgt...
    Mein UMTS Modul funktionierte nicht mehr richtig, also wollte ch es unrooten und S-On schalten um die Garantie zu nutzen... Das funktionierte nicht (siehe Thred) und ich gab's auf... nach ca einem 3/4 Jahr hab ich es dann nochmals probiert und es hat dann geklappt, weil ich meinen Fehler erkannte... Mein UMTS Modul laeuft uebrigens auch wieder - ohne Garantie in anspruch zu nehmen.
    Also was ich alles genau gemacht hab... Liegt bereits fast ein Jahr zurueck...
     
  19. fr0g, 27.12.2012 #19
    fr0g

    fr0g Junior Mitglied

    Beiträge:
    38
    Erhaltene Danke:
    12
    Registriert seit:
    28.10.2011
    Ja ok. trotzdem danke!
    Ich versuchs jetzt auch nochmal mit neuem adb und gfree.
     
  20. fr0g, 10.01.2013 #20
    fr0g

    fr0g Junior Mitglied

    Beiträge:
    38
    Erhaltene Danke:
    12
    Registriert seit:
    28.10.2011
    So, habs dann letzendlich einfach mit S-Off und Stock-Rom in meinem M-Markt abgegeben und es wurde ohne Probleme repariert. Anscheinend hat man es zwar gemerkt, denn komischerweise hat mein repariertes Gerät S-On...kann aber auch daran liegen, dass laut Verkäufer wohl irgendwas größeres getauscht wurde, da das Handy eine neue Seriennummer habe.
    Im Endeffekt hat aber alles MIT S-Off funktioniert!
     

Diese Seite empfehlen