1. Nimm jetzt an unserem 2. ADVENT-Gewinnspiel teil - Alle Informationen findest Du hier!

DHCP Request scheitert

Dieses Thema im Forum "LG Optimus Speed (P990) Forum" wurde erstellt von F4t4l, 20.04.2011.

  1. F4t4l, 20.04.2011 #1
    F4t4l

    F4t4l Threadstarter Neuer Benutzer

    Beiträge:
    20
    Erhaltene Danke:
    3
    Registriert seit:
    08.08.2009
    Hallo miteinander,

    ich habe jetzt schon des öfteren Probleme mit meiner Wifi-Verbindung gehabt. Und zwar öfters nachdem mein Telefon in den Ruhezustand gewechselt hat, und deshalb das Wifi abgeschaltet hat, kann ich mich danach nicht nochmal mit meinem AP verbinden... in den Einstellungen steht nur das die IP-Adresse abgerufen wird und nach ein paar minuten führt er dann erneut ein Scan durch und versuchts nochmal. Erst ein neustart schafft dann abhilfe... gibts noch jemand der solche Probleme hat? Oder gibts per ADB nen command der abhilfe schafft? Auf dauer ist es schon sehr nervig, besonders da O2 heute auch noch probleme mit ihrer Datenverbindung hat....
    Am Router liegts auch nicht, da ich mich mit meinem Laptop etc. ohne Probleme verbinden kann.
    Auf meinem LGOS läuft MoDaCo FR12 Fear Edition.

    Danke schonmal :)
     
    Zuletzt bearbeitet: 20.04.2011
  2. Haggy, 20.04.2011 #2
    Haggy

    Haggy Android-Experte

    Beiträge:
    562
    Erhaltene Danke:
    81
    Registriert seit:
    03.08.2009
    Phone:
    Nexus 4
    Tablet:
    Kindle Fire HDX7
    Wearable:
    LG G Watch
    Könnte trotzdem am Router liegen - bzw an der DHCP-Lease-Zeit. Kannst du mal mit logcat nachschauen, was da genau schief geht wenn das Telefon versucht die Verbindung wieder herzustellen?
     
  3. F4t4l, 20.04.2011 #3
    F4t4l

    F4t4l Threadstarter Neuer Benutzer

    Beiträge:
    20
    Erhaltene Danke:
    3
    Registriert seit:
    08.08.2009
    ok hier mal mein logcat:

    04-20 12:19:52.131: ERROR/WifiHW(1127): wifi=> wifi_load_driver

    04-20 12:19:53.061: ERROR/WifiHW(1127): property_get access wifi.interface: [wlan0]
    04-20 12:19:53.166: ERROR/WifiHW(1127): get_ifindex_byname[wlan0:22] after insmod with retry_count:30
    04-20 12:19:53.166: ERROR/WifiHW(1127): ------------------------------------------
    04-20 12:19:53.166: ERROR/WifiHW(1127): success insmod ^^
    04-20 12:19:53.166: ERROR/WifiHW(1127): ------------------------------------------


    04-20 12:19:53.171: DEBUG/WifiService(1127): BroadcastReceiver : android.intent.action.BATTERY_CHANGED
    04-20 12:19:53.171: DEBUG/WifiService(1127): ACTION_BATTERY_CHANGED pluggedType: 2
    04-20 12:19:53.171: DEBUG/WifiService(1127): BroadcastReceiver : android.intent.action.SIM_STATE_CHANGED
    04-20 12:19:53.171: INFO/WifiService(1127): USIM loaded - Ready state

    hier versucht er dann zu verbinden:


    04-20 12:19:53.451: ERROR/WifiInfo(1127): setSSID null
    04-20 12:19:53.451: VERBOSE/WifiStateTracker(1127): Connection to supplicant established, state=DISCONNECTED
    04-20 12:19:53.471: ERROR/statfs(1127): org block : 0 avaial, 567894 free
    04-20 12:19:53.471: ERROR/statfs(1127): limit block : 0 avaial, 547414 free
    04-20 12:19:53.633: INFO/wpa_supplicant(25033): wpa_inital_scan_onoging was set. Discard scan result
    04-20 12:19:54.453: INFO/wpa_supplicant(25033): CTRL-EVENT-STATE-CHANGE id=-1 state=2 BSSID=00:00:00:00:00:00
    04-20 12:19:54.453: INFO/wpa_supplicant(25033): WPS-AP-AVAILABLE
    04-20 12:19:54.453: WARN/wpa_supplicant(25033): wpa_supplicant_scard_init ssid->eap.pcsc=(null)
    04-20 12:19:54.453: WARN/wpa_supplicant(25033): USIM: scard_init function
    04-20 12:19:54.453: INFO/wpa_supplicant(25033): Trying to associate with 00:0f:b5:15:73:e0 (SSID='CIASurveillanceVan' freq=2462 MHz)
    04-20 12:19:54.453: VERBOSE/WifiMonitor(1127): Event [CTRL-EVENT-STATE-CHANGE id=-1 state=2 BSSID=00:00:00:00:00:00]
    04-20 12:19:54.453: VERBOSE/WifiStateTracker(1127): Changing supplicant state: DISCONNECTED ==> SCANNING
    04-20 12:19:54.461: INFO/wpa_supplicant(25033): CTRL-EVENT-STATE-CHANGE id=-1 state=3 BSSID=00:0f:b5:15:73:e0
    04-20 12:19:54.576: VERBOSE/WifiMonitor(1127): Event [WPS-AP-AVAILABLE ]
    04-20 12:19:54.576: VERBOSE/WifiMonitor(1127): Event [Trying to associate with 00:0f:b5:15:73:e0 (SSID='CIASurveillanceVan' freq=2462 MHz)]
    04-20 12:19:54.576: VERBOSE/WifiMonitor(1127): Event [CTRL-EVENT-STATE-CHANGE id=-1 state=3 BSSID=00:0f:b5:15:73:e0]
    04-20 12:19:54.581: VERBOSE/WifiStateTracker(1127): Changing supplicant state: SCANNING ==> ASSOCIATING

    04-20 12:19:54.581: DEBUG/ConnectivityService(1127): STATE_CHANGED for: featureId: -1, typeName: WIFI; stateDISCONNECTED/SCANNING
    04-20 12:19:54.581: DEBUG/ConnectivityService(1127): Dropping ConnectivityChange for WIFI: DISCONNECTED/SCANNING
    04-20 12:19:54.581: DEBUG/ConnectivityService(1127): STATE_CHANGED for: featureId: -1, typeName: WIFI; stateCONNECTING/CONNECTING
    04-20 12:19:54.581: DEBUG/ConnectivityService(1127): ConnectivityChange for WIFI: CONNECTING/CONNECTING

    hier hat er dann angeblich eine Verbindung(zumindest wechselt er in den State connected):

    04-20 12:19:55.168: INFO/wpa_supplicant(25033): CTRL-EVENT-STATE-CHANGE id=1 state=4 BSSID=00:0f:b5:15:73:e0
    04-20 12:19:55.168: VERBOSE/WifiMonitor(1127): Event [CTRL-EVENT-STATE-CHANGE id=1 state=4 BSSID=00:0f:b5:15:73:e0]
    04-20 12:19:55.168: VERBOSE/WifiStateTracker(1127): Changing supplicant state: ASSOCIATING ==> ASSOCIATED
    04-20 12:19:55.171: INFO/wpa_supplicant(25033): Associated with 00:0f:b5:15:73:e0
    04-20 12:19:55.171: INFO/wpa_supplicant(25033): CTRL-EVENT-STATE-CHANGE id=1 state=7 BSSID=00:00:00:00:00:00
    04-20 12:19:55.171: INFO/wpa_supplicant(25033): CTRL-EVENT-CONNECTED - Connection to 00:0f:b5:15:73:e0 completed (auth) [id=1 id_str=]
    04-20 12:19:55.171: ERROR/WifiInfo(1127): setSSID CIASurveillanceVan
    04-20 12:19:55.171: VERBOSE/WifiMonitor(1127): Event [Associated with 00:0f:b5:15:73:e0]
    04-20 12:19:55.171: VERBOSE/WifiMonitor(1127): Event [CTRL-EVENT-STATE-CHANGE id=1 state=7 BSSID=00:00:00:00:00:00]
    04-20 12:19:55.171: VERBOSE/WifiMonitor(1127): Event [CTRL-EVENT-CONNECTED - Connection to 00:0f:b5:15:73:e0 completed (auth) [id=1 id_str=]]
    04-20 12:19:55.171: VERBOSE/WifiStateTracker(1127): Changing supplicant state: ASSOCIATED ==> COMPLETED
    04-20 12:19:55.171: ERROR/StatusBarPolicy(1127): isRilReset data = false
    04-20 12:19:55.181: ERROR/WifiInfo(1127): getSSID CIASurveillanceVan
    04-20 12:19:55.181: ERROR/WifiInfo(15128): setSSID CIASurveillanceVan
    04-20 12:19:55.181: ERROR/WifiInfo(15128): getSSID CIASurveillanceVan
    04-20 12:19:55.181: VERBOSE/WifiStateTracker(1127): New network state is CONNECTED
    04-20 12:19:55.191: ERROR/WifiInfo(1127): setSSID CIASurveillanceVan
    04-20 12:19:55.191: ERROR/WifiInfo(1127): getSSID CIASurveillanceVan
    04-20 12:19:55.191: ERROR/WifiInfo(1127): getBSSID 00:0f:b5:15:73:e0
    04-20 12:19:55.191: INFO/MusicStatusBarControl(1127): === Action INFO :android.net.wifi.STATE_CHANGE
    04-20 12:19:55.191: ERROR/StatusBarPolicy(1127): isRilReset data = false
    04-20 12:19:55.191: DEBUG/ConnectivityService(1127): STATE_CHANGED for: featureId: -1, typeName: WIFI; stateCONNECTING/OBTAINING_IPADDR
    04-20 12:19:55.191: DEBUG/ConnectivityService(1127): Dropping ConnectivityChange for WIFI: CONNECTING/OBTAINING_IPADDR
    04-20 12:19:55.231: ERROR/WifiInfo(1127): setSSID CIASurveillanceVan
    04-20 12:19:55.241: ERROR/StatusBarPolicy(1127): isRilReset data = false
    04-20 12:19:55.241: ERROR/WifiInfo(1127): getSSID CIASurveillanceVan
    04-20 12:19:55.241: ERROR/WifiInfo(15128): setSSID CIASurveillanceVan
    04-20 12:19:55.241: ERROR/WifiInfo(15128): getSSID CIASurveillanceVan


    und dann kommt ne weile nix und zum schluss dann das :


    04-20 12:20:55.404: INFO/WifiStateTracker(1127): DhcpHandler: DHCP request failed: Timed out waiting for DHCP to finish
    04-20 12:20:55.404: ERROR/WifiStateTracker(1127): [dhcp handler] release sWiFiDhcpWakeLock
    04-20 12:20:55.404: INFO/wpa_supplicant(25033): CTRL-EVENT-STATE-CHANGE id=1 state=8 BSSID=00:00:00:00:00:00
    04-20 12:20:55.404: VERBOSE/WifiMonitor(1127): Event [CTRL-EVENT-STATE-CHANGE id=1 state=8 BSSID=00:00:00:00:00:00]
    04-20 12:20:55.411: VERBOSE/WifiStateTracker(1127): Changing supplicant state: COMPLETED ==> DORMANT
    04-20 12:20:55.411: INFO/wpa_supplicant(25033): CTRL-EVENT-DISCONNECTED - Disconnect event - remove keys
    04-20 12:20:55.411: INFO/wpa_supplicant(25033): CTRL-EVENT-STATE-CHANGE id=-1 state=8 BSSID=00:00:00:00:00:00
    04-20 12:20:55.411: VERBOSE/WifiMonitor(1127): Event [CTRL-EVENT-DISCONNECTED - Disconnect event - remove keys]
    04-20 12:20:55.411: VERBOSE/WifiMonitor(1127): Event [CTRL-EVENT-STATE-CHANGE id=-1 state=8 BSSID=00:00:00:00:00:00]
    04-20 12:20:55.521: VERBOSE/WifiStateTracker(1127): New network state is DISCONNECTED
    04-20 12:20:55.521: VERBOSE/WifiStateTracker(1127): Changing supplicant state: DORMANT ==> DORMANT
    04-20 12:20:55.521: INFO/MusicStatusBarControl(1127): === Action INFO :android.net.wifi.STATE_CHANGE
    04-20 12:20:55.521: ERROR/StatusBarPolicy(1127): isRilReset data = false
    04-20 12:20:55.521: ERROR/WifiInfo(1127): setSSID null
    04-20 12:20:55.521: DEBUG/ConnectivityService(1127): STATE_CHANGED for: featureId: -1, typeName: WIFI; stateDISCONNECTED/FAILED
    04-20 12:20:55.521: DEBUG/ConnectivityService(1127): ConnectivityChange for WIFI: DISCONNECTED/FAILED
    04-20 12:20:55.521: DEBUG/ConnectivityService(1127): handleConnectionFailure: on net (1)
    04-20 12:20:55.521: VERBOSE/ConnectivityService(1127): Attempt to connect to WIFI failed.


    ich werd daraus einfach nich schlau... und mir fällt grad auf das dazwischen en haufen Warnungen von Flex sind. Aber gut das hat ja damit nix zu tun denk ich
     
  4. Haggy, 20.04.2011 #4
    Haggy

    Haggy Android-Experte

    Beiträge:
    562
    Erhaltene Danke:
    81
    Registriert seit:
    03.08.2009
    Phone:
    Nexus 4
    Tablet:
    Kindle Fire HDX7
    Wearable:
    LG G Watch
    Hmm, das ist in der Tat seltsam. Entweder kriegst du beim Wiederverbinden keinen neuen Lease vom Router - weil dieser denkt, du bist noch verbunden, oder aber das Telefon selbst erhängt sich da irgendwo. Was ist denn das für ein Router/AP?! Ich würde mal googlen ob das Problem schon bekannt ist. Hier im Forum meinten auch einige, es gäbe Probleme mit Fritzboxen. Ich für meinen Teil hänge zuhause an einem Linksys und auf Arbeit an einem Lancom - beides mal keine Probleme.
     
  5. F4t4l, 20.04.2011 #5
    F4t4l

    F4t4l Threadstarter Neuer Benutzer

    Beiträge:
    20
    Erhaltene Danke:
    3
    Registriert seit:
    08.08.2009
    also hier habe ich nen etwas älteren netgear mr814v2. Aber da ich noch student bin und nah an der uni wohne, kann ich mich auch dort ins wlan einklinken. und die ham soweit ich weiß auch netgear equipment. jedoch funzt das auch nich... Egal wo ichs versuch das handy will einfach keine IP-Adresse bekommen! Ich kann mal ein komplettes Logcar hochladen vllt gibts da dann noch iwas zu finden.
     

    Anhänge:

  6. Haggy, 20.04.2011 #6
    Haggy

    Haggy Android-Experte

    Beiträge:
    562
    Erhaltene Danke:
    81
    Registriert seit:
    03.08.2009
    Phone:
    Nexus 4
    Tablet:
    Kindle Fire HDX7
    Wearable:
    LG G Watch
    Ist alles Stock bei dir, oder ein Custom-ROM/Root?! Falls letzteres könntest du auf gut Glück mal ein neues Radio (Baseband) flashen. Links hier im Forum. Das Baseband ist unter Anderem auch für Wifi zuständig.
     
  7. F4t4l, 20.04.2011 #7
    F4t4l

    F4t4l Threadstarter Neuer Benutzer

    Beiträge:
    20
    Erhaltene Danke:
    3
    Registriert seit:
    08.08.2009
    jap ist MoDaCo fr 12 drauf. Hab vor kurzem erst das neueste Baseband geflasht aber lad mir grad die vorherige Version runter.. Mal schauen ob die den Fehler beseitigt!
     
  8. gaia, 20.04.2011 #8
    gaia

    gaia Android-Hilfe.de Mitglied

    Beiträge:
    57
    Erhaltene Danke:
    2
    Registriert seit:
    29.08.2009
    Hallo!

    Habe auch von Zeit zu Zeit dieses Problem. Alles (noch) Stock. Zuhause verbindet er sich manchmal nicht erneut. Ein paar Mal WLAN ein/aus haben geholfen, dann ging es wieder.
    Bei meiner Mutter wollte er beim ersten Einrichten der dortigen Verbindung auch nicht so recht.
     
  9. F4t4l, 20.04.2011 #9
    F4t4l

    F4t4l Threadstarter Neuer Benutzer

    Beiträge:
    20
    Erhaltene Danke:
    3
    Registriert seit:
    08.08.2009
    Ok das baseband downgrade brachte auch keine abhilfe. An der Hardware kann es ja auch nicht liegen oder?

    Gesendet mit der Android-Hilfe.de-App
     
  10. Haggy, 20.04.2011 #10
    Haggy

    Haggy Android-Experte

    Beiträge:
    562
    Erhaltene Danke:
    81
    Registriert seit:
    03.08.2009
    Phone:
    Nexus 4
    Tablet:
    Kindle Fire HDX7
    Wearable:
    LG G Watch
    Versuch mal dein Netz aus der Liste zu entfernen (Klicken > Entfernen) und dann aufs Neue. Wenn das hilft is wohl die Software etwas verbuggt. Kollege meinte vorhin er kannt das von seinem Androidfon (ganz anderes MOdell)
     
  11. F4t4l, 20.04.2011 #11
    F4t4l

    F4t4l Threadstarter Neuer Benutzer

    Beiträge:
    20
    Erhaltene Danke:
    3
    Registriert seit:
    08.08.2009
    Danke für den tipp aber leider half das auch nicht. Ich hab jetzt auch mein WLAN öfters an und ausgeschaltet aber bisher immer das selbe Resultat. Nur ein neustart hilft bisher....

    Gesendet mit der Android-Hilfe.de-App
     
  12. Keno, 21.04.2011 #12
    Keno

    Keno Fortgeschrittenes Mitglied

    Beiträge:
    289
    Erhaltene Danke:
    39
    Registriert seit:
    03.04.2010
    Hoi,
    Also ich habe jetzt nicht die Punktgenaue Lösung, aber versuch doch zu verhindern dass sich Dein Tel. im Standby abhängt.

    Guck mal unter Menu - Einstellung - Wireless - Wlan Einst. - Menu - erweitert - und dann Wlan Standby Richtlinie. "Niemals"
    Unter 2.2 funktioniert das zwar nicht 100%, ist aber trotzdem ein Versuch wert...

    Schöne Festtage und Gruss aus Zürich
    Keno
     
    Zuletzt bearbeitet: 21.04.2011

Diese Seite empfehlen