1. Nimm jetzt an unserem Uhans - 3. ADVENT - Gewinnspiel teil - Alle Informationen findest Du hier!

DHD - Visionary funktioniert nicht

Dieses Thema im Forum "Root / Hacking / Modding für HTC Desire HD" wurde erstellt von atrost, 27.02.2011.

  1. atrost, 27.02.2011 #1
    atrost

    atrost Threadstarter Erfahrener Benutzer

    Beiträge:
    165
    Erhaltene Danke:
    7
    Registriert seit:
    21.02.2011
    Phone:
    HTC Desire HD
    Hallo Forum,
    hat schon mal jemand erfolgreich mit Visionary auf dem DHD gearbeitet?
    Bei mir kann ich es starten und die Menüs im Startbildschirm bedienen. Nach Anwählen einer Option kommt die dazugehörige Meldung, danach passiert aber nichts mehr.
    Habe das Original-Rom 1.72 mit T-Mobile Banking drauf.
    Habe irgendwo bei einer Debranding-Anleitung gelesen, dass man erst downgraden muss auf 1.32. Muss ich das tatsächlich machen, auch wenn ich gar nicht debranden will? Ist der Downgrade auf 1.32 nicht ein Rückschritt?
    Ich möchte eigentlich nur einige Autostarts löschen.
    Gruss, Andreas.
     
  2. Kiray1982, 27.02.2011 #2
    Kiray1982

    Kiray1982 Android-Guru

    Beiträge:
    3,286
    Erhaltene Danke:
    969
    Registriert seit:
    22.11.2010
    ja du musst downgraden, alles rooten etc und dann kannst wieder updaten.
    dazu einfach die anleitungen lesen. Da steht alles zu genüge.
    Auch deine Frage taucht dort auf, incl. o.g. Antwort.
     
  3. Lion13, 27.02.2011 #3
    Lion13

    Lion13 Ehrenmitglied

    Beiträge:
    16,673
    Erhaltene Danke:
    5,019
    Registriert seit:
    17.04.2010
    Phone:
    iPhone SE, Google Nexus 5x
    Tablet:
    Google Nexus 7 (2013)
    Wearable:
    Pebble Time
    Sonstige:
    Amazon Fire TV
    Wie Kiray korrekt schreibt, kommst du um diesen Schritt nicht herum, da HTC den Bootloader ab Version 1.7x verändert hat - deshalb funktioniert VISIONary+ damit nicht mehr. Wenn du Root haben willst, geht kein Weg an einem Downgrade vorbei. Natürlich ist es insofern ein Rückschritt, daß es eine ältere OS-Version ist (die Änderungen von 1.3x auf 1.7x halten sich aber in Grenzen) - aber normalerweise wird das Downgrade dafür genutzt, nach Root und S-OFF ein anderes ROM zu flashen, das dann auf aktuellem Stand ist (z.B. RevoHD mit 2.2.1 oder CM7 mit Gingerbread).

    Möglicherweise kommt irgendwann eine Root-Möglichkeit für 1.7x (oder höher), aber die Jungs bei den xda-devs sind schon Monate dabei, bisher leider vergeblich.
     
    Kiray1982 bedankt sich.
  4. TimeTurn, 27.02.2011 #4
    TimeTurn

    TimeTurn Foren-Inventar

    Beiträge:
    15,109
    Erhaltene Danke:
    2,892
    Registriert seit:
    01.05.2010
    Phone:
    Huawei Nexus 6P
    Tablet:
    Sony Xperia Z2 Tablet
    Mit dem Bootloader hat das nichts zu tun, 2.2.1 (also 1.7x / 1.8x) lässt sich einfach nicht mit VISIONary+ rooten, weil das Exploit, das den Apps Rootrechte verschafft bei 2.2.1 nicht mehr funktioniert, da Google die Sicherheitslücke geschlossen hat beim Update von 2.2 auf 2.2.1. Das ist nicht nur beim DHD so, das war auch schon so beim Milestone oder kurz gesagt: bei allen 2.2.1 Androiden.

    @atrost: Genau das ist auch der Grund, warum das Downgrade nötig ist: Weil man 2.2.1 nicht per App rooten kann, es aber keinen anderen Weg zu permanenten Root gibt als per App zu rooten, da erst dann der Bootloader ersetzt werden kann, was die Installation höherer Versionen erlaubt - da muss man dann aber auch wieder aufpassen und kein RUU nehmen, da das wieder den Bootloader und das Recovery bügeln würde ,was das Ganze wieder rückgängig macht. Aber Stoney (he_stheone64) hat ein deodexed Stock ROM 1.72 veröffentlicht, was root bereits drin hat - das kannste dann nach dem rooten und dem installieren von ClockworkMod mit dem ROM-Manager einfach mit ClockworkMod einspielen.

    Da Du ein branding hast musste auch nich die SuperCID setzen - das machste dann mit dem Easy Radio S-Off Tool - das steht aber auch in der Anleitung.
     
  5. Lion13, 28.02.2011 #5
    Lion13

    Lion13 Ehrenmitglied

    Beiträge:
    16,673
    Erhaltene Danke:
    5,019
    Registriert seit:
    17.04.2010
    Phone:
    iPhone SE, Google Nexus 5x
    Tablet:
    Google Nexus 7 (2013)
    Wearable:
    Pebble Time
    Sonstige:
    Amazon Fire TV
    Ja, das ist der eine Teil des Problems - ich war aber auch der Meinung, daß HTC zusätzlich noch am Bootloader "herumgeschraubt" hat... Jedenfalls habe ich das auf mehreren Seiten im I-Net gelesen. Ist aber auch egal - Tatsache ist, daß es nicht mehr funktioniert und niemand weiß, ob es je funktionieren wird... :winki:
     
  6. TimeTurn, 28.02.2011 #6
    TimeTurn

    TimeTurn Foren-Inventar

    Beiträge:
    15,109
    Erhaltene Danke:
    2,892
    Registriert seit:
    01.05.2010
    Phone:
    Huawei Nexus 6P
    Tablet:
    Sony Xperia Z2 Tablet
    Sach mal so eine Seite, wär ma nich uninteressant nachzulesen :)
     
    Zuletzt bearbeitet: 28.02.2011
  7. Lion13, 28.02.2011 #7
    Lion13

    Lion13 Ehrenmitglied

    Beiträge:
    16,673
    Erhaltene Danke:
    5,019
    Registriert seit:
    17.04.2010
    Phone:
    iPhone SE, Google Nexus 5x
    Tablet:
    Google Nexus 7 (2013)
    Wearable:
    Pebble Time
    Sonstige:
    Amazon Fire TV
    Erst mal suchen... Habe ich mir leider nicht als Link gespeichert. :o
     

Diese Seite empfehlen