1. Nimm jetzt an unserem 2. ADVENT-Gewinnspiel teil - Alle Informationen findest Du hier!

Einstellungsmöglichkeit "Nationales Daten-Roaming" fehlt

Dieses Thema im Forum "Samsung Galaxy S2 (I9100) Forum" wurde erstellt von FANATLA, 18.02.2012.

  1. FANATLA, 18.02.2012 #1
    FANATLA

    FANATLA Threadstarter Android-Experte

    Beiträge:
    641
    Erhaltene Danke:
    147
    Registriert seit:
    25.11.2011
    Phone:
    SGS5mini G800F
    Da mein Problem die Original Firmwares und auch die Custom Firmwares betrifft poste ich es hier.
    Ich habe in meiner Branding-Firmware von 3 AT unter der Einstellung "Daten-Roaming" diese Auswahlmöglichkeiten: "Deaktivieren", "National Roaming nur" und "Alle Netzwerke". Ich brauche dieses "National Roaming nur" deswegen weil 3 AT (reines UMTS-Netz) bei Nichtempfang ein nationales Roaming zu A1 (GSM) benutzt und in diesem Fall für Datenverbindungen das EGDE von A1 nutzt. Beim nationalen Roaming ist die Datenverbindung zwar langsamer aber es wirkt sich nicht auf die Kosten aus. Beim internationalen Roaming (z.B. Netz aus Deutschland) würden aber Kosten anfallen, weshalb ich es nicht für alle Netzwerke aktivieren will.
    Bei allen Firmwares (egal ob Stock oder Custom Rom) ohne Branding die ich bis jetzt ausprobieren wollte fehlt diese Einstellung, es gibt bei Daten-Roaming lediglich einen Haken zum ein-/ausschalten, aber keine Einstellung dass nur nationales Roaming erlaubt sein soll.
    Ich kann deshalb keine dieser Custom Roms oder ICS-Betas wirklich gebrauchen.
    Ist diese Einstellung nur bei den Branding-Firmwares von meinem Provider verfügbar? Liegt es vielleicht nur an der CSC und kann beim Flashen einer 3-teiligen FW die CSC von meinem Provider benutzen damit diese Einstellung verfügbar ist?
    Ich habe nämlich gerade die neuste ICS-Beta angetestet und das einzige was mich störte war wieder diese fehlende Einstellungsmöglichkeit, hab das Ganze also wieder rückgängig gemacht.
    Ich befürchte dass ich dann auch nach dem offiziellen Release von ICS noch immer auf ein (wahrscheinlich noch späteres) Update seitens meines Providers warten muss, um diese Einstellungsmöglichkeit zu haben.
     
  2. email.filtering, 20.02.2012 #2
    email.filtering

    email.filtering Gast

    Ich kann Dir, als selbst Betroffener, nur bestätigen, dass der Punkt "Nationales Daten-Roaming" lediglich in wenigen Betriebssystemversionen vorhanden ist. So fehlt er beispielsweise auch in der XWLA4. Allerdings habe ich bisher noch nie so recht drauf geachtet, ob das hauptsächlich "freie", also Branding-freie Versionen betrifft, doch ist das - aus dem Bauch heraus - gut möglich.
     
    FANATLA bedankt sich.
  3. robomobile, 20.02.2012 #3
    robomobile

    robomobile Android-Hilfe.de Mitglied

    Beiträge:
    120
    Erhaltene Danke:
    19
    Registriert seit:
    11.03.2011
    Du könntest versuchen im Ordner /system/etc die Datei spn-conf.xml um den Fakehomenetzeintrag für 3AT und A1 zu erweitern und schauen ob es dann funktioniert.
    Das freie Galaxy S hat das gleiche Problem. Hier kannst du mal nachlesen worum es geht und wie es geht beim S (S2 dürfte analog sein imho):
    http://www.android-hilfe.de/root-ha...chtung-drei-osterreich-gingerbread-2-3-a.html

    Eine Drei gebrandete Firmware könnte natürlich auch helfen das Problem zu lösen. Die CSC alleine bestimmt nicht. Aber wer will auf einem freien Handy freiwillig schon eine Brandingfirmware...

    Dieses "Issue" ist Drei sehr wohl bekannt, putzt sich aber an Samsung ab. Und Samsung verweist wieder auf Drei...womit wir beim "Salzamt" gelandet wären. :biggrin:
     
    FANATLA bedankt sich.
  4. FANATLA, 20.02.2012 #4
    FANATLA

    FANATLA Threadstarter Android-Experte

    Beiträge:
    641
    Erhaltene Danke:
    147
    Registriert seit:
    25.11.2011
    Phone:
    SGS5mini G800F
    danke werd mir das mal anschauen (Link funktioniert momentan nicht), aber wenigstens gibt es Hoffnung, es sah nämlich anfangs so aus als stehe ich ziemlich alleine mit diesem Problem da.
    Ich hab zwar ein gebrandetes Gerät aber ich möchte ja trotzdem andere ROMs testen.
     
  5. FANATLA, 20.02.2012 #5
    FANATLA

    FANATLA Threadstarter Android-Experte

    Beiträge:
    641
    Erhaltene Danke:
    147
    Registriert seit:
    25.11.2011
    Phone:
    SGS5mini G800F
    Die Änderung der Datei /system/etc/spn-conf.xml hat das Problem gelöst. Habe wie in deinem verlinkten Thread die folgende Zeile hinzugefügt:
    <spnOverride numeric="23210" fake_home_on="23201"/> <!-- 3 @ 3 AT -->

    Ich hatte dabei zwar das Problem, dass sich die Datei nicht ändern bzw. überschreiben ließ, da diese vermutlich gerade in Verwendung war. Nach Wechsel in den Offline-Modus hat es aber funktioniert. Seit dem Neustart wurde dann auch 3 nicht mehr mit "R" angezeigt und Datenverbindung über Edge funktioniert trotz deaktiviertem Daten-Roaming.

    Ich denke dass ich somit die Einstellung "National Roaming nur" nicht mehr brauche wenn diese bei irgendeinem ROM nicht verfügbar ist.
     
  6. robomobile, 21.02.2012 #6
    robomobile

    robomobile Android-Hilfe.de Mitglied

    Beiträge:
    120
    Erhaltene Danke:
    19
    Registriert seit:
    11.03.2011
    Freut mich, daß es geklappt hat. Dann kann ich mich nun langsam bei meinem auch dranwagen. :winki:

    Nur daß das dann automatisch bei jedem ("irgendeinem") Rom auch funktioniert, würde ich so nicht unterschreiben wollen.

    Habe gerade gestern Beiträge von mcdaniels und extralife im Galaxy S Forum gelesen, wo manches wieder betreffend der Funktion dieser Datei offenbar in Frage gestellt wird.

    http://www.android-hilfe.de/root-ha...uctcode-wichtig-fuer-einbuchung-heimnetz.html

    Es bleibt also interessant. :rolleyes2:
     
  7. robomobile, 24.02.2012 #7
    robomobile

    robomobile Android-Hilfe.de Mitglied

    Beiträge:
    120
    Erhaltene Danke:
    19
    Registriert seit:
    11.03.2011
    Aber zumindest für die GB 2.3.4 XWKI4 Stock Rom funktioniert diese erweiterte spn-conf.xml noch, auch fürs SGS2. Hab´s heute erledigt und vor Kurzem getestet. Befund: Einwandfrei. :smile:
    Wie das mit ICS dann sein wird in einem Monat, bin ich jetzt schon gespannt.:unsure:
     
  8. FANATLA, 20.03.2012 #8
    FANATLA

    FANATLA Threadstarter Android-Experte

    Beiträge:
    641
    Erhaltene Danke:
    147
    Registriert seit:
    25.11.2011
    Phone:
    SGS5mini G800F
    Jetzt ist es so weit, hab mir ICS (XXLPQ) geflasht und festgestellt dass die spn-conf.xml unter ICS ignoriert wird.

    siehe auch hier

    Hab jetzt einfach mal Datenroaming ausgeschaltet, da ich sowieso fast immer (dort wo ich bin) 3AT-Empfang habe und A1-Roaming nicht brauche. Wäre aber praktisch wenn es mal eine Lösung gäbe.

    Dieser Vorschlag mit dem init.d-Script aus dem SGS-Forum hat bei mir nicht funktioniert (gerade nochmal probiert mit Siyah 3.0 beta3)
     
  9. FANATLA, 23.03.2012 #9
    FANATLA

    FANATLA Threadstarter Android-Experte

    Beiträge:
    641
    Erhaltene Danke:
    147
    Registriert seit:
    25.11.2011
    Phone:
    SGS5mini G800F
    Hab eine Frage bezüglich des "National-Roaming"-Problems für 3AT-User die in Grenznähe wohnen und ICS haben (damit "3" nicht mehr als Roaming mit "R" angezeigt wird sondern auch als Heimnetz erkannt wird). Da die spn-conf.xml unter ICS ignoriert wird, habe ich ein Script gefunden, das dieses Problem lösen soll:
    Code:
    #!/system/bin/sh
    
    getprop | grep operator
    echo A1_3 start
    
    setprop gsm.sim.operator.alpha "3"
    setprop gsm.operator.isroaming false
    
    getprop | grep operator
    echo A1_3 done
    Ich verwende den Siyah-Kernel (3.0b6 derzeit) aber es sollte ja mit jedem Kernel funktionieren der init.d-Scripts unterstützt.

    Das Problem ist dass ich nicht weiß ob das Script "nur" nicht funktioniert, oder überhaupt nicht ausgeführt wird. Wenn es ausgeführt wird aber nicht funktioniert, sollten ja zumindest die "echo"-Meldungen angezeigt werden, oder nicht? Diese werden jedoch bei mir nicht angezeigt bzw. wenn überhaupt, wo sollten die angezeigt werden?
     
  10. Jense, 27.03.2012 #10
    Jense

    Jense Android-Hilfe.de Mitglied

    Beiträge:
    77
    Erhaltene Danke:
    14
    Registriert seit:
    27.03.2012
    Hallo zusammen,

    ich habe ein Galaxy S2, benutze einen Dual-Sim Adapter, weil ich in Deutschland wohne und im Ausland arbeite. Das Umschalten funktionierte bisher problemlos.
    Gestern Abend habe ich mein Handy (ich glaube Ihr nennt es) 'geflasht' und Android 4.0.3. installiert. Es funktioniert alles einwandfrei, nur eines macht mich ein wenig stutzig:

    Ich habe im Display den korrekten Netzbetreiber stehen, über der Signalstärkeanzeige steht jedoch das R für roaming. In den Einstellungen steht auch roaming und das meine Nummer unbekannt ist. Ich will natürlich nicht roamen, weil das im Ausland megaviel Geld kostet ...

    Hat noch jemand dieses Problem oder eine Lösung für mich?

    Darf ich davon ausgehen, dass ich im richtigen Netz angemeldet bin (so steht es im Display)?

    Vielen Dank für Eure Hilfe.

    Lieben Gruß

    Der Jense
     
  11. email.filtering, 28.03.2012 #11
    email.filtering

    email.filtering Gast

    Du weißt aber schon, dass es auch ein Inlandsroaming gibt!?

    Wie wär's also mit zweckdienlichen Hinweisen; z.B. zum jeweiligen Netzbetreiber usw.?
     
    Zuletzt von einem Moderator bearbeitet: 28.03.2012
  12. Jense, 28.03.2012 #12
    Jense

    Jense Android-Hilfe.de Mitglied

    Beiträge:
    77
    Erhaltene Danke:
    14
    Registriert seit:
    27.03.2012
    Ich arbeite in den Niederlanden und das Netzwerk, dass ich dort benutze ist KPN. Das Roamingsymbol erscheint erst seitdem ich Android 4.0.3 installiert habe. Die SIM Karte von KPN ist die erste in meinem Adapter und die von O2, die ich in Deutschland benutze ist Nr 2. Hier taucht das Roamingsymbol nicht auf.

    Sorry, wenn ich nicht ausführlich genug war/bin ...

    Inlandsroaming kenne ich, nur wundert mich das Roamingsymbol, da es bisher nur bei Auslandsroaming auftrat.
     
  13. HTCDesire, 28.03.2012 #13
    HTCDesire

    HTCDesire Android-Guru

    Beiträge:
    2,683
    Erhaltene Danke:
    474
    Registriert seit:
    13.05.2010
    Phone:
    Samsung Galaxy S5 (G900)
    Warum deaktivierst du dann in den Einstellungen nicht das Roaming?
     
  14. Jense, 28.03.2012 #14
    Jense

    Jense Android-Hilfe.de Mitglied

    Beiträge:
    77
    Erhaltene Danke:
    14
    Registriert seit:
    27.03.2012
    Lieben Dank für Eure Antworten. Ich hatte inzwischen Kontakt mit dem Netzbetreiber, der mir versicherte, dass essich tatsächlich um 'Inlandsroaming' handelt, da da noch ein zweiter Anbieter in Sachen Netz mit drinhängt.

    Lieben Gruß

    Jense
     
  15. olkawe, 29.03.2012 #15
    olkawe

    olkawe Android-Hilfe.de Mitglied

    Beiträge:
    98
    Erhaltene Danke:
    11
    Registriert seit:
    10.01.2011
    Hallo,

    Das wusste ich noch gar nicht, kannst du mir verraten welcher Anbieter das ist?

    Gruß und Danke
     
  16. HTCDesire, 29.03.2012 #16
    HTCDesire

    HTCDesire Android-Guru

    Beiträge:
    2,683
    Erhaltene Danke:
    474
    Registriert seit:
    13.05.2010
    Phone:
    Samsung Galaxy S5 (G900)
    Deine Frage ist doch schon beantwortet vom TE!
     
  17. FANATLA, 24.04.2012 #17
    FANATLA

    FANATLA Threadstarter Android-Experte

    Beiträge:
    641
    Erhaltene Danke:
    147
    Registriert seit:
    25.11.2011
    Phone:
    SGS5mini G800F
    Ich habe seit einer Woche die I9100XWLP7 (DBT) drauf und heute zufällig festgestellt, dass damit nationales Datenroaming zwischen Drei und A1 einwandfrei funktioniert! :thumbup:

    Es fehlt zwar die Einstellungsmöglichkeit dafür, ich habe also Datenroaming deaktiviert, aber ich war heute mal zufällig im A1-Roaming unterwegs und da wurde kein R beim Empfangsbalken angezeigt und ich hatte Edge-Verbindung.

    Als ich noch die LPQ oder LPS (Polen) hatte, wurde die Datenverbindung unterbrochen und das R angezeigt, sobald ich im A1-Roaming war, die Zeile in der spn-conf.xml wurde also ignoriert (bzw. die gesamte Datei).
    Ich habe mir dann die spn-conf.xml angesehen und bemerkt, dass diese die Zeile "<spnOverride numeric="23210" fake_home_on="23201"/>" enthält jedoch an anderer Stelle als davor und mit dem Kommentar "<!-- H3G Network -->. Die Datei hat das Änderungsdatum 3.4.2012 (genau wie das Build-Datum dieser Firmware) und auch fast alle anderen Dateien und Ordner unter /etc haben exakt dieses Datum und auch die gleiche Uhrzeit.

    Ich vermute daher dass die deutsche LP7 diese spn-conf.xml mit sich bringt und diese auch nicht mehr ignoriert, somit ist diese Firmware für Kunden von "3 AT" wieder interessant!
     
    robomobile bedankt sich.
  18. chris_555, 17.07.2012 #18
    chris_555

    chris_555 Neuer Benutzer

    Beiträge:
    4
    Erhaltene Danke:
    0
    Registriert seit:
    17.07.2012
    Hallo

    Habe seit ca. 4 Tagen immer ein kleines R über den Empfangsbalken und kein Internet empfang mehr.

    Datenroaming ist deaktiviert.
    Packetdaten aktiviert.

    Netz wurde auf 3-2G eingestellt dann bleibt es ca. 5 min ohne R über den Empfangsbalken und dann kommt wieder einer und der Internetempfang ist auch weg :mad2: :mad2: :mad2:

    Wenn ich auf Netz automatisch auswählen stelle geht das Internet aber ist wieder das R über den Empfangsbalken.

    kann mir da Bitte wer helfen?

    mfg Christian

    EDIT: Habe in der Wohnung fast keinen 3(drei Austria) Empfang. Kann es sein das es sich dann zu A1 einloggt? Und dann das R drüber steht? Bis her sind noch keine kosten herangfallen!
     
    Zuletzt bearbeitet: 17.07.2012
  19. abemann, 17.07.2012 #19
    abemann

    abemann Ehrenmitglied

    Beiträge:
    2,107
    Erhaltene Danke:
    934
    Registriert seit:
    07.03.2012
    Phone:
    Samsung Galaxy S4
    Befindest du dich im Grenzgebiet zu irgendwas?
    Kann dir nur soweit helfen, das ich weiß, das wenn das r über dem Empfangsbalken ist, du im Roaming bist, also in einem ausländischen Netz eingebucht bist.
    War gerade in den Staaten und hatte da die ganze Zeit ein r über dem Balken. Auch wenn Datenroaming ausgeschaltet ist, das hat damit nichts zu tun.
    Vielleicht das Netz mal manuell wählen.

    Binford... more Power!
     
    chris_555 bedankt sich.
  20. chris_555, 17.07.2012 #20
    chris_555

    chris_555 Neuer Benutzer

    Beiträge:
    4
    Erhaltene Danke:
    0
    Registriert seit:
    17.07.2012
    Okay danke bin ca. 100 km von der österreichisch-ungarischen Grenze weg.

    Wenn ich es manuel wähle bleibt es ca. 5 min lang normal und dann steht wieder ein R darüber. :mad:

    MfG Christian
     
    Zuletzt von einem Moderator bearbeitet: 17.07.2012

Diese Seite empfehlen

Besucher kamen mit folgenden Begriffen auf unsere Seite:

  1. android national roaming