1. Nimm jetzt an unserem 2. ADVENT-Gewinnspiel teil - Alle Informationen findest Du hier!

Erst WLAN dann mobiles Netz = keine Verbindung.

Dieses Thema im Forum "Samsung Galaxy S (I9000) Forum" wurde erstellt von tachyon, 29.06.2010.

  1. tachyon, 29.06.2010 #1
    tachyon

    tachyon Threadstarter Android-Hilfe.de Mitglied

    Beiträge:
    53
    Erhaltene Danke:
    3
    Registriert seit:
    28.04.2010
    Hallo,

    ich habe mal wieder ein Problem.
    Wenn ich beim Galaxy das Wlan ein und dann wieder aus schalte, dann funktioniert anschließend das mobile Internet (Provider: o2) nicht mehr.

    Ausgangslage: Mobiles Netz funktioniert, HSDPA wird angezeigt.
    Abfolge der Bedienungen: APNDoid Sperren -> Wlan ein -> Wlan aus -> APNDroid entsperren.
    Neue Lage: Es wird in der Statusleiste eine aktive HSDPA-Verbindung angezeigt, jedoch komme ich mit keine Anwendung ins Netz.

    Umschaltung auf Flugmodus und zurück bringt leider auch nichts. Nur Aus- und Einschalten hilft.

    Hat das Problem noch jemand? Oder weiß vllt. jemand eine Lösung?
     
  2. scheichuwe, 29.06.2010 #2
    scheichuwe

    scheichuwe Android-Ikone

    Beiträge:
    5,440
    Erhaltene Danke:
    2,541
    Registriert seit:
    09.09.2009
    Phone:
    LG G4
    Das Problem APNdroid und O2-Netz (andere Netze können auch betroffen sein, weiß ich aber nix drüber) gibt's beim Milestone auch. Lösung:
    Neustart. Hast du ja selbst schon festgestellt.

    Warum aber benutzt du APNdroid überhaupt.
    Wenn du WLAN aktivierst, dann ist automatisch die mobile Datenverbindung deaktiviert. Das war bisher bei jedem Android-Phone so, würde mich wundern, wenn das beim Galaxy S anders wär.
     
  3. Lion13, 29.06.2010 #3
    Lion13

    Lion13 Ehrenmitglied

    Beiträge:
    16,673
    Erhaltene Danke:
    5,019
    Registriert seit:
    17.04.2010
    Phone:
    iPhone SE, Google Nexus 5x
    Tablet:
    Google Nexus 7 (2013)
    Wearable:
    Pebble Time
    Sonstige:
    Amazon Fire TV
    Zumindest beim HTC Desire und Legend wurde das Problem schon einige Male berichtet - durfte also eher ein Android-Bug sein als am Galaxy liegen.

    Versuche mal folgendes: -> Einstellungen -> Drahtlos und Netzwerke -> Mobile Netzwerke -> Netzwerkmodus: hier mal auf "Nur GSM" stellen, das Menü verlassen, ein paar Sekunden warten, bis das Symbol für die Signalstärke wieder aktiv ist, und dann wieder zurück auf "GSM/WCDMA automatisch" stellen.
     
  4. tachyon, 29.06.2010 #4
    tachyon

    tachyon Threadstarter Android-Hilfe.de Mitglied

    Beiträge:
    53
    Erhaltene Danke:
    3
    Registriert seit:
    28.04.2010
    Hilft leider auch nicht.

    Irgendwie seht es so aus, als wenn die Anwendungen nicht mal versuchen, irgendwas zu machen. Wenn ich z.B. im Browser eine Seite öffne kommt quasi instant die Meldung "Webseite nicht verfügbar". Wenn Wlan an ist, aber kein Netz zur Verfügung steht sieht man wenigstens, dass er versucht, sich zu verbinden. Hier aber nicht.

    Eine Verbindung ist aber den Symbolen nach da. Auch unter Einstellungen->Telefoninfo->Status wird "Verbunden" mit Typ "HSDPA" gemeldet. Sehr mysteriös...
     
  5. Lion13, 29.06.2010 #5
    Lion13

    Lion13 Ehrenmitglied

    Beiträge:
    16,673
    Erhaltene Danke:
    5,019
    Registriert seit:
    17.04.2010
    Phone:
    iPhone SE, Google Nexus 5x
    Tablet:
    Google Nexus 7 (2013)
    Wearable:
    Pebble Time
    Sonstige:
    Amazon Fire TV
    Wie scheichuwe schon bemerkt hat: Kannst du mal ausprobieren, ob das Problem auch besteht, wenn du nur länger WLAN nutzt, also ohne APNdroid?

     
  6. tachyon, 29.06.2010 #6
    tachyon

    tachyon Threadstarter Android-Hilfe.de Mitglied

    Beiträge:
    53
    Erhaltene Danke:
    3
    Registriert seit:
    28.04.2010
    Ja, das kann ich später mal machen, wenn ich wieder Wlan zur Verfügung habe.

    (Für den oben beschriebenen Test habe ich nur Wlan ein- und ausgeschaltet, ohne dabei eine Vebindung zu haben.)
     
  7. djmarques, 29.06.2010 #7
    djmarques

    djmarques Ehrenmitglied

    Beiträge:
    13,430
    Erhaltene Danke:
    2,648
    Registriert seit:
    03.08.2009
    Wieso du die Verbindung mit APN Droid wegmachst,dann wlan ein, wlan aus und apn wieder herstellst versteh ich nicht...

    wenn wlan aktiv ist,dann ist die datenverbindung sowieso weg...
    probiers mal ohne deaktivieren
     
  8. tachyon, 29.06.2010 #8
    tachyon

    tachyon Threadstarter Android-Hilfe.de Mitglied

    Beiträge:
    53
    Erhaltene Danke:
    3
    Registriert seit:
    28.04.2010
    Das war jetzt nur zum schnellen Testen, ob es irgendwie mit Wlan+APNdroid zusammenhängt.

    Normalerweise benutzt ich zuhause Wlan und APNdroid ist die meiste Zeit auf "Sperren" gestellt. Nur wenn ich unterwegs mal was im Netz checken will entsperre ich.

    Und da kommt dann das Problem. Wenn vorher irgendwann mal Wlan an war, geht die Verbindung nicht mehr...
     
  9. tachyon, 29.06.2010 #9
    tachyon

    tachyon Threadstarter Android-Hilfe.de Mitglied

    Beiträge:
    53
    Erhaltene Danke:
    3
    Registriert seit:
    28.04.2010
    Tja, ohne APNdroid geht es tatsächlich...
     
  10. Tanis64, 30.06.2010 #10
    Tanis64

    Tanis64 Android-Experte

    Beiträge:
    653
    Erhaltene Danke:
    309
    Registriert seit:
    14.04.2010
    Phone:
    Samsung Galaxy S4
    Dann Versuch Dein Glück mal mirt Quick Settings, bei mir gehts damit ohne probleme
     
  11. dodo2801, 30.06.2010 #11
    dodo2801

    dodo2801 Android-Hilfe.de Mitglied

    Beiträge:
    99
    Erhaltene Danke:
    9
    Registriert seit:
    28.06.2010
    Ich habe das Problem auch schon des öfteren gehabt, und ich benutze kein APNdroid.
     
  12. Lion13, 30.06.2010 #12
    Lion13

    Lion13 Ehrenmitglied

    Beiträge:
    16,673
    Erhaltene Danke:
    5,019
    Registriert seit:
    17.04.2010
    Phone:
    iPhone SE, Google Nexus 5x
    Tablet:
    Google Nexus 7 (2013)
    Wearable:
    Pebble Time
    Sonstige:
    Amazon Fire TV
    Dito - und ich habe bisher kein rechtes Muster erkennen können; bei mir ist das jetzt in 3 Monaten ca. 4- oder 5mal passiert. Und HTC hat laut des Beitrags eines Users in einem anderen Thread zugegeben, daß der Bug bekannt ist und daran gearbeitet wird, also (hoffentlich!) in einem zukünftigen Update gefixt wird.
     
  13. tachyon, 30.06.2010 #13
    tachyon

    tachyon Threadstarter Android-Hilfe.de Mitglied

    Beiträge:
    53
    Erhaltene Danke:
    3
    Registriert seit:
    28.04.2010
    Ist es denn ein reines HTC Problem? Weil dann sollte das SGS ja theoretisch nicht davon betroffen sein.
     
  14. Lion13, 30.06.2010 #14
    Lion13

    Lion13 Ehrenmitglied

    Beiträge:
    16,673
    Erhaltene Danke:
    5,019
    Registriert seit:
    17.04.2010
    Phone:
    iPhone SE, Google Nexus 5x
    Tablet:
    Google Nexus 7 (2013)
    Wearable:
    Pebble Time
    Sonstige:
    Amazon Fire TV
    Das weiß nur HTC... :o

    Könnte aber auch ein allgemeines 2.1-Problem sein, da auch Milestone-User betroffen sind.
     
  15. Chris101, 30.06.2010 #15
    Chris101

    Chris101 Ehrenmitglied

    Beiträge:
    1,409
    Erhaltene Danke:
    465
    Registriert seit:
    16.06.2010
    beim start ist kein einrichtungsprogramm gekommen wie bei Legend N1 oder Desire

    hab kein internet :(

    erbitte um hilfe
     
  16. dodo2801, 30.06.2010 #16
    dodo2801

    dodo2801 Android-Hilfe.de Mitglied

    Beiträge:
    99
    Erhaltene Danke:
    9
    Registriert seit:
    28.06.2010
    Nein, ich hab das Galaxy S!

    Aber ich denke das das ein Android Bug ist der mit 2.2 sicher behoben wird.
     
  17. Max1985, 30.06.2010 #17
    Max1985

    Max1985 Android-Hilfe.de Mitglied

    Beiträge:
    102
    Erhaltene Danke:
    6
    Registriert seit:
    25.06.2010
    Mir ist aufgefallen wenn ich WLAN aktiviert habe, es dann zur Seite lege und nach einer gewissen Zeit wieder nutze, das er automisch in die Mobilnetzdatenverbindung geht, obwohl eigentlich ein WLAN-Netz vorhanden ist.

    Nach dem Entsperren sieht man dann wie es dann wieder zu WLAN wechselt.

    Gibt es dafür eine Lösung, bzw warum bleibt das Gerät nicht im WLAN?

    Mfg Max
     
  18. Lion13, 30.06.2010 #18
    Lion13

    Lion13 Ehrenmitglied

    Beiträge:
    16,673
    Erhaltene Danke:
    5,019
    Registriert seit:
    17.04.2010
    Phone:
    iPhone SE, Google Nexus 5x
    Tablet:
    Google Nexus 7 (2013)
    Wearable:
    Pebble Time
    Sonstige:
    Amazon Fire TV
    Schau mal bei -> Einstellungen -> Drahtlos und Netzwerke -> WiFi-Einstellungen -> Menütaste -> Erweitert -> Wi-Fi Standby-Richtlinie - wenn du dort auf "Niemals" stellst, geht das WLAN-Modul nicht in den Standby, sondern bleibt aktiv.
     
    Max1985 bedankt sich.
  19. enrage, 03.07.2010 #19
    enrage

    enrage Fortgeschrittenes Mitglied

    Beiträge:
    335
    Erhaltene Danke:
    60
    Registriert seit:
    25.06.2010
    Habe folgendes bemerkt. Sobald ich meine SSID unterdrücke erhalte ich die Probleme. Habe meine eingebenes WLAN-Netz im Handy gelöscht. SSID wieder freigegeben und es im Handy neu konfiguriert.

    Siehe da (ich benutze auch o2 o) es geht. Kaum deaktivere ich WLAN springt mein Internetzugang von o2 an, aktiviere ich WLAN geht es wieder aus. apndroid habe ich auch installiert.


    Standby-Richtlinie habe ich auf "Bildschirm dunkel" WLAN Verbindung ist stabil dabei, sofern ich ausm Standby zurückkehre.
     
  20. can

    can Android-Hilfe.de Mitglied

    Beiträge:
    46
    Erhaltene Danke:
    0
    Registriert seit:
    28.05.2010
    Ich habe am Anfang gedacht das mein Grät Defekt ist weil mein WLAN sich abgemeldet hat bei Standby, beim Desire war das nicht so.

    Aber letztendlich finde ich das gut weil so WLAN abgeschaltet wird um Strom zu sparen.
    Sollte man natürlich nur aktivieren wen man ein Daten Flat hat.

    ich bin begeistert vom Akku verbrauch meines Gerätes.:cool:
     

Diese Seite empfehlen