1. Nimm jetzt an unserem Uhans - 3. ADVENT - Gewinnspiel teil - Alle Informationen findest Du hier!

Exchange Active Sync bringt einen Fehler

Dieses Thema im Forum "Google Nexus One Forum" wurde erstellt von Aleks, 21.10.2010.

  1. Aleks, 21.10.2010 #1
    Aleks

    Aleks Threadstarter Neuer Benutzer

    Beiträge:
    5
    Erhaltene Danke:
    0
    Registriert seit:
    21.10.2010
    Hallo Android-Hilfe,

    ich hab ein Problem mit dm Exchange Active Sync beim HTC Nexus One.
    Bei anderen mit Android - Geräten (HTC Legend, HTC Mini etc.) läuft es ohne Probleme.

    Hier das Problem:

    Mit dem Nexus One bricht der Exchange Active Sync mit folgender Fehlermeldung ab:

    Mit der Option SSL Verwenden:
    "! Einrichtung konnte nicht abgeschlossen werden.
    Verbindung zu Server kann aufgrund eines Sicherheitsfehlers nicht geöffnet werden." :thumbup:

    läuchtet ein - drum auch die Option
    --> Alle SSL-Zertifikate akzeptieren:

    "! Einrichtung konnte nicht abgeschlaossen werden.
    Verbingung zum Server kann nicht geöffnet werden." :cursing:

    Bei den anderen Androidgeräten läuft der Sync zwischen MS Exchange und Mobilephone, wobei auch das Menü zum einstellen sich zum Nexus One unterscheidet.
    Die Möglichkeiten der Einstellungen bei manuelle Konfiguration wirken etwas abgespeckt.

    Über den Browser ist OWA erreichbar.
    Mit dem APP Touchdown läuft es komischerweise auch.

    Hilfe - hat jemand eine Lösung für dieses Problem??

    Ich wäre um jeden Ratschlag dankbar, das Gerät wurde bei Vodafone Germany gekauft.

    Android Version:
    2.2

    Baseband-Version
    32.41.00.32U_5.08.00.04

    Kernel-Version:
    2.6.32.9-27227-g3c98b0d
    haley@m4-dev #1

    Build-Nr.
    FRF91

    please help
     
    Zuletzt bearbeitet: 22.10.2010
  2. RinTinTigger, 22.10.2010 #2
    RinTinTigger

    RinTinTigger Gast

    Hey, das Problem kenne ich und hatte ich auch. ich habe es umgangen und einen anderen mailclient genommen (Touchdown) der ist aber leider kostenpflichtig. Versuch es doch mal mit der Trial version und schau, ob das Problem da auch noch persistent ist!
     
  3. Aleks, 22.10.2010 #3
    Aleks

    Aleks Threadstarter Neuer Benutzer

    Beiträge:
    5
    Erhaltene Danke:
    0
    Registriert seit:
    21.10.2010
    Hallo RintinTrigger,

    danke für deinen Tipp.
    Touchdown hab ich auch schon als alternative laufen (die Trial) und auch etliche andere Apps mit Exchange funktion getestet.

    Aber es kann doch nicht sein, dass Touchdown auf dem N1 das einzige Sync App ist das läuft...?!?

    Es ist schon schade für ein Smartphone das viel Geld kostet und eine für geschäftliche Zwecke wichtige Funktiunalität nicht kann obwohl sie angeboten wird. (Exchange Active Sync)
    Mit anderen Android Geräten läuft es doch auch und unsere Company will kein Geld für zusätzliche Lizenzen bereit stellen...

    Hat jemand vielleicht eine Lösung?????????
     
  4. garak, 22.10.2010 #4
    garak

    garak Ehrenmitglied

    Beiträge:
    8,270
    Erhaltene Danke:
    4,795
    Registriert seit:
    12.12.2009
    Installiere dir doch mal aLogcat und schaue in die Logdatei, warum die Verbindung nicht zustande kommen will. Vielleicht erkennst du daraus ja etwas, das dir weiterhilft.

    [​IMG]
     
    Aleks bedankt sich.
  5. Aleks, 22.10.2010 #5
    Aleks

    Aleks Threadstarter Neuer Benutzer

    Beiträge:
    5
    Erhaltene Danke:
    0
    Registriert seit:
    21.10.2010
    Dank dir, für den Tipp - daraus werde ich leider auch nicht schlauer - da er keinen Grund bringt warum er nicht weitermacht...

    Gibt es noch eine andere Möglichkeit?
     
  6. garak, 23.10.2010 #6
    garak

    garak Ehrenmitglied

    Beiträge:
    8,270
    Erhaltene Danke:
    4,795
    Registriert seit:
    12.12.2009
    Dass du mal euren Admin bittest den Verbindungsversuch anzusehen, warum bzw. wo die Verbindung hängen bleibt.
     
  7. el_larso, 25.10.2010 #7
    el_larso

    el_larso Erfahrener Benutzer

    Beiträge:
    191
    Erhaltene Danke:
    16
    Registriert seit:
    20.04.2010
    Ist es mal wieder das altbekannte Problem mit dem selbst signierten Zertifikaten?

    Wenn euer Exchange Admin das Activ Sync Zertifikat selbst signiert hat und kein offizielles einer offiziellen Zertifizierungsstelle nutzt, dann akzeptiert Froyo das selbst signierte Zert. nicht.
    HTC legend und Mini dümpeln ja noch mit Android 2.1 rum.
     
  8. r0ckster05, 25.10.2010 #8
    r0ckster05

    r0ckster05 Erfahrener Benutzer

    Beiträge:
    208
    Erhaltene Danke:
    15
    Registriert seit:
    08.03.2010
    sorry hab jetzt erst gesehen das es dazu noch ein anderes aktuelleres posting gibt.
    habe nun das gleichge problem mit einem milestone 2.2 testbuild.
    heißt das etwa ab 2.2 kein exchange active sync mehr wenn man ein selbstsigniertes zertifikat benutzt?
    also keine chance auf änderung? quasi wieder mal kein bug sondern ein feature. dann leider kein 2.2 für mich.
     
  9. el_larso, 25.10.2010 #9
    el_larso

    el_larso Erfahrener Benutzer

    Beiträge:
    191
    Erhaltene Danke:
    16
    Registriert seit:
    20.04.2010
    Jo... wahrscheinlich wegen der Sicherheit ;)
     
  10. Aleks, 26.10.2010 #10
    Aleks

    Aleks Threadstarter Neuer Benutzer

    Beiträge:
    5
    Erhaltene Danke:
    0
    Registriert seit:
    21.10.2010
    Ich bin selber in der IT - Abteilung unserer Firma...
    Aber ich frage meinen Firewall-Kollegen, dass er da mal loggen soll...
    Vielleicht bringt das Aufschluß. ;)
     
  11. Aleks, 26.10.2010 #11
    Aleks

    Aleks Threadstarter Neuer Benutzer

    Beiträge:
    5
    Erhaltene Danke:
    0
    Registriert seit:
    21.10.2010
    Diese Geräte haben laut Einstellungen / Telefonstatus auch schon die 2.2er Version drauf.
    Und da läuft der Sync ohne Probleme mit selbstsignierten Zertifikaten...
     
  12. r0ckster05, 26.10.2010 #12
    r0ckster05

    r0ckster05 Erfahrener Benutzer

    Beiträge:
    208
    Erhaltene Danke:
    15
    Registriert seit:
    08.03.2010
    sieht tatsächlich so aus,, als wenn er selbstsignierte zertifikate nich annehmen möchte. die funktion alle zertifikate akzeptieren müsste da eigentlich greifen, tut es aber nicht.
    dann sind anscheind alle anderen geräte die in der kombination laufen wohl große sicherheitsrisiken :biggrin:
    google handys sind die letzte sicherheitsbarriere. es könnten ja daten auf irgendwelche dubiosen server synchronisiert werden. das wäre ja garnicht google like ... ooh mann...

    mit dem cm6 release funktioniert die exchangeanbindung übrigens.
    da laufen komplett andere binaries.
     
  13. Minutourus, 27.10.2010 #13
    Minutourus

    Minutourus Fortgeschrittenes Mitglied

    Beiträge:
    422
    Erhaltene Danke:
    53
    Registriert seit:
    13.09.2010
    Es liegt schlicht und ergreifend daran das das Stamm Zertifikat einfach nicht im Speicher vorhanden ist und da kann man noch so viele selbst-signierte Mail Zertifikate benutzen wie man will.

    Es gibt noch einen Workaround einfach von hier ein Zertifikat für den Exchange Server erstellen. Das dauert in der Regel 10 Minuten und das Stamm Zertifikat ist bei Android schon dabei. StartCom Freie SSL Zertifikationsstelle
     
  14. r0ckster05, 27.10.2010 #14
    r0ckster05

    r0ckster05 Erfahrener Benutzer

    Beiträge:
    208
    Erhaltene Danke:
    15
    Registriert seit:
    08.03.2010
    auf dem exchangeserver selbsignierte zertifkate sind sind nicht selten und funktionieren in anderen geräten windows mobile,Iphone,blackberry und mit android <2.2 ohne probleme.
    da muß man sich nur mal die threads dazu durchlesen.
    ausserdem ist die option "alle zertifikate zulassen" für den ... wenn eben nicht alle zertifikate akzeptiert werden.
    ausserdem wird von einem release zum andern das verhalten der exchangeanbindung verändert ohne das es großartig in der logchanges von froyo erwähnung findet.
     
  15. r0ckster05, 28.10.2010 #15
    r0ckster05

    r0ckster05 Erfahrener Benutzer

    Beiträge:
    208
    Erhaltene Danke:
    15
    Registriert seit:
    08.03.2010
    workaround für exchange 2007 und selbst signierten zertifikaten

    unter clientzugriff/active sync/clientzertifikate ignorieren.
     

Diese Seite empfehlen