1. Nimm jetzt an unserem Uhans - 3. ADVENT - Gewinnspiel teil - Alle Informationen findest Du hier!

Externes USB Gerät

Dieses Thema im Forum "Sony Xperia S Forum" wurde erstellt von Bobbie25, 05.08.2012.

  1. Bobbie25, 05.08.2012 #1
    Bobbie25

    Bobbie25 Threadstarter Android-Experte

    Beiträge:
    456
    Erhaltene Danke:
    38
    Registriert seit:
    15.04.2012
    Hat jemand schonmal geschafft ein externes USB Gerät anzuschließen?

    USB Sticks gehen jedenfalls nicht.

    Grüsse aus Neuss, gesendet von meinem Sony Xperia S
     
  2. *capricorn*, 05.08.2012 #2
    *capricorn*

    *capricorn* Android-Experte

    Beiträge:
    450
    Erhaltene Danke:
    61
    Registriert seit:
    22.04.2012
    Ich habe schon 1x einen USB-Stick angeschlossen gehabt, der wurde problemlos erkannt
     
  3. Kuni, 05.08.2012 #3
    Kuni

    Kuni Fortgeschrittenes Mitglied

    Beiträge:
    407
    Erhaltene Danke:
    48
    Registriert seit:
    11.03.2010
    Wenn der USB Stick NTFS formatiert ist, dann wird der sehr wahrscheinlich nicht funktionieren
    - 2 USB Sticks ausprobiert (16GB und 2GB) > läuft
    - Fujitsu Funkmaus+Tastatur-Kombi > läuft
    - Logitech Funkmaus > läuft
    - 1TB NTFS Festplatte > läuft nicht, was mich aber nicht schockiert :D
    - Laserdrucker > läuft nicht, war fast albern das auszuprobieren :D
     
  4. alxus one, 05.08.2012 #4
    alxus one

    alxus one Android-Hilfe.de Mitglied

    Beiträge:
    127
    Erhaltene Danke:
    15
    Registriert seit:
    28.08.2010
    Phone:
    Nexus One
    Sparsame Sticks gehen bei mir auch. Dagegen ein USB3.0 32GB Stick von CnMemory nicht. Das Handy meldet, das ein Verbraucher zu viel Strom braucht und schaltet diesen als gleich ab. Ich nehme an, mit einem aktiven Hub dürfte es aber trotzdem gehen.
     
  5. Bobbie25, 06.08.2012 #5
    Bobbie25

    Bobbie25 Threadstarter Android-Experte

    Beiträge:
    456
    Erhaltene Danke:
    38
    Registriert seit:
    15.04.2012
    Genau das ist bei meinem 64 Gb auch... Ich hab auf fat32 formatiert....

    Werde mal auf ext2 testen...

    Grüsse aus Neuss, gesendet von meinem Sony Xperia S
     
  6. Kuni, 06.08.2012 #6
    Kuni

    Kuni Fortgeschrittenes Mitglied

    Beiträge:
    407
    Erhaltene Danke:
    48
    Registriert seit:
    11.03.2010
    Ich habe jetzt einen 8gb verbatim Stick probiert > zu wenig Strom, aber lässt sich wirklich durch einen aktiven USB hub lösen
     
  7. Bobbie25, 06.08.2012 #7
    Bobbie25

    Bobbie25 Threadstarter Android-Experte

    Beiträge:
    456
    Erhaltene Danke:
    38
    Registriert seit:
    15.04.2012
    [​IMG]So kurzer Report

    Transcend ultraSpeed 64Gb
    funktioniert tadellos

    Fat32 mit 4kb blockgroesse an
    /mnt/sda01

    Gemountet mit al Mass storage Manager...

    Dann mit bs Player 1080p mkv abgespielt. Perfekt!

    Genau richtig für den Urlaub...

    Allerdings gerootetes sxs 4.0.4.


    Grüsse aus Neuss, gesendet von meinem Sony Xperia S
     
    Zuletzt bearbeitet: 06.08.2012
  8. Klingelton, 06.08.2012 #8
    Klingelton

    Klingelton Junior Mitglied

    Beiträge:
    35
    Erhaltene Danke:
    0
    Registriert seit:
    20.07.2012
    Ich hatte leider bislang überhaupt keinen Erfolg. Allerdings habe ich inzwischen von "OTG-Kabeln" gelesen und keine Ahnung, ob meines ein solches ist... Jedenfalls passiert beim Anschließen (Stick, Maus) überhaupt nichts.

    Mit 2 Apps habe ich versucht, der Sache auf den Grund zu gehen.

    "USB Host Diagnostics" zeigt nur Fragezeichen ("Claims Support - ?" usw.) - was müsste da stehen/steht da bei Euch?

    "USB Host Controller" sagt: "S3C SUB Host Driver not found! Root hub is not present, USB host mode not active or not available!"

    Wenn ich das richtig sehe, müssten doch selbst bei einem falschen Kabel die Apps wenigstens erkennen, dass das SXS (rooted stock 4.0.4) theoretisch USB-Hostmode beherrscht? Und laut diesem Thread geht es ja... :confused2:

    Bin für jeden Hinweis dankbar!
     
  9. Bobbie25, 07.08.2012 #9
    Bobbie25

    Bobbie25 Threadstarter Android-Experte

    Beiträge:
    456
    Erhaltene Danke:
    38
    Registriert seit:
    15.04.2012
    Jedes micro USB Kabel welches am den microUSB controller angeschlossen wird, gilt als slave, dass sxs als Master. Dies handeln otg Kabel selbst aus. Basis hierfür sind die pol Belegung die bei nicht otg kabeln anders sind. Also nochmal, genau wie früher bei IDE/Slave handelt auch hier die Einheit es microUSB chip wer was ist aus. Nun scheinst du ein nicht otg fähiges Kabel erwischt zu haben ( etwa ältere Nokia oder LG Kabel).

    Zunächst kommt hinzu das der microUSB Port des sxs leider passiv ist, was ich sehr bedauerlich finde, somit sind Festplatten ohne eigene Stromversorgung fast ausgeschlossen. Dh die Festplatten würde durchaus laufen, allerdings fangen sie beim anschliessen mindestens 600 mA Strom zu ziehen, meist deutlich mehr. Danach begnügen Sue sich zwar mit 200 mA. Dies liegt aber imnernoch doppelt über der Spezifikation.

    Tja mich würde daher interessieren:

    - Wer hat SSD zum laufen gebracht
    - Wer hat HDD ( aktiv) zum laufen gebracht

    Ferner hab ich festgestellt, dass ics/Gb neue Medien im fat32 ( lba ) Modus formatiert. Blockgroesse 4kb.

    Standard mässig kann es mit ntfs ( auch als exFAT bekannt ) nichts anfangen. Die Zusatzapps können ntfs ebenfalls nicht mounten. Weder als sda01 noch angehangen im System...

    Gerade getestet

    - 4 Gb verbatim store'n'go geht
    - USB kartenleser geht nicht ( da aktiv)



    Grüsse aus Neuss, gesendet von meinem Sony Xperia S
     
    Klingelton bedankt sich.
  10. Klingelton, 07.08.2012 #10
    Klingelton

    Klingelton Junior Mitglied

    Beiträge:
    35
    Erhaltene Danke:
    0
    Registriert seit:
    20.07.2012
    Ok, das mit Master/Slave leuchtet mir schon ein. Ich dachte deshalb auch, man müsse softwaremäßig was umstellen im Gerät. Bei anderer Belegung reicht das natürlich nicht.

    Kabel habe ich vorhin erst gekauft. Es ist ein 20 cm langes, auf dem natürlich wie heute üblich nix draufsteht.

    Mich wundert aber weiterhin, was die beiden genannten Apps anzeigen. Zeigen die bei Dir denn dasselbe an (Fragezeichen / Driver not found)? "Bemerken" die also erst, dass das SXS USB Host kann, wenn da was dranhängt?

    Will nur sichergehen, dass das Kabel wirklich das einzige Problem ist. Link zu funktionierendem (und wenn möglich günstigem) wäre auch willkommen... :smile:

    Vielen Dank!
     
  11. Bobbie25, 07.08.2012 #11
    Bobbie25

    Bobbie25 Threadstarter Android-Experte

    Beiträge:
    456
    Erhaltene Danke:
    38
    Registriert seit:
    15.04.2012
    Das mitgelieferte schon probiert?

    Grüsse aus Neuss, gesendet von meinem Sony Xperia S
     
  12. *capricorn*, 07.08.2012 #12
    *capricorn*

    *capricorn* Android-Experte

    Beiträge:
    450
    Erhaltene Danke:
    61
    Registriert seit:
    22.04.2012
    Das mitgelieferte? Meinst du Kabel? Du weißt aber schon, das die meisten kein USB-Adapter Kabel im Lieferumfang hatten?

    gesendet von meinem Sony Xperia S
     
  13. Klingelton, 07.08.2012 #13
    Klingelton

    Klingelton Junior Mitglied

    Beiträge:
    35
    Erhaltene Danke:
    0
    Registriert seit:
    20.07.2012
    Gab's das überhaupt, dass da so eins dabei war? Ich hatte nur ein ganz normales Ladekabel mit 2 Steckern, keins mit Buchse (und schon gar nicht so'n Y-Ding, das wg. Stromversorgung empfohlen wird, aber so weit komme ich ja gar nicht).

    Könnte nicht bitte mal jemand, bei dem es geht, "USB Host Diagnostics" und "USB Host Controller" installieren und dann ohne angeschlossenes Kabel/Gerät melden, ob da dasselbe steht wie bei mir? - Nämlich nur Fragezeichen ("Claims Support - ?" usw.) bzw. "S3C SUB Host Driver not found! Root hub is not present, USB host mode not active or not available!".

    Für mich sieht das nämlich immer noch so aus, als könnte bei mir softwareseitig was nicht stimmen, aber das könnte man so ausräumen. Vielen Dank!
     
  14. FNT

    FNT Junior Mitglied

    Beiträge:
    38
    Erhaltene Danke:
    7
    Registriert seit:
    05.05.2011
    Steht bei mir auch da. Ich denke das Programm braucht evtl. Root? Unter "Laufende Apps" gibts bei mir einen Dienst der "usbotg" heißt. Ich denk das müsste also funktionieren. Mein Kabel kommt erst noch. Kann also nichts testen. :D
     
    Klingelton bedankt sich.
  15. Klingelton, 07.08.2012 #15
    Klingelton

    Klingelton Junior Mitglied

    Beiträge:
    35
    Erhaltene Danke:
    0
    Registriert seit:
    20.07.2012
    Root hab ich ja. Allerdings fordern die beiden Apps komischerweise kein Root an, das hatte mich auch schon gewundert. Nur bei "USB Host Controller" erschien nach wildem Rumprobieren mal eine Anfrage, aber nicht beim Start der App. Bei "Diagnostics" kam gar nix.

    Den Dienst hab ich auch laufen, danke für den Tipp! Wenn Kabel da, bitte mal berichten. Woher stammt es denn, ebay?
     
  16. FNT

    FNT Junior Mitglied

    Beiträge:
    38
    Erhaltene Danke:
    7
    Registriert seit:
    05.05.2011
    Nein, ich hab mir eins bei Dealextrem gekauft. :D Also irgendein China zeugs. :D
    Ich werde berichten, kann aber noch etwas dauern. :D
     
  17. Klingelton, 07.08.2012 #17
    Klingelton

    Klingelton Junior Mitglied

    Beiträge:
    35
    Erhaltene Danke:
    0
    Registriert seit:
    20.07.2012
    Klingt ja extrem. :D

    Vielleicht kann ja irgendjemand anders hier mal die Herkunft seines mit Xperia S funktionierenden OTG-Kabels (und evtl. Y-Kabels) schon jetzt enthüllen. Einen zweiten Flop würde ich gerne vermeiden, auch wenn der Laden das erste wohl zurücknehmen wird.
     
  18. Bobbie25, 07.08.2012 #18
    Bobbie25

    Bobbie25 Threadstarter Android-Experte

    Beiträge:
    456
    Erhaltene Danke:
    38
    Registriert seit:
    15.04.2012
    Das richtige otg Kabel zu finden ist schwer,weil die exporteure nicht extra beschriften. Ich hätte mein sxs als Version in hk gekauft da war ein Kabel bei...

    [​IMG]

    [​IMG]

    [​IMG]


    [​IMG]


    Grüsse aus Neuss, gesendet von meinem Sony Xperia S
     
    Zuletzt bearbeitet: 07.08.2012
  19. Kuni, 07.08.2012 #19
    Kuni

    Kuni Fortgeschrittenes Mitglied

    Beiträge:
    407
    Erhaltene Danke:
    48
    Registriert seit:
    11.03.2010
    Ich verstehe das Problem mit dem Adapter nicht... Im Zubehör-Abteil hier im XS Forum steht einiges dazu. Ich bin darüber auf folgenden Adapter gestoßen: Nokia CA-157 on-the-go USB Adapter: Amazon.de: Elektronik
    Ist super verarbeitet, funktioniert einwandfrei und ist super günstig.
     
    Zuletzt von einem Moderator bearbeitet: 17.06.2015
    Klingelton bedankt sich.
  20. Klingelton, 09.08.2012 #20
    Klingelton

    Klingelton Junior Mitglied

    Beiträge:
    35
    Erhaltene Danke:
    0
    Registriert seit:
    20.07.2012
    Besten Dank für den Tipp! ;) Ich hatte es noch gar nicht in irgendwelche Unterforen hier geschafft, keine Zeit... Hatte ich aber ohnehin noch vor!
     

Diese Seite empfehlen