1. Nimm jetzt an unserem 2. ADVENT-Gewinnspiel teil - Alle Informationen findest Du hier!

Falsche Tastenbelegung bei herausschiebbarer Tastatur

Dieses Thema im Forum "Samsung Galaxy 551 (I5510) Forum" wurde erstellt von jojoxx, 08.07.2011.

  1. jojoxx, 08.07.2011 #1
    jojoxx

    jojoxx Threadstarter Neuer Benutzer

    Beiträge:
    2
    Erhaltene Danke:
    0
    Registriert seit:
    08.07.2011
    Hallo zusammen,
    nach einem gescheiterten Versuch neue Fonts aufzuspielen, hatte ich mein 551 endlich so weit, das es überhaupt nicht mehr startete :blushing:. Mittlerweile habe ich es allerdings geschafft mit Odin wieder eine lauffähige Firmware aufzuspielen. Das einzigste Problem dabei ist, dass sich meine Tastatur jetzt wie eine QWERTY verhält (also das übliche. Z-Y vertauscht, kein ß, usw). Hat jemand eine Idee, wie man das Tastaturlayout wieder auf QWERTZ stellen kann? Habe schon alle möglichen Menüs durchforstet, aber noch keine entsprechende Einstellung gefunden.

    Danke schon mal für jeden Hinweis!
    Gruß
    Jo
     
  2. jojoxx, 08.07.2011 #2
    jojoxx

    jojoxx Threadstarter Neuer Benutzer

    Beiträge:
    2
    Erhaltene Danke:
    0
    Registriert seit:
    08.07.2011
    Habs gerade selbst rausgefunden. Falls nochmal jemand das Problem hat:

    Mit *#272*IMEI# den Sales Code auf DBT stellen.
     
  3. melchers64, 15.08.2011 #3
    melchers64

    melchers64 Neuer Benutzer

    Beiträge:
    6
    Erhaltene Danke:
    1
    Registriert seit:
    26.07.2011
    Phone:
    Samsung Galaxy 551
    und statt den Buchstaben IMEI die IMEI Nummer eingeben oder wie?
    Und wieso einen "sales Code" eingeben, ist das Handy dann etwa gebranded?:confused:

    ok, habs probiert. Also statt IMEI 15stellige imei angeben und es startet ein
    Auswahlmenü für die Vorkonfiguration "preconfig" oder "sales code".
    In der PDA i5510xwkd4 Version von
    samfirmware ist MOT (slovenisch) vorgewaehlt, man kann aber auf ATO stellen
    (Österreich) und z und y sind wieder an altgewohnter Stelle.
     
    Zuletzt bearbeitet: 15.08.2011
    game_freak bedankt sich.
  4. Cracksoldier, 29.08.2011 #4
    Cracksoldier

    Cracksoldier Neuer Benutzer

    Beiträge:
    22
    Erhaltene Danke:
    0
    Registriert seit:
    23.04.2011
    Hi, Ich habe vor kurzem mein Galaxy 551 auf XWKD4
    geupdated und danach per "Super One Click" gerooted.
    Es funzt auch alles soweit nur das auf der herrausschiebaren
    Tastatur einige Tasten vertauschten sind. Es handelt sich
    hierbei um das "a", das "q", "das "y", das "z", das "m" und
    das "p". Ich habe die Locale auf de_AT geändert jedoch
    ändert sich nichts.

    MFG Cracksoldier
     
  5. mute, 04.10.2011 #5
    mute

    mute Android-Hilfe.de Mitglied

    Beiträge:
    66
    Erhaltene Danke:
    11
    Registriert seit:
    26.01.2011
    Hallo,
    da auf meinem Galaxy 551 das "offizielle" 2.3.4 Probleme machte, musste ich zurück flashen auf 2.2.
    Leider hatte ich bei keinem ROM von News - www.SamFirmware.com ein Quertz-Layout.
    Das scheint daran zu liegen, dass die CSC geflasht wird, welche eine Art Region-Code enthält.
    Um den Region-Code auf ein Land mit Qwertz zu ändern müsst ihr dann wie folgt vorgehen:



    1. "ruft" *#06# an und schreibt euch eure IMEI auf

    2. das gleiche nochmal mit *#272*<eure IMEI>#
    Nun seht ihr welcher Code bei euch eingestellt ist und welche verfügbar sind. Diese sind 3-stellig und können mit dieser Liste verglichen werden.

    3. Sucht einen deutschen Code und installiert dieses Paket


    Im Falle der neusten 2.2 Firmware (I5510XWKD4 ## CSC - I5510OXXKD3) steht der Code auf "MOT" für Slovenien. Ein deutscher Code ist nicht verfügbar, jedoch "AUT". Und glücklicherweise haben diese den gleichen Tastaturstandard.
    Installiert also "AUT", das Galaxy bootet neu und fertig.


    PS: für Qwertz bei 2.3.4 benutzt bitte das Tutorial von schwix
     
    Zuletzt bearbeitet: 04.10.2011
  6. tomtommarojak, 05.10.2011 #6
    tomtommarojak

    tomtommarojak Neuer Benutzer

    Beiträge:
    8
    Erhaltene Danke:
    0
    Registriert seit:
    05.10.2011
    Ich habe mein Handy auf 2.3.4 gemacht. Dann hab ich es gerootet und wie in der Anleitung die Tastenlayouts ausgetauscht. Nur statt dass ß oder ? zurückzubekommen hab ich jetzt auch keine Löschtaste mehr.
     
  7. markus.hauer, 06.10.2011 #7
    markus.hauer

    markus.hauer Neuer Benutzer

    Beiträge:
    1
    Erhaltene Danke:
    0
    Registriert seit:
    26.07.2011
    Moin zusammen,

    ich schliesse mich an, bei mir ist der Fehler mit der Tastatur auch !

    Der Rest ging nach der oben gepinnten Anleitung super, wie gesagt bis hinterher auf der Hardwaretastatur einige Tasten total durcheinander sind.

    Hat jemand einen Tipp wie ich das Layout wieder richtig hin bekomme ?
     
  8. schwix, 08.10.2011 #8
    schwix

    schwix Fortgeschrittenes Mitglied

    Beiträge:
    363
    Erhaltene Danke:
    62
    Registriert seit:
    17.01.2011
    Phone:
    Samsung Galaxy 551
    Für beide gilt:

    1. Welches Tastaturlayout habt ihr benutzt? Im thread auf den ich im Tutorial verlinke gibt es 2 Beiträge, der erste Beitrag ist der richtige.

    2. Sicherstellen das BEIDE alten tastaturlayoutfiles überschrieben wurden. Wenn ihr die Dateien in Ordner geschoben habt wo vorher nicht die selbe datei schon drin war, habt ihr was verkehrt gemacht.

    Also für beide:

    Bitte Schritt für Schritt erklären was ihr gemacht habt.
     
  9. tomtommarojak, 10.10.2011 #9
    tomtommarojak

    tomtommarojak Neuer Benutzer

    Beiträge:
    8
    Erhaltene Danke:
    0
    Registriert seit:
    05.10.2011
    Habe datei vom ersten beitrag gedownloadet. Mit winrar entpackt. Den ordner aufs handz verschoben und die dateien in den angegebenen ordner verschoben. Dann kam die Anfrage ob ich die Dateien ueberschreiben will. Ich habe dies bei beiden dateien bestätigt. Dann habe ich das Handz rebootet. Dannach waren die einstelllungen immer noch gleich und die tasten verdreht, vorallem die zweitbellegung ist stark verdrhet. Sonst hat alles aber super funktioniert.
     
  10. Hobbyfranke, 10.10.2011 #10
    Hobbyfranke

    Hobbyfranke Neuer Benutzer

    Beiträge:
    7
    Erhaltene Danke:
    0
    Registriert seit:
    10.10.2011
    Zuallererst möchte ich mich mal herzlich bei schwix fuer die hervorragende Anleitung bedanken - hat alles super geklappt und bin mit Gingerbread auch absolut zufrieden läuft alles einfach viel schneller und besser

    Allerdings habe ich wie tomtommarojak auch Probleme mit dem Hardware-Tastaturlayout - diverse Tasten sind falsch belegt - z und y sind aber korrekt belegt - ich werde nachher nochmal eine genauere Aufstellung der Falschbelegungen posten und mir die beiden Dateien im Editor anschauen

    Bin mir ebenfalls sicher die Dateien in die richtigen Ordner reingepackt zu haben

    Sorry dass ich hier ohne Punkt und Komma schreibe - die beiden habe ich noch nicht gefunden :-/
     
  11. Hobbyfranke, 10.10.2011 #11
    Hobbyfranke

    Hobbyfranke Neuer Benutzer

    Beiträge:
    7
    Erhaltene Danke:
    0
    Registriert seit:
    10.10.2011
    Hab's gelöst:

    Hatte übersehen, dass sich die sec_keypad.kcm.bin bei mir im Verzeichnis /system/usr/keylayout/ befindet.

    Die heruntergeladene Datei also nochmal dorthin kopiert (alte überschrieben) - Neustart - alles funktioniert - super Tastaturlayout.

    Jetzt nochmal ein rundum glückliches Danke an schwix !
     
  12. tomtommarojak, 11.10.2011 #12
    tomtommarojak

    tomtommarojak Neuer Benutzer

    Beiträge:
    8
    Erhaltene Danke:
    0
    Registriert seit:
    05.10.2011
    Hat bei mir nicht geholfen. Hab es noch mal neu gedownloadet und in den Ordner wie in der Anleitung kopiert. Nach dem Neustart hat es dann trotzdem noch nicht funktioniert.
    Könnte mir jemand die Dateien schicken, bei dem es funktioniert hat.
    Danke schonmal im Vorraus und auch danke an schwiz für das sonst super tuturial.
     
  13. schwix, 11.10.2011 #13
    schwix

    schwix Fortgeschrittenes Mitglied

    Beiträge:
    363
    Erhaltene Danke:
    62
    Registriert seit:
    17.01.2011
    Phone:
    Samsung Galaxy 551
    Freut mich das die Lösung gefunden wurde ;)
     
  14. Hobbyfranke, 11.10.2011 #14
    Hobbyfranke

    Hobbyfranke Neuer Benutzer

    Beiträge:
    7
    Erhaltene Danke:
    0
    Registriert seit:
    10.10.2011
    @tomtommarojak: hast Du mal in den beiden Ordnern nachgeschaut, welche Dateien dort drin sind - also auf Nummer sicher gehst Du, wenn Du BEIDE Dateien in BEIDE Ordner reinschmeisst und die vorhandenen jeweils überschreibst. Neustart und dann sollte es funktionieren.

    Ansonsten könntest Du ja mal posten, welche Dateien in den beiden Verzeichnissen sind.
     
  15. schwix, 11.10.2011 #15
    schwix

    schwix Fortgeschrittenes Mitglied

    Beiträge:
    363
    Erhaltene Danke:
    62
    Registriert seit:
    17.01.2011
    Phone:
    Samsung Galaxy 551
    Stell sicher, dass es diese 2 Ordner sind, du die Ordner nich vertauscht hast und nich beide Dateien in einem Ordner stecken:

    keychars

    und

    keylayouts

    im Ordner "keychars" befinden sich (zumindest bei mir) folgende Dateien:

    qwerty.kcm.bin
    qwerty2.kcm.bin
    sec_keypad.kcm.bin

    Im Ordner "keylayout" befinden sich folgende Dateien:

    AVRCP.kl
    qwerty.kl
    sec_jack.kl
    sec_keypad.kl

    Stell sicher, das die richtige Datei im richtigen ordner ist. Im zeweifelsfall , lösche die alten dateien und schieb die neuen in den ordner.
     
  16. tomtommarojak, 11.10.2011 #16
    tomtommarojak

    tomtommarojak Neuer Benutzer

    Beiträge:
    8
    Erhaltene Danke:
    0
    Registriert seit:
    05.10.2011
    hab ich probiert bringt leider nix

    schwiz könstest du mir kurz deien dateien schicken?
     
    Zuletzt bearbeitet: 11.10.2011
  17. schwix, 11.10.2011 #17
    schwix

    schwix Fortgeschrittenes Mitglied

    Beiträge:
    363
    Erhaltene Danke:
    62
    Registriert seit:
    17.01.2011
    Phone:
    Samsung Galaxy 551
  18. tomtommarojak, 11.10.2011 #18
    tomtommarojak

    tomtommarojak Neuer Benutzer

    Beiträge:
    8
    Erhaltene Danke:
    0
    Registriert seit:
    05.10.2011
    thx werde se gleich testen
     
  19. tomtommarojak, 11.10.2011 #19
    tomtommarojak

    tomtommarojak Neuer Benutzer

    Beiträge:
    8
    Erhaltene Danke:
    0
    Registriert seit:
    05.10.2011
    hab es jetzt probiert. Jezt funktionieren warum auch immer überhaupt keine tasten mehr. Auch die Menü taste und ausschalte taste nicht.
     
  20. schwix, 11.10.2011 #20
    schwix

    schwix Fortgeschrittenes Mitglied

    Beiträge:
    363
    Erhaltene Danke:
    62
    Registriert seit:
    17.01.2011
    Phone:
    Samsung Galaxy 551
    Flash mal neu und guck ob der fehler dann verschwindet.
     

Diese Seite empfehlen