1. Nimm jetzt an unserem Uhans - 3. ADVENT - Gewinnspiel teil - Alle Informationen findest Du hier!

Fehlermeldung im Recovery

Dieses Thema im Forum "Root / Hacking / Modding für Samsung Galaxy Note" wurde erstellt von Semenchkare, 19.06.2012.

  1. Semenchkare, 19.06.2012 #1
    Semenchkare

    Semenchkare Threadstarter Android-Lexikon

    Beiträge:
    932
    Erhaltene Danke:
    135
    Registriert seit:
    10.12.2010
    Phone:
    iPhone 6s plus
    Ich erhalte beim Flashen eines neuen Kernels oder ROMs im Recovery immer folgende Fehlermeldung:

    E: Can't open /cache/recovery/last_instal
    E: failed to open last_instal: Read-only file system.

    Was ist "E:" und was müsste ich tun, um diese Fehlermeldung nicht mehr zu erhalten?
     
  2. cheezusweezel, 19.06.2012 #2
    cheezusweezel

    cheezusweezel Android-Ikone

    Beiträge:
    4,252
    Erhaltene Danke:
    4,552
    Registriert seit:
    06.02.2009
    Da stimmt was mit den Partitionen nicht, d.h. entweder Kernel-bezogen oder durch den Wechsel von GB auf ICS oder CM9 und wieder zurück, auch mal zwischendrin über MobileOdin usw. ! Bei mir war das erst nach dem Weg zurück auf GB, Full-Wipe, neues ROM wieder behoben ...
     
    xvs1100 und Semenchkare haben sich bedankt.
  3. meier2009, 19.06.2012 #3
    meier2009

    meier2009 Android-Lexikon

    Beiträge:
    1,484
    Erhaltene Danke:
    515
    Registriert seit:
    13.12.2011
    E: = Error ;-)

    und der rest ist selbsterklärend, oder ?

    Das hat dann mit dem einbinden der Parts zu tun, wie weezel sachte.

    Hatte das auch immer wieder mal, nu hab ich einmal alle Part´s gemountet, dann formatiert und danach die REchte gefixed.
    Daraufhin RR6 blank druff.

    Seitdem (Bisher) keine Probs beim Kernelflashen oder CleanScripten oder sonstiges.
     
    Semenchkare bedankt sich.
  4. unhold 31, 19.06.2012 #4
    unhold 31

    unhold 31 Android-Experte

    Beiträge:
    639
    Erhaltene Danke:
    680
    Registriert seit:
    30.04.2012
    Wäre interessant festzustellen woher und warum. Aktuell scheinen doch einige von diesem Problem betroffen zu sein. Ich habe es ähnlich gelöst wie meier2009 und momentan ist alles ok.
     
  5. Semenchkare, 19.06.2012 #5
    Semenchkare

    Semenchkare Threadstarter Android-Lexikon

    Beiträge:
    932
    Erhaltene Danke:
    135
    Registriert seit:
    10.12.2010
    Phone:
    iPhone 6s plus
    Kannst du mal beschreiben, wie du das gemacht hast? Reicht das mounten alleine nicht aus? Scheint ja nur an irgendwelchen Zugriffsrechten zu liegen. Mit "E:" ist dann wohl eine Art "Laufwerk" gemeint. Fragt sich nur, wo man was ändern muss.
     
  6. meier2009, 19.06.2012 #6
    meier2009

    meier2009 Android-Lexikon

    Beiträge:
    1,484
    Erhaltene Danke:
    515
    Registriert seit:
    13.12.2011
    nein E = Error !

    hat nichts mit den typischen Windows Laufwerken zu tun

    in der Linuxwelt sind das immer mountpoints!

    ne Festplatte heißt z.B. hda1 oder hda2

    und im android sind das dann die /cache , /system, /emmc usw

    im cwr in Mounts/Storage
    alle Mounten wenn möglich
    dann formaten und danach im CWR unter Advanced FIX PERMISSIONS
    und danach dann die Zip installieren!

    darum auch mein Tip, NIMM DIE EX-SD raus (falls vorhanden) je nach kernel und cwr ist bei manchen intern und extern vertauscht, ruckzuck hast dann deine karte gelöscht auf der vorher deine sicherungen und ROM-zip´s untergebracht hast!

    denn wenn sd formatierst, gibt´s nix mehr zum flashen !!! :D

    also aufpassen, wer keine ex-sd hat, natürlich NICHT auch die interne Formatieren!!!!!

    UND, die ZIP Vorher auf die Speicher schreiben, wenn nämlich kein OS mehr drauf ist wirds auch wieder schwieriger!
     
    alpha, xvs1100, Semenchkare und eine weitere Person haben sich bedankt.
  7. Semenchkare, 20.06.2012 #7
    Semenchkare

    Semenchkare Threadstarter Android-Lexikon

    Beiträge:
    932
    Erhaltene Danke:
    135
    Registriert seit:
    10.12.2010
    Phone:
    iPhone 6s plus
    Reicht nicht ein Mounten mit Root Explorer ohne dass man gleich alles formatieren muss?
     
  8. trahzebuck, 20.06.2012 #8
    trahzebuck

    trahzebuck Android-Lexikon

    Beiträge:
    1,001
    Erhaltene Danke:
    1,570
    Registriert seit:
    30.01.2012
    Phone:
    Huawei GX8 RIO-L01
    Habe ich das überlesen oder auf welchem Kernel bist Du gerade?
    Pass ein wenig auf, bei den vielen Formatierungen...

    Also ich hatte die Meldung auch schon ein paar mal.
    Wipe cache, dalvik und erneutes Flashen des Kernel hat das immer gelöst.

    Falls das hartnäckig ist, solltest Du cheezusweezel's Rat befolgen und nochmal "ganz vorne" mit GB und Pit neu anfangen...
     
  9. Semenchkare, 20.06.2012 #9
    Semenchkare

    Semenchkare Threadstarter Android-Lexikon

    Beiträge:
    932
    Erhaltene Danke:
    135
    Registriert seit:
    10.12.2010
    Phone:
    iPhone 6s plus
    Welchen Kernel ich verwende, müsste links stehen. Eigentlich wollte ich ja gar nichts formatieren, sondern mittels Root-Explorer mounten. Fragt sich nur, was
     
  10. trahzebuck, 20.06.2012 #10
    trahzebuck

    trahzebuck Android-Lexikon

    Beiträge:
    1,001
    Erhaltene Danke:
    1,570
    Registriert seit:
    30.01.2012
    Phone:
    Huawei GX8 RIO-L01
    ich habe hier offenbar was nicht mitbekommen. Dachte es geht um eine Fehlermeldung im Recovery? Was soll da der Root-Explorer?

    Was war nochmal Deine Frage? Oder ist das Ding erledigt?
    Wenn ja, was haste gemacht?
     
  11. Semenchkare, 20.06.2012 #11
    Semenchkare

    Semenchkare Threadstarter Android-Lexikon

    Beiträge:
    932
    Erhaltene Danke:
    135
    Registriert seit:
    10.12.2010
    Phone:
    iPhone 6s plus
    Nach der Beschreibung von cheezusweezel soll ja was mit den Partitionen nicht stimmen. Die Fehlermeldung (siehe ersten Beitrag) deutet ja darauf hin, dass auf einem bestimmten Bereich nur lesender, aber kein schreibender Zugriff möglich ist. Daher meine Idee, mittels Root-Explorer eine Änderung der Zugriffsrechte vorzunehmen. Oder bin ich da total auf dem Holzweg?
     
  12. cheezusweezel, 20.06.2012 #12
    cheezusweezel

    cheezusweezel Android-Ikone

    Beiträge:
    4,252
    Erhaltene Danke:
    4,552
    Registriert seit:
    06.02.2009
    Eher mit dem Zugriff auf die Partitionen, aber das haben die anderen ja bereits besser erklärt ... ;)
     
  13. trahzebuck, 20.06.2012 #13
    trahzebuck

    trahzebuck Android-Lexikon

    Beiträge:
    1,001
    Erhaltene Danke:
    1,570
    Registriert seit:
    30.01.2012
    Phone:
    Huawei GX8 RIO-L01
    Da fürchte ich ist Holzweg angesagt. Ich wüsste nicht, wie Du mit dem Root Explorer was an den Partitionen ändern könntest.
    Also die bisherigen Tipps nix bringen, kann ich cheezusweezel und mich nur wiederholen. Flash GB mit PIT. Dann bist Du "sauber".
     
  14. humiboy, 20.06.2012 #14
    humiboy

    humiboy Android-Lexikon

    Beiträge:
    1,169
    Erhaltene Danke:
    105
    Registriert seit:
    13.04.2011
    Phone:
    Samsung Galaxy Note 4
    Diese Fehlermeldungen bzw ähnliche hab ich auch jetzt nicht im Kopf ob genau die selben denke aber schon seit dem ich auf Goku v1 bin. Andere Kernels keine Fehlermeldungen
     
  15. VtecMac, 21.06.2012 #15
    VtecMac

    VtecMac Gewerbliches Mitglied

    Beiträge:
    504
    Erhaltene Danke:
    424
    Registriert seit:
    26.10.2010
    Phone:
    LG G5
    Tablet:
    Samsung Galaxy Note 10.1 2014
    Moin,

    ich hatte das selbe Problem, bei mir hats folgendermaßen funktioniert den Fehler zu beseitigen:

    ins CWM - jBroid geflasht - Reboot Recovery - neuen Kernel Flashen

    tada, Fehler wech. :)

    Gruß,
    Mac
     
    Zuletzt bearbeitet: 21.06.2012
  16. primicx, 21.06.2012 #16
    primicx

    primicx Erfahrener Benutzer

    Beiträge:
    207
    Erhaltene Danke:
    23
    Registriert seit:
    15.12.2011
    Hatte ich auch,

    wipe cache partiton,
    thema beendet.
     
    bommel@slash bedankt sich.
  17. Semenchkare, 22.07.2012 #17
    Semenchkare

    Semenchkare Threadstarter Android-Lexikon

    Beiträge:
    932
    Erhaltene Danke:
    135
    Registriert seit:
    10.12.2010
    Phone:
    iPhone 6s plus
    Habe ich gemacht, hat aber leider nichts gebracht. Ich wechsel häufiger die Kernel und ROMs und habe jedesmal zuvor im Recovery jBroid geflasht. Die Fehlermeldung bleibt. Scheint zwar keine erkennbar negative Auswirkung zu haben, irritierend ist die Meldung (siehe erster Beitrag) aber schon.
     
  18. cheezusweezel, 22.07.2012 #18
    cheezusweezel

    cheezusweezel Android-Ikone

    Beiträge:
    4,252
    Erhaltene Danke:
    4,552
    Registriert seit:
    06.02.2009
    E = Error ! Anderer Kernel bzw. Recovery kann es beseitigen. Spätestens LC1+PIT natürlich sowieso.
    Gibt einige Varianten, SuFu bringt vielleicht (hoffentlich) weiter.
     
  19. xvs1100, 25.07.2012 #19
    xvs1100

    xvs1100 Erfahrener Benutzer

    Beiträge:
    167
    Erhaltene Danke:
    103
    Registriert seit:
    21.02.2012
    So, hatte gerade ein paar heisse Stunden mit meinem Note hinter mir. Plötzlich konnte ich den System-Ordner nicht mehr auf R/W setzen und im SuperSU schlug das verlangte Binary-Update dauernd fehl. Ich war ne geraume Zeit wirklich ratlos. Dann fand ich heraus, dass ich zwar noch root hatte, aber kein Nand unlock mehr.
    Na gut, ich entschied mich, nochmals von Null anzufangen, d.h. mehrteilige pre-rooted GB-ROM via PC-Odin flashen usw. So konnte ich das Problem beheben.
    Was schlussendlich den Fehler auslöste, kann ich nicht mehr nachvollziehen. Ich weiss nur, dass ich vermutlich in letzter Zeit etwas zu wild und unsauber herumgeflasht habe. Irgendwann kamen im CWM immer wieder gewisse Fehlermeldungen, wie schon ein paar Posts weiter oben erwähnt. Gewisse Flashvorgänge gingen zwar trotzdem, aber irgendwann (weiss leider auch nicht mehr genau wann) konnte ich die besagten R/W-Mounts nicht mehr ausführen.
    An dieser Stelle noch ein spezielles Danke an cheezusweezel und seine hilfreichen Posts und Links hier im Forum!
     
    cheezusweezel bedankt sich.
  20. craNk, 25.07.2012 #20
    craNk

    craNk Erfahrener Benutzer

    Beiträge:
    201
    Erhaltene Danke:
    36
    Registriert seit:
    31.08.2011
    Phone:
    Sony Xperia Z3+
    Wearable:
    Sony Smartwatch 3
    Den fehler hatte ich des öfteren. Ich denke der fehler taucht auf, wenn manden jBroid script ausführt. Den fehler habe ich aber mit der folgenden Methode gelöst:

    Boot ins Recovery
    Flashen des jBroid Script
    Neuen Kernel Flashen
    Dann unter Advanced->reboot recovery
    Dann beim reboot nochmal von neu jBroid Script
    Kernel Flashen

    Danach war bei mir diese meldung weg

    Gesendet von meinem GT-N7000 mit Tapatalk 2
     
    xvs1100 bedankt sich.

Diese Seite empfehlen