1. Nimm jetzt an unserem 2. ADVENT-Gewinnspiel teil - Alle Informationen findest Du hier!

Fehlermeldung TUN/TAP

Dieses Thema im Forum "LG Optimus Black (P970) Forum" wurde erstellt von lebkuchenmann, 12.10.2011.

  1. lebkuchenmann, 12.10.2011 #1
    lebkuchenmann

    lebkuchenmann Threadstarter Neuer Benutzer

    Beiträge:
    18
    Erhaltene Danke:
    2
    Registriert seit:
    12.10.2011
    Hallo zusammen,

    ich bin neu hier und ich bin nicht so begabt, was Foren angeht, aber ich habe folgendes Problem:

    Mein LG ist gerooted und ich habe superuser-Rechte. Das habe ich aus dem Grunde gemacht, weil ich sehr gerne CISCO any connect nutzen will, damit ich ins WLAN-Netz komme!

    Ist auch soweit kein Problem. Ich kann das Programm nutzen (welches es für Samsung auch so zu benutzen gibt und auch keine Probleme mit der Verbindung), aber wenn ich mich dann verbinden will mit dem Netzwerk, dann bekomme ich folgende Fehlermeldung:

    This device does not meet minimum requirements to run this software. A TUN/TAP driver could not be located. Please ensure a TUN/TAP module is compiled with your kernel or located in /data/local/kernel_modules/.

    Ich habe hier im Forum auch schon die ein oder andere Datei gefunden, nur wäre ich sehr froh darüber, wenn mir jemand verraten könnte, wie ich diese ins Handy einbinde!?

    Schönen Gruß und schonmal vielen Dank
    Lebkuchenmann
     
  2. KennySavage, 12.10.2011 #2
    KennySavage

    KennySavage Erfahrener Benutzer

    Beiträge:
    182
    Erhaltene Danke:
    36
    Registriert seit:
    03.06.2011
    Phone:
    UMI Super
    Tablet:
    Onda V975M
    am besten mit nem filemanager mit dem du auch auf die rootverzeichnisse kommst ;)
    und dann die datei aus dem forum in dem angegebenen verzeichnis ablegen

    grüße

    kenny
     
  3. lebkuchenmann, 12.10.2011 #3
    lebkuchenmann

    lebkuchenmann Threadstarter Neuer Benutzer

    Beiträge:
    18
    Erhaltene Danke:
    2
    Registriert seit:
    12.10.2011
    Das habe ich ja schon getan!
    Aber was mich gewundert hat ist, dass es diese Ordner vorher nicht gab!

    Die Fehlermeldung bleibt bestehen! :confused2:
     
  4. KennySavage, 12.10.2011 #4
    KennySavage

    KennySavage Erfahrener Benutzer

    Beiträge:
    182
    Erhaltene Danke:
    36
    Registriert seit:
    03.06.2011
    Phone:
    UMI Super
    Tablet:
    Onda V975M
    brauch die datei vllcht andere rechte ? bzw überhaupt erst mal rechte ? die musst du dann natürlich auch noch vergeben ^^ dafür am besten mal in deiner quelle nachlesen

    grüße

    Kenny
     
  5. lebkuchenmann, 12.10.2011 #5
    lebkuchenmann

    lebkuchenmann Threadstarter Neuer Benutzer

    Beiträge:
    18
    Erhaltene Danke:
    2
    Registriert seit:
    12.10.2011
    Also ich habe mich mal noch durch das Netz gesucht und bin dann auf andere Handytypen gestoßen, wie beschrieben wird, wie man diese Dateien compilieren kann.

    Aber ich finde leider nicht wirklich was für das LG P970! :sad:
     
  6. zibl, 17.10.2011 #6
    zibl

    zibl Neuer Benutzer

    Beiträge:
    12
    Erhaltene Danke:
    0
    Registriert seit:
    14.05.2011
    Hallo,
    ich habe auch das gleiche Problem mit dem TUN device. Ich habe zwar unterschiedliche tun.ko Dateien gefundgefunden und sie in das entsprechende Verzeichnis (was zuvor nicht vorhanden war) abgelegt, aber ich bekomme weiterhin die Fehlermeldung.

    Über verschiedene Rechte ist in den Foren nichts zu lesen, einige User nutzen user rwx. Das bringt bei mir allerdings auch nicht den gewünschten Erfolg.

    Hat jemand eine fehlerfreie tun.ko und/oder eine Installationsanleitung für das P970?

    So long, zibl
     
  7. androiddummy, 18.10.2011 #7
    androiddummy

    androiddummy Neuer Benutzer

    Beiträge:
    20
    Erhaltene Danke:
    2
    Registriert seit:
    15.05.2011
  8. lebkuchenmann, 18.10.2011 #8
    lebkuchenmann

    lebkuchenmann Threadstarter Neuer Benutzer

    Beiträge:
    18
    Erhaltene Danke:
    2
    Registriert seit:
    12.10.2011
    Es geht ja schon lange nicht mehr um die Datei, sondern eher darum, wie ich diese richtig einbinde!!! :sleep:

    Gruß
     
  9. androiddummy, 18.10.2011 #9
    androiddummy

    androiddummy Neuer Benutzer

    Beiträge:
    20
    Erhaltene Danke:
    2
    Registriert seit:
    15.05.2011
    Gibt es eine Fehlermeldung beim laden des Moduls in der adb shell oder im Terminal?
    insmod tun.ko
     
  10. lebkuchenmann, 18.10.2011 #10
    lebkuchenmann

    lebkuchenmann Threadstarter Neuer Benutzer

    Beiträge:
    18
    Erhaltene Danke:
    2
    Registriert seit:
    12.10.2011
    Hier mal ein Bild von der Fehlermeldung!
     

    Anhänge:

  11. androiddummy, 18.10.2011 #11
    androiddummy

    androiddummy Neuer Benutzer

    Beiträge:
    20
    Erhaltene Danke:
    2
    Registriert seit:
    15.05.2011
    Hallo. Danke für den Screenshot der Fehlermeldung :)
    Mehr würde mich allerdings das Ergebnis des insmod tun.ko Befehls interessieren. Könntest du das Ergebnis posten? Gerne auch noch das Ergebnis von lsmod.

    Viele Grüße
     
  12. lebkuchenmann, 18.10.2011 #12
    lebkuchenmann

    lebkuchenmann Threadstarter Neuer Benutzer

    Beiträge:
    18
    Erhaltene Danke:
    2
    Registriert seit:
    12.10.2011
    Wenn du mir erklären würdest, wie es genau funktioniert, dann kann ich das Ergebnis auch posten! g
     
  13. androiddummy, 18.10.2011 #13
    androiddummy

    androiddummy Neuer Benutzer

    Beiträge:
    20
    Erhaltene Danke:
    2
    Registriert seit:
    15.05.2011
    Glaub mit der ADB Shell würde es jetzt zu lange dauern und dafür gibt's auch schon ne menge howtos. Also dann machen wir es mit dem Android Terminal Emulator (gibts im Market).

    Android Terminal Emulator starten und folgende Befehle auf der Kommandozeile eingeben:

    Code:
    su
    cd /data/local/kernel_modules/
    insmod tun.ko
    
    Ausgabe dann hier posten.

    Dann noch lsmod im Terminal ausführen
    Code:
    lsmod
    
    Ausgabe dann hier posten.

    Kernel Version wäre auch noch interessant. Wobei dies wohl nur bei installierter busybox funktionieren wird:
    Code:
    uname -a
    
    Ausgabe dann hier posten.
     
    lebkuchenmann bedankt sich.
  14. lebkuchenmann, 18.10.2011 #14
    lebkuchenmann

    lebkuchenmann Threadstarter Neuer Benutzer

    Beiträge:
    18
    Erhaltene Danke:
    2
    Registriert seit:
    12.10.2011
    Werde es wohl erst heute Nacht prüfen, aber schonmal den Teil des Compilierens posten!
    Das Problem ist, dass unser wlan abgestürzt ist und ich das Endergebnis in den nächsten Tagen posten werde!

    schönen Gruß
     
  15. androiddummy, 18.10.2011 #15
    androiddummy

    androiddummy Neuer Benutzer

    Beiträge:
    20
    Erhaltene Danke:
    2
    Registriert seit:
    15.05.2011
    Hast du das tun.ko Modul selbst kompiliert?
     
  16. lebkuchenmann, 18.10.2011 #16
    lebkuchenmann

    lebkuchenmann Threadstarter Neuer Benutzer

    Beiträge:
    18
    Erhaltene Danke:
    2
    Registriert seit:
    12.10.2011
    Da der Ordner nicht besteht, muss ich den Ordner erstellen und die Datei tun.ko dareinstellen, damit es funktioniert???
     
  17. zibl, 18.10.2011 #17
    zibl

    zibl Neuer Benutzer

    Beiträge:
    12
    Erhaltene Danke:
    0
    Registriert seit:
    14.05.2011
    Ich bekomme folgendes geschrieben :

     
  18. lebkuchenmann, 18.10.2011 #18
    lebkuchenmann

    lebkuchenmann Threadstarter Neuer Benutzer

    Beiträge:
    18
    Erhaltene Danke:
    2
    Registriert seit:
    12.10.2011
    Die Zeilen kann ich soweit bestätigen!!
     
  19. androiddummy, 18.10.2011 #19
    androiddummy

    androiddummy Neuer Benutzer

    Beiträge:
    20
    Erhaltene Danke:
    2
    Registriert seit:
    15.05.2011
    @lebkuchenmann: Laut deiner geposteten Fehlermeldung sucht die Cisco any connect Anwendung in dem Verzeichnis nach der tun.ko - Daher würde ich den Ordner erstellen und die tun.ko dort reinkopieren.

    @zibl: Dein tun.ko Modul kann nicht geladen werden. Ich habe das Modul schonmal für das Stockrom kompiliert und es kann auch noch unter V10E geladen werden. Benutzt du auch das Stockrom? Falls ja, hast du das tun.ko Modul aus diesem Thread verwendet? http://www.android-hilfe.de/root-ha...t-wo-befinden-sich-die-vpn-einstellungen.html
     
    lebkuchenmann bedankt sich.
  20. androiddummy, 18.10.2011 #20
    androiddummy

    androiddummy Neuer Benutzer

    Beiträge:
    20
    Erhaltene Danke:
    2
    Registriert seit:
    15.05.2011

Diese Seite empfehlen