1. Nimm jetzt an unserem 2. ADVENT-Gewinnspiel teil - Alle Informationen findest Du hier!

[Fix] 3G/UMTS Verbindungsunterbrechungen mit Donut und JC6 AMSS

Dieses Thema im Forum "Root / Hacking / Modding für Samsung Galaxy" wurde erstellt von Obihörnchen, 19.08.2010.

  1. Obihörnchen, 19.08.2010 #1
    Obihörnchen

    Obihörnchen Threadstarter Android-Lexikon

    Beiträge:
    1,225
    Erhaltene Danke:
    755
    Registriert seit:
    27.02.2010
    Phone:
    Nexus 4
    Tablet:
    Nexus 7 (2013)
    Der gute jakax (Macher von JIT-Hack, Sleepbugfix, optimierter dalvikvm von 1.6.4.4) hat mal wieder einen Fix veröffentlicht, dieser soll die Verbindungsabbrüche vom 3G/UMTS Netzwerk unter Donut und JC6 Baseband beheben.

    Link: Fix 3G/UMTS network interruptions with donut and JC6 AMSS - Android Forums


    Das ganze auf deutsch:


    Dieses Paket ersetzt Standard ril Komponenten.

    Download ril-no-dormant.zip from Sendspace.com - send big files the easy way
    Mirror: http://box23.org/pub/7500/misc/patches/jakax-ril-no-dormant.zip (thx @ inFECT)

    Man muss Root haben um es anzuwenden (hat ja eh jeder Galaxo/Gaosp Nutzer ;))

    Entpacken, Originaldateien sichern und dann:
    Code:
    adb remount
    adb push lib/libril.so /system/lib/
    adb push bin/rild /system/bin/
    adb push bin/radiooptions /system/bin/
     
    adb shell chmod 777 /system/bin/rild
    adb shell chmod 777 /system/bin/radiooptions
     
    ... Alles weitere ist nur technische Erläuterung.
     
    Zuletzt bearbeitet: 19.08.2010
    Marjun bedankt sich.
  2. inFECT, 19.08.2010 #2
    inFECT

    inFECT Android-Experte

    Beiträge:
    594
    Erhaltene Danke:
    239
    Registriert seit:
    28.01.2010
  3. gluf, 19.08.2010 #3
    gluf

    gluf Fortgeschrittenes Mitglied

    Beiträge:
    332
    Erhaltene Danke:
    26
    Registriert seit:
    31.03.2010
    Habe diese verbindungsabbrueche garnie festgestellt.
    Sind die euch bekannt?
     
  4. Buffy, 19.08.2010 #4
    Buffy

    Buffy Neuer Benutzer

    Beiträge:
    14
    Erhaltene Danke:
    0
    Registriert seit:
    05.07.2010
    habe ich quasi ständig. ich bin gute 50% der zeit nicht erreichbar, weil mein handy keinen empfang hat.
     
  5. KiLLiNGFREZZi, 19.08.2010 #5
    KiLLiNGFREZZi

    KiLLiNGFREZZi Android-Hilfe.de Mitglied

    Beiträge:
    122
    Erhaltene Danke:
    11
    Registriert seit:
    12.07.2010
    Jop ist bei mir gestern auch aufgetreten, Dachte schon mein Vertrag sei gespeert xD
     
  6. Dixiklo990, 19.08.2010 #6
    Dixiklo990

    Dixiklo990 Gast

    ja ist ja alles sehr schön....

    was noch besser wäre für die User die sich nicht ganz so gut auskennen wie genau die diesen Patch installieren....

    also eine kleine Anleitung step by step was zu machen ist.

    ich kann zwar die Software updaten und installieren und so einrichten wie ich es brauche, aber mit Terminal arbeiten und im System herumwerken das trau ich mir nicht zu ohne Anleitung.

    Wäre nett wenn jemand kurz schreiben kann was man genau machen muss.

    Wo müssen die Dateien hinkopiert werden.
    Wo muss ich was genau eingeben.

    Muss ich das ganze im Handy direkt machen, oder logge ich mich über den Computer ins Handy ein über ssh oder oder oder.......
     
  7. inFECT, 19.08.2010 #7
    inFECT

    inFECT Android-Experte

    Beiträge:
    594
    Erhaltene Danke:
    239
    Registriert seit:
    28.01.2010
    Eh? Anleitung ist doch im ersten Post detaliert vorhanden.
     
  8. Obihörnchen, 19.08.2010 #8
    Obihörnchen

    Obihörnchen Threadstarter Android-Lexikon

    Beiträge:
    1,225
    Erhaltene Danke:
    755
    Registriert seit:
    27.02.2010
    Phone:
    Nexus 4
    Tablet:
    Nexus 7 (2013)
    Erst Android SDK installieren und den USB Treiber für dein Galaxy.
    Dann per Kommandozeile (Start>Ausführen>CMD) in den ...android-sdk/tools Ordner wechseln. Die Dateien aus dem runtergeladenen zip-File dort reinkopieren und dann die Befehle eingeben.
    Fertig.
     
  9. Smeagle, 19.08.2010 #9
    Smeagle

    Smeagle Fortgeschrittenes Mitglied

    Beiträge:
    444
    Erhaltene Danke:
    30
    Registriert seit:
    16.07.2010
    Phone:
    Samsung Galaxy S5 (G900)
    Ganz so einfach ist es nicht:

    C:\android-sdk-windows\tools>adb push libril.so /system/lib/
    failed to copy 'libril.so' to '/system/lib/libril.so': Read-only file system

    - Oliver
     
  10. inFECT, 19.08.2010 #10
    inFECT

    inFECT Android-Experte

    Beiträge:
    594
    Erhaltene Danke:
    239
    Registriert seit:
    28.01.2010
    adb remount
     
    Smeagle bedankt sich.
  11. Smeagle, 19.08.2010 #11
    Smeagle

    Smeagle Fortgeschrittenes Mitglied

    Beiträge:
    444
    Erhaltene Danke:
    30
    Registriert seit:
    16.07.2010
    Phone:
    Samsung Galaxy S5 (G900)
    Danke, hat geklappt ;)

    Jetzt weiß ich nur nicht, wie ich teste ob es funktioniert ;)

    Aber ich hatte schon oft gemerkt, das E-PLUS auf UMTS oft nicht ging aber GPRS schon... Vielleicht lag es daran. Spannend ;)

    - Oliver
     
  12. Marjun, 19.08.2010 #12
    Marjun

    Marjun Android-Lexikon

    Beiträge:
    1,696
    Erhaltene Danke:
    158
    Registriert seit:
    27.04.2010
    Phone:
    Huawei Ascend P7
    Funz das nur bei der JC6 Firmware ? Wenn man eine ander e drauf hat braucht man das garnicht installen, hatte nämlich auch bei der II5 Abrrüche, könnte aber auch an eplus gelegen haben, teste gerade mal die I7500TGYIL3 und gerade frisch Galaxo 1.6.4 drauf
     
  13. Smeagle, 19.08.2010 #13
    Smeagle

    Smeagle Fortgeschrittenes Mitglied

    Beiträge:
    444
    Erhaltene Danke:
    30
    Registriert seit:
    16.07.2010
    Phone:
    Samsung Galaxy S5 (G900)
    So wie ich den fix verstehe, sollte es zumindest nicht schaden. Und wo es wirklich was bringt schwer zu sagen ;)
    Ich persönlich habe einfach das beste Gefühl mit der "neuesten, offiziellen" Version. Würde keine aus anderen Ländern und Netzen nehmen wollen. Aber die Bedenken sind vielleicht unbegründet, schwer zu sagen, da mir das nötige Know How dazu fehlt.

    - Oliver
     
  14. Obihörnchen, 19.08.2010 #14
    Obihörnchen

    Obihörnchen Threadstarter Android-Lexikon

    Beiträge:
    1,225
    Erhaltene Danke:
    755
    Registriert seit:
    27.02.2010
    Phone:
    Nexus 4
    Tablet:
    Nexus 7 (2013)
    Genau das hast du aber gemacht xD
    JC6 ist aus Russland und ich glaube nicht das du aus Russland kommst ;)

    Ob es auch bei anderen Basebands funktioniert... keine Ahnung. Laut jakax ist es speziell (und nur?) für JC6.
     
  15. Smeagle, 19.08.2010 #15
    Smeagle

    Smeagle Fortgeschrittenes Mitglied

    Beiträge:
    444
    Erhaltene Danke:
    30
    Registriert seit:
    16.07.2010
    Phone:
    Samsung Galaxy S5 (G900)
    Oh,

    Danke für den Hinweis. Als ich die drauf getan hatte, hatte ich die Buchstabencodes noch nicht gekannt und mich nur danach gerichtet, dass das die neuste war! Ganz blöde Idee, dann gehe ich mal gleich auf die letze von E-Plus zurück, da ich auch im E-Plus Netz bin, dürfte das die sicherste für mich sein.

    Gruß,
    - Oliver
     
  16. Obihörnchen, 20.08.2010 #16
    Obihörnchen

    Obihörnchen Threadstarter Android-Lexikon

    Beiträge:
    1,225
    Erhaltene Danke:
    755
    Registriert seit:
    27.02.2010
    Phone:
    Nexus 4
    Tablet:
    Nexus 7 (2013)
    Hab das ganze jetzt mal selber getestet. Schön in der Nacht, damit die Störfaktoren fast 0 sind.
    Hab das Handy die ganze Zeit an genau der gleichen Stelle liegen und den Speed per Speedtest.net (app) gemessen. Server war nur 20 Meilen entfernt :) Jeweils 3 Test hintereinander.

    Ohne Fix schwankte der Speed manchmal sehr stark. Sah fast so aus als ob die Verbindung sporadisch abbricht.

    Mit Fix lief das ganze flüssiger und ich hab ca. 500kb/s mehr Speed. Kann auch nur Zufall sein aber wie gesagt hab ich davor und dannach immer 3 Messungen durchgeführt und bei allen kam so +-100 das gleiche raus.
     
  17. Marjun, 20.08.2010 #17
    Marjun

    Marjun Android-Lexikon

    Beiträge:
    1,696
    Erhaltene Danke:
    158
    Registriert seit:
    27.04.2010
    Phone:
    Huawei Ascend P7
    War ja klar bei mir gehts wieder nicht

    Code:
    c:\android-sdk-windows\tools>adb remount
    remount succeeded
    
    c:\android-sdk-windows\tools>adb push lib/libril.so /system
    cannot stat 'lib/libril.so': No such file or directory
    
    c:\android-sdk-windows\tools>adb push bin/rild /system/bin/
    cannot stat 'bin/rild': No such file or directory
    
    c:\android-sdk-windows\tools>adb push bin/radiooptions /sys
    cannot stat 'bin/radiooptions': No such file or directory
     
  18. HenkerLenker, 20.08.2010 #18
    HenkerLenker

    HenkerLenker Android-Lexikon

    Beiträge:
    1,162
    Erhaltene Danke:
    113
    Registriert seit:
    10.03.2010
    Phone:
    Sony Xperia Z2
    Also ich hab den Fix heute mal installiert..., da ich heute beim Spenden schon wiedermal kein I-Net hatte und das so das einzige ist womit ich die Zeit rum bekomme hab ich mich endlich auch mal an den Fix ran gewagt.

    Mein erster eindruck ist recht positiv, ich hab das gefühl das die Seiten sich schneller aufbauen als zuvor obwohl ich nur auf EDGE zurück greifen kann und bis jetzt hab ich auch noch kein Problem gehabt die I-Net verbindung überhaupt aufzubauen sei es jetzt über Browser(Opera Mini) noch Messenger Programme(ICQ, MSN, VZ)..., alles scheint so zu funktionieren wie es sollte und das zum ersten mal;)
     
  19. Obihörnchen, 20.08.2010 #19
    Obihörnchen

    Obihörnchen Threadstarter Android-Lexikon

    Beiträge:
    1,225
    Erhaltene Danke:
    755
    Registriert seit:
    27.02.2010
    Phone:
    Nexus 4
    Tablet:
    Nexus 7 (2013)
    Wenn man es nicht wie beschrieben macht kann es auch nicht klappen -.-

    Code:
    cannot stat 'lib/libril.so': No such file or directory
    Die Fehlermeldung sagt dir doch schon alles. du hast deine Dateien an die falsche Stelle entpackt. Den angegebenen Ordner oder Datei (..\lib\libril.so) gibt es bei dir nicht unter diesem Pfad.

    radiooptions muss bei dir unter:
    Code:
    c:\android-sdk-windows\tools\bin\radiooptions
    liegen.
    rild bei:
    Code:
    c:\android-sdk-windows\tools\bin\rild
    libril.so muss dort liegen:
    Code:
    c:\android-sdk-windows\tools\lib\libril.so
     
    Zuletzt bearbeitet: 20.08.2010
    Marjun bedankt sich.
  20. Smeagle, 20.08.2010 #20
    Smeagle

    Smeagle Fortgeschrittenes Mitglied

    Beiträge:
    444
    Erhaltene Danke:
    30
    Registriert seit:
    16.07.2010
    Phone:
    Samsung Galaxy S5 (G900)
    Der zielpfad braucht auch noch einen / am anfang.

    - Oliver
     

Diese Seite empfehlen