1. Nimm jetzt an unserem Uhans - 3. ADVENT - Gewinnspiel teil - Alle Informationen findest Du hier!

Flashplayer downgrade setzt sich nach Neustart zurück

Dieses Thema im Forum "Root / Hacking / Modding für Samsung Galaxy Tab" wurde erstellt von digi1, 24.04.2011.

  1. digi1, 24.04.2011 #1
    digi1

    digi1 Threadstarter Fortgeschrittenes Mitglied

    Beiträge:
    351
    Erhaltene Danke:
    62
    Registriert seit:
    25.03.2011
    Hallo,
    ich habe ein Problem. Da nach dem Update auf JMG einige Streams nicht mehr liefen, habe ich diverse Flashplayer-Versionen ausprobiert. Eine relativ alte Version brachte den gewünschten Erfolg. Die lies sich auch ohne Probleme installieren , nach der üblichen Rückfrage, das der Flashplayer eine System-App sei und ob man trotzdem installieren will.
    Alles läuft nach der Installation so wie es sein soll, nur wenn ich das Tab komplett ausschalte und neu boote, ist der installierte Downgrade verschwunden und der alte Zustand wieder da. Update ich aber auf die neueste 10.2 des Flashplayers im Market, dann bleibt dieser Zustand nach einem Reboot erhalten. Das nützt mir natürlich nichts, da auch mit dem 10.2 die Streams nicht laufen. Wo kommen die alten Dateien wieder her nach dem Neustart?
    OK, man kann damit leben bis eventuell Firmware 2.3 kommt, nach jedem der seltenen Restarts den Flashplayer neu zu installieren, aber mich interessieen doch die Zusammenhänge.
    Gruß digi1
     
  2. rolituba, 24.04.2011 #2
    rolituba

    rolituba Ehrenmitglied

    Beiträge:
    9,853
    Erhaltene Danke:
    5,215
    Registriert seit:
    30.12.2010
    Ich würde den player mit titanium backup löschen ... dann den alten player nochmals installieren! (das autoupdate im market deaktivieren)
     
  3. digi1, 24.04.2011 #3
    digi1

    digi1 Threadstarter Fortgeschrittenes Mitglied

    Beiträge:
    351
    Erhaltene Danke:
    62
    Registriert seit:
    25.03.2011
    Ja, das habe ich auch schon ins Auge gefasst, nur löscht Titanum Backup nur die beiden *.so-Dateien aus app/app/Flashplayer/lib, wie er sie auch bei "Durchsuchen" erkennt.
    Diese beiden Dateien (libflashplayer.so und libysshared.so) scheinen die einzigen für Flashplayer verantwortlichen Dateien zu sein.
    Diese beiden Dateien werden bei der Installation des alten Flasplayers auch ausgetauscht (hab ich kontrolliert) und sind nach einem Restart wieder zurückgesetzt.
    Einfach auf Löschen will ich nicht gehen, denn ich hasse Automatismen, die ich nicht selbst kontrollieren kann. Auf alle Fälle erscheint auch nach manuellem Löschen dieser Dateien der im System integrierte Flashplayer wieder. Mir scheint, als ob der bei jedem Booten neu geschrieben wird, allerdings nur, wenn die Version niedriger/älter ist als der integrierte.
    Da ich nach dem letzten Firmwareupdate über Kies die signierten Bootlader draufhabe und bei mir der Patch zum designieren nicht greift, will ich nicht unbedingt mehr als nötig "rumpfuschen", zumal ja in nächster Zeit das Problem durch 2.3 gelöst wird.
     
  4. rolituba, 24.04.2011 #4
    rolituba

    rolituba Ehrenmitglied

    Beiträge:
    9,853
    Erhaltene Danke:
    5,215
    Registriert seit:
    30.12.2010
    @bootloader patch: kann sein, dass du den mehrmals ausführen musst ... hat bei einem anderen user mit jmg funktioniert!
    Was du noch machen kannst ist, die "alte" playerinstallation mit tb sichern, dann kannst es nach jedem neustart mit einem klick wiederherstellen und musst nicht immer deinstallieren, installieren usw.
     
  5. digi1, 24.04.2011 #5
    digi1

    digi1 Threadstarter Fortgeschrittenes Mitglied

    Beiträge:
    351
    Erhaltene Danke:
    62
    Registriert seit:
    25.03.2011
    Ist schon klar, deinstallieren muss ich ja nicht, dass passiert doch automatisch. Wie ich schon sagte, kann ich damit leben, falls doch mal neu gebootet werden muss, den Flashplayer neu zu installieren, das geht auch ruck zuck. Hätte mich nur mal interessiert, wie der Automatismus so abläuft. Irgendwo muss ja auch die Version abgelegt sein, vielleicht kann ich die faken. Ich vermute, beim Starten wird geprüft, ob die installierte Version älter als die integrierte (wo auch immer) Version ist und im Falle einer älteren Version ersetzt. Könnte ich eine neuere Version vorgaugeln, könnte es sein, dass es dann funktioniert.
    Ich bin schon froh, dass es endlich wieder die Streams wiedergibt, dass ich wieder Zattoo schauen kann.
    Gruß digi1
     
  6. rolituba, 24.04.2011 #6
    rolituba

    rolituba Ehrenmitglied

    Beiträge:
    9,853
    Erhaltene Danke:
    5,215
    Registriert seit:
    30.12.2010
    ... hab jetzt mal mit ghost commander in den roots gestöbert, da gibts im ordner system/app die datei install_flash_player.apk ... die könnte der übeltäter sein?
     
    Zuletzt bearbeitet: 24.04.2011
    digi1 bedankt sich.
  7. digi1, 24.04.2011 #7
    digi1

    digi1 Threadstarter Fortgeschrittenes Mitglied

    Beiträge:
    351
    Erhaltene Danke:
    62
    Registriert seit:
    25.03.2011
    Das könnte es sein, ich werde der Sache mal nachgehen. Ich werde mir diese *.apk mal entpacken und schauen, ob es sich um eine reine Flashplayer installation handelt. Da könnte man das Teil einfach austauschen.

    Danke

    Gruß digi1

    Hurraaa, der Spuk ist vorbei... Ich habe die alte, funktionierende Flashplayer.apk (Flashplayer 10.1.92.8) einfach in "install_flash_player.apk" umbenannt und in den system/app-Ordner kopiert (die alte Datei vorher gesichert und gelöscht). Im sicher zu gehen, hatte ich vorher beide *.apk entpackt und verglichen, ob nicht andere Strukturen verwendet werden.
    Die Vermutung hat sich bestätigt, dass beim Booten geprüft wird, ob der aktuell installierte Flashplayer älter ist als der in der "install_flash_player.apk" vorhandene. Sowohl der Player 10.1.105 als auch der 10.2 bleiben nach einem Neustart erhalten, falls man upgedadet hat. Löscht man den nachinstallierten Flashplayer bzw. das Update, wird automatisch der aus der "install_flash_player.apk " installiert (beim nächsten booten).
    Somit wäre die Sache gelöst und man kann sich ohne großen Flashvorgänge den Fehler bei der Streamwiedergabe fixen.
    Vielen Dank an rolituba für den Hinweis mit der "install_flash_player.apk ", der letztendlich die Lösung brachte.
     
    Zuletzt bearbeitet: 24.04.2011
  8. john.katzenbach, 25.04.2011 #8
    john.katzenbach

    john.katzenbach Android-Experte

    Beiträge:
    619
    Erhaltene Danke:
    46
    Registriert seit:
    08.06.2010
    Genial das mit dem alten Flashplayer. Hat mich auch tierisch genervt, dass keine Streams über die bekannten ;-) Kino Seiten mehr gingen. Aber mit dem Tipp von dir, genial. Hab mir auch den alten Falshplayer besorgt und alles geht wieder. So macht das Tab gleich wieder mehr Spass. Ich muss jetzt nur noch in den entsprechenden Ordner das ganze kopieren, damit auch nach einem Neustart alles so bleibt. Echt Klasse!!!
     

Diese Seite empfehlen