1. Nimm jetzt an unserem Uhans - 3. ADVENT - Gewinnspiel teil - Alle Informationen findest Du hier!

G1 - Loop ins Recoverymenü

Dieses Thema im Forum "Root / Hacking / Modding für T-Mobile G1" wurde erstellt von _sunny, 09.11.2011.

  1. _sunny, 09.11.2011 #1
    _sunny

    _sunny Threadstarter Neuer Benutzer

    Beiträge:
    13
    Erhaltene Danke:
    0
    Registriert seit:
    09.02.2011
    Phone:
    T-Mobile G1
    Hallo zusammen,

    ich verzweife schon den zweiten Tag in sämtlichen Foren dieser Welt zum Thema Flash, Recovery, DangerSPL, etc...

    Vorgeschichte:
    Hatte mein G1 vor einiger Zeit mal per OneKlickRoot gerootet und mit ClockworkMod das Recovery installiert und dann anhand Winnes FAQ mir das Super E ROM aufgespielt (ich glaube ich musste dazu damals die DangerSPL flashen).

    Da die Kiste mit der Zeit wirklich träge wurde, wollte ich es 'neu aufsetzen' und in dem Zuge gleich mal die ein oder andere ROM austesten, um eine performante dauerhaft zu flashen.

    ...

    Ist bestimmt schon 1 Jahr her das ganze..Vom Wissen ist auch nicht mehr viel übrig geblieben, nur, dass ich die SDCard mit Clockwork partitioniert hab und von dort aus automatisch nach dem Boot im Recovery gelandet bin, von wo aus ich damals die DangerSPL und das ROM geflasht hab.

    Also war ich so blauäugig und hab mir das CyanogenMod 6.1-ROM über ClockworkMod geladen und installieren lassen (mit Backup etc.).
    Nach der Installation hing das Gerät immer imm Bootscreen fest.:

    [​IMG]

    Also hab ich am nächsten Tag, weils schon spät war erst mal gestöbert und gestöbert..dabei bin ich fast durchgedreht, weil ich bei diesen ganzen Sammelthreads 'für Noobs' auf keinen grünen Zweig gekommen bin.

    Andauernd war die Rede von Fastboot, etc. Bis ich gerafft hab, dass es einen Fastboot-Mode im Handy gibt (also Cam + Auflegen) und ein Dektop Programm, welches auch Fastboot heißt..schonmal total verwirrt, weil ich ja am Handy keine ihrer Befehle eintippen konnte.

    Dann wollte ich mein altes Super E wiederherstellen..hab ja ein Backup erstellen lassen..der Restore ist, achtung es folgt eine unerwartete Wende in meiner Glückssträhne, Abgebrochen -.-...Phantastisch.

    Ok also weiterschauen. Nach ner Weile Informationen aufsaugen und darüber schlafen, wollte ich nun die HaykuroSPL aufspielen, da diese ja universell für alle ROMs ist. Für die neueren Android-Versionen brauchte ich aber auch eine neue Radio Version.

    Ok, alles besorgt. Und dann in der Reihenfolge geflasht:
    • 1. Radio
    • 2. SPL
    • 3. ROM

    Kein Erfolg. Egal welche Rom. Hängt immer im Bootfenster von oben.
    Ich hab in der Zwischenzeit so viel Stuff geflasht, dass mir die Finger bluten.
    Aber immer in den jeweiligen Radio-SPL Kombinationen wie sie im Tut zu finden waren.

    Mir ist dann aufgefallen, dass er im Fastboot-Mode immer ganz kurz eine Liste abgearbeitet hat und immer ein 'NOT FOUND' zurückgegeben hat. Hab das mal mit der Cam eingefangen:

    [​IMG]

    Ich weiß jetzt leider wirklich nicht mehr welches Forum/Seite das war auf der ich dann eine Image mit dem Namen 'DREAIMG.nbh' gefunden hab. Auf der gab es dann auch ein update.zip.
    Ich hab da dann mal einen Blick reingeworfen und gesehen, dass ein radio und recovery Image enthalten waren.

    Der Flash über Home + Auflegen und dann .zip from SDCard funktionierte einwandfrei (aber was weiß ich schon :huh:) hier die Bilder der Reihenfolge nach:

    1. [​IMG]
    2. [​IMG]
    3. [​IMG]
    4. [​IMG]
    5. [​IMG]
    6. [​IMG]

    Nach dem Reboot:
    7. [​IMG]

    Lande ich ständig in einem Recovery-Menü, das ich mit ALT+L aktivieren muss.
    8. [​IMG]

    Das Fastboot-Menü ist nicht wiederzuerkennen:
    9. [​IMG]

    Egal welche 'DREAIMG.NBH' ich nun auf die Karte lade und im Fastboot-Modus flashen will, ich erhalte immer die Meldung 'not allow' und einem Fehlercode oder ähnliches:
    [​IMG] :thumbdn:

    Es hat sich auch die Hboot Version verändert. Was soll das genau sein?
    • Radio = Sämtliche Wireless bzw. Funkt Treiber, etc.
    • SPL = Umverteilung von Systemressourcen!? Bzw. Umverlagerung der vorhandenen Ressourcen für optimale Performance.
    • HBOOT = ???

    Das System hängt aber nicht nach dem Booten sondern startet einfach immer bei Bild 8 und wartet auf Eingaben.

    Jetzt weiß ich nicht mehr so recht weiter, weil ich keine komplett gezippte update.zip finde, die mir sämtliche Images beinhaltet (also so wie die, mit der ich scheinbar das System ungewollt downgegradet habe).

    PS: Ja das Display-Glas ist leider geplatzt, nichtsdestotrotz liebe ich das Handy und wills auch wieder zum Leben erwecken, aber dafür brauch ich jetzt einfach eure Hilfe...

    Ich hab jetzt erstmal Sodbrennen von dem ganzen Theater und hau mich hin..Damn, um 0600 wieder raus..


    Viele Grüße
     
  2. Steppo, 09.11.2011 #2
    Steppo

    Steppo Android-Lexikon

    Beiträge:
    1,894
    Erhaltene Danke:
    247
    Registriert seit:
    19.02.2010
    Na dann, soll dir mal geholfen werden ;)

    Also zum Verständnis erstmal: Der Haykuro-SPL IST der DangerSPL, nur das er anders heißt. Zum Rest, was Radio und das ganze ist will ich jetzt nicht näher drauf eingehen (kostet mir dann doch zuviel Zeit), wo dus dann zwar wüsstest, aber dennoch nicht mehr brauchen würdest.

    Soo. Ins Recovery kommst du ja automatisch. Wenn du dann ALT-L drückst, kannst du ja die Funktionen einblenden (soweit ich mich erinnere...). Auf jeden Fall ist mit Root jetzt nichts mehr :p

    Das einzige was noch fehlt wäre das Rom, und da wird dann auch nurnoch das Stock-Rom funktionieren :)

    Die update.zip für das Stock-Rom lädst du jetzt erstmal HIER herunter und flashst das dann übers Recovery. Bin gespannt...
     
    _sunny bedankt sich.
  3. winne, 09.11.2011 #3
    winne

    winne Android-Guru

    Beiträge:
    3,788
    Erhaltene Danke:
    644
    Registriert seit:
    09.05.2009
    Phone:
    S60
    Wearable:
    Pebble schwarz
    Sollte die obige Datei nicht funktionieren (ist die modifizierte Version aus der Unroot-Anleitung) dann versuche die One-Klick-Version über das Fullupdate der Version 1.5. Findest du alles hier: 2.2 Root Methode (One Klick) .

    Edit:
    Zum Thema Downgrade: Zumindest das Radio entspricht der Version 1.5/1.6, was eine Statuszuordnung deines G1 im Moment etwas schwierig gestaltet.
     
    Zuletzt bearbeitet: 09.11.2011
    _sunny bedankt sich.
  4. _sunny, 09.11.2011 #4
    _sunny

    _sunny Threadstarter Neuer Benutzer

    Beiträge:
    13
    Erhaltene Danke:
    0
    Registriert seit:
    09.02.2011
    Phone:
    T-Mobile G1
    Ok, danke euch beiden erstmal und auch tonne für die PM.

    Ich bin gerade von der Arbeit gestiefelt gekommen und setzt mich gleich dran...das muss klappen Jungs! :D

    Aber ich bin guter Dinge.

    Bis später. Ich melde mich dann mit der Erfolgsmeldung oder evtl. Problemen wieder ;).

    ************
    EDIT********
    ************

    Ok hab jetzt beide Versionen getestet. Die von steppo liefert folgendes:

    [​IMG]

    Und die Version von Winne übersteht zwar die Prüfung, landet danach aber trotzdem immer wieder im Recovery. Egal wie lange ich auch warte es tut sich leider nichts.
     
    Zuletzt bearbeitet: 09.11.2011
  5. tonne99, 09.11.2011 #5
    tonne99

    tonne99 Android-Hilfe.de Mitglied

    Beiträge:
    73
    Erhaltene Danke:
    58
    Registriert seit:
    19.09.2010
    Tablet:
    Motorola Xoom
    Hi,
    wenn sich die DREAIMG.nbh RC7 nicht flashen lässt, könnte es an der SD-Karte liegen.
    Die sollte Fat32 formatiert und ggf. eine GoldCard sein.
    Hier ein Hinweis aus dem CyanogenMod Wiki:
    Gruß,
    tonne
     
    _sunny bedankt sich.
  6. _sunny, 09.11.2011 #6
    _sunny

    _sunny Threadstarter Neuer Benutzer

    Beiträge:
    13
    Erhaltene Danke:
    0
    Registriert seit:
    09.02.2011
    Phone:
    T-Mobile G1
    Hmm, ich hab mal hier reingeschaut:

    http://www.android-hilfe.de/root-ha...-g1/1158-howto-root-mit-goldcard-loesung.html

    Aber da benötigt man ja ein funktionierendes Gerät auf dem man dann mit Astaro eine Datei ausliest, etc.

    Wie mache ich mir eine GoldCard ohne Windows-Phone und ohne Dateimanager in Android?
    Hab auch gerade keine andere microSD am Start..

    Hab gerade die SD normal formatiert und versuche es mal erneut.
     
  7. winne, 09.11.2011 #7
    winne

    winne Android-Guru

    Beiträge:
    3,788
    Erhaltene Danke:
    644
    Registriert seit:
    09.05.2009
    Phone:
    S60
    Wearable:
    Pebble schwarz
    Hab ich erwartet. :flapper:
    Hab ich nicht erwartet. :confused2:

    Hast du mit Alt+W schon mal nen Wipe gemacht ?
     
  8. _sunny, 09.11.2011 #8
    _sunny

    _sunny Threadstarter Neuer Benutzer

    Beiträge:
    13
    Erhaltene Danke:
    0
    Registriert seit:
    09.02.2011
    Phone:
    T-Mobile G1
    Jo, vor dem Flash immer schön gewiped.

    Habs auch jetzt noch mal versucht, aber das Ding rennt immer wieder zurück ins Recovery und das wars dann.
     
  9. winne, 09.11.2011 #9
    winne

    winne Android-Guru

    Beiträge:
    3,788
    Erhaltene Danke:
    644
    Registriert seit:
    09.05.2009
    Phone:
    S60
    Wearable:
    Pebble schwarz
    Problem ist: Ich habe keine Ahnung was du vorher wirklich geflasht hast, denn es war keine RC7. Dazu hast du auch das falsche Radio drauf. Eine .nbh läßt sich nur mit einer Goldcard flashen und bei der RC7 hast du dann den Bootloader 0.95.0000 und eine Radio mit 1.X.....
    Da das orginale Recovery dir nicht viel Spielraum bietet, wirst du um die Erstellung einer Goldcard nicht umhinkommen.

    Alles was du benötigst findest du hier: 21. Programme zum rooten

    Das weitere wäre dann der Link zum One-Klick-root, den du schon hast.

    Jetzt benötigst du eigentlich nur noch die Goldcard, aber das ist ohne funktionierendes Gerät etwas schwierig. Ich geh mal kurz in mich. :winki:

    Edit: War schon ziemlich chaotisch dein Vorgehen aus dem ersten Thread. :winki:
     
  10. winne, 09.11.2011 #10
    winne

    winne Android-Guru

    Beiträge:
    3,788
    Erhaltene Danke:
    644
    Registriert seit:
    09.05.2009
    Phone:
    S60
    Wearable:
    Pebble schwarz
  11. _sunny, 09.11.2011 #11
    _sunny

    _sunny Threadstarter Neuer Benutzer

    Beiträge:
    13
    Erhaltene Danke:
    0
    Registriert seit:
    09.02.2011
    Phone:
    T-Mobile G1
    Hehe auf jeden Fall war es das..das Problem war nur, das mein Verständnis von der ganzen Materie mit den Problemen zugenommen haben ^^...

    Davor hatte ich ne funktionierende ROM aber kaum Wissen mehr, jetzt hab ich schon einiges mehr dazu gelernt, aber ein im Koma liegendes G1...

    Aber nicht aufgeben, das mit der Linux LiveCD klingt doch gut, ich werd das mal versuchen, danke dir!
     
  12. _sunny, 13.11.2011 #12
    _sunny

    _sunny Threadstarter Neuer Benutzer

    Beiträge:
    13
    Erhaltene Danke:
    0
    Registriert seit:
    09.02.2011
    Phone:
    T-Mobile G1
    Hi Leute,

    also hab mir gerade ne goldcard erstellt und die dreaimg.nbh geflasht..zumindest versucht.

    er hat diesmal mit dem flashen begonnen, war alles super, bis zum boot step.

    da is er dann abgebrochen.:

    [​IMG]


    woran kann das liegen? hatte mir schon löcher in den bauch gefreut..

    VG
     
  13. DiSa, 13.11.2011 #13
    DiSa

    DiSa Android-Experte

    Beiträge:
    483
    Erhaltene Danke:
    80
    Registriert seit:
    06.11.2009
    Könnte an defektem Speicher liegen, wenn Du Glück hast und noch genügend Reservespeicher zur Verfügung steht, wird dieser automatisch ausgetauscht.

    Wenn fastboot funktionieren würde, würde ich Dir jetzt raten, den Speicherbereich mit

    fastboot erase boot

    zu löschen ... ;)
     
    _sunny bedankt sich.
  14. _sunny, 13.11.2011 #14
    _sunny

    _sunny Threadstarter Neuer Benutzer

    Beiträge:
    13
    Erhaltene Danke:
    0
    Registriert seit:
    09.02.2011
    Phone:
    T-Mobile G1
    hmm ok, was schlägst du also vor?

    wenn ich das handy per kabel anschließe und starte kommt beim G1-Bootscreen links oben rot hinterlegt der 'fastboot'-schriftzug. würde demnach dein vorgeschlagener weg funktionieren?

    wenn ja was brauche ich genau dazu? java sdk, usb treiber, evtl. noch etwas?

    VG
     
  15. DiSa, 13.11.2011 #15
    DiSa

    DiSa Android-Experte

    Beiträge:
    483
    Erhaltene Danke:
    80
    Registriert seit:
    06.11.2009
    Links oben rot hinterlegt? Kenne ich so nicht, aber ob fastboot funktioniert kannst Du einfach herausfinden:

    fastboot binary auf PC installieren, Phone mit PC verbinden und in den Fastboot-Modus bringen (Start mit back+power) dann vom PC aus:

    fastboot devices

    eingeben.
    Leider bin ich aktuell nicht am PC, sonst würde ich Dir einen Link aufs Fastboot Binary schicken, so muss Du halt googlen ;)

    Edit: Usb Treiber solltest Du installiert haben, sonst geht's nicht. Siehe XDA-Thread über ADB und Fastboot.


    Ahh ... noch eine Frage: Wenn Du einen SPL mit fastboot hast (Nach den Bildern zu urteilen hast/hattest Du den 1.33.2005) warum willst Du dann eine dreaimg.nbh flashen? Ich würde mit

    fastboot erase system -w
    fastboot erase boot
    fastboot erase recovery

    den internen Speicher komplett löschen und danach über

    fastboot flash recovery <recovery.img>

    ein neues Recovery flashen. Anschließend ins Recovery booten und ein neues ROM installieren.
     
    Zuletzt bearbeitet: 13.11.2011
  16. tonne99, 13.11.2011 #16
    tonne99

    tonne99 Android-Hilfe.de Mitglied

    Beiträge:
    73
    Erhaltene Danke:
    58
    Registriert seit:
    19.09.2010
    Tablet:
    Motorola Xoom
    Den 1.33.2005 hatte er auch drauf, hat dann aber wohl irrtümlich auf 0.95.0000 zurückgeflasht (siehe Post 1, Bild unter Punkt 8 ).
    Und seitdem ist das G1 wohl fürchterlich durcheinander ;-(

    Gruß,
    tonne
     
  17. DiSa, 13.11.2011 #17
    DiSa

    DiSa Android-Experte

    Beiträge:
    483
    Erhaltene Danke:
    80
    Registriert seit:
    06.11.2009
    Aber dann hätte er kein fastboot mehr ... Er hat aber geschrieben, dass er fastboot auf dem Screen liest ?)
     
  18. tonne99, 13.11.2011 #18
    tonne99

    tonne99 Android-Hilfe.de Mitglied

    Beiträge:
    73
    Erhaltene Danke:
    58
    Registriert seit:
    19.09.2010
    Tablet:
    Motorola Xoom
    Das sehe ich genauso, aber _sunny schreibt ja im ersten Post:

    Und daher gehe ich davon aus, dass der Bootloader wohl etwas "durcheinander" ist.
    Ich bin mal gespannt, wie das hier weitergeht.

    Gruß,
    tonne
     
  19. _sunny, 14.11.2011 #19
    _sunny

    _sunny Threadstarter Neuer Benutzer

    Beiträge:
    13
    Erhaltene Danke:
    0
    Registriert seit:
    09.02.2011
    Phone:
    T-Mobile G1
    Hi Leute,

    also nach dem fehlgeschlagenen flash vom dreaimg.dbh kommt jetzt weder der bootscreen, noch das recovery menü nach dem start.

    er läuft direkt in den regenbogenscreen.

    Er wechselt jedoch von 'Serial0' auf 'einfach nichts'. Also da ist dann der grüne Bereich durchgehend ohne weißen Streifen auf dem die Informationen stehen.

    Is das ein Indikator für irgendetwas?
    Leider macht Windows keine anstalten irgendein USB Gerät zu erkennen :bored:

    VG
     
  20. tonne99, 14.11.2011 #20
    tonne99

    tonne99 Android-Hilfe.de Mitglied

    Beiträge:
    73
    Erhaltene Danke:
    58
    Registriert seit:
    19.09.2010
    Tablet:
    Motorola Xoom
    Hi,
    ich bin überfragt, ob es nun ein Defekt vom Flashspeicher sein könnte oder "nur" ein zerschossener Bootloader.
    Dazu sollten sich Experten wie winne oder Steppo mal äußern.
     

Diese Seite empfehlen