1. Nimm jetzt an unserem Uhans - 3. ADVENT - Gewinnspiel teil - Alle Informationen findest Du hier!

Galerie: Thumbnails dauern ewig

Dieses Thema im Forum "Samsung Galaxy (I7500) Forum" wurde erstellt von fexpop, 27.08.2009.

  1. fexpop, 27.08.2009 #1
    fexpop

    fexpop Threadstarter Android-Experte

    Beiträge:
    877
    Erhaltene Danke:
    128
    Registriert seit:
    17.07.2009
    Hallo,

    bei meinem Galaxy dauert es ewig, bis die Thumbnails einer Galerie angezeigt werden. Für 200 Bilder rechnet das Galaxy schon mal knapp 20 Minuten. Und das fast jedesmal erneut. Das Galaxy scheint sich die Thumbnails inefach nicht immer zu merken. (Manchmal schon, hab noch keine Regelmäßigkeit entdecken können).

    Ist das bei euch auch so?
     
  2. koy, 27.08.2009 #2
    koy

    koy Erfahrener Benutzer

    Beiträge:
    205
    Erhaltene Danke:
    20
    Registriert seit:
    16.07.2009
    Wollte auch schon einen Post drüber schreiben.

    Desto größer die Bilder sind (in MB) desto länger dauert es. Ich habe ein paar Bilder von der DSLR drauf (12mp) und diese brauchen ewig um zu laden.

    Bei einem Neustart sind sie immer weg; sie verschwinden aber auch manchmal einfach nur so (ich glaube immer dann, wenn mehr RAM gebraucht wird (also mehrere Programme geöffnet werden), bin mir dabei aber nicht sicher.

    Ich würde auch gerne wissen ob dies bei allen Android Handys der Fall ist, und ob man da was machen kann, so dass die für immer gespeichert bleiben.
     
  3. arctic, 27.08.2009 #3
    arctic

    arctic Fortgeschrittenes Mitglied

    Beiträge:
    271
    Erhaltene Danke:
    15
    Registriert seit:
    14.02.2009
    Also ich wollet ursprünglich meine komplette Fotosammlung auf Magic-Auflösung runterrechnen und auf mein Magic übernehmen. Aber schon nur beim ersten Ordner ~30 Bilder... muss man warten um die Thumbnails zu sehen Oo

    Da war mein Nokia 6234 schneller =D

    Also Spaß macht es, zumindest mit dem Standart Gallerie Programm nicht.

    "Mal eben grad so" in der Vorlesung oder so kurz nen bestimmtes Foto von paar hundert herbeiscrollen, wie ich das vom IPhone her gesehen habe, ist also nicht.
     
  4. koy, 27.08.2009 #4
    koy

    koy Erfahrener Benutzer

    Beiträge:
    205
    Erhaltene Danke:
    20
    Registriert seit:
    16.07.2009
    Das heißt dein Magic speichert die Thumbnails auch nicht auf Dauer?

    Da muss es doch was geben um diese dauerhaft zu speichern?
     
    Zuletzt bearbeitet: 27.08.2009
  5. winne, 27.08.2009 #5
    winne

    winne Android-Guru

    Beiträge:
    3,788
    Erhaltene Danke:
    644
    Registriert seit:
    09.05.2009
    Phone:
    S60
    Wearable:
    Pebble schwarz
    @ koy

    versuche mal Gallery Glider. Der läuft bei mir super schnell. Habe allerdings auch keine riesigen Fotoalben auf dem G1. :D

    Ist leider kein Tip für Galaxy-Besitzer, da es da nicht laufen soll. :eek:

    Gruß Winne
     
  6. Jay1982, 27.08.2009 #6
    Jay1982

    Jay1982 Android-Experte

    Beiträge:
    666
    Erhaltene Danke:
    71
    Registriert seit:
    17.07.2009
    Hm...
    Also ich hab atm ca. 350 Bilder in der Gallery, davon ca. 300 von ner 10MP Digicam (also auch nichts kleines). Nach dem ich die einmal komplett durchrechnen lassen hab für die Anzeige hab ich die Thumbnails auch nach diversen Reboots noch da. Dauert zwar auch kurz bis die alle geladen sind, aber das dauert vielleicht 3 bis 5 Sekunden, dann kann ich in der Übersicht alle sehen.

    PS: Galaxy mit Update
     
  7. koy, 28.08.2009 #7
    koy

    koy Erfahrener Benutzer

    Beiträge:
    205
    Erhaltene Danke:
    20
    Registriert seit:
    16.07.2009
    Das heißt bei dir speichert er die Thumbnails mit Galaxy, auch nach einem Reboot?

    Das ist natürlich eigenartig, dass es bei dir diese speichert, und bei anderen Leuten nicht...
     
  8. dj_ecr, 28.08.2009 #8
    dj_ecr

    dj_ecr Android-Hilfe.de Mitglied

    Beiträge:
    117
    Erhaltene Danke:
    34
    Registriert seit:
    11.08.2009
    Also bei mir wird eventuell auch was gespeichert.
    Hab ueber 2000 Photos, das dauerte beim ersten mal ewig, jetzt sind es noch 2-3 sekunde pro bild.

    @Jay1982: Dauert es bei dir wirklich fuer mehr als 1-2 Bildschirme voll Bilder nur 3-5 sekunden oder pro Bild? Und hat es das erst mal wirklich laenger gedauert, oder sind deine Bilder einfach nur kleiner (Dateigroesse) und laden deshalb so schnell?
     
  9. Jay1982, 28.08.2009 #9
    Jay1982

    Jay1982 Android-Experte

    Beiträge:
    666
    Erhaltene Danke:
    71
    Registriert seit:
    17.07.2009
    @koy:
    Ja ich habe seit dem ich die Bilder draufgemacht habe, bestimmt schon mind. 5 Reboots gemacht.

    @dj_ecr:
    So extra nochmal geschaut:

    Anzahl: ca. 350
    Gesamtgröße: ca. 725 MB
    Davon 300 Bilder in 3888 Pixel x 2592 Pixel, mit einer Größe von 2MB bis 4MB

    Das erste Mal Thumbnails erstellen hat auch so 10 Minuten gedauert, das mit den 3 bis 5 Sekunden nehm ich zurück, ich glaube da hatte gestern was anderes noch gehakt. Geh ich auf die Gallery, habe ich sofort alle Thumbnails da. Ich scroll zwar sofort wie ein blöder nach unten, bin aber langsamer als das Galaxy die Thumbnails eingelesen hat, d.h. ich sehe keine grauen Vorschauen.
     
  10. CJ78, 28.08.2009 #10
    CJ78

    CJ78 Fortgeschrittenes Mitglied

    Beiträge:
    271
    Erhaltene Danke:
    7
    Registriert seit:
    09.07.2009
    Meins verliert auch immer die Thumbnails. Jedes mal wenn ich die Galerie aufrufe dauert es wieder ewig bis die Bilder geladen sind
     
  11. cclement, 13.10.2009 #11
    cclement

    cclement Neuer Benutzer

    Beiträge:
    13
    Erhaltene Danke:
    0
    Registriert seit:
    22.05.2009
    ja das ich wirklich total lässtig! kann man nicht ein anderes programm auf dem market nehmen? am iphone muss ich da überhaupt nicht warten!

    mfg
    cc
     
  12. Jay1982, 13.10.2009 #12
    Jay1982

    Jay1982 Android-Experte

    Beiträge:
    666
    Erhaltene Danke:
    71
    Registriert seit:
    17.07.2009
    Hm...
    Also wie gesagt ich hab dieses Problem überhaupt nicht und hatte es noch nie (egal mit welcher Firmware). Einmal einlesen und dann läufts wie geschmiert, egal wie oft ich reboote...

    Was mir noch einfallen würde:
    Habt ihr die Bilder auf einer externen Karte gespeichert? Bei mir liegen die auf der internen (aus Ermangelung einer externen *g*).
     
  13. androbi, 13.10.2009 #13
    androbi

    androbi Android-Hilfe.de Mitglied

    Beiträge:
    136
    Erhaltene Danke:
    18
    Registriert seit:
    06.08.2009
    Phone:
    Samsung Galaxy S7 edge
    habe das problem auch. und zwar immer wenn ich das galaxy via usb mit dem pc verbinde und als laufwerk freigebe. danach muss jedes mal die galerie neu geladen werden. habe meine bilder mehrheitlich auf der externen sd-karte (die bilder auf der internen müssen aber auch jedes mal neu geladen werden).

    jemand eine idee? :confused:
     
  14. Jay1982, 13.10.2009 #14
    Jay1982

    Jay1982 Android-Experte

    Beiträge:
    666
    Erhaltene Danke:
    71
    Registriert seit:
    17.07.2009
    Hm... Was hastn aufm PC für ein Betriebssystem?

    Mein Galaxy hängt auch öfter am Laptop (Linux), von daher könnte es ja theoretisch sein das Windows die Thumbnails zerschießt und dann Android damit wiederum nichts anfangen kann und diese neu berechnen muss.
     
  15. androbi, 13.10.2009 #15
    androbi

    androbi Android-Hilfe.de Mitglied

    Beiträge:
    136
    Erhaltene Danke:
    18
    Registriert seit:
    06.08.2009
    Phone:
    Samsung Galaxy S7 edge
    habs mit windows vista und xp versucht -> bei beiden das gleiche verhalten. komisch ist auch, dass die thumbnails alle auf der internen sd-karte vorhanden wären (/sdcard/DCIM/.thumbnails/), auch für die fotos der externen sd-karte... trotzdem erstell das galerie-app die thumbnails immer wieder neu. leider bauen die meisten anderen galerie-apps auf die thumbnails vom standard-app auf....hmmm...?? :confused:
     
  16. Jay1982, 13.10.2009 #16
    Jay1982

    Jay1982 Android-Experte

    Beiträge:
    666
    Erhaltene Danke:
    71
    Registriert seit:
    17.07.2009
    Also habs mal getestet:

    Galaxy an PC mit Vista und /sdcard/DCIM/Camera/ geöffnet => Verbindung getrennt => Gallery App berechnet THumbnails neu


    Galaxy an Laptop mit Ubuntu und selbiges gemacht => Gallery App berechnet Thumbnails neu

    Laut Änderungsdatum der Thumbnails werden diese aber nicht geändert von Vista oder Ubuntu... Sehr mysteriös o.0
     
  17. Psycholein, 13.10.2009 #17
    Psycholein

    Psycholein Android-Experte

    Beiträge:
    851
    Erhaltene Danke:
    69
    Registriert seit:
    13.07.2009
    ich schätze, dass die App keine Datenbankeinträge macht oder Checksummen erstellt
    demnach muss die nach entfernen der SD-Karte davon ausgehen, dass vllt ne ganze neue ins Handy eingelegt wurde und berechnet die Thumbnails stupide neu

    hoffen wir, dass da bald ne besser App kommt (vllt in 1.6) ;)
     
  18. Jay1982, 13.10.2009 #18
    Jay1982

    Jay1982 Android-Experte

    Beiträge:
    666
    Erhaltene Danke:
    71
    Registriert seit:
    17.07.2009
    Stimmt leider, grad nochmal am Laptop getestet, auch wenn ich nicht auf das Bilderverzeichnis zugreife, werden danach alle Thumbs neu berechnet... Dann hatte ich die letzten Male wohl nur zum Laden angesteckt gehabt, ohne die SD freizugeben.

    Da kann man wirklich nur auf Besserung hoffen...
     
    androbi bedankt sich.
  19. androbi, 13.10.2009 #19
    androbi

    androbi Android-Hilfe.de Mitglied

    Beiträge:
    136
    Erhaltene Danke:
    18
    Registriert seit:
    06.08.2009
    Phone:
    Samsung Galaxy S7 edge
    danke für die hilfe! da bleibt nur noch hoffen, abwarten und tee trinken... :(
     
  20. RaZZe, 13.10.2009 #20
    RaZZe

    RaZZe Gast

    dito.
    das original gallery app ist eh fürn arsch.
    hier heisst es wirklich abwarten und tee trinken...
     

Diese Seite empfehlen