1. Nimm jetzt an unserem 2. ADVENT-Gewinnspiel teil - Alle Informationen findest Du hier!

[Gelöst] Allwinner Tablet resettet sich bei jedem Start

Dieses Thema im Forum "Weitere Hersteller allgemein" wurde erstellt von thepope, 17.05.2012.

  1. thepope, 17.05.2012 #1
    thepope

    thepope Threadstarter Neuer Benutzer

    Beiträge:
    5
    Erhaltene Danke:
    0
    Registriert seit:
    17.05.2012
    Phone:
    ZTE Blade
    Hallo,

    ich hab ein riesiges Problem mit meinem neuen (billigen) Tablet aus Fernost.
    Ist ein Allwinner Cortex A8 mit Android 4.0.3
    Es lief am Anfang super, aber ich hab dann einige Änderungen vorgenommen und jetzt spinnt es total.
    Ich hab die vold.fstab geändert (mit einem vorgefertigten Skript) um die SD Karte als externen Speicher zu mounten, anstatt dem 2ten internen Speicher
    (das blöde Teil hat den fest verbauten Speicher schon auf intern und extern aufgeteilt).
    Außerdem hab ich an der build.prop rumgespielt, daran sollte es aber nicht liegen. Die Änderungen hab ich auch wieder rückgängig gemacht.
    Ich hab dann noch Chainfire3D installiert und auch da lief noch alles normal.

    Nach mehreren Starts sah es allerdings so aus:
    Alles hat sich auf den Ursprungszustand zurück gestellt. Sprache, Apps, einfach alles ist weg. Alles außer den Systemdateien die ich per root
    ändern kann ist bei jedem neuen Start alles weg.
    Außerdem ist der interne Speicher irgendwie verschwunden; bzw. ist der Balken (Belegung/Freier SPeicher) komplett grün, 0.00B sind frei und ca. 35MB Apps sind installiert.
    Externer Speicher, USB-Geräte etc. werden noch richtig erkannt.
    So lässt sich auch fast nichts installieren, er erkennt ja keinen Speicher, oder nur den, der schon verwendet wird.

    Das mit fstab hab ich schon versucht rückgängig zu machen, aber ich weiß leider nicht wie die Standardeinstellung aussehen sollte.
    Chainfire3D hab ich über ADB deinstalliert.

    Ich hab keine Ahnung wie das alles zusammenhängt. Wahrscheinlich speichert er keine Einstellungen, weil er auf den internen Speicher nicht mehr zugreifen kann.
    Ich hoffe es hat jemand Ahnung davon, ich verzweifele total!

    Hier ist übrigens der jetzige Inhalt der fstab:

    Tausendfachen Dank an den, der mir helfen kann!
     
    Zuletzt bearbeitet: 17.05.2012
  2. darkyboy, 17.05.2012 #2
    darkyboy

    darkyboy Gast

    thepope bedankt sich.
  3. hävksitol, 17.05.2012 #3
    hävksitol

    hävksitol Ehrenmitglied

    Beiträge:
    12,603
    Erhaltene Danke:
    8,873
    Registriert seit:
    11.01.2011
    Tablet:
    Lenovo Ideapad A2109A
    In dem von Dir zitierten Thread war das Updaten der Busybox schuld, hier (beim TE) ist es aller Wahrscheinlichkeit nach die modifizierte void.fstab, weswegen der Link wohl leider nicht weiterhelfen wird.
     
    thepope bedankt sich.
  4. thepope, 17.05.2012 #4
    thepope

    thepope Threadstarter Neuer Benutzer

    Beiträge:
    5
    Erhaltene Danke:
    0
    Registriert seit:
    17.05.2012
    Phone:
    ZTE Blade
    Ich küsse dir die Füße!
    An das verdammte Busybox hab ich gar nicht gedacht!
    Und Google hat in >3 Stunden diesen Link nicht ausgespuckt.
    Per ADB Shell verschoben -> Partitionen wieder da, Einstellungen bleiben erhalten.

    Soweit ich jetzt herausgefunden habe ist fstab sowieso nur für die
    zusätzlichen Mountpoints zuständig - nicht für das System selber.


    :tongue::love::love::love::love::love::love::thumbup::thumbup::thumbup::thumbup::thumbup: Daaaaaankeeeeeeeeeeee!
     
  5. hävksitol, 17.05.2012 #5
    hävksitol

    hävksitol Ehrenmitglied

    Beiträge:
    12,603
    Erhaltene Danke:
    8,873
    Registriert seit:
    11.01.2011
    Tablet:
    Lenovo Ideapad A2109A
    @thepope,
    schön, daß Du Dein Problem lösen konntest.


    @alle

    1. Das zeigt, wie wichtig es ist, als Hilfesuchender immer vollständige Infos zu liefern - aufgrund der vorliegenden Daten (die ja keinerlei Hinweise auf eine modifizierte Busybox lieferten) habe ich auf etwas anderes diagnostiziert.
    2. Dennoch eine Warnung: Die Modifizierung der void.fstab führt bei vielen Tablets (auch wenn sie der Logik nach korrekt durchgeführt wurde) immer wieder zu nicht-benutzbaren Tablets. Also besser vorher fragen, ob eine Änderung am aktuellen Tablet auch wirklich schadlos vorgenommen werden darf!
     
    thepope bedankt sich.
  6. Innos, 22.05.2012 #6
    Innos

    Innos Erfahrener Benutzer

    Beiträge:
    170
    Erhaltene Danke:
    7
    Registriert seit:
    06.01.2011
    Phone:
    Samsung Galaxy S4 (i9500)
    thepope bedankt sich.
  7. thepope, 22.05.2012 #7
    thepope

    thepope Threadstarter Neuer Benutzer

    Beiträge:
    5
    Erhaltene Danke:
    0
    Registriert seit:
    17.05.2012
    Phone:
    ZTE Blade
    Naja ich setz das mal noch hier rein (ein großes Review in neuem Thread lohnt sich bei der Vielzahl an unterschiedlichen China-Tablets nicht wirklich):
    Erstmal: Holy Cow! So billig? Also bei mir waren es 107 Euro, Portofrei, 20 Euro Steuer
    Es ist übrigens nicht exakt das Modell, das du da verlinkt hast. Deines sieht etwas besser aus (Touch-Buttons) und hat eine GC800 GPU - meines eine Mali 400.
    Der Einfachheit halber poste ich dir mein englisches Review für den Käufer:
    Aber gerne schreibe ich noch mehr zu meiner Erfahrung damit, oder beantworte Dir Fragen.

    @hävksitol: Ich hatte ja versucht viele Infos zu geben. Wenn ich mich an Busybox erinnert hätte bzw. auf die Idee gekommen wäre, dass auch andere Dinge als die gelisteten das Problem verursacht haben könnten, hätte ich das natürlich erwähnt :\
     
  8. Innos, 22.05.2012 #8
    Innos

    Innos Erfahrener Benutzer

    Beiträge:
    170
    Erhaltene Danke:
    7
    Registriert seit:
    06.01.2011
    Phone:
    Samsung Galaxy S4 (i9500)
    Fragen erstmal nicht. Das Ding muss ja erstmal ankommen, dann sehen wir weiter. Das mit dem Memory Split ist sicher etwas, was geändert werden müsste...

    Das mit dem unbrauchbaren Bildschirm kann aber auch am Ladegerät liegen. Ich habe einen China Billig USB-Adapter, und wenn ich den verwende um mein HTC zu laden, ist der Screen unbrauchbar und reagiert kaum. Mit anderen Adaptern kein Problem...
     
  9. chris67, 23.05.2012 #9
    chris67

    chris67 Android-Lexikon

    Beiträge:
    1,554
    Erhaltene Danke:
    295
    Registriert seit:
    27.10.2010
    @thepope: Die Kombi CPU/GPU wird interessanterweise bei den Poduktspezifikationen öfters mal verwechselt.

    So ist es richtig:
    CPU Rockchip RK2918 = GPU GC800
    CPU Allwinner A10 = GPU Mali400

    Die Mali400 ist um einiges schneller als die GC800.
     
  10. Innos, 23.05.2012 #10
    Innos

    Innos Erfahrener Benutzer

    Beiträge:
    170
    Erhaltene Danke:
    7
    Registriert seit:
    06.01.2011
    Phone:
    Samsung Galaxy S4 (i9500)
    Wenn das Ding da ist, poste ich Fotos und Benchmarks.
     
  11. thepope, 23.05.2012 #11
    thepope

    thepope Threadstarter Neuer Benutzer

    Beiträge:
    5
    Erhaltene Danke:
    0
    Registriert seit:
    17.05.2012
    Phone:
    ZTE Blade
    Da das Gerät über USB nicht laden möchte und ich nicht weiß welche Norm der andere Stecker hat kann ich das momentan nicht überprüfen.

    Edit: Ich hab jetzt mal versucht mit einem Netzstecker-USB-Ladegerät am Mini-USB Slot zu laden.
    Daraufhin hat sich das Ding verselbstständigt. Hat ohne Berührung Apps gestartet und ist wahllos auf der Tastatur gesprungen. Das die Dinger so empfindlich auf Stromquellen reagieren? o.O
     
    Zuletzt bearbeitet: 24.05.2012
  12. M.Judersleben, 19.09.2013 #12
    M.Judersleben

    M.Judersleben Android-Hilfe.de Mitglied

    Beiträge:
    56
    Erhaltene Danke:
    3
    Registriert seit:
    19.07.2013
    Phone:
    Samsung S4
    Grüße thepope darf man fragen wie du die Partionen verschoben hast über adb habe warscheinlich das gleiche Problem
     
  13. xminister, 19.09.2013 #13
    xminister

    xminister Ehrenmitglied

    Beiträge:
    8,000
    Erhaltene Danke:
    3,958
    Registriert seit:
    08.11.2011
    Phone:
    LG, Wiko, Huawei, HTC
    Tablet:
    Acer W3-810, Dell Venue 8 Pro, i.onik 11.6
    Er hat die busybox verschoben, nicht die Partition. ;)
     
  14. M.Judersleben, 20.09.2013 #14
    M.Judersleben

    M.Judersleben Android-Hilfe.de Mitglied

    Beiträge:
    56
    Erhaltene Danke:
    3
    Registriert seit:
    19.07.2013
    Phone:
    Samsung S4
    ah ok und wie geht das über die adb console?:confused2:
     

Diese Seite empfehlen

Besucher kamen mit folgenden Begriffen auf unsere Seite:

  1. allwinner tablet

    ,
  2. Allwinner Tablet zurücksetzen