1. Nimm jetzt an unserem 2. ADVENT-Gewinnspiel teil - Alle Informationen findest Du hier!

[Gelöst] Mac: Externe SD - Kein Zugriff über USB (JPY)

Dieses Thema im Forum "Root / Hacking / Modding für Samsung Galaxy S" wurde erstellt von bytewise, 25.01.2011.

  1. bytewise, 25.01.2011 #1
    bytewise

    bytewise Threadstarter Junior Mitglied

    Beiträge:
    32
    Erhaltene Danke:
    0
    Registriert seit:
    09.09.2010
    Hallo,

    seit JPY (glaube ich. Früher hat es jedenfalls mal funktioniert.) kann ich mit meinem Mac nicht mehr die externe SD des Galaxy S als USB-Laufwerk einbinden.

    Der Zugriff auf die 6GB der internen SD funktioniert ohne Probleme über USB.

    USB-Debugging ist an, USB-Modus ist auf Massenspeicher gestellt.

    Wenn ich das SGS mit dem Mac per USB verbinde, kommt eine Warnmeldung auf dem Mac: "Das eingelegte Medium konnte von diesem Computer nicht gelesen werden. Initialisieren, Ignorieren, Abbrechen"

    Ohne USB-Debugging passiert komischerweise genau das gleiche, d.h. ich kann auf die interne SD ohne Probleme zugreifen, aber nicht auf die externe SD.

    Auf dem Mac läuft die neueste Version von Mac OS X (10.6.6).

    Auf dem SGS läuft die normale JPY mit dem JPY-Kernel mit Voodoo Lagfix (http://dl.project-voodoo.org/stock+Voodoo-5.0.3-Froyo-GT-I9000-XXJPY.tar). Kein Custom ROM o.ä.

    Kann mir jemand helfen?
     
    Zuletzt bearbeitet: 27.01.2011
  2. extralife, 25.01.2011 #2
    extralife

    extralife Android-Guru

    Beiträge:
    2,217
    Erhaltene Danke:
    818
    Registriert seit:
    22.09.2010
    Warum nicht initialisieren?

    ansonsten probier die card mal in einem card-reader

    using Tapatalk
     
  3. bytewise, 25.01.2011 #3
    bytewise

    bytewise Threadstarter Junior Mitglied

    Beiträge:
    32
    Erhaltene Danke:
    0
    Registriert seit:
    09.09.2010
    Initialisieren bedeutet formatieren/partitionieren. Das will ich nicht, denn es sind auch Daten auf der Karte. Ich habe das aber spaßeshalber mal aufgerufen, es öffnet sich das Festplatte-Dienstprogramm und zeigt mir ein komisches Laufwerk mit 209,7 MB ("Samsung GT-I9000 Card Media")an, ohne Partition. Sehr seltsam. (Meine externe SD-Karte hat 16 GB).

    Im SD-Card-Reader funktioniert die Karte einwandfrei. Im SGS selber übrigens auch. :winki:
     
  4. backylasek, 25.01.2011 #4
    backylasek

    backylasek Android-Guru

    Beiträge:
    2,260
    Erhaltene Danke:
    266
    Registriert seit:
    17.09.2010
    hast du es mal mit usb debugging aus und dann auf massenspeicher versucht????
     
  5. bytewise, 25.01.2011 #5
    bytewise

    bytewise Threadstarter Junior Mitglied

    Beiträge:
    32
    Erhaltene Danke:
    0
    Registriert seit:
    09.09.2010
    Ohne USB-Debugging passiert komischerweise genau das gleiche, d.h. ich kann auf die interne SD ohne Probleme zugreifen, aber nicht auf die externe SD.
     
  6. backylasek, 25.01.2011 #6
    backylasek

    backylasek Android-Guru

    Beiträge:
    2,260
    Erhaltene Danke:
    266
    Registriert seit:
    17.09.2010
    aber sie wird vom phone erkannt????hol sie mal raus und leg sie neu ein....
     
  7. bytewise, 25.01.2011 #7
    bytewise

    bytewise Threadstarter Junior Mitglied

    Beiträge:
    32
    Erhaltene Danke:
    0
    Registriert seit:
    09.09.2010
    Hab ich schon versucht, siehe oben, da habe ich sie in meinen SD-Card-Reader eingelegt und an den Mac angesteckt, was einwandfrei funktionierte.

    Habe sie dann unter Mac mal überprüfen und reparieren lassen. Das hat nichts geändert. Sie funktioniert weiterhin im SGS selbst korrekt, aber nicht als USB-Laufwerk.
     
  8. extralife, 25.01.2011 #8
    extralife

    extralife Android-Guru

    Beiträge:
    2,217
    Erhaltene Danke:
    818
    Registriert seit:
    22.09.2010
    Hmm mount Problem...

    Hast du root -welchen kernel ?

    Falls root - öffne mal /system/etc/vold.fstab
    sollte so aussehen

    Code:
    # externel sdcard
    {
        mount_deep = 1
        ums_path = /sys/devices/platform/s3c-usbgadget/gadget/lun1/file
        asec = enable
        mbr_policy = overwrite
    
    wichtig ist hier /lun1

    Bei der internen sollte /lun0 stehen

    Check das mal, wenn möglich

    using Tapatalk
     
    Zuletzt bearbeitet: 26.01.2011
  9. bytewise, 25.01.2011 #9
    bytewise

    bytewise Threadstarter Junior Mitglied

    Beiträge:
    32
    Erhaltene Danke:
    0
    Registriert seit:
    09.09.2010
    Ich habe root, ja.

    Kernel ist die JPY-Version des Voodoo-Entwicklers. Ext4-Lagfix ist auch angeschaltet (nein, die externe SD ist kein Ext4 :winki: )

    Die vold.fstab stimmt mit Deinen Angaben genau überein.
     
  10. extralife, 26.01.2011 #10
    extralife

    extralife Android-Guru

    Beiträge:
    2,217
    Erhaltene Danke:
    818
    Registriert seit:
    22.09.2010
    wenn du nicht weißt ob es vorher funktionierte, wird es schwierig die fehlerquelle einzugrenzen

    weiters wären detailliertere angaben zur firmware (stock jpy - custom rom - darkys, docs, ...), kernel (supercurio - v5.1?) hilfreich gewesen

    kann dir an dieser stelle nur raten in den entsprechenden rom/kernel-threads zu suchen, oder einen anderen kernel zu flashen
     
  11. bytewise, 27.01.2011 #11
    bytewise

    bytewise Threadstarter Junior Mitglied

    Beiträge:
    32
    Erhaltene Danke:
    0
    Registriert seit:
    09.09.2010
  12. bytewise, 27.01.2011 #12
    bytewise

    bytewise Threadstarter Junior Mitglied

    Beiträge:
    32
    Erhaltene Danke:
    0
    Registriert seit:
    09.09.2010
    Ich habe das Problem gelöst.

    Ich habe die SD-Karte in einem SD-Kartenleser unter Windows ausprobiert, und dort ging sie auch nicht. Ich habe von dort aus versucht, sie zu formatieren, was nicht funktionierte.

    Unterm Mac konnte ich die Karte zwar in Fat32 formatieren, es funktionierte aber auch dann komischerweise nicht, über das SGS und USB darauf zuzugreifen.

    Also ins Ubuntu rein, neu partitioniert und in Fat32 formatiert. Jetzt läuft die Karte überall :)

    Was ich nach dieser Betriebssystem-Odyssee aber nun weiß, und was wirklich super ist: Unter JPY funktioniert der Zugriff vom Mac auf den USB-Massenspeicher des SGS auch ohne das USB-Debugging!

    Endlich.

    Danke an alle, die sich beteiligt haben ;)
     

Diese Seite empfehlen