Gerootete deutsche Firmware für das K1 WiFi+3G

Dieses Thema im Forum "Root / Custom-ROMs / Modding für Lenovo IdeaPad K1" wurde erstellt von soudry, 05.04.2012.

  1. soudry, 05.04.2012 #1
    soudry

    soudry Threadstarter Android-Hilfe.de Mitglied

    Beiträge:
    135
    Erhaltene Danke:
    40
    Registriert seit:
    19.03.2012
    Hallo zusammen,

    khanning88 hat auf xda-developers.com die aktuelle deutsche Firmware (12_12_M_GE) für das Lenovo IdeaPad K1 WiFi+3G hochgeladen. Root, Busybox und CWM Recovery sind integriert. Den xda-Thread findet ihr hier. Der Downloadlink ist hier.

    Zum Installieren einfach im APX-Modus starten. Falls ihr Windows benutzt, muss der APX-Treiber installiert sein. Danach die Datei entpacken und das Skript/die Batch-Datei ausführen. Beim Flashen gehen alle Daten auf dem Tablet verloren.
     
    markus276, saschay2k und kjeenink haben sich bedankt.
  2. Ora, 11.04.2012 #2
    Ora

    Ora Marketing-Assistent Team-Mitglied

    Beiträge:
    4,681
    Erhaltene Danke:
    1,932
    Registriert seit:
    06.04.2012
    Wenn es dann mal einer getan hat, könnte dieser dann mal das versuchen und prüfen ob das GPS FIX Problem damit erledigt?
     
  3. The Authlaw, 06.06.2012 #3
    The Authlaw

    The Authlaw Fortgeschrittenes Mitglied

    Beiträge:
    296
    Erhaltene Danke:
    17
    Registriert seit:
    17.02.2012
    Hallo,
    ich habe noch mal zwei Fragen/ Probleme mit dieser Version:

    1. Wie kann man auf die orginal Firmware restoren ?

    2. Ich habe folgenden Bug bei mir festgestellt. Wenn ich das Gerät ans Ladekabel hänge geht es aus. Wenn ich es dann neu starte, kommt manchmal ein Bootloop. Wenn nicht startet das Pad nach einer gewissen Zeit neu. Das passiert aber nicht, wenn ich es nicht lade.

    Jemand ne Idee woran es liegen könnte ?

    LG

    TA
     
  4. Ora, 06.06.2012 #4
    Ora

    Ora Marketing-Assistent Team-Mitglied

    Beiträge:
    4,681
    Erhaltene Danke:
    1,932
    Registriert seit:
    06.04.2012
    Wipe mal den Cache, wenn es mit recovery boot geht

    Gesendet von meinem LT18i mit Tapatalk 2
     
  5. The Authlaw, 06.06.2012 #5
    The Authlaw

    The Authlaw Fortgeschrittenes Mitglied

    Beiträge:
    296
    Erhaltene Danke:
    17
    Registriert seit:
    17.02.2012
    Hab ich schon mal gemacht.
    Dann kam beim Starten von meinen Apps nurnoch Fehlermeldungen.
    In den Werkszustand gesetzt, Apps neu installiert und dieses am jungfräulichen System getestet.
    Macht auch den Fehler. Gibts irgendwie ne Möglichkeit im Ergebnislog zu sehen, ob bzw. welche App den Fehler macht ?

    LG
    The Authlaw
     
  6. soudry, 07.06.2012 #6
    soudry

    soudry Threadstarter Android-Hilfe.de Mitglied

    Beiträge:
    135
    Erhaltene Danke:
    40
    Registriert seit:
    19.03.2012
    Hallo. Treten die Probleme mit deinem Tablet erst auf, seitdem du diese Firmware verwendest oder schon vorher? Bist du dir sicher, dass du das K1-Modell mit 3G (UMTS) hast? Nur dafür ist diese Firmware vorgesehen.
     
  7. The Authlaw, 07.06.2012 #7
    The Authlaw

    The Authlaw Fortgeschrittenes Mitglied

    Beiträge:
    296
    Erhaltene Danke:
    17
    Registriert seit:
    17.02.2012
    Hallo Soudry,
    ja ich habe die 3G Version. Mit der orginal Firmware gings. ich hatte es allerdings zur Reparatur, weil die 3,5mm Buchse defekt war. Hab dann direkt
    in die modifizierte draufgepackt und da kams dann zu den Problemen.

    Es scheint aber eher ein Problem mit der Software zu sein. Manchmal funktioniert das Laden während des Surfens mit dem Tab. Nach wenigen Minuten (10- 20 Minuten) kommts zum reboot.


    Interessanterweise wird nun das Tablett in google Play auch als XOOM erkannt...


    Hat Keiner solche Probleme ?


    LG

    the Authlaw
     
  8. soudry, 07.06.2012 #8
    soudry

    soudry Threadstarter Android-Hilfe.de Mitglied

    Beiträge:
    135
    Erhaltene Danke:
    40
    Registriert seit:
    19.03.2012
    Ich weiß nicht genau, ob bei dir ein Hardware- oder ein Software-Problem vorliegt. Um das zu testen, kannst du den Ursprungszustand aber annähernd wiederherstellen.

    Dazu musst du diese Datei herunterladen. Nach dem Entpacken startest du das Lenovo K1 im APX-Modus, führst die Datei "Flash-RUN ME.cmd" und wählst dort "Install K1_A301_02_02_110725_US /- STOCK ONLY!". Jetzt sollte die originale US-Firmware auf deinem Gerät sein.

    Dann diese Datei herunterladen, umbennen in "update.zip" und ablegen auf dem K1 im Ordner /sdcard/Download. Danach einfach neustarten.
    Dann das gleiche mit dieser Datei machen.
    Wenn das soweit geklappt hat, machst du noch ein Update direkt von K1 aus (also in den Android-Einstellungen). Nachdem das abgeschlossen ist, würde ich noch einen Factory Reset machen (auch in den Einstellungen). Wenn es dann noch Probleme gibt, ist es wohl ein Hardware-Problem.
     
    lotus und knex haben sich bedankt.
  9. breeder, 12.07.2012 #9
    breeder

    breeder Android-Experte

    Beiträge:
    575
    Erhaltene Danke:
    44
    Registriert seit:
    22.05.2012
  10. soudry, 12.07.2012 #10
    soudry

    soudry Threadstarter Android-Hilfe.de Mitglied

    Beiträge:
    135
    Erhaltene Danke:
    40
    Registriert seit:
    19.03.2012
    "Nvflash Windows Drivers" ist der APX-Treiber, den du brauchst, um eine Firmware von einem Windows-PC aus zu flashen.

    "K1_CWM_120109_M_GE_Rooted.zip" ist die deutsche Root-Firmware mit UMTS-Unterstützung. "updater_120109_M_GE_R2.zip" ist ein Update für die deutsche Root-Firmware, das einige Verbesserungen bringt (z.B. init.d-Unterstützung). "Honeycomb_statusbar_120109.zip" entfernt die Anpassungen von Lenovo an der Statusbar.

    "K1_CWM_120109_Rooted_nvflash_R2.zip" und "updater_120109_R2.zip" sind Dateien für die amerikanischen Tablets ohne UMTS.
     
  11. breeder, 12.07.2012 #11
    breeder

    breeder Android-Experte

    Beiträge:
    575
    Erhaltene Danke:
    44
    Registriert seit:
    22.05.2012
    ich dank die soudry, alles geklärt.

     
  12. breeder, 17.07.2012 #12
    breeder

    breeder Android-Experte

    Beiträge:
    575
    Erhaltene Danke:
    44
    Registriert seit:
    22.05.2012
    Also das mit dem init.d-support aus der updater_120109_R2.zip funktioniert hier nicht. egal was ich nach /system/etc/init.d reinschiebe, nicht ein einziges script wird aus geführt obwohl die rechte passen. Die Scripte manuell angestossen tun was sie tun sollen.
    Jemand ne Idee?

     
  13. soudry, 18.07.2012 #13
    soudry

    soudry Threadstarter Android-Hilfe.de Mitglied

    Beiträge:
    135
    Erhaltene Danke:
    40
    Registriert seit:
    19.03.2012
    Treffen für deine Skripte diese Regeln zu? Ich weiß allerdings nicht, ob das so auch für Android 3.2 gilt.
     
  14. breeder, 18.07.2012 #14
    breeder

    breeder Android-Experte

    Beiträge:
    575
    Erhaltene Danke:
    44
    Registriert seit:
    22.05.2012
    Es funktioniert hier nicht, der Testscript wird nicht abgearbeitet. Und es ist auch so wie in dem Link von dir.
    Vielleicht hat ja jemand noch Idee.

     
  15. breeder, 18.07.2012 #15
    breeder

    breeder Android-Experte

    Beiträge:
    575
    Erhaltene Danke:
    44
    Registriert seit:
    22.05.2012
    Vielleicht sollte ich mal zeigen was im Testscript steht der da heisst 99test oder S99test. Beides funktioniert nicht
    Code:
    #!/system/bin/sh
    #
    touch /testdatei
    
    wie gesagt, er tu es aber nicht.

    …
     
  16. breeder, 18.07.2012 #16
    breeder

    breeder Android-Experte

    Beiträge:
    575
    Erhaltene Danke:
    44
    Registriert seit:
    22.05.2012
    Mit dem Paket updater_120109_M_GE_R2.zip ist kein init.d funktion zu bekommen. Irgendwas stimmt damit nicht oder es fehlt ne Datei oder was weiss ich.

    Hat irgend jemand das schon mal ausprobiert mit dem Paket?

    …
     
  17. Toll, 29.07.2012 #17
    Toll

    Toll Android-Hilfe.de Mitglied

    Beiträge:
    139
    Erhaltene Danke:
    1
    Registriert seit:
    28.02.2012
    Tablet:
    Lenovo IdeaPad K1
    Das mit dem Flashen hat wunderbar geklappt. Es gibt dort allerdings eine updater zip-datei die zum Update auf die external sd card kopiert werden soll:
    1. Put the Honeycomb_statusbar_120109.zip on the external sd card storage (Internal will not work)
    Problem: Ich kann auf die externe sd Karte (über den ES Dateiexplorer) nichts speichern. Es kommt immer die fehlgeschlagen-Meldung. Mein Gerät ist gerootet und ES Explorer hat su-Rechte.

    Im CWM steht unten links der Hinweis E:Can't mount /sdcard/

    Mache ich irgendetwas falsch oder habe ich etwas vergessen?:confused2:

    @breeder
    Hast du die updater-zipDatei auf der ext. Sd Karte speichern und entpacken können?
     
    Zuletzt bearbeitet: 30.07.2012
  18. Toll, 30.07.2012 #18
    Toll

    Toll Android-Hilfe.de Mitglied

    Beiträge:
    139
    Erhaltene Danke:
    1
    Registriert seit:
    28.02.2012
    Tablet:
    Lenovo IdeaPad K1
    Gibt es niemanden, der mir bzgl. der updater Datei helfen könnte? :ohmy:
     
  19. breeder, 30.07.2012 #19
    breeder

    breeder Android-Experte

    Beiträge:
    575
    Erhaltene Danke:
    44
    Registriert seit:
    22.05.2012
    Ich wage mal zu behaupten das da beim flashen was nicht richtig gelaufen ist, bei mir ging alles auf Anhieb.
    Mehr fälllt mir dazu nicht ein, sorry.

    …
     
  20. Toll, 30.07.2012 #20
    Toll

    Toll Android-Hilfe.de Mitglied

    Beiträge:
    139
    Erhaltene Danke:
    1
    Registriert seit:
    28.02.2012
    Tablet:
    Lenovo IdeaPad K1
    Nach viermaligem Flashen müsste doch einmal gut sein, oder?

    Wie oder mit was schiebst du die updater-zip-Datei in den Ordner external_sd?
     

Diese Seite empfehlen