1. Nimm jetzt an unserem Uhans - 3. ADVENT - Gewinnspiel teil - Alle Informationen findest Du hier!

GPS-Empfang, Kompass und Lagesensoren (Standard-ROM)

Dieses Thema im Forum "LG Optimus Speed (P990) Forum" wurde erstellt von JCool, 10.05.2011.

  1. JCool, 10.05.2011 #1
    JCool

    JCool Threadstarter Android-Experte

    Beiträge:
    690
    Erhaltene Danke:
    89
    Registriert seit:
    25.02.2010
    Phone:
    Nexus 5X
    Tablet:
    Nexus 10
    Hallo zusammen,
    irgendwie verhält sich mein GPS-Modul, aber auch der Kompass und die Lagesensoren merkwürdig. Es gibt ja hier schon einen Thread bzgl. der GPS-Genauigkeit, der hilft aber nicht so richtig weiter für Standard-ROM-User.

    Zu meinen Problemen:

    Zum testen der GPS-Daten, des Lagesensors und des Kompasses habe ich mir die App "GPS Status" installiert.

    => In der Anwendung "GPS Status" wurde der braune "Lagekreis" nicht mittig angezeigt, obwohl das LGOS absolut ruhig und gerade auf dem Tisch lag. Ich habe nun einfach mal die Lagesensoren über die Tools von "GPS Status" kalibriert. Nun ist der Kreis korrekt in der Mitte.
    Frage: Anscheinend war der Lagesensor nicht korrekt kalibriert - geht das Kalibrieren nicht mit Bordmitteln des LGOS? Und greift diese Kalibrierung mittels "GPS Status" nun auch für alle anderen Anwendungen?

    => Heute morgen während meine S-Bahnfahrt saß ich ca. 75cm vom Fenster entfernt und habe (bei aktiver Datenverbindung) das GPS-Modul aktiviert. Nach einigen Sekunden (vielleicht 10 Sekunden) wurden die ersten Satelliten angezeigt, nach kurzer Zeit waren es immer zwischen 5 und 7 Stück. Allerdings hat es das LGOS in 30 Minuten nicht geschafft, auch nur einen Fix hinzubekommen (Anzeige in "GPS Status"). Mein altes HTC Desire schaffte in der S-Bahn schon nach wenigen Sekunden die aktuelle Positionsbestimmung (also inkl. Sat-Fix).
    Frage: Wenn mein LGOS Satelliten anzeigt, muss mein GPS-Modul doch in Ordnung sein, oder? Warum gibt es keinen Sat-Fix? Wenn das LGOS ruhig auf dem Balkontisch liegt, schafft es nach einiger Zeit die Positionsbestimmung (also auch den Sat-Fix) - allerdings auch eher im Minutenbereich. Bei meinen alten HTC Desire waren es nur wenige Sekunden...

    => Der Kompass zeigt in der S-Bahn (also fahrend) teilweise nicht die korrekte Himmelsrichtung an. Steht die Bahn ruhig, passt es ziemlich gut - so wie die Bahn fährt, dreht sich der Kompass teilweise sprunghaft. Wenn das GPS-Modul deaktiviert ist, scheint der Kompass "ruhiger" zu sein.
    Frage: Wie verhält sich Eure Kompass-Anzeige, wenn Ihr z.B. im Zug oder in einem fahrenden Auto sitzt? Warum wird der Kompass bei eingeschaltetem GPS-Modul "unruhig"?

    "GPS Status" bietet ja die Möglichkeit, die A-GPS-Daten manuell zu löschen bzw. neu zu laden. Das bringt bei mir gar nichts, einen Sat-Fix in der fahrenden Bahn habe ich nicht hinbekommen.

    Hinter diesen Tests steht natürlich die Frage, ob GPS-Modul/Lagesensor/Kompass bei meinem Gerät möglicherweise defekt sind. Wenn es an der Firmware liegt, müssten ja eigentlich alle hier mit einem Standard-ROM diese Probleme haben...

    Würde mich über Euer Feedback zu den obigen Fragen freuen.

    Gruß
    JCool

    Für mich wichtig:
    Bitte nur Tipps zum Standard-LG-ROM! Ich nutze kein Custom-Room und möchte auch nicht rooten.
     
  2. BigM83, 10.05.2011 #2
    BigM83

    BigM83 Android-Hilfe.de Mitglied

    Beiträge:
    62
    Erhaltene Danke:
    7
    Registriert seit:
    04.04.2011
    Hi.

    Also ich kann dir nur bei der Kompassproblematik helfen, da schaut es nämlich wie folgt aus:
    Ein Kompass misst ein magentisches Feld und überall wo Strom fließt wird auch ein magnetisches Feld erzeugt (In Abhängigkeit der Stromstärke). Und Metall in der Nähe beeinflusst magnetische Felder, also auch das der Erde.
    -> In Zügen, U-Bahn, Auto, unter Hochspannungsmasten oder Bahntrassen etc. etc. kannst du dich nicht 100%ig auf den Kompass verlassen.

    Ich selber hatte mal den Auftrag einen hochgenauen Magnetfeldsensor zu entwicklen und kann dir sagen, dass du schon Probleme bekommst wenn in 6 bis 7 Meter Entfernung ein LKW vorbei fährt!

    Der Rest mit dem GPS ist echt ärgerlich!

    Greez
    BigM
     
  3. Melonos, 11.05.2011 #3
    Melonos

    Melonos Android-Lexikon

    Beiträge:
    955
    Erhaltene Danke:
    179
    Registriert seit:
    13.04.2011
    Phone:
    Samsung Galaxy S5 (G900)
    Bei mir dauert es mit dem Fix auch ewig, obwohl ich die Schritte aus dem thread zur GPS-Genauigkeit durchgeführt habe.

    Hier bei mir am fenster im Büro kann ich das Fenster öffnen und das Gerät direkt dahin legen und bekomme gar keinen Fix - auch nicht nach Stunden.
    Gut, das fenster geht nach Norden und die Satelliten stehen eher in der anderen Richtung, aber trotzdem sollte es irgendwann gehen.
     
  4. JCool, 11.05.2011 #4
    JCool

    JCool Threadstarter Android-Experte

    Beiträge:
    690
    Erhaltene Danke:
    89
    Registriert seit:
    25.02.2010
    Phone:
    Nexus 5X
    Tablet:
    Nexus 10
    Zeigt Dir den das LGOS (z.B. mittels App "GPS Status") denn überhaupt Satelliten an? Bei mir tauchen immerhin Satelliten auf, nur der dann noch notwendig Fix kommt nicht/dauert ewig.

    Da wenigstens schon mal Satelliten erkannt werden, hoffe ich auf einen Softwarefehler - oder wird der Sat-Fix durch Hardware realisiert?. Wenn noch nicht einmal Satelliten aufgeführt werden, ist vielleicht doch die Hardware defekt?
     
  5. Melonos, 11.05.2011 #5
    Melonos

    Melonos Android-Lexikon

    Beiträge:
    955
    Erhaltene Danke:
    179
    Registriert seit:
    13.04.2011
    Phone:
    Samsung Galaxy S5 (G900)
    Satelliten werden mir schon angezeigt, allerdings nicht in richtung Norden.
    Wahrscheinlich sind da gerade keine...
     
  6. scroogle, 12.05.2011 #6
    scroogle

    scroogle Junior Mitglied

    Beiträge:
    36
    Erhaltene Danke:
    0
    Registriert seit:
    11.05.2011
    Hi,

    ja bei mir ist das mit den Satelliten ebenso, ich nutze die App GPS Test,
    mit dieser bekomme ich auch mehrere Sattelitten (zuerst meist 4 bis 5 und nach kurzer Zeit 7 bis 9) angezeigt aber nicht als aktiv.

    Irgendwie scheint hier in der Software das Mapping nicht zu funktionieren.

    FRAGE: Hat das bereits ein anderere/r gehabt und gelöst?

    Wenn ich das nicht zum Laufen bekomme werde ich das LGOS zurückgeben müssen.

    Gruß
     
    Zuletzt bearbeitet: 12.05.2011
  7. JCool, 12.05.2011 #7
    JCool

    JCool Threadstarter Android-Experte

    Beiträge:
    690
    Erhaltene Danke:
    89
    Registriert seit:
    25.02.2010
    Phone:
    Nexus 5X
    Tablet:
    Nexus 10
    Ich habe es bislang in einem anderen Thread so verstanden, dass die A-GPS Implementierung von LG nicht korrekt (für Deutschland) ist. Denn nur mittels A-GPS ist ja ein schneller SAT-Fix möglich. Wenn man rooten möchte, scheint es eine manuelle Lösung für dieses Problem zu geben.
    Da ich allerdings nicht rooten möchte, wollte ich nur erst einmal sichergehen, dass mein GPS-Modul hardwareseitig in Ordnung ist (denn sonst müsste ich das LGOS ja tauschen). Da bislang noch niemand wiedersprochen hat, hoffe ich mal, dass das GPS-Modul läuft, wenn wenigstens schon mal Satelliten gefunden werden.
    Ein funktionierendes A-GPS wird dann hoffentlich bald softwareseitig von LG nachgeliefert. So wie zur Zeit geht es wirklich nicht und ist praktisch nicht nutzbar.
     
  8. scroogle, 12.05.2011 #8
    scroogle

    scroogle Junior Mitglied

    Beiträge:
    36
    Erhaltene Danke:
    0
    Registriert seit:
    11.05.2011
    Ja JCool,

    rooten wollte ich jetzt auch noch nicht, ist mein erstes Android.
    Klar nach ner Weile werde ich mich mehr und mehr einarbeiten, aber im Moment erwarte ich einfach bei einem Teil für 400 Euronen, dass sowas funktioniert.

    Da es bei anderen ja durchaus funktioniert und ich wie Du (hoffe Du ist OK) denke, dass das GPS Modul an sich funktioniert, sonst könnten die Satelliten ja nicht erkannt werden, sollte es doch machbar sein.

    Gruß
     
  9. LG-Tommi, 12.05.2011 #9
    LG-Tommi

    LG-Tommi Android-Hilfe.de Mitglied

    Beiträge:
    108
    Erhaltene Danke:
    5
    Registriert seit:
    02.05.2011
    Ich habe dieselben Probleme.
    WEiß einer, ob diese Base-BAnd-sache aus dem anderen Thread das Problem behebt?

    lg, Tommi
     
  10. scroogle, 12.05.2011 #10
    scroogle

    scroogle Junior Mitglied

    Beiträge:
    36
    Erhaltene Danke:
    0
    Registriert seit:
    11.05.2011
    Hi Tommi,

    also ich habe bei mir als Baseband 1035.21_20110405 und da habe ich die beschriebenen Probleme, es ist wohl die aktuelle somit würde ich behaupten Nein.

    Als LGE habe ich die V10b

    werde evtl. mal nach einem Update auf V10c schauen und drauf machen, zuvor aber noch alles sichern und erst mal einen Reset machen, hoffentlich ist es dann schon besser.

    Viele Grüße

    scroogle
    (the anonym use of google)
     
  11. LG-Tommi, 12.05.2011 #11
    LG-Tommi

    LG-Tommi Android-Hilfe.de Mitglied

    Beiträge:
    108
    Erhaltene Danke:
    5
    Registriert seit:
    02.05.2011
    Hi Scroogle,
    danke für die Antwort. Halte uns mal auf dem Laufenden.

    @All:
    Kann ich c überhaupt noch aufspielen, wenn ich jetzt MoDaCo drauf habe?

    lg, Tommi
     
    scroogle bedankt sich.
  12. cpm

    cpm Erfahrener Benutzer

    Beiträge:
    151
    Erhaltene Danke:
    19
    Registriert seit:
    01.07.2009
    Auch wenn es weh tut, ich hab mein P990 jetzt eingepackt und hab die SIM wieder in mein Milestone 1 gesteckt. Quälend langsame Menüs, aber GPS-Fix im Gebäude bei 1 Meter Abstand zum Fenster. Wird es wohl doch ein SGS2 mit Sirf GPS Chip...... Schade für 404€ wäre es sonst ein Schnäppchen gewesen

    just my 2 ct.

    CPM
     
  13. JCool, 13.05.2011 #13
    JCool

    JCool Threadstarter Android-Experte

    Beiträge:
    690
    Erhaltene Danke:
    89
    Registriert seit:
    25.02.2010
    Phone:
    Nexus 5X
    Tablet:
    Nexus 10
    Also ich habe vor 2 Wochen das Update von LG eingespielt und habe nun also V10c.
    Beim GPS - oder sagen wir mal A-GPS - hat sich dadurch nichts verändert. Für einen Sat-Fix brauche ich noch immer Minuten...
     
  14. LG-Tommi, 13.05.2011 #14
    LG-Tommi

    LG-Tommi Android-Hilfe.de Mitglied

    Beiträge:
    108
    Erhaltene Danke:
    5
    Registriert seit:
    02.05.2011
    Hi Leute,
    ich konnte das Prob. jetzt mit den Tips aus dem anderen Thredd lösen, über diese Nokia-Dings-Umstellung im Hidden Menü. Es bedurfte keines Updates.
    Es haben sich sowohl die Geschindigkeit, als auch die Genauigkeit extrem verbessert. Ich komme jetzt bis auf 7 bis 7 m Genauigkeit und das, obwohl es hier heute richtig bedeckt ist.
    Das gilt für zu Fuß und im Auto.
    Also macht das wie in dem anderen Thread beschrieben und werdet froh.

    lg, Tommi
     
  15. JCool, 13.05.2011 #15
    JCool

    JCool Threadstarter Android-Experte

    Beiträge:
    690
    Erhaltene Danke:
    89
    Registriert seit:
    25.02.2010
    Phone:
    Nexus 5X
    Tablet:
    Nexus 10
    Es gibt einen Thread mit Infos, wie man den A-GPS-Mode in den Griff bekommt (bzw. korrekt für die Nutzung in Deutschland einstellt). Allerdings brauchte man dafür Root-Rechte. Meinst Du den Thread?

    Gibt es überhaupt irgendjemanden mit einem Standard-ROM, beim dem der SAT-Fix wie gewohnt in wenigen Sekunden da ist? Denn wenn LG bei den A-GPS-Settings Mist gebaut hat, müsste ja jeder mit einem Standard-ROM diese GPS-Probleme haben.

    Irgendwie ist es doch schwer vorstellbar, dass die vielen Tausend LGOS-Nutzer in Deutschland (davon wahrscheinlich 99,9% mit dem Standard-ROM) alle das GPS nicht vernünftig nutzen können, weil LG beim A-GPS Mist gebaut hat...
     
    scroogle bedankt sich.
  16. LG-Tommi, 13.05.2011 #16
    LG-Tommi

    LG-Tommi Android-Hilfe.de Mitglied

    Beiträge:
    108
    Erhaltene Danke:
    5
    Registriert seit:
    02.05.2011
    Ja, ich glaube, wir reden über denselben Thread.

    Nach meinem Eindruck sin die wirklich üblen GPS-Fehler - von etwaigen Einzelfällen mal abgesehen - wohl wahrscheinlich eher auf das Einspielen der vielen Custom-Roms zurückzuführen. Die dürften nämlich die Europa-Einstellungen killen.

    Ich hatte auch den Eindruck, dass GPS mit Stock-Rom besser gegangen ist. Jetzt läuft es aber auch mit dem MoDaCo so gut wie vorher. Ob besserkann ich nicht genau sagen.

    lg, Tommi
     
    scroogle bedankt sich.
  17. ruditb, 13.05.2011 #17
    ruditb

    ruditb Junior Mitglied

    Beiträge:
    30
    Erhaltene Danke:
    12
    Registriert seit:
    05.05.2011
    Phone:
    LG G4
    Hallo,

    man kann die A-GPS Einstellungen auch verbessern ohne zu "rooten". Das steht in demselben Thread. Lediglich die fehlende GPS.conf kann man nur nachinstallieren wenn man das Gerät "rootet". Aber die Korrektur der APS Konfiguration hat bei mir schon mal derart geholfen, dass ich nach ca 10-20 Sekunden einen Fix bekomme. Allerdings muss ich dafuer draussen sein.

    Hier gibts eine deutsche Beschreibung wie man es macht:
    http://www.android-hilfe.de/root-ha...5761-how-gps-optimierungen-fuer-das-lgos.html

    Dort ab Schritt 2 den Anweisungen folgen. Dann bekommt man zumindest ein verbessertes A-GPS.

    Gruss
    RudiTB
     
    Zuletzt bearbeitet: 13.05.2011
    scroogle bedankt sich.
  18. scroogle, 13.05.2011 #18
    scroogle

    scroogle Junior Mitglied

    Beiträge:
    36
    Erhaltene Danke:
    0
    Registriert seit:
    11.05.2011
    Hi RudiTB,

    danke allein der Schritt 2 bringt enorm viel, möchte jetzt noch den Schritt 3 machen, bringt der noch was?

    Wenn ja ich habe noch keinen Launcher und im Marktplatz auch keinen Launcher pro gefunden um in das Hidden Menue zu kommen.
    Kann mir jemend einen Launcher empfehlen?
    Oder wie komme ich sonst ins Hidden Menue.

    Gruß scroogle
     
  19. MichaC., 13.05.2011 #19
    MichaC.

    MichaC. Android-Hilfe.de Mitglied

    Beiträge:
    124
    Erhaltene Danke:
    24
    Registriert seit:
    24.10.2010
    1809#*990# eingeben

    Gesendet mit der Android-Hilfe.de-App
     
    scroogle bedankt sich.
  20. JCool, 13.05.2011 #20
    JCool

    JCool Threadstarter Android-Experte

    Beiträge:
    690
    Erhaltene Danke:
    89
    Registriert seit:
    25.02.2010
    Phone:
    Nexus 5X
    Tablet:
    Nexus 10
    Jetzt habe ich es endlich geschafft, dass ich noch unter 30 Sekunden einen SAT-Fix habe - und das sogar im Gebäude hinter einer Scheibe. Immer noch Stock-ROM, immer noch ohne Root-Rechte.

    Die Lösung gab es in einem anderen Thread, in dem man für die A-GPS-Daten einen Nokia-Server einträgt :biggrin:

    Da nicht jeder lange suchen will, schreibe ich hier die Lösung auch einfach noch mal rein:

    Schritt 1:
    Der APN, über den man in das Internet geht, darf unter Typ nicht nur "default" stehen haben, sondern dort sollte "default,supl" stehen. Also einfach dort eintragen oder einen neuen APN mit diesen Werten anlegen und aktiv schalten.

    Schritt 2:
    Das Hidden-Menü aktivieren über Ziffernfeld: 1809#*990#

    Schritt 3:
    Im Hidden Menü dann den Nokia-Server eintragen:
    1. Menü "GPS Test"
    2. Menü "System Settings"
    3. Menü "MOLR Protocol", dort muss "User-Plane" gewählt sein
    4. Zurück und Menü "SULP Setting" und dann "SLP Server Setting"
    5. Neuen Server-Eintrag (über Menü-Taste) erzeugen. Daten slp address: supl.nokia.com, port: 7275, Certificate leer lassen und TLS nicht anhaken
    6. Den neuen Nokia-Server auswählen (Zeile muss markiert sein)
    7. Zurück und Haken bei "SLP Auto Provision" setzen
    8. Zurück und Menü "Misc", dort Haken bei "Auto Cold Start" setzen

    Hidden Menü mittels Back-Taste verlassen. Fertig.

    Hoffe, es hilft Euch weiter.
     
    Sip62, Slim Krid und scroogle haben sich bedankt.

Diese Seite empfehlen