1. Nimm jetzt an unserem 2. ADVENT-Gewinnspiel teil - Alle Informationen findest Du hier!

GPS-Tag beim Fotografieren tut nicht - Software Bug ?

Dieses Thema im Forum "Samsung Galaxy S Plus (I9001) Forum" wurde erstellt von matt44, 03.01.2012.

  1. matt44, 03.01.2012 #1
    matt44

    matt44 Threadstarter Android-Hilfe.de Mitglied

    Beiträge:
    63
    Erhaltene Danke:
    3
    Registriert seit:
    19.11.2011
    Hallo,

    leider funktioniert bei mir die GPS Funktion beim Fotografieren nicht richtig.
    Nur wenn ich in der Kamera "Serienbildfunktion" oder "Comic" (das bringt mich ja echt weiter) einstelle, werden die Koordinaten in die Exif-Daten geschrieben.

    Habe mir dann gestern für teuer Geld :drool: CameraZOOM FX geladen.
    Ergebis: hier tut es gar nicht (oder ich blicke es nicht).

    Könntet Ihr mal bitte austesten, wie es bei Euch ist.

    Meine Firmware: 2.3.3.


    Gruss Matthias
     
  2. matt44, 04.01.2012 #2
    matt44

    matt44 Threadstarter Android-Hilfe.de Mitglied

    Beiträge:
    63
    Erhaltene Danke:
    3
    Registriert seit:
    19.11.2011
    Hallo,

    es wäre echt super, wenn irgendeiner mal kurz sein GPS anschaltet, ein Bild macht und mir dann sagt, ob der GPS Tag im Bild ist.

    Grüsse Matthias
     
  3. SnoPoX, 04.01.2012 #3
    SnoPoX

    SnoPoX Android-Lexikon

    Beiträge:
    1,112
    Erhaltene Danke:
    523
    Registriert seit:
    07.12.2011
    Ich nutze 2.3.6 (I9001XXKPU_I9001XXKPH_I9001DBTKP1) und habe gerade mal ein Testfoto gemacht. Habe GPS aktivieren lassen, nachdem ich die Funktion "GPS Tag" in den Kameraeinstellungen angehakt habe.
    Habe zwei Fotos geschossen, bin dann in die Galerie und habe sie geöffnet. Dann "Auf Karte anzeigen" gewählt und zack, war Maps offen mit der Position (naja, ungefähr richtig). Also die GPS Koordinaten waren in den Bildern.
     
  4. xebit, 04.01.2012 #4
    xebit

    xebit Android-Experte

    Beiträge:
    696
    Erhaltene Danke:
    117
    Registriert seit:
    30.10.2011
    bei mir hat es auch funktioniert...
     
  5. Fulminator, 04.01.2012 #5
    Fulminator

    Fulminator Gast

    Ich vermute mal, es steht und fällt mit der Dauer bis zum ersten GPS-Fix...

    *************************
    (Mit Tapatalk)
     
  6. SnoPoX, 04.01.2012 #6
    SnoPoX

    SnoPoX Android-Lexikon

    Beiträge:
    1,112
    Erhaltene Danke:
    523
    Registriert seit:
    07.12.2011
    Probier das aus, hat bei mir auch geholfen, zumindest bekomme ich nun super schnell nen Fix. Vielleicht wirds ja dann auch mit den Bildern. Zurückstellen kann man die Änderungen im Zweifel ja auch noch, also auf einen Test würde ich es ankommen lassen :)

    -> xda-developers - View Single Post - [9001]GPS Lag

    vor dem Wählen des Codes -> GPS anmachen
     
  7. matt44, 04.01.2012 #7
    matt44

    matt44 Threadstarter Android-Hilfe.de Mitglied

    Beiträge:
    63
    Erhaltene Danke:
    3
    Registriert seit:
    19.11.2011
    Erst mal vielen Dank für die Hilfe.

    Am GPS Fix lag es bei mir nicht.
    Es tut ja, der GPS Tag wird aber nur dann ins Bild geschrieben, wenn ich ein mit der Serienbildfunktion mache. Mache ich dann ein Bild im Normalmodus, werden keine GPS Daten ins Bild gechrieben. UNd die Qualität der Serienbilder ist hat ziemlich mies.

    Mit CameraZOOM FX, das ich mir extra noch runtergeladen hatte, geht gar nichts.

    Ist das ein Bug in der Firmware 2.3.3. ?

    Aber viel falsch machen kann man hier doch nicht:

    1. GPS anschalten, Fix abwarten (habe GPS-Status, das sehe ich genau, was Sache ist).
    2. Kamera anschalten, GPS Funktion einschalten, in der Kamera wird das GPS Symbol sichtbar.
    3. So, und jetzt muss es funktionieren. Tut es aber nicht ?

    Weiß jemand Rat ?

    Gruss Matthias
     
  8. matt44, 04.01.2012 #8
    matt44

    matt44 Threadstarter Android-Hilfe.de Mitglied

    Beiträge:
    63
    Erhaltene Danke:
    3
    Registriert seit:
    19.11.2011
    Ich bin´s nochmal und jetzt versteh´ ich noch weniger.

    Probiert mal Folgndes: schaltet mal das GPS ein, und macht dann ein Bild im Normalmodus der Kamera.
    Wenn man sich dieses Bild jetzt in der Galerie anschaut, kann man die Option "Auf Karte anzeigen" aufrufen.
    Unter "Details" kommen dann auch die Koordinaten.

    So weit, so gut.

    Und jetzt schaut Euch dasselbe Bild man mit einem externen Viewer an, z.B. QuickPic. Hier werden keine GPS Daten mehr angezeigt.

    Und jetzt versucht mal, dieses Bild in einen anderen Ordner zu kopieren. Sobald man das gemacht hat, sind die GPS Daten weg.
    Ich habe das Bild auch per Mail an mich versandt, GPS Daten sind ebenfalls weg.
    Nur im Ausgangssordner werden die GPS Daten angezeigt und auch nur mit der Galerie.

    So: und wenn ich jetzt aber ein Serienbild mache, kann ich die Bilder beliebig verschieben und kopieren, der GPS Tag bleibt im Bild und wird auch mit QuickPic angezeigt.

    Ist das bei Euch auch so ?

    Gruss Matthias
     
  9. matt44, 21.01.2012 #9
    matt44

    matt44 Threadstarter Android-Hilfe.de Mitglied

    Beiträge:
    63
    Erhaltene Danke:
    3
    Registriert seit:
    19.11.2011
    Hallo,

    ich muss das Thema nochmal aufgreifen.

    Wäre echt super, wenn irgendjemand mal eine Aufnahme (volle Auflösung 5MP) mit GPS Tag machen könnte. Und dann verschiebt das Bild mal bitte mal in irgendeinen anderen Ordner. Ist der GPS Tag dann noch da ?

    Wie gesagt: bei meinen S+ (FW 2.3.3.) wird der GPS-Tag nur in die EXIF Daten geschrieben, wenn ich die Serienbildfunktion oder die Panoramaaufnahme nutze.
    Ist echt nervig, weil die Aufklösung hier halt sehr gering ist.

    Bei Samsung habe ich auch schon angefragt, die haben mir gertane, einen Werksreset durchzuführen. Bevor ich das mache und alle Daten weg sind, würde ich halt gerne wissen, ob das ein allgemeines Problem ist oder nur mein Gerät betrifft.

    Schon mal besten Dank im Voraus.

    Gruss Matthias
     
  10. braini, 21.01.2012 #10
    braini

    braini Android-Guru

    Beiträge:
    2,278
    Erhaltene Danke:
    861
    Registriert seit:
    13.09.2011
    Phone:
    OnePlusOne, LG G4(gekauft am 03.05.16, †am 26.07.)
    Tablet:
    Nexus 7 3G (2012)
    Mit FW 2.3.6 wurde die Kamera definitiv verbessert.
    Einen Versuch ist es wert.
    Gesendet mit der Android-Hilfe.de-App
     
  11. Curry_Snacker, 21.01.2012 #11
    Curry_Snacker

    Curry_Snacker Fortgeschrittenes Mitglied

    Beiträge:
    281
    Erhaltene Danke:
    31
    Registriert seit:
    16.01.2012
    Phone:
    bq Aquaris X5 Cyanogen Edition
    Das Selbe wollte ich auch schreiben @braini. Da wurde doch auch mit der neuen FW nicht nur die Cam, sondern auch das GPS verbessert, vielleicht hängt das auch damit zusammen und funktioniert nach dem Update. Versuch es doch mal =)
     
  12. matt44, 21.01.2012 #12
    matt44

    matt44 Threadstarter Android-Hilfe.de Mitglied

    Beiträge:
    63
    Erhaltene Danke:
    3
    Registriert seit:
    19.11.2011
    Updaten auf 2.3.6.
    Traue ich mich nicht, nachdem was ich hier gelesen habe.

    Vor allem wei0 ich immer noch nicht, ob das ein Porblem meines Handys ist oder ein generell ein Problem von 2.3.3.

    Ob sich ev. doch noch mal jemand die Zeit, nimmt um das mal auszutesten, was ich 2 Beiträge weiter oben geschrieben habe ?

    Gruss Matthias
     
  13. Rhonin, 29.05.2012 #13
    Rhonin

    Rhonin Android-Lexikon

    Beiträge:
    1,997
    Erhaltene Danke:
    1,246
    Registriert seit:
    28.09.2011
    Phone:
    XPeria Z3c
    Kann ich bestätigen, das funzt, aber der GPS-Tag ist nicht im bildeigenen EXIF gespeichert sondern wohl in einer separaten Datei extern. Denn wie auch schon berichtet, ist die GPS-Information bei Betrachtung mit einem externen Viewer verschwunden.

    Falls einer eine Lösung schon hat, bitte melden :) ich beginne parallel mal auch mit der Nachforschung. Ob eine externe Datei existiert und wie man die Daten dann in EXIF rein bekommt.

    Gruß

    Rhonin

    EDIT: Habe das hier noch gefunden im Forum. GPS -> EXIF
     
    Zuletzt bearbeitet: 29.05.2012
  14. mausbock, 29.05.2012 #14
    mausbock

    mausbock Android-Lexikon

    Beiträge:
    1,153
    Erhaltene Danke:
    189
    Registriert seit:
    03.03.2012
    Phone:
    Galaxy S7
    Tablet:
    Nexus 7 3G
    Hi, ich hatte es bereits in einen andern Thread geschrieben. Das Problem selbst kann ich nicht lösen, aber die fehlenden Infos nachträglich in das Bild schreiben. Hier mein Post von damals: http://www.android-hilfe.de/showthread.php?t=157809

    Die App haben schon mehere aus dem Forum bekommen und sie funktioniert.
     
  15. Rhonin, 29.05.2012 #15
    Rhonin

    Rhonin Android-Lexikon

    Beiträge:
    1,997
    Erhaltene Danke:
    1,246
    Registriert seit:
    28.09.2011
    Phone:
    XPeria Z3c
    Hatte ich gerade auch gefunden - sorry - Wie wäre es, wenn Du die apk einfach mal an ein Post hängst, wenn Du sie nicht im market veröffentlichen willst :biggrin: - Fände sicherlich nicht nur ich ziiiemlich klasse :thumbsup:

    Danke schon mal

    Rhonin
     
    mausbock bedankt sich.
  16. mausbock, 29.05.2012 #16
    mausbock

    mausbock Android-Lexikon

    Beiträge:
    1,153
    Erhaltene Danke:
    189
    Registriert seit:
    03.03.2012
    Phone:
    Galaxy S7
    Tablet:
    Nexus 7 3G
    Danke für den Hinweis! Wusste gar nicht, dass das hier so einfach geht. In anderen Foren, wo ich unterwegs bin, muss man teilweise sogar Bilder im Netz hosten, um sie anzuzeigen.
    Im verlinkten Beitrag ist jetzt die APK angehangen.
     

Diese Seite empfehlen