1. Nimm jetzt an unserem Uhans - 3. ADVENT - Gewinnspiel teil - Alle Informationen findest Du hier!

GPS - Verbindungsaufbau

Dieses Thema im Forum "HTC Legend Forum" wurde erstellt von guitargod, 20.03.2011.

  1. guitargod, 20.03.2011 #1
    guitargod

    guitargod Threadstarter Fortgeschrittenes Mitglied

    Beiträge:
    443
    Erhaltene Danke:
    43
    Registriert seit:
    14.04.2010
    Hi zusammen,

    manchmal nutz ich die Navi-Funktion von Google Maps.
    In letzter Zeit ist mir etwas sehr negatives aufgefallen. Der Verbindungsaufbau per GPS (also das Auffinden von Sateliten) dauert sehr lange. Als ich mein Legend neu gekauft hatte (April10) ging das meiner Meinung nach noch recht flott, jetzt wart ich bis zu eine halben Stunde.

    Die Navi-Funktion wird somit unbrauchbar, wenn man schon eine halbe Stunde vorher einschalten muss. Geschweige denn, was passiert, wenn man durch einen Tunnel fährt und von neuem ein Signal gesucht wird...

    Wie sieht's bei euch aus? Ähnliche Erlebnisse? Ideen für Abhilfe?

    Freundliche Grüße

    PS:
    GPS ist immer aus, außer wenn ich's wirklich brauche.
    Android 2.2 Stock
     
  2. Wazy, 20.03.2011 #2
    Wazy

    Wazy Android-Hilfe.de Mitglied

    Beiträge:
    109
    Erhaltene Danke:
    4
    Registriert seit:
    19.03.2011
    Da musst aber dazusagen, wie lange zuvor das GPS abgeschaltet war. Je länger die Pause, desto länger dauert es auch. Wobei natürlich eine halbe Stunde absurd ist.

    Wie lange dauert der Sat-Fix, wenn das GPS zum Beispiel nur 10 Minuten ausgeschaltet war. Teste am besten im Freien (nicht im Auto), um vergleichbarere Bedingungen zu haben. Hast du das Auto eventuell gewechselt?
     
  3. guitargod, 20.03.2011 #3
    guitargod

    guitargod Threadstarter Fortgeschrittenes Mitglied

    Beiträge:
    443
    Erhaltene Danke:
    43
    Registriert seit:
    14.04.2010
    Hi,
    hab mich eigentlich gar nicht auf das Auto bezogen. Meine Erfahrungen hab ich sowohl mit der Driving- als auch Walking-Navigation gemacht (alles unter Freiem Himmel).
    Ich kann mir die Füße in den Bauch stehen, aber die Verbindung kommt einfach nicht zu Stande. Erst nach ewiger Zeit (und ja - bis zu einer halbe Stunde!) tut sich was.

    Wie schon geschrieben schalt ich GPS eben erst ein, wenn ich es brauche. D.h. es ist mal ein paar Wochen aus, wenn ich es dann verwenden will, braucht das aufbauen der Verbindung so lang.

    Scheint so, als wär ich der Einzige, der so lange Wartezeiten hat?
     
  4. Skeezix, 20.03.2011 #4
    Skeezix

    Skeezix Fortgeschrittenes Mitglied

    Beiträge:
    258
    Erhaltene Danke:
    82
    Registriert seit:
    11.04.2010
    Phone:
    Xiaomi Redmi Note 4
    Dass ein GPS-Fix schon einmal 30 Minuten dauert, ist durchaus denkbar. Das sollte aber nicht vorkommen, wenn du deinem Legend erlaubst, die ungefähre Position per Mobilfunk zu bestimmen (AGPS = Assisted GPS). Schau mal unter Einstellungen/Standort & Sicherheit ob du Drahtlosnetzwerke aktiviert hast. Dann sollte der GPS-Satfix innerhalb von ein paar Sekunden funktionieren.

    Technische Hintergründe bei Wikipedia: Assisted Global Positioning System ? Wikipedia

    Gruß, Thomas
     
  5. guitargod, 20.03.2011 #5
    guitargod

    guitargod Threadstarter Fortgeschrittenes Mitglied

    Beiträge:
    443
    Erhaltene Danke:
    43
    Registriert seit:
    14.04.2010
    Hi,
    AGPS hab ich natürlich aktiviert. Hilft bei der Navigation mit Maps aber gar nix. Gibt ja schließlich nur den ungefähren Standpunkt an. Zum "echten" navigieren braucht es aber genauere Koordinaten, wie sie eben GPS liefert. Und eben das braucht lang, länger als ich es gewohnt bin...deshalb die Frage meinerseteits, ob ihr schon ähnliches beobachtet habt...aber wohl anscheinend nicht. Hätte ja sein können, dass sich da auf Grund des 2.2 Updates was geändert hat, oder auch, dass ich einen HW-Defekt hab, da ich die Navigation lang nicht genutzt hab (das letzte mal wahrscheinlich vorm 2.2 Update..)
     
  6. Wazy, 21.03.2011 #6
    Wazy

    Wazy Android-Hilfe.de Mitglied

    Beiträge:
    109
    Erhaltene Danke:
    4
    Registriert seit:
    19.03.2011
    Das ist nur für die Geschwindigkeit des Erstfix relevant.

    Wie lange braucht dein Erstfix, wenn du nur die typischen 10 Stunden GPS-Pause machst, nicht die erwähnten "Wochen"?
     
  7. Skeezix, 21.03.2011 #7
    Skeezix

    Skeezix Fortgeschrittenes Mitglied

    Beiträge:
    258
    Erhaltene Danke:
    82
    Registriert seit:
    11.04.2010
    Phone:
    Xiaomi Redmi Note 4
    Es geht bei AGPS ja auch nicht um die Navigation, sondern um den ersten fix.
    Wenn du GPS einschaltest, weiß dein Handy erst einmal prinzipiell überhaupt nicht, wo es ist, geschweige denn, welche GPS-Satelliten gerade am Himmel sind. Also wird erstmal kräftig geguckt, was denn so alles empfangen wird.
    Wenn du dir den Wikipedia Artikel durchliest, wirst du die Details genauer kennenlernen.
    Hat das Handy aber über AGPS eine ungefähre Position und noch dazu eine hinreichend genaue Uhrzeit, kann es die relevanten Satelliten ziemlich schnell herausfinden. Ein GPS-Fix bei meinem Legend dauert keine 10 Sekunden.

    Damit das in dieser Zeit funktioniert, müssen zwei Bedingungen erfüllt sein:
    1. grobe Position über LBS bzw. sichtbare W-Lans
    2. vorhandene Internetverbindung

    1. könnte bei E-Plus Providern scheitern, da E-Plus zum 1.1.2011 LBS abgeschaltet hat.
    2. ist selbstredend

    Schau mal, wie es bei dir aussieht mit 1. und 2.

    Gruß, Thomas
     
  8. guitargod, 22.03.2011 #8
    guitargod

    guitargod Threadstarter Fortgeschrittenes Mitglied

    Beiträge:
    443
    Erhaltene Danke:
    43
    Registriert seit:
    14.04.2010
    Hab's jetzt ein paar mal probiert. Mein Betreiber ist übrigens drei Österreich, AGPS funktioniert im Maps ganz gut.

    Verbindungsaufbau dauert trotzdem ewig...irgendwann geht's dann aber. Kann man wohl nix machen.
     
  9. Tanis64, 22.03.2011 #9
    Tanis64

    Tanis64 Android-Experte

    Beiträge:
    653
    Erhaltene Danke:
    309
    Registriert seit:
    14.04.2010
    Phone:
    Samsung Galaxy S4
    Servus,
    Was für eine Version von Android läuft auf Deinem Legend ? Wenn es die 2.2 ist, check mal ob es vieleicht der Init bug ist.
    Der frisst bis zu 80% der Systemleistung - Workaround unter Einstellungen Anwendungen Entwicklung USB Debugging einschalten, Legend neu starten. Ansonsten lade Dir mal GPS Status aus dem Market, da gibt es die Möglichkeit unter Menutaste, Tools A-GPS-Daten, diese direkt runterzuladen.
    Gruß Christopher

    Sent from my GT-I9000 using Tapatalk
     
  10. guitargod, 23.03.2011 #10
    guitargod

    guitargod Threadstarter Fortgeschrittenes Mitglied

    Beiträge:
    443
    Erhaltene Danke:
    43
    Registriert seit:
    14.04.2010
    Hi, USB Debugging ist aktiviert...init bug macht also hier keine Probleme...
     

Diese Seite empfehlen