1. Nimm jetzt an unserem Uhans - 3. ADVENT - Gewinnspiel teil - Alle Informationen findest Du hier!

H264 Videos (720p und 1080i) abspielen?

Dieses Thema im Forum "Lenovo IdeaPad A1 Forum" wurde erstellt von Lenoid, 04.03.2012.

  1. Lenoid, 04.03.2012 #1
    Lenoid

    Lenoid Threadstarter Android-Guru

    Beiträge:
    2,378
    Erhaltene Danke:
    447
    Registriert seit:
    25.12.2011
    Phone:
    Sony Ericsson Xperia Pro
    Tablet:
    Samsung Galaxy Note 8.0 (N5110)
    Ich habe eine externe Festplatte an meine FritzBox angeschlossen und als Fritz.NAS eingerichtet. Darauf lagern Filme, die ich aus aus dem Fernsehen aufgenommen habe. Alle sind als Transportstream (.ts) aufgenommen. Zugriff auf die Filme ist auch kein Problem.

    Soweit alles ok. Das Problem ist, dass selbst SD-Videos (MPEG2) noch leicht ruckeln wenn ich sie auf dem A1 abpielen lassen möchte. Von H264 in 720p bzw. 1080i ganz zu schweigen.

    Ich nutze den MX Video Player, versucht habe ich S/W-Rendering und H/W-Rendering. Ich weiß, dass das A1 micht die stärkste Hardware hat, aber vielleicht kennt jemand einen Player mit besserem Rendering. Gerade SD in MPEG2 sollte doch problemlos möglich sein.
     
  2. Schippi, 04.03.2012 #2
    Schippi

    Schippi Android-Experte

    Beiträge:
    496
    Erhaltene Danke:
    66
    Registriert seit:
    27.12.2011
    Probier mal den "MoboPlayer" , der spielt bei mir bis 720p alles ziemlich ruckelfrei ab.
    SD Videos einwandfrei.
    Aber das A1 hat leider Probleme mit Videos.

    Gesendet von meinem A1_07 mit der Android-Hilfe.de App
     
    Zuletzt bearbeitet: 05.03.2012
  3. Lenoid, 05.03.2012 #3
    Lenoid

    Lenoid Threadstarter Android-Guru

    Beiträge:
    2,378
    Erhaltene Danke:
    447
    Registriert seit:
    25.12.2011
    Phone:
    Sony Ericsson Xperia Pro
    Tablet:
    Samsung Galaxy Note 8.0 (N5110)
    Dank für den Tipp! Ich habe den Moboplayer gerade ausprobiert. Wenn er mal ein Video abspielt, dann leider auch nicht besser als MX. MPEG2 spielt er seltsamerweise gar nicht ab, H264 nur manchmal, WMV ist auch nicht besser als MX.
     
  4. jwusel, 05.03.2012 #4
    jwusel

    jwusel Android-Hilfe.de Mitglied

    Beiträge:
    147
    Erhaltene Danke:
    23
    Registriert seit:
    18.02.2012

    Moin, Moin, bei mir funktionieren der MX Video Player Pro sowohl der Mobo Video Player Pro über eine Fritz!Box Fon 7390 mit Labor FRITZ!OS 05.09-21864 BETA und den gängigen Video Codecs in der Auflösung 1280x720 beide gleich gut. Sie laufen sauber und flüssig.

    Ich benutze hauptsächlich die Apps iMediaShare 4.02 mit Fritz!App Media V.028 und MXVideo Player Pro 1.5a

    Manchmal gibt es mit dem Codec: H264 – MPEG-4 AVC (part 10) (avc1) Probleme über WLAN N, aber nicht immer.

    Schau mal mit WiFi Finder, wie viele Leute bei Dir auf dem gleichen Kanal senden und empfangen. Das ist ein großes Problem für Videostreams.

    Gruß jwusel
     
  5. Lenoid, 05.03.2012 #5
    Lenoid

    Lenoid Threadstarter Android-Guru

    Beiträge:
    2,378
    Erhaltene Danke:
    447
    Registriert seit:
    25.12.2011
    Phone:
    Sony Ericsson Xperia Pro
    Tablet:
    Samsung Galaxy Note 8.0 (N5110)
    Hi, ich habe eine FritzBox 3270 samt aktueller Final-Firmware. Der WLAN-Kanal ist bereits so eingestellt, dass es da keine Überlappungen gibt. Die Videos ruckeln selbst dann, wenn ich direkt neben der FritzBox bin.
    Mit meinem Notebook (WLAN G) habe ich selbst bei 1080i keinerlei Probleme obwohl das ein Stockwerk höher ist. An der FritzBox kann daher eigentlich nicht liegen, oder?

    Aufzeichnen tue ich die Filme immer so wie sie gesendet werden (TS halt, nichts wird konvertiert).

    Ich werde heute mal iMediaShare und Fritz!App Media ausprobieren.

    Was ist am MX Media Player Pro eigentlich besser? Im Market steht nichts darüber.
     
    Zuletzt bearbeitet: 05.03.2012
  6. Forwarder78, 05.03.2012 #6
    Forwarder78

    Forwarder78 Android-Hilfe.de Mitglied

    Beiträge:
    88
    Erhaltene Danke:
    53
    Registriert seit:
    13.02.2012
    Steht doch groß dabei im Market:
    "DIES IST DIE WERBEFREIE VERSION..."


    Gesendet von meinem A1_07
     
  7. wolliw, 05.03.2012 #7
    wolliw

    wolliw Android-Hilfe.de Mitglied

    Beiträge:
    131
    Erhaltene Danke:
    4
    Registriert seit:
    19.08.2011
    Hallo zusammen,
    Habe auf Grund der Hinweise hier auch mal schnell die beiden Apps installiert. FritzMedia kann das Medium nicht abspielen.
    Mit imediashare Lite funktioniert es ganz prima. Ich bin echt begeistert.
    Ich kann auch bequem auf freigegebene Filme via Netzwerk vom PC zugreifen.

    Gesendet von meinem A1_07 mit der Android-Hilfe.de App
     
  8. Lenoid, 05.03.2012 #8
    Lenoid

    Lenoid Threadstarter Android-Guru

    Beiträge:
    2,378
    Erhaltene Danke:
    447
    Registriert seit:
    25.12.2011
    Phone:
    Sony Ericsson Xperia Pro
    Tablet:
    Samsung Galaxy Note 8.0 (N5110)
    Ok, habe ich glatt übersehen. AdFree Android leistet ganze Arbeit, noch keine Werbung entdeckt. :laugh:


    Die beiden Apps werde ich später ausprobieren.
     
  9. Lenoid, 05.03.2012 #9
    Lenoid

    Lenoid Threadstarter Android-Guru

    Beiträge:
    2,378
    Erhaltene Danke:
    447
    Registriert seit:
    25.12.2011
    Phone:
    Sony Ericsson Xperia Pro
    Tablet:
    Samsung Galaxy Note 8.0 (N5110)
    Ich habe jetzt beide Apps ausprobiert.

    Fritz!App Media kann leider keine Videos wiedergeben. Hier wird nur die Audiospur wiedergegeben.

    iMediaShare spielt leider auch nichts ab. Hier komme ich in eine Endlosschleife wenn ich das Video auswähle: "Mein Telefon" -> "Aktion durchführen mit" (iMediaShare) -> "Mein Telefon" -> usw.
    Das Ganze habe ich mit H264 (720p, 1080i), MPEG2 (SD) (alle drei jeweils als TS) und WMV (SD) probiert. Wenn ich die Datei mit dem ES Datei Explorer in den MX Video Player öffne, wird sie abgespielt, es ruckelt halt.
    Weiß jemand Rat?
     
  10. jwusel, 06.03.2012 #10
    jwusel

    jwusel Android-Hilfe.de Mitglied

    Beiträge:
    147
    Erhaltene Danke:
    23
    Registriert seit:
    18.02.2012
    So, jetzt habe ich mal folgendes gemacht:

    Ich habe einen kleinen Film zu Testzwecken konvertiert.
    Ausgangsvorrausetzung ist folgende:

    1. USB Festplatte als Fritz!NAS System an Fritz!Box 7390; WLAN N System; Power max. 300 MBit/s Brutto.

    2. IdeadPad Tablet A1_07, WLAN N System; Power max. 65 MBit/s Netto

    3. Film Format: 720p; 30 Bilder/s; Codec: H264 – MPEG-4 AVC (part 10) (avc1)

    Bei der Wiedergabe mit allen Playern muss das A1 den Film öfters nachladen und kommt somit ins stocken.

    Ich habe nun den Film konvertiert.

    4. Film Format: 720p; 30Bilder/s; Codec: H264- MPEG-4 xViD

    Die Wiedergabe klappt mit allen Playern vorzüglich.

    Fazit: Man könnte sagen, das A1 hat ein Problem mit dem avc1 Codec.

    Das war´s auf die Schnelle.

    Gruß jwusel
     
    knulle, Lenoid und ollborg haben sich bedankt.
  11. Lenoid, 06.03.2012 #11
    Lenoid

    Lenoid Threadstarter Android-Guru

    Beiträge:
    2,378
    Erhaltene Danke:
    447
    Registriert seit:
    25.12.2011
    Phone:
    Sony Ericsson Xperia Pro
    Tablet:
    Samsung Galaxy Note 8.0 (N5110)
    Die Ausgangssituation ist bei mir gleich (bis auf die FritzBox, das A1 ist übrigens bei den Tests direkt daneben).

    Das Filmformat ist bei 720p (50 Bilder/s, Das Erste HD, ZDF HD, Arte HD) bzw. 1080i immer H264 MPEG4-AVC, bei SD MPEG2.
    Extra umkonvertieren lohnt sich sich für mich nicht, u.a. dauert es zu lange und vor allem habe ich nicht genug Platz auf der NAS-Platte.

    Dein Fazit klingt logisch, da habe ich wohl Pech gehabt. Du hast die Filme ja auch mit iMediaShare abgespielt.
    Aber warum bekomme ich die Filme in iMediaShare grundsätzlich nicht abgespielt?
    Und warum ruckelt im MX Video Player selbst MPEG2 SD? Liegt das vielleicht an der Bitrate (ca. 6Mbit)? Den getesteten Film hatte ich von Das Erste SD aufgenommen. Ich werde mal einen Film vom WDR auf das NAS kopieren und testen. Der hat nur die halbe Größe.

    Sollte das klappen versuche ich mal die Dateien mit TS-Doctor zu verkleinern. Der schneidet den Füllmaterial raus welches eigentlich nur Ballast ist. Die Bildqualität soll nicht verringert werden, nur die Dateigröße um ca. 50%.
     
  12. jwusel, 06.03.2012 #12
    jwusel

    jwusel Android-Hilfe.de Mitglied

    Beiträge:
    147
    Erhaltene Danke:
    23
    Registriert seit:
    18.02.2012
    Moin, Moin, ich spiele den Film nicht mit iMediaShare ab, sondern iMediaShare stellt nur die Verbindung zum NAS Media Server her, genau so wie man mit dem ES Datei Explorer eine Verbindung zum selbigen herstellen kann. Das Abspielen erfolgt mit den bereits bekannten Playern.

    Bei HDTV werden in der Regel zwischen 8 und 13 MBit/s übertragen. Das ist für das A1 in der Regel kein Problem. Mit meinem A1 empfange ich z. B die Sender ARD u. ZDF per Samsung SmartTV UE 40 D7090 und der Samsung App Smart View in hervorragender Qualität mit dem Codec MPEG-4 AVC.

    Meine Kamera kann max. 720p, 30 Bilder/s und verarbeitet die Aufnahmen mit dem Codec MPEG-4 AVC (part 10) (avc1). Aber bei manchen Filmen kommt das A1 ins stocken. Warum, weshalb? Der Fernseher spielt das ohne Probleme.

    MPEG 2, Format 720x556, spielt mein A1 ohne Probleme, auch bis zu 8 MBit/s.

    Es hilft nur probieren.

    Gruß jwusel
     
  13. Lenoid, 06.03.2012 #13
    Lenoid

    Lenoid Threadstarter Android-Guru

    Beiträge:
    2,378
    Erhaltene Danke:
    447
    Registriert seit:
    25.12.2011
    Phone:
    Sony Ericsson Xperia Pro
    Tablet:
    Samsung Galaxy Note 8.0 (N5110)
    Ich habe jetzt auch noch mal getestet.

    HDTV von Das Erste HD von ca. 12 MBit/s auf ca. 7 MBit/s (geschätzt) mit TS Doctor geschrumpft. Dieser Film ruckelt genauso wie zuvor.

    Einen anderen von Das Erste SD konnte ich von 7 MBit/s leider nicht wesentlich verkleinern.

    Jetzt habe ich noch einen Film vom WDR mit 3-4 MBit/s auf das NAS kopiert und siehe da, er läuft absolut flüssig. Alle Filme wurden mit derselben TV-Karte und demselben Aufnahmeprogramm aufgenommen und nicht bearbeitet (höchstens eben mit TS Doctor). Ich nutze den MX Video Player (Software Mode).
    Das A1 kommt wohl nur mit deutlich weniger als 7 MBit/s zurecht, so zumindest mein Eindruck. Warum bei dir 8 Mbit/s kein Problem sind ist mir ein Rätsel. Vielleicht liegt es daran, dass in meinem Film von Das Erste SD keine "unnötige Füllmenge" drin war (habe ich ja mit TS Doctor festgestellt, der die Datei nur minimal verkleinert hat) und in deinen sind vielleicht Füllmengen die das A1 gar nicht berechnen muss. Das wäre eine Theorie von mir.
    Ich werde morgen noch mal ein paar SD-Filme mit hoher Bitrate per TS Doctor verkleinern und schauen, ob sich die Dateigröße verringern lässt und wenn ja ob sowohl Ursprungsdatei als auch die verkleinerte Datei sich problemlos abspielen lassen.
     
  14. jwusel, 07.03.2012 #14
    jwusel

    jwusel Android-Hilfe.de Mitglied

    Beiträge:
    147
    Erhaltene Danke:
    23
    Registriert seit:
    18.02.2012
    Hallo, ja präzise Messergebnisse kann ich so auch nicht liefern. Aber gefühlsmäßig über den Damen geblickt, kann ich auch nur feststellen, es geht oder es geht nicht.

    Für den SD Test, Format 576i, habe ich von einer Original-CD, von der ich weiß, dass diese eine sehr hohe Bitrate ausweist, eine VOB Datei extrahiert.

    Diese habe ich auf das NAS System kopiert und über WLAN n mit dem A1 empfangen. Die Qualität ist ausgezeichnet.

    Es muss an den HDTV und SDTV Streams liegen! Das kann ich aber leider mit meinen Möglichkeiten nicht nachvollziehen.

    Gruß jwusel
     
  15. New-A-One, 07.03.2012 #15
    New-A-One

    New-A-One Erfahrener Benutzer

    Beiträge:
    206
    Erhaltene Danke:
    15
    Registriert seit:
    05.02.2012
    Es ist auch ein riesen Unterschied, ob die Files über DLNA (Netzwerk) oder direkt vom Gerät abgespielt werden.

    Selbst wenn die Datenraten im Netzwerk theoretisch ausreichen, sieht es in der Praxis teilweise anders aus.

    Greetz
     
  16. Lenoid, 07.03.2012 #16
    Lenoid

    Lenoid Threadstarter Android-Guru

    Beiträge:
    2,378
    Erhaltene Danke:
    447
    Registriert seit:
    25.12.2011
    Phone:
    Sony Ericsson Xperia Pro
    Tablet:
    Samsung Galaxy Note 8.0 (N5110)
    Jetzt ist es mir auch klar, warum jwusel keine Probleme hat. Er streamt einfach die Datei weiter und nicht das Videosignal. D.h. das A1 hat auch keine große Arbeit.
    Weil MPEG2 müsste das A1 sonst problemlos abspielen können. Tut es aber nicht bei zu hohen Bitraten.

    Ich habe heute nochmals SD getestet und komme zum selben Ergebnis.
    Das A1 ist halt einfach nicht für Filme gemacht. :(
     
  17. jwusel, 07.03.2012 #17
    jwusel

    jwusel Android-Hilfe.de Mitglied

    Beiträge:
    147
    Erhaltene Danke:
    23
    Registriert seit:
    18.02.2012
    Moin, Moin,

    ein DVD VOB-File ist MPEG 2, mit 576i. Natürlich wird das File über WLAN n gecodet und gestreamt , anschließend dekodiert der VideoPlayer den Stream. Der Prozessor im A1, der ARMv7, hat genügend mit so einem riesigen Input zu tun.

    So, nach vielen Tests
    mit und ohne WLAN n, 300 MBit (brutto)
    bei unterschiedlichen VideoCodecs und Containern
    mit einer Auflösung von 720p und 50 Bildern/s,
    kann ich für mich feststellen,
    dass der VideoCodec XviD im AVI Container
    am besten bei allen Konfigurationen abgeschnitten hat.

    Ich habe das IdeaPad A1 geflasht und gerootet;
    den CPU Wert auf Min 800 - 1000 Max gesetzt.

    Es klappt bei mir ausgezeichnet!!!

    Gruss jwusel
     
  18. Skelli, 08.03.2012 #18
    Skelli

    Skelli Android-Hilfe.de Mitglied

    Beiträge:
    107
    Erhaltene Danke:
    21
    Registriert seit:
    10.12.2011
    Mehr als 65 Mbit/s scheint das Tablet gar nicht zu schaffen, zumindest meldet mir das mein Router. Während meine PCs 300 Mbit/s erreichen, kommt mein Samsung Galaxy übrigens auch nicht über 65 Mbit/s
     
  19. Catzenjaeger, 08.03.2012 #19
    Catzenjaeger

    Catzenjaeger Android-Hilfe.de Mitglied

    Beiträge:
    89
    Erhaltene Danke:
    0
    Registriert seit:
    21.02.2012
    Bittte noch einmal im Klartext:

    ich möchte Filme die ich auf meiner neuen externen 32gb karte draufpacke abspielen. Ich möchte diese am TV und auch im gerät selbst ausgeben. Software gibts ja dafür. Allerdings schmiert mein Bluray Player von Sony ab (muss netzstecker ziehen) wenn ich versuche 1 gb große Datein abzuspielen. Mit dem internen Player (mojo) gehts aber das Format stimmt nicht.

    Könnt ihr noch einmal posten wie ich Filme genau konvertieren muss damit die gut ausschaun? ich meine welche größe? Das a1 müßte ja eigentlich breitbild haben oder?
    welche Codecs muss ich einstellen damit alles perfekt läuft? Hier gibts ja unterschiedliche Meinungen und Erfahrungen - vielleicht kann man eine kleine FAQ machen und die stickern weil das Thema Filme bestimmt noch öfters kommt.

    Danke schonmal an alle
     
  20. jwusel, 08.03.2012 #20
    jwusel

    jwusel Android-Hilfe.de Mitglied

    Beiträge:
    147
    Erhaltene Danke:
    23
    Registriert seit:
    18.02.2012
    Moin, Moin,

    das ist ja auch so ok. Die Übertragungsrate von 65 MBit/s (Netto) sollte allemal unter guten Bedingungen ausreichen, ein Video-File in der Größenordnung von 720p einwandfrei zu übertragen (streamen). Mein Smartphone macht auch 65 MBit/s, das TV Gerät schafft 135 MBit/s, meine Wii schafft 54 MBit/s (WLAN g), unter Homebrew Channel mit Wii Media Player 1.2.3 und Zwischenspeicher-Füllung von 100%, und das IdeaPad A1 macht auch seine 65 MBit/s.

    Sämtliche Geräte können einen 720p AVI-Videostream mit dem Codec xVid ohne Verzögerungen komplett abspielen. Nur die Wii musste öfters ein paar Mal nachladen.

    Ach so, der WLAN n Standard geht bis max. 600MBit/s.

    Guss jwusel
     

Diese Seite empfehlen