1. Nimm jetzt an unserem 2. ADVENT-Gewinnspiel teil - Alle Informationen findest Du hier!

Handy connected nicht im fastboot

Dieses Thema im Forum "LG GW620 Forum" wurde erstellt von Thenos, 31.01.2011.

  1. Thenos, 31.01.2011 #1
    Thenos

    Thenos Threadstarter Junior Mitglied

    Beiträge:
    32
    Erhaltene Danke:
    0
    Registriert seit:
    31.01.2011
    Hey^^

    hoffe das ist wirklich das erste posting des problems...wen nicht habich wohl was in der sufu übersehen oder nicht gefunden.
    Das Problem ist das ich mein GW620 auf Android 2.2 setzten wollte wofür ich es in den fastboot bringen musste...nachdem ich das getan hatte schloss ich es an und wollte es nach einer anleitung (YouTube - How to Install Android 2.2 onto LG EVE GW620 using Windows 7!) anschliesen und "formatieren" aber mein pc hat es nicht erkannt. Es gab einen error ton vom pc (hab übbrigends Win7 x64) und ich versuchte den treiber zu löschen beim gerätemanager.

    Aber immer wen ich ihn deinstalliere das handy ausstecke und wieder einstecke, installiert sich kein neuer treiber sondern der alte namens Android 1.0 mit dem es sich nicht verbinden lässt.

    Kann mir da jemand weiter helfen wie ich es hinkriege das es verbindet oder ein neuer treiber geladen wird?

    Edit: Hab den kompletten Thread von Froyo 2.2.1 läuft auf GW620 durchgelunzt aber nicht gefunden. Hab wie dort steht den treiber deinstalliert und neu angeschlosse, nix passiert...auch nicht an einen anderen Win 7 pc anzuschliesen hilft nicht. Und an nen Win Vista auch nicht und treiber habe ich niergends verwendtbare gefunden..alle funzen nicht.
    Edit2: hab auch den WinFlasher versucht, allerdings findichim usb driver ordner zwar dateien aber nichts um treiber zu installieren oder sowas.

    Vielen dank im vorraus für hilfe
     
    Zuletzt bearbeitet: 01.02.2011
  2. Thenos, 06.02.2011 #2
    Thenos

    Thenos Threadstarter Junior Mitglied

    Beiträge:
    32
    Erhaltene Danke:
    0
    Registriert seit:
    31.01.2011
    Könnte mir bitte jemand mal helfen... das Problem hatte bisher offenbar echt keiner...
     
  3. th_e86, 07.02.2011 #3
    th_e86

    th_e86 Android-Hilfe.de Mitglied

    Beiträge:
    97
    Erhaltene Danke:
    3
    Registriert seit:
    19.11.2010
    Hast du die Treiber denn manuell ausgewählt? Also im Gerätemanager Gerät auswählen -> "Treibersoftware aktualisieren" -> "manuelle Suche" -> "Aus einer Liste wählen" -> "alle Geräte anzeigen" -> "Verzeichnis wählen" (müssen nicht die genauen Bezeichnungen sein). Von den Nicht signierten Treibern benötigst du das "Android ADB Interface". Falls er es nicht installieren kann, machst du das gleiche Prozedere mit einen der anderen mit Fragezeichen versehen USB Geräte (waren bei mir um die 4).

    Den USB Treiber erhältst du z.B. wenn du das Android SDK installierst und dort die USB Treiber herunterlädst. Im entsprechenden Verzeichnis müsste dann noch eine Datei namens Android_WindUSB sein. Die wählst du für o.g. Treiberinstallation aus. Vorher musst du sie laut OpenEtna noch editieren:

    • Note: For windows, you need to add this to your android_winusb.inf in the android sdk usb driver in the [Google.NTx86] section for x86 or in [Google.NTamd64] section for 64bit windows:
    • ;LG eve
      %SingleAdbInterface% = USB_Install, USB\VID_18D1&PID_D00D
      %CompositeAdbInterface% = USB_Install, USB\VID_18D1&PID_D00D&MI_01


    Vielleicht war ja was dabei, dass dich weitergebracht hat.
     
  4. Thenos, 07.02.2011 #4
    Thenos

    Thenos Threadstarter Junior Mitglied

    Beiträge:
    32
    Erhaltene Danke:
    0
    Registriert seit:
    31.01.2011
    Also das Problem ist unter andrem, es existiert unter der von dir beschriebenen Stellle kein Android ADB Interface, gibts bei mir nicht und in dem treiber ordner existiert bei mir auch keine Android_WindUSB datei sondern nur androi_usb, androidusb.sys, androidusba64 und WdfCoInstaller01005 dateien..
     
  5. th_e86, 07.02.2011 #5
    th_e86

    th_e86 Android-Hilfe.de Mitglied

    Beiträge:
    97
    Erhaltene Danke:
    3
    Registriert seit:
    19.11.2010
    Habe den Ordner mal hochgeladen. Irgendwohin entpacken und das Verzeichnis später bei der Geräteinstallation angeben.

    kostenlos Dateien hochladen bei File Upload X


    Zu dem Android ADB Interface: Das existiert auch noch nicht im Gerätemananger sondern du kannst es erst ganz zum Schluss bei der Treiberinstallation auswählen
     
  6. Thenos, 08.02.2011 #6
    Thenos

    Thenos Threadstarter Junior Mitglied

    Beiträge:
    32
    Erhaltene Danke:
    0
    Registriert seit:
    31.01.2011
    Ok hab alles so gemacht. Allerdings häng ich jetz wo anders und zwar beim fastboot -w. Habich den akku drin, kommt <waiting for device> und wennich den akku raus hab schlatet sichs immer wieder aus und ein und ich kann nichtmal mehr als 3 sec angemeldet sein mit dem gerät. Die Treiber sind jetz richtig drauf.
     
  7. N2k1, 17.02.2011 #7
    N2k1

    N2k1 Moderator Team-Mitglied

    Beiträge:
    7,896
    Erhaltene Danke:
    1,693
    Registriert seit:
    17.02.2011
    Wenn waiting for device kommt, ist der Treiber definitiv nicht richtig installiert.
     
  8. Thenos, 18.02.2011 #8
    Thenos

    Thenos Threadstarter Junior Mitglied

    Beiträge:
    32
    Erhaltene Danke:
    0
    Registriert seit:
    31.01.2011
    Also die Treiber sind 100% richtig drauf...sagt mir mein pc...es macht auch das typische geräusch dazu. Und ich hab alles nach th_e86's Anleitung gemacht...der muss richtig drauf sein. Kann ja mal an nem anderen pc versuchen
     
  9. N2k1, 18.02.2011 #9
    N2k1

    N2k1 Moderator Team-Mitglied

    Beiträge:
    7,896
    Erhaltene Danke:
    1,693
    Registriert seit:
    17.02.2011
    Was wird denn im Device-Manager angezeigt?
     
  10. alois25, 18.02.2011 #10
    alois25

    alois25 Android-Hilfe.de Mitglied

    Beiträge:
    49
    Erhaltene Danke:
    2
    Registriert seit:
    26.08.2010
    Ich habe exakt das gleiche Problem - nämlich "waiting for device" im Winflasher bei angeschlossenem GW620 im Fastboot-Modus.

    Irgendwas mache ich bei der Treiberinstallation offenbar falsch. Ich bitte um Fehlersuche:

    Ich habe unter Win7 mittels LG Mobile Support Tool den GW620-USBTreiber runtergeladen, dann meldete sich der Install Wizard, konfigurierte die neue Software-Instalation, dann kam die Meldung "LG Mobile Driver erfogreich installiert". (Es ist die LGWindowsMobile_USBDriver_WHQL_ML_Ver_1.0.exe)

    Als nun ich das Handy mit eingelegte SD-Karte per USB verband, erschien zwar eine Meldung, dass eine neue Hardware erkannt wurde, aber leider wird im Computer (Arbeitsplatz) kein Laufwerksbuchstabe oder ein Massenspeicher angezeigt.

    Alle anschließenden Versuche, dem Handy im Fastboot-Modus Froyo aufzuspielen, schljugen natürlich fehl, da der Winflasher beim entscheidenen Schritt "Wipe" einfach nur meldet: "waiting for device".

    Wie ich in verschiedenen Threads hier sehe, bin ich nicht der Einzige mit diesem Problem. Aber eine für mich verständliche Lösung habe ich nirgends gefunden. Einige Antworten haben mich sogar eher verwirrt. Ich bitte um eine halbwegs idiotensichere Anleitung, um die USB-Verbindung herzustellen. Danke!
     
  11. N2k1, 18.02.2011 #11
    N2k1

    N2k1 Moderator Team-Mitglied

    Beiträge:
    7,896
    Erhaltene Danke:
    1,693
    Registriert seit:
    17.02.2011
    Welches System nutzt Du?
    Welches System ist derzeit auf dem Telefon?
    Es gibt 5 Modi
    a) Fastboot (Leider ändern sich die VID und PID je nach benutzter Firmware)
    b) Emergency Mode (bei anderen Qualcomm Geräten Download Mode genannt)
    c) Normaler Modus (nur hier braucht man außer dem Emergency Mode die LG Treiber)
    d) USB Debugging Mode (Hier hat man die ADB Shell - ADB = Android Debugging Bridge)
    e) Massenspeicher Modus (Nur hier hat man vom PC aus den direkten Zugriff auf die Speicherkarte - leider unter Windows nicht immer erfolgreich)

    A erreicht man durch drücken der Leertaste wenn die Hintergrundbeleuchting an, aber sonst nichts auf dem Bildschirm ist
    B erreicht man durch drücken der "1" (und festhalten) während man das Telefon startet
    C/D ist im eingeschaltetem Zustand, je nachdem, ob man unter Setup/Developing/USB Debug den haken hat - oder eben nicht.
    E erreicht man, wenn man in der "Notification bar" auf USB geht und dann auf Massenspeicher (oder per Setup)

    Für alle 5 Modi braucht man den jeweiligen Treiber - sonst geht gar nichts.
    Für a und d kann man hier das passende Inf-File laden: Index of /n2k1/winprogs (Eins der beiden sollte passen)

    Sollte man Win x64 nutzen, so muß man das inf File noch editieren - oder mir die VID/PID mitteilen..
     
  12. Thenos, 19.02.2011 #12
    Thenos

    Thenos Threadstarter Junior Mitglied

    Beiträge:
    32
    Erhaltene Danke:
    0
    Registriert seit:
    31.01.2011
    1. Ich hab Windows 7 x64 also wo mussich was editieren?
    2. Hab Android 1.5 drauf.
    Bei den Treibern steht unter dem Verzeichniss Android Phones als Treiber " Android ADB Interface" was bedeutet ist habs richtig installiert...dennoch bei einstecken des handys das ich übrigends nicht ohne akku im fastboot starten kann da es dann immer wieder aus und angeht nur waiting for device

    Vllt machich ja was bei dem cmd ding falsch. Ich geb einfach ein "cd C:\Users\*****\Desktop\android-sdk-windows\tools" wo eben auch der ordner ist und dann einfach nachdem ich enter gedrückt hab noch "fastboot -w" vllt machich da was falsch aber danach kommt eben <waiting for device>
     
    Zuletzt bearbeitet: 19.02.2011
  13. N2k1, 20.02.2011 #13
    N2k1

    N2k1 Moderator Team-Mitglied

    Beiträge:
    7,896
    Erhaltene Danke:
    1,693
    Registriert seit:
    17.02.2011
    ADB = Android Debug Bridge..
    Das heißt, daß Du im Normalmodus per "ADB shell" auf das Handy zugreifen kannst.
    Was steht aber da, wenn Du es im Fastboot mode hast?
    Dann sollte was von "bootloader" dastehen..
     
  14. Thenos, 12.03.2011 #14
    Thenos

    Thenos Threadstarter Junior Mitglied

    Beiträge:
    32
    Erhaltene Danke:
    0
    Registriert seit:
    31.01.2011
    So hab das erasen hinbekommen auch wen über den winflasher es geht und beim normalen nicht aber wurstsalat.

    So ich hab jetz das problem das er beim writing boot bsolut immer ein failure bekommen....woran liegt das???

    Hab schon Amon Ra Recovery ausprobiert...dann kommt beim handy son auswahlfenster...ich bin dann auf wipe aber wie kann ich das bestätigen/ists das richtige?

    Achja und ich ahbs nach der Anleitung gemacht http://www.guimmer.co.cc/open-etna-winflasher/winflasher-3-1-tutorial
     
    Zuletzt bearbeitet: 12.03.2011
  15. N2k1, 12.03.2011 #15
    N2k1

    N2k1 Moderator Team-Mitglied

    Beiträge:
    7,896
    Erhaltene Danke:
    1,693
    Registriert seit:
    17.02.2011
    Wenn der Boot-Bereich probleme macht, hilft ein normales "wipen" nicht.
    Hier einfach mal nach "dd if=/dev/zero" oder "cat /dev/zero" suchen..
    (Mußte es selbst lange nicht machen)
    Sollte aber in der ADB shell dann "dd if=/dev/zero of=/dev/mtdblock/mtd2" sein .. einfach mal nachsehen, wie der korrekte Pfad dann im Amon_Ra ist ..
    (Natürlich ohne ANführungszeichen - aber das ist wohl klar?!)


    PS: Ist es ein Boot Image von etwa 7 MB Größe? Wenn ja, dann ignorier den Fehler oder nutze ein kleineres.. da stehen am Ende eh nur Nullen)
     
  16. Thenos, 12.03.2011 #16
    Thenos

    Thenos Threadstarter Junior Mitglied

    Beiträge:
    32
    Erhaltene Danke:
    0
    Registriert seit:
    31.01.2011
    Ok also wo soll ich danach suchen?? Und was ist ADB shell? Hab echt kein plan was du meinst.

    Das boot.img hat genau 2,9 mb größe
     
  17. email.filtering, 12.03.2011 #17
    email.filtering

    email.filtering Gast

    Wenn Du nicht verstehst was ADB ist und was der Befehl shell dann macht, wird's etwas mühsam Dir zu helfen. Vielleicht solltest Du Dich mal ordentlich zum Thema einlesen, dann die offenen Fragen klären und erst anschließend das Gehirn Deines Handys austauschen. ;)

    Ach ja liebe Windows-Nutzer: Verwendet echte Ordner und keine "virtuellen"! Der Desktop ist ein solcher "virtueller" Ordner, weil er über eine Systemvariable angesprochen wird. Und diese Tatsache, aber eben auch die darin enthaltenen Sonderzeichen, machen vielen Programmen schwer zu schaffen! Kopiert also den zu flashenden Krempel inklusive des zum Flashen notwendigen Programms (nebst all dessen "Zutaten") in einen "realen" Ordner ohne alle Sonderzeichen, z.B. C:\LGFLASH, und startet den Flashvorgang von diesem Ordner aus!

    Die meisten Geräte kann man auch per Fastboot flashen, was nun wirklich ultra-easy funktioniert. Das sind ein paar lausige Befehle die man leicht verstehen kann und dann für jede zu flashende Partition anwendet.
    Die für uns interessanten Partitionen heißen boot, recovery und system. Ganz selten brauchen wir auch noch data (da sind unsere persönlichen Änderungen drinnen. Die Partition cache können wir hingegen ruhigen Gewissens ignorieren.
     
    Zuletzt von einem Moderator bearbeitet: 12.03.2011
  18. Thenos, 12.03.2011 #18
    Thenos

    Thenos Threadstarter Junior Mitglied

    Beiträge:
    32
    Erhaltene Danke:
    0
    Registriert seit:
    31.01.2011
    1. Was eine adb ist weis ich..wurde ja hier schon 1ooo mal gepredigt.
    2. Es gibt devinitiv auch eine leichtere erklär methode. Ich hab mir das thema 1oo nla durchgelesen und es stand weder in der anleitung noch sonst wo was von einer shell also nach nicht son wind und erklärst mir....wen nicht dann nicht aber man kann doch auh nicht von mir erwarten das ich alles weis.
    3. Infos die mir nicht helfen....helfen mir nicht...also schreib keine "omg wieso weist du das nicht/ wieso bist du so blöd" sätze
    4. Ich bin verdammt angepisst weilich seit monaten mich damit rumschlag und langsam kein bock mehr hab
     
  19. N2k1, 12.03.2011 #19
    N2k1

    N2k1 Moderator Team-Mitglied

    Beiträge:
    7,896
    Erhaltene Danke:
    1,693
    Registriert seit:
    17.02.2011
    Hey, immer schön locker bleiben!
    Ich erklär es doch schon..
    ADB ?? Android Debug Bridge.
    Das Programm adb.exe findet man in dem SDK.
    Eine Option für das Programm heißt shell - und es öffnet sich eben eine ebendiese.
    Nun hat man eine Kommandozeile des Telefons (Achtung: Ab hier benötigt man Linux-Befehle und Syntax!)

    Im Amon_Ra ist man automatisch root, so daß man alles darf..
     
  20. email.filtering, 12.03.2011 #20
    email.filtering

    email.filtering Gast

    Das ganze ADB- & Fastboot-Zeug gibt's für Windows-Nutzer auch in meinem Downloadbereich, sodass man sich nicht einmal das riesige Android-SDK herunterladen oder im Internet großartig herumsuchen muss.
     

Diese Seite empfehlen