1. Nimm jetzt an unserem 2. ADVENT-Gewinnspiel teil - Alle Informationen findest Du hier!

Handy start nach einiger Zeit nicht mehr (AGG3 & Kyrillos)

Dieses Thema im Forum "Root / Hacking / Modding für Samsung Galaxy 3" wurde erstellt von iceman808, 18.02.2012.

  1. iceman808, 18.02.2012 #1
    iceman808

    iceman808 Threadstarter Junior Mitglied

    Beiträge:
    27
    Erhaltene Danke:
    0
    Registriert seit:
    19.01.2011
    Hallo zusammen,

    hab seid einer Woche mein Galaxy geflashed zuerst mit Kyrillos 9.5 dann mit AGG3 (beide OC) da ich dachte das würde mein Problem lösen, jetzt bin ich wieder bei Kyrillos, da es keine Besserung gab und ich Kyrillos schöner finde. Bei mir kommt es zu folgendem:

    Wenn ich mein Handy ein Zeit lang ausschalte (Ausknopf kurz gedrückt) reagiert es nicht mehr auf den Homeknopf zum Aufwecken. Aber erst nach einer gewissen Zeit. Danach bleibt mir nur noch ein komplettes Reboot durch das lange drücken des Ausknopfes.

    Zuerst dachte ich dass es an SetCPU Screen Off (83-400 ondemand) liegt, dass hab ich mittlerweile schon deaktiviert. Meine anderen SetCPU Einstellungen, obwohl ich mittlerweile kaum noch glaube das es daran liegt:
    - Main: 800-83 ondemand
    - Profiles:
    In Call (400-200 ondemand Prio:100)
    Temp > 50°C (400-83 ondemand Prio: 100)
    00:00-05:10 (400-83 ondemand Prio 99)
    - Voltage: 1200-1000: -100mV, 900-700: -50mV, Der Rest 0mV

    Ich benutze Hybriddata2sd mit 1GB auf der SD-Card

    Außerdem hab ich folgende Programme installiert die ständig laufen (ohne Garantie für Vollständigkeit):
    - Screebl Light
    - UberSocial
    - 3G WatchDog pro
    - Smart Keyboard
    - Timer(Alarm)

    Hat jemand eine Idee was das Problem ist oder wie ich dem auf den Grund gehen kann?

    Vielen Dank schon mal für die Hilfe :)
     
  2. Keinbockwurst, 18.02.2012 #2
    Keinbockwurst

    Keinbockwurst Android-Guru

    Beiträge:
    3,013
    Erhaltene Danke:
    649
    Registriert seit:
    07.02.2011
    Hört sich nach einem "sleep of death" an. Erhöhe mal die minimale taktfrequenz. Das sollte das Problem lösen.
     
  3. iceman808, 18.02.2012 #3
    iceman808

    iceman808 Threadstarter Junior Mitglied

    Beiträge:
    27
    Erhaltene Danke:
    0
    Registriert seit:
    19.01.2011
    Hi, danke für den Tip werde ich mal ausprobieren, wenn meine neue Vermutung sich als falsch erweist.

    Ich hatte screebl aktiviert aber die Lagesensoren ausgeschaltet. Hat jemand die Erfahrung gemacht, dass dies zu Problemem führt?
     
  4. Keinbockwurst, 18.02.2012 #4
    Keinbockwurst

    Keinbockwurst Android-Guru

    Beiträge:
    3,013
    Erhaltene Danke:
    649
    Registriert seit:
    07.02.2011
    Was meinst du mit screebl?
     
  5. iceman808, 18.02.2012 #5
    iceman808

    iceman808 Threadstarter Junior Mitglied

    Beiträge:
    27
    Erhaltene Danke:
    0
    Registriert seit:
    19.01.2011
    Screebl ist eine App, die je nach Lage/Winkel den Screen ein oder ausschaltet bzw. das automatische Abschalten des Screens verhindert. Ist eigentlich recht praktisch, wenn man längere Sachen liest oder sich ansieht.

    Aber das war's auch nicht.

    Nachdem ich die Min Taktung auf 200MHz hoch gesetzt habe hatte ich den Fehler immer noch.

    Nun hab ich die WLan Verbindung unter Verdacht. Wenn ich das Wlan am Handy ausschalte hatte ich die letzten 2Std keinen SOD...

    Ich suche weiter...
     
  6. Keinbockwurst, 18.02.2012 #6
    Keinbockwurst

    Keinbockwurst Android-Guru

    Beiträge:
    3,013
    Erhaltene Danke:
    649
    Registriert seit:
    07.02.2011
    ist ja komisch.. unter einer stock-rom ist das ganze nicht passiert?
     
  7. iceman808, 18.02.2012 #7
    iceman808

    iceman808 Threadstarter Junior Mitglied

    Beiträge:
    27
    Erhaltene Danke:
    0
    Registriert seit:
    19.01.2011
    was sind stock-roms?

    wie gesagt kyrillos 9.5 und agg3 hab ich benutzt.
     
  8. Keinbockwurst, 18.02.2012 #8
    Keinbockwurst

    Keinbockwurst Android-Guru

    Beiträge:
    3,013
    Erhaltene Danke:
    649
    Registriert seit:
    07.02.2011
    Stock roms sind die offiziellen roms von Samsung!
     
  9. qaysedcftgb, 19.02.2012 #9
    qaysedcftgb

    qaysedcftgb Gast

    mal ins blaue reingeraten:
    83MHz als minimum sind superwenig, da wuerde ich mich mal langsam von 200 runtertasten
    Und auch 200 sehe ich schonals sehr gering an, eigentlich als absolutes minium, um ein reagieren im Screenoff zu gewaehren

    Erschwerend hinzu kommen noch die undervoltages.
    Vielleicht hakt es hier.

    Jetzt muss ich mal nach dem Sinn fragen:
    eine CPU wird uebertaktet, bekommt aber dazu weniger Strom?
    Mir kommt da der Vergleich auf:
    Los Esel, Renn schneller, aber denk nicht, dass Du mehr zu trinken bekommst.

    Also:
    wenn uebertakten, dann geh mal langsam ran:
    OC OK, aber bei voller Leistung
    wenns dann laeuft, dann kannst den Saft immer noch runterdrehen.
    Aber bedenke:
    kein input, kein Output
    Kein Strom, keine Leistung.
    Einfache Sache.
    Weisst Du wieviel CPU Dein Handy benoetigt, nur um den Screen einzuschalten?
    Grab ihm dabei das Wasser/Strom ab und schon geht nichts mehr, ist logisch oder?
    Ist wie ein Peak beim Einschalten eines Rechners. Das Netzteil macht es mit oder auch nicht. Mal geht es gut, mal nicht. Je nach Bedarf und Toleranz.

    Geh folgende Schritte:
    Undervoltagen erstmal vergessen
    1. Taktraten ausloten
    2. zu den Taktraten dann die Voltages angleichen
    Ich habe das undervoltagen aufgegeben, dazu hat mich eine einfache Einsparrechnung gebracht.
    Die Volts die ich mir einspare, in Relation zum Gesamtverbrauch, standen in keinem Verhaeltnis zur Zeit die ich aufbrauchen muesste um dies zu verifizieren, ohne Neustarts zu riskieren. Geh ich halt zwei Stunden frueher ans Netz, was solls.

    Ist ein sehr langer Prozess, ich weiss, aber nur so kommst Du ans Ziel. Nicht alles auf einmal und immer nur an einer Schraube drehen. Somit bekommst Du eine Verhaltensweise Deines Handys raus. Jedes Handy reagiert anders.

    Viel Erfolg
    qaysed
     
  10. iceman808, 25.02.2012 #10
    iceman808

    iceman808 Threadstarter Junior Mitglied

    Beiträge:
    27
    Erhaltene Danke:
    0
    Registriert seit:
    19.01.2011
    Hallo zusammen,

    ich konnte das Problem einige Zeit lang beheben, indem ich alles gewiped hab was geht und dann von Grund auf alles neu installiert und Konfiguriert hab. Leider hielt das nur eine Woche. Nun krieg ich wieder den "Sleep of Dead". Allerdings hab ich das Problem wahrscheinlich gefunden, weiß aber nicht wie ich es beheben kann.

    im g3mod.log steht etwas davon, dass das Filesystem korrupt ist:

    Checking mmcblk0p2
    /dev/block/mmcblk0p2: clean, 191/499712 files, 206750/999425 blocks
    Checking stl6
    /dev/block/stl6: clean, 1242/13600 files, 47410/54400 blocks
    Checking stl7
    /dev/block/stl7 contains a file system with errors, check forced.
    /dev/block/stl7: Inodes that were part of a corrupted orphan linked list found.


    /dev/block/stl7: UNEXPECTED INCONSISTENCY; RUN fsck MANUALLY.
    (i.e., without -a or -p options)
    Checking stl8

    /dev/block/stl8: clean, 12/2176 files, 143/8704 blocks
    Data2SD Enabled - Hybrid Mode
    Multi-OS Data Enabled: FROYO
    System detected: samsung/GT-I5800/GT-I5800/GT-I5800:2.2/FROYO/XXJPU:user/release-keys
    System booted with Samsung Froyo kernel mode
    Compcache disabled

    Leider weiß ich nicht was ich tun muss um das Problem zu lösen. Bei meiner Suche im Forum bin ich auf "CWM adb shell" gestoßen, leider weiß ich als blutiger Linux/Android Anfänger überhaupt nicht wie und wo ich diese Shell finde...

    Kann mir jemand da weiterhelfen?
     
  11. qaysedcftgb, 25.02.2012 #11
    qaysedcftgb

    qaysedcftgb Gast

    WOW!
    Da bist aber ganz schoen in die Untiefen gegangen, RESPEKT!

    Eine ADB Shell ist recht einfach:
    [How To] Setup ADB for Windows/ Mac - xda-developers
    das ist unter Windows die adb.exe und zwei DLLs. Die einfach in den Pfad legen (Windows) und schon kannst Du ADB aus jeder AdminCMD nutzen.
    ---
    c:\adb shell
    # su
    ---
    und schon kann es losgehen mit den Linux Befehlen.
    mount zeigt Dir z.B. alle Mountpoints an... auch stl7 sollte dabei sein

    Wenn es Dir weiterhilft... durch Tests mit KMapp habe ich mir wohl die komplette stl7 irgendwann diese Woche zerspant, die war komplett weg!
    Habs nicht direkt bemerkt. :w00t00:
    stl7 ist intern und hat mit der sd nichts zu tun.

    Alle versuche mit wipe und Co scheiterten.
    Letztenendes habe ich einfach die stock, deodexed XXJPU nochmal geflasht.
    -> I5800XXJPU_deodex_stock_prerooted.rar

    seither habe ich wieder die stl7 verfuegbar.
    Wie sieht man noch, dass die stl7 am Ende ist?
    -> mach mal titanium backup auf... hast Du gleich nach dem Start unten
    ---
    System-ROM
    intern <- das ist die stl7!!
    SD-Karte
    ---

    Ob der Aufwasch mut dem komplett Flash sein muss, kann ich echt nicht sagen, aber seitdem ich die obige Stock reingepresst habe und meine CR wieder draufgebuegelt, ist alles da, wo es sein soll.

    Du kannst ja mal folgendes machen:
    lad Dir die one-package-ROM oben mal runter, oeffne das TAR mit totalcommander, schmeiss alles raus, ausser die cache Datei!
    Dann als one package neu flashen.
    Ist ein Himmelfahrtskommando, ich weiss, aber evtl. eine Moeglichkeit, falls kein Linux Crack (z.B. mankokoma) ums Eck kommt und was konstruktiveres aus dem Aermel schuettelt.

    Viele Gruesse
    qaysed
     
  12. qaysedcftgb, 25.02.2012 #12
    qaysedcftgb

    qaysedcftgb Gast

    Zuletzt von einem Moderator bearbeitet: 25.02.2012
  13. quatschkopf, 25.02.2012 #13
    quatschkopf

    quatschkopf Android-Experte

    Beiträge:
    621
    Erhaltene Danke:
    54
    Registriert seit:
    13.02.2011
    also ich hab den sleepof death auch wieder vermehrt seid ich den kernel g3mod 2.4.1 habe.
    nun hab ich wieder zurück geflasht auf 2.3
    mal sehn ob es wieder besser wird oder ob es doch an der agg3 liegt die ich grade teste. :)
     
  14. qaysedcftgb, 25.02.2012 #14
    qaysedcftgb

    qaysedcftgb Gast

    @quatschkopf

    poste doch mal deine
    g3mod.log
    data2sd.log
    und den adb output von
    # mount
     
  15. quatschkopf, 26.02.2012 #15
    quatschkopf

    quatschkopf Android-Experte

    Beiträge:
    621
    Erhaltene Danke:
    54
    Registriert seit:
    13.02.2011
    Hier erst mal die g3mod.log. Der Rest folgt.

    Checking mmcblk0p2
    /dev/block/mmcblk0p2: clean, 276/250480 files, 314002/500449 blocks
    Checking stl6
    /dev/block/stl6: clean, 1377/13600 files, 48447/54400 blocks
    Checking stl7
    /dev/block/stl7 contains a file system with errors, check forced.
    /dev/block/stl7: Inodes that were part of a corrupted orphan linked list found.

    /dev/block/stl7: UNEXPECTED INCONSISTENCY; RUN fsck MANUALLY.
    (i.e., without -a or -p options)
    Checking stl8
    /dev/block/stl8: clean, 13/2176 files, 144/8704 blocks
    Data2SD Enabled - Hybrid Mode
    Multi-OS Data Enabled: FROYO
    System detected: FROYO
    System booted with Samsung Froyo kernel mode
    Compcache disabled

    So weiter...

    Data2SD Enabled - Hybrid Mode
    Cleaning up symlinks
    - /data/app is a symlink
    - /data/dalvik-cache is a symlink
    - /data/log is a symlink
    Connecting Hybrid Data2SD Links
    - /data/app linked to /sdext/app
    - /data/log linked to /sdext/log
    - /data/dalvik-cache linked to /sdext/dalvik-cache

    Was meinst du mit dem dritten?

    Gesendet von meinem GT-I5800 mit der Android-Hilfe.de App
     
  16. qaysedcftgb, 26.02.2012 #16
    qaysedcftgb

    qaysedcftgb Gast

    der dritte Punkt hat sich eruebrigt
    das haette gezeigt, ob Du ueberhaupt ein stl7 hast
    waere stl7 weg, waere deine data2sd.log deutlich kuerzer, ist sie nicht, also obsolet

    aber...
    vergleich mal Deine Logdatei
    ...
    /dev/block/stl7 contains a file system with errors, check forced.
    /dev/block/stl7: Inodes that were part of a corrupted orphan linked list found.

    /dev/block/stl7: UNEXPECTED INCONSISTENCY; RUN fsck MANUALLY.
    (i.e., without -a or -p options)

    mit icemans Posting#10
    http://www.android-hilfe.de/root-ha...eit-nicht-mehr-agg3-kyrillos.html#post2772801
    und meinen Nachfolgepostings genau durch.
    #11 zeigt eine brachiale Art
    #12 zeigt den sanften Weg

    Viel Spass beim reparieren.
    Ohne das bereinigen der Logs wirst auch Du keine Chance haben, egal mit welcher ROM.

    Jetzt darfst noch den DANKE Button auf dieses Posting druecken.
    Gerne auch auf Posting #12, dafuer dass ich Dir die SuFu im Board erspart habe.

    Viele Gruesse
    qaysed
     
    Keinbockwurst und quatschkopf haben sich bedankt.
  17. quatschkopf, 26.02.2012 #17
    quatschkopf

    quatschkopf Android-Experte

    Beiträge:
    621
    Erhaltene Danke:
    54
    Registriert seit:
    13.02.2011
    So ich hab die .zip aus dem anderen Thema mal geglaubt und siehe da! Es sieht besser aus.

    Checking mmcblk0p2
    /dev/block/mmcblk0p2: clean, 81/250480 files, 186337/500449 blocks
    Checking stl6
    /dev/block/stl6: clean, 1380/13600 files, 51031/54400 blocks
    Checking stl7
    /dev/block/stl7: clean, 2627/12512 files, 31832/50048 blocks
    Checking stl8
    /dev/block/stl8: clean, 13/2176 files, 145/8704 blocks
    Data2SD Enabled - Hybrid Mode
    Multi-OS Data Enabled: FROYO
    System detected: FROYO
    System booted with Samsung Froyo kernel mode
    Compcache disabled


    Gesendet von meinem GT-I5800 mit der Android-Hilfe.de App
     
  18. Keinbockwurst, 26.02.2012 #18
    Keinbockwurst

    Keinbockwurst Android-Guru

    Beiträge:
    3,013
    Erhaltene Danke:
    649
    Registriert seit:
    07.02.2011
    *verneig*
     
  19. qaysedcftgb, 26.02.2012 #19
    qaysedcftgb

    qaysedcftgb Gast

    besten Dank fuer das positive Feedback!
    Das gab einen DANKE Button! Gutes liest man selten.

    die Sachen von mankokoma haben Hand und Fuss, da kann man blind vertrauen
    (meine Herren Gesangsverein, habe ich den SchleimKuebel grad umgestossen? ;) )

    Selbstredend bekommt mankokoma auch einen DANKE Button von mir, da eigentlich IHM die Ehre gebuehrt und nicht mir.

    Und auch iceman hat ein DANKE von mir verdient, dass er das G3 Log gebracht hat.
    Das war der Ausloeser, darauf kommt mal einer... echt RESPEKT!

    Wegen meiner duerft Ihr Eure Danke bei mir auch loeschen, da ich nur 1+1 zusammengerechnet habe.

    Ich werde diesen Thread in sehr deutlicher Erinnerung halten und bei der QAGG3 V6 ROM einfliessen lassen.

    Viele Gruesse
    qaysed
     

Diese Seite empfehlen