1. Nimm jetzt an unserem 2. ADVENT-Gewinnspiel teil - Alle Informationen findest Du hier!

(Hat) Das Ace hat Probleme mit bestimmten Speicherkarten!?

Dieses Thema im Forum "Samsung Galaxy Ace (S5830i)" wurde erstellt von gurkietier, 12.05.2012.

  1. gurkietier, 12.05.2012 #1
    gurkietier

    gurkietier Threadstarter Android-Hilfe.de Mitglied

    Beiträge:
    70
    Erhaltene Danke:
    0
    Registriert seit:
    28.03.2011
    Hallo,
    hatte vor längerer Zeit mein Gerät gerootet und eigentlich funktioniert mein Samsung auch sehr gut. Ich hab eine 32er GB Speicherkarte drin mit 2.Partitionen.
    Jetzt ist in den letzten Tagen allerdings bei Neustart immer das Problem, daß er die Speicherkarte nicht richtig ausliest und die Apps auf dem Gerät nicht angezeigt werden. Auch stürzt das Gerät immer halb ab, nicht ganz, sondern es tut sich , wenn man den Home-Button drückt wenn z.B. keine Reaktion mehr ist, ein schwarzer Bildschirm auf, dann vibriert es ganz kurz und leise und dann wird mir wieder der Sperrbildschirm angezeigt und auch der Mobilanbieter wird dann für kurze Zeit nicht angezeigt (es kommt der Hinweis "Kein Dienst"). Ich komm dann jedes Mal wieder ohne Probleme in den Homebildschirm rein aber für kurze Zeit sind dann auch alle Symbole weg und die Medien werden wieder neu gescannt aber leider werden die Apps auf der externen Speicherkarte auf dem Homebildschirm nicht angezeigt. Das ganze passiert manchmal auch ohne daß ich auf den Homebildschirm drücke.
    Die Speicherkarte hab ich schon formatiert, dann neu partitioniert und das Backup der Daten wieder auf beide Laufwerke der Speicherkarte raufgespielt.
    Ich versteh auch noch nicht ganz ob das ein Problem der Speicherkarte oder des Gerätes generell ist? Die Speicherkarte kann ich ohne Probleme unter dem Ordner "eigene dateien" auf dem handy ohne probleme öffnen und komm auch an alle Dateien ran. Aber die Apps werden als Symbole nicht auf meinem Gerät angezeigt und wenn ich Link2SD starte, rödelt er zwar ewig, stürzt dann aber wie oben beschrieben ab und das Spielchen geht von vorne los.... Ich habe übrigens keinen Vertrag bzw. ein gesimlocktes Gerät, nur als Hinweis...
    Hat einer das auch schon gehabt? Was kann man da machen?
     
  2. red-orb, 13.05.2012 #2
    red-orb

    red-orb Android-Ikone

    Beiträge:
    4,037
    Erhaltene Danke:
    819
    Registriert seit:
    12.10.2011
    Das könnten erste Anzeichen für einen defekt der SD sein

    Gesendet vom ACE
     
  3. L30nh4rt, 14.05.2012 #3
    L30nh4rt

    L30nh4rt Android-Lexikon

    Beiträge:
    1,015
    Erhaltene Danke:
    214
    Registriert seit:
    06.06.2011
    Phone:
    Nexus 5
    was benutzt du für ein Rom?
    Ich hatte ähnliche Probleme mit verschieden CustomRom´s und erst die CM7.2 behob das Problem.

    es kann sein das sich der zugriff deiner 2. Partition verabschiedet. Ist ein Sicherheitsmechanismus von Android. Das ganze kannst du mit dem Terminal emulator nachvollziehen, wenn du "mount" eingibst.
    Dabei sollte unter anderem deine externe Partition auftauchen und wie der Zugriff darauf derzeit ist.
    Dazu gab es hier auch schon 2 Threads, leider kann ich sie auf die schnelle nicht finden -.- wenn doch poste ich Sie gleich

    EDIT: hach und schon bin ich über den nächsten Thread gestolpert der genau das Problem von mir damals beschreibt:
    hier der Link:http://www.android-hilfe.de/root-ha...-mit-cm7-sd-karte-beim-start.html#post2414756
    darin hat mir damals derderl8 weiter geholfen
     
    Zuletzt bearbeitet: 14.05.2012
  4. gurkietier, 16.05.2012 #4
    gurkietier

    gurkietier Threadstarter Android-Hilfe.de Mitglied

    Beiträge:
    70
    Erhaltene Danke:
    0
    Registriert seit:
    28.03.2011
    Hallo,
    die SD Karte ist neu, ich hatte vorher eine 16 GB und die jetzt gegen eine 32 GB ersetzt. Die funktionierte eigentlich einwandfrei, hab sie auch nochmal gelöscht, neu formatiert und die Daten wieder per Back up eingespielt....

    @L30nh4rt
    Wo kann ich sehen, was ich für eine ROM benutze?
    Wie mach ich das mit dem Terminal emulator? Direkt auf dem PC mit angeschlossener Speicherkarte oder auf dem Ace selber?
    Ich hab das Mini tool partition wizard home edition, damit habe ich auch die Karte in zwei parts geteilt, da wird mir das noch ohne Probleme angezeigt, daß die 2. Partion noch da ist :confused:
    Nachtrag: Ich habe das Handy nach der Anleitung der xda-developers gerootet, was gut geklappt habt aber sonst nichts weiter gemacht, nichts geflasht oder sonstiges. hab nur "superuser", link2sd und titanum backup an root-zugriff-apps drauf....
     
    Zuletzt bearbeitet: 16.05.2012
  5. Counterfeit, 21.05.2012 #5
    Counterfeit

    Counterfeit Neuer Benutzer

    Beiträge:
    3
    Erhaltene Danke:
    0
    Registriert seit:
    21.05.2012
    Hallo Ihr Lieben,
    nachdem ich schon öfter via Google hier Hilfe fand, dachte ich mir wo ich nun trotz google nicht weiterkomme, frage ich hier mal nach.

    Folgendes passierte mit meinem Handy bzw. meinen Daten.

    Vor einiger Zeit viel mir auf, das mein Handy meinen Klingelton nicht abspielte, naja nicht wirklich was bei gedacht, wieder neu raufgemacht die mp3.

    Dann etwas später wieder das gleiche, da ist mir aufgefallen, dass mehrere Lieder fehlen. Alles andere war vorhanden, Bilder, Apps etc. funktionierte auch alles soweit...

    Wieder ein Paar Tage später nach einem Neustart wegen leeren Akkus, fehlten mir Apps...
    Ich habe dann versucht die Karte rein raus, das übliche Neustart... bla bla also n bisl kenn ich mich dann halt aus und hab das standart Programm durchgezogen, alles mal gecheckt, mal nimmt er die Karte mal net.
    Wenn das Handy die Karte nimmt ist der Medienscanner im Nu fertig obwohl das net sein kann.

    So dann habe ich nun die SD Karte mal in meinen Laptop geschmissen und was muss ich da sehen, erleben??? :-( Alles weg!

    Die ganzen Daten werden nur als komische Hieroglyphen angezeigt, Keine Bilder mehr da Keine Musik Nix, Null!

    Ich lasse gerade nen Recovery Programm durchlaufen damit ich wenigstens meine Bilder retten kann :-(

    Jetzt aber zu der Frage.....

    Defekt scheint sie ja nicht zu sein die Liebe SD Karte denn der Pc nimmt sie ja...

    vorher hat auch alles geklappt, in meiner Familie haben noch 3 andere die gleiche SD und es geht....

    WORAN LIEGT ES??? Hüüüüülffeeee!!!

    Ich hoffe Ihr habt nen Guten Tipp Parat damit es nicht nochmal passiert :-(

    Sorry für den Roman aber ich wollte es ausführlich schildern.

    Liebe Grüße Nadine
     
  6. Sabai, 21.05.2012 #6
    Sabai

    Sabai Fortgeschrittenes Mitglied

    Beiträge:
    314
    Erhaltene Danke:
    21
    Registriert seit:
    02.05.2012
    Hi,

    sieht so aus, als wäre das Filesystem korrupt. Hast du mal das Filesystem mal überprufen lassen mit deinem Laptop ?

    Ansonsten würde ich versuchen zu retten, was zu retten ist und auf den PC sichern. Dann einfach (ebenfalls mit dem Laptop) die Karte neu formatieren
    ( nicht im Quick Mode) und die Daten wieder zurück kopieren. Am besten nimmst du dafür ein Backup/Image Programm.

    Wenn deinem Handy der Strom ausgeht, wird die Karte vermutlich nicht sauber "unmounted". Das kann zu einem inkonsistenten Filesystem führen.

    Gruß

    Sabai
     
  7. Counterfeit, 21.05.2012 #7
    Counterfeit

    Counterfeit Neuer Benutzer

    Beiträge:
    3
    Erhaltene Danke:
    0
    Registriert seit:
    21.05.2012
    Danke für deine Antwort!

    Ja ich denke ich rette jetzt noch das was übrig bleibt denn sonst ist da nix mehr zu retten, so ärgerlich! wieder stunden meines Lebens vergeudet...

    Naja... aber ne andere Frage... es kann doch aber nicht sein das wenn mein Handy leer geht da alles ausm Lot läuft oder?
    Was kann man denn dagegen tun? oder kann man da garnix machen? denn das wäre echt mies :-/:cursing::scared:
     
  8. Sabai, 21.05.2012 #8
    Sabai

    Sabai Fortgeschrittenes Mitglied

    Beiträge:
    314
    Erhaltene Danke:
    21
    Registriert seit:
    02.05.2012
    Hi,

    Nein, normalerweise nicht. Erfahrungsgemäß arbeitet das Filesystem
    auch noch, wenn es nicht "sauber" unmounted wurde. Trotzdem ist das FS danach nicht mehr in einem konsistenten Zustand. Wenn das dann aber ein paar mal vorkommt und dann noch viel Daten geschrieben, gemoved oder gelöscht werden, *kann* sowas schon mal vorkommen.

    Doch klar, da kann man Vorsorge treffen.

    - Das Handy ausschalten, bevor der Strom ausgeht. Alternativ kannst du in den Settings auch die SD Karte unmounten, wenn der Akku zur Neige geht.

    - Falls es doch vorkommt, daß das Handy ausgeht, einfach einen Filesystem Check der SD Karte auf einem Windows Rechner durchführen. Dann sollte alles wieder im Lot sein.

    Generell empfehle ich Partitionen und Filesysteme von einem Windows Rechner aus anzulegen. Ausser extX Partitionen :)


    Gruß

    Sabai
     
  9. Counterfeit, 21.05.2012 #9
    Counterfeit

    Counterfeit Neuer Benutzer

    Beiträge:
    3
    Erhaltene Danke:
    0
    Registriert seit:
    21.05.2012
    Danke für Deine Tipps!
    Dann werde ich jetzt mal schauen das ich meine Daten gerettet bekomme (Meine Revovery Programme mögen mich heute auch nicht) und dann werde ich mal von neuem alles starten und deine Tipps beherzigen und dann hoffen dass es nicht mehr passiert :)
     
  10. red-orb, 22.05.2012 #10
    red-orb

    red-orb Android-Ikone

    Beiträge:
    4,037
    Erhaltene Danke:
    819
    Registriert seit:
    12.10.2011
    Normalerweise werden die Geräte aber sauber vom Betriebssystem runter gefahren wenn der Akku zu schwach ist also sollte auch bei schwachem Akku dein FS nicht korrupt sein.
    Das FS kann kaputt gehen wenn man die Sd einfach aus dem Handy zieht da ist Linux etwas pingelliger als Windows.
    Der Mediascan prüft beim Starten vom Teledon normalerweise auch auf Fehler im FS der SD.

    gesendet vom ACE
     
  11. Sabai, 22.05.2012 #11
    Sabai

    Sabai Fortgeschrittenes Mitglied

    Beiträge:
    314
    Erhaltene Danke:
    21
    Registriert seit:
    02.05.2012
    Hi,

    Ich hab keine Ahnung, ob und ab welchem Ladezustand das Handy runtergefahren wird. Auch in dem Manual hab ich dazu nichts gefunden.
    Deswegen schrieb ich ja auch *vermutlich* :rolleyes2:

    Also wenn eine extX Partition auf der SD Karte ist, wird defintiv nichts modifiziert auf dem FS, auch wenn es sich im Status "unclean" befindet.
    Unter Linux mit "e2fsck -vf (device)" sieht das dann ganz anders aus.

    Auch bei FAT32 Partitionen bin ich nicht sicher, da die Partition *vermutlich* schon längst gemounted ist, bevor der Mediascanner seine Arbeit aufnimmt.

    Ausserdem ist es meiner Meinung nach immer besser, wenn man bei solchen Sachen auf native Tools (in dem Fall Windows) zurückgreift.

    Gruß

    Sabai
     
  12. red-orb, 22.05.2012 #12
    red-orb

    red-orb Android-Ikone

    Beiträge:
    4,037
    Erhaltene Danke:
    819
    Registriert seit:
    12.10.2011
    Wann ein Handy runter gefahren wird hängt von der Kapazität des Akkus und der benötigten Spannung des Gerätes ab.
    Je nachdem wieviel Spannung der Akku noch liefern kann ist der Abschaltzeitpunkt unterschiedlich
    Der Mediascanner greift nur auf eine gemountete Partition zu und prüft dann Daten und Fehler.
    Das allerdings nur sehr Oberflächlich
    Selbst wenn eine ext Partition existiert kann das trotzdem durch entfernen der SD kaputt gehn da u.U der Masterfiletable beschädigt werden kann.
    Windows ist nicht unbedingt zum Formatieren von SD-Karten geeignet besser man nimmt ein geeignetes Tool wie z.B. mini Partition Wizzard oder Acronis
     
  13. Sabai, 22.05.2012 #13
    Sabai

    Sabai Fortgeschrittenes Mitglied

    Beiträge:
    314
    Erhaltene Danke:
    21
    Registriert seit:
    02.05.2012
    Hi,

    danke für deine Antwort.

    Selbstverständlich, ich hoffe mein Post hat nichts anderes suggeriert.:rolleyes2:

    Okay, ich hab da bis jetzt keine negativen Erfahrungen gemacht, aber ich benutze Windows auch fast nur ausschliesslich beruflich. Also so selten wie möglich :)

    Ich nehme aber an, das die von dir genannten Tools ebenfalls unter Windows laufen, und genau darum ging es mir. Nämlich um die Kompatibilität des OS zu dem zu verwaltenden FS.

    Ich würde ja auch niemals ein Windows Shareware Programm zum verwalten von extX Partitionen verwenden, sondern immer auf native *nics zurückgreifen. Desgleichen für Microsoft basierende Filesysteme.


    Gruß

    Sabai
     
    Zuletzt bearbeitet: 23.05.2012
  14. kante1510, 04.06.2012 #14
    kante1510

    kante1510 Neuer Benutzer

    Beiträge:
    2
    Erhaltene Danke:
    0
    Registriert seit:
    04.06.2012
    moin moin,

    folgendes problem....
    in unbestimmten zeitabständen (mal ne stunde mal 2 tage) kommt immer wieder..."sd karte wird nicht erkannt" oder "sd karte ist beschädigt" hab sie sowohl am pc als auch mitm ace formatiert bringt aber nix ... kommt immer wieder... nehm ich sie raus und pack sie wieder rein wird sie auch sofort wieder erkannt...

    was könnt da das problem sein:confused2:
     
  15. red-orb, 05.06.2012 #15
    red-orb

    red-orb Android-Ikone

    Beiträge:
    4,037
    Erhaltene Danke:
    819
    Registriert seit:
    12.10.2011
    es könnte sein das der Chip der SD-Karte eine Macke hat hast du mal eine andere Karte versucht.
    nimm mal dieses Tool hier um die Karte zu formatieren
     
  16. CarosAce, 13.06.2012 #16
    CarosAce

    CarosAce Neuer Benutzer

    Beiträge:
    10
    Erhaltene Danke:
    1
    Registriert seit:
    13.06.2012
    Hi :)

    also ich hab auch dieses Sd-Karten Problem auch und zwar taucht das meistens nach dem Medienscann auf.
    Ich schalte das Handy dann aus und fahre es wieder hoch. Dann geht wieder alles. vlt liegt es ja an einer App ? ich hab so das Gefühl, dass mache Apps nicht ganz "sauber" sind, obwohl Sie vom Anti-Virus geprüft worden sind und für ok empfunden wurden.
     
  17. olivetti67, 13.06.2012 #17
    olivetti67

    olivetti67 Neuer Benutzer

    Beiträge:
    4
    Erhaltene Danke:
    0
    Registriert seit:
    04.05.2012
    Hab das gleiche Problem mit 8GB-Medion-SD-Karte.
    Kurz raus, dann wieder rein hilft zwar, aber mehrmals am Tag ist einfach nur nervig. Ich probier heute noch eine zweite Medion (gab zwei zusammen bei Aldi), glaube aber nicht an ein anderes Ergebnis.

    Oliver
     
  18. kante1510, 17.06.2012 #18
    kante1510

    kante1510 Neuer Benutzer

    Beiträge:
    2
    Erhaltene Danke:
    0
    Registriert seit:
    04.06.2012
    das kann doch nicht sein!
    habe es auch nochmal mit einer anderen sd karte versucht aber das problem taucht immer wieder auf... so langsam nervt es echt richtig ...

    keine irgendwelche anderen lösungsvorschläge?
     
  19. Karanlik84, 17.06.2012 #19
    Karanlik84

    Karanlik84 Junior Mitglied

    Beiträge:
    42
    Erhaltene Danke:
    1
    Registriert seit:
    29.02.2012
    Phone:
    Sony Xperia P
    Hatte auch das Problem, vor meinem Live Walkman das Ace und die Speicherkarte wurde auch alle Nase lang nicht erkannt, scheint beim 5830i öfter aufzutreten wie man es hier ließt.
    Habs dann umgetauscht.
     
  20. flaue, 27.06.2012 #20
    flaue

    flaue Neuer Benutzer

    Beiträge:
    4
    Erhaltene Danke:
    0
    Registriert seit:
    09.03.2012
    Hi,

    genau das Gleiche bei mir :cursing: (S5830i).
    Schon jemand über eine Lösung gestolpert? :crying:

    LG
     

Diese Seite empfehlen