1. Nimm jetzt an unserem Uhans - 3. ADVENT - Gewinnspiel teil - Alle Informationen findest Du hier!

Hilfe bei Installation CM7 - Fehler "E: Can´t mount /sdcard"

Dieses Thema im Forum "Custom-ROMs für Motorola Defy" wurde erstellt von FrankDr, 16.01.2012.

  1. FrankDr, 16.01.2012 #1
    FrankDr

    FrankDr Threadstarter Erfahrener Benutzer

    Beiträge:
    160
    Erhaltene Danke:
    13
    Registriert seit:
    21.02.2011
    Ich habe ein Defy mit 2.1 eclair gehabt.

    - mittels superoneclick gerootet
    - Das ganze System full wipe gemacht
    - Auf dem platten System 2ndInit installiert (0.6.1)
    - Ich habe gapps sowie "cm7.1.0-RC1-jordan-signed.zip" auf der SD-Karte.
    (mit/ohne versucht: wieder in das Customer Rom Boot-Menü (ClockworkMod Recovery) und dort wieder wipe data/factory reset)


    Problem:
    Wenn ich auf im Boot-Loader auf Recovery --> install zip from sdcard --> choose zip from sdcard --> Fehler "E: Can´t mount /sdcard"

    ABER: Ich kann auch sowohl vom Defy, als auch vom PC auf die SD-Karte zugreifen (ich habe das ganze auch mit einer zweiten Micro-SD-Karte probiert, also es liegt nicht als den Karten selbst).

    Hat es was mit dem Punkt "apply sdcard: update.zip" zu tun. eine solche Datei habe ich nicht, bzw. wenn ich es anwähle kommt ebenfalls "E: can´t mount SDCARD:update.zip" Installation aborted.

    PS: Ich lese seit geschlagenen 5 Stunden durch alle möglichen Threads, aber nun bin ich mit meiner Weisheit am Ende und nach all der Zeit, habe ich nichts ausser ein Defy Eclair im Werkszustand :crying:
     
    Zuletzt bearbeitet: 16.01.2012
  2. Gazman, 16.01.2012 #2
    Gazman

    Gazman Android-Lexikon

    Beiträge:
    1,482
    Erhaltene Danke:
    507
    Registriert seit:
    01.10.2011
    FrankDr bedankt sich.
  3. FrankDr, 16.01.2012 #3
    FrankDr

    FrankDr Threadstarter Erfahrener Benutzer

    Beiträge:
    160
    Erhaltene Danke:
    13
    Registriert seit:
    21.02.2011
    Hmm, ich bin eigentlich strikt nach Anleitung vorgegangen. Dort steht leider nirgends, dass es Pflicht ist, auf Froyo umzusteigen vorher. Zudem steht ja extra zu Beginn
    Factory Rest für Eclair
    und
    Factory Rest für Froyo

    und es steht mehrmals, dass alle Links dabei wäre, die man zum Umstieg benötigt. Das stimmt wohl leider nicht, denn es steht nirgends dass man auf Froyo umsteigen muss, geschweige denn wie das funktioniert. Das heisst, ich mach nun erstmal doch Froyo drauf (muss mal sehn, wie das geht und welche Version ich nehme. Vorschlag?), aber hoffe natürlich dass dort oder danach nicht das gleiche Problem besteht "E: Can´t mount /sdcard"
     
    Zuletzt bearbeitet: 16.01.2012
  4. Gazman, 16.01.2012 #4
    Gazman

    Gazman Android-Lexikon

    Beiträge:
    1,482
    Erhaltene Danke:
    507
    Registriert seit:
    01.10.2011
    Na ja, super deutlich ist es nicht, da hast Du wohl Recht. Allerdings ist auf Seite 10 die (Froyo) CE Deblur verlinkt, und ohne Froyo geht´s halt definitiv nicht.
    Flash-Anleitung ist ja auch in der PDF, sonst schau mal hier: Motorola Defy flashen
    Und mit Froyo geht es dann auch wirklich, hab ich selber schon x-mal gemacht (und am Anfang nach genau dieser Anleitung).

    Gruß

    Christoph
     
  5. FrankDr, 16.01.2012 #5
    FrankDr

    FrankDr Threadstarter Erfahrener Benutzer

    Beiträge:
    160
    Erhaltene Danke:
    13
    Registriert seit:
    21.02.2011
    Hey,
    das mit dem flashen war wirklich kein Problem (nach Anleitung gemacht und hier im Forum per suche die (Froyo) CE Deblur downgeloadet).

    Und Himmel, Arsch und Zwirn: Das war es!
    Froyo war ruckzuck installiert/geflashed und anschließend habe ich die Prozedur, welche ich den ganzen Tag versucht hatte (quasi die Anleitung) nochmal gemacht und CM7 war auch ruckzuck installiert. Diesmal kam der Fehler nicht mehr und die SD-Card wurde sofort erkannt (dazu war wohl Froyo notwendig).

    Also vielen Dank! :thumbsup:
     
  6. RATTAR, 16.01.2012 #6
    RATTAR

    RATTAR Gast

    Hey Gazman,

    Domingo2010 und ich sind davon ausgegangen daß man automatisch froyo flasht wenn man die bilderbasierte Anleitung Seite für Seite abarbeitet.

    Den FactoryReset für eclair benötigt man um Froyo zu flashen, und danach wird CM7 installierst.

    :blushing:grummel:cursing:, grummel:sad::laugh:
     
    Dirk64 bedankt sich.
  7. FrankDr, 16.01.2012 #7
    FrankDr

    FrankDr Threadstarter Erfahrener Benutzer

    Beiträge:
    160
    Erhaltene Danke:
    13
    Registriert seit:
    21.02.2011
    FUCK. Ich Ochse hatte den ganzen Tag Gedult und nun habe ich im Eifer des Gefechts die gapps vergessen zu installieren. Ich habe also CM7 ohne google Market.

    Muss ich alles rückgängig machen?
     
  8. FrankDr, 16.01.2012 #8
    FrankDr

    FrankDr Threadstarter Erfahrener Benutzer

    Beiträge:
    160
    Erhaltene Danke:
    13
    Registriert seit:
    21.02.2011
    Für mich als Laien hatte sich das so in der Anleitung gelesen wie:
    - Wer Eclair hat, macht hiermit einen Wipe und muss nicht flashen
    - Wer Froyo hat, macht hiermit einen Wipe und muss allerdings anschließend noch flashen

    Denoch tausend Dank für eure Anleitung. Ansonsten ist die ja absolut prima! Nur wart ihr eben schon mehr im Thema, so dass es für euch selbstverständlich war und für mich als Laien eben nicht :thumbup:
     
  9. Gazman, 16.01.2012 #9
    Gazman

    Gazman Android-Lexikon

    Beiträge:
    1,482
    Erhaltene Danke:
    507
    Registriert seit:
    01.10.2011
    Habt Ihr ja auch Recht damit - aber es steht halt da nicht dick und fett:
    Erst Froyo flashen, sonst geht es nicht
    !


    Fühlt Euch bitte nicht in Eurer Arbeit kritisiert- die ist super!

    @FrankDr: Einfach die Gapps via Clockwork Recovery und install zip from sdcard installieren.

    Gruß

    Christoph
     
  10. RATTAR, 16.01.2012 #10
    RATTAR

    RATTAR Gast

    War ja auch nicht ganz ernst gemeint, mein Gegrummel.:tongue::thumbup:
     
  11. FrankDr, 16.01.2012 #11
    FrankDr

    FrankDr Threadstarter Erfahrener Benutzer

    Beiträge:
    160
    Erhaltene Danke:
    13
    Registriert seit:
    21.02.2011
    So, es ist alles drauf. Alle apps wieder installiert und die Sicherung der Kontakte/Kalender wieder drauf.

    Nur ist mir aufgefallen, dass Swype fehlt!
    Ich habe die apk über https://beta.swype.com/android/get/ downgeloadet und installiert, aber die Beta hat nur englisch & spanisch :-( Hat da Jemand ne einfach Lösung parat? Ich habe auf die Schnelle keine Antwort gefunden (und nachdem ich den ganzen Tag seit 13 Uhr schon 10 Stunden am Defy hocke auch keinen Bock mehr).
     
  12. RATTAR, 16.01.2012 #12
    RATTAR

    RATTAR Gast

    Wenn du Swype installiert hast kannst du unter Einstellungen > Sprache & Tastatur >Swype-Einstellungen > Sprachoptionen weitere Sprachpakete downloaden
     

Diese Seite empfehlen