[HILFE] HTc Desire debuggen

Dieses Thema im Forum "Android App Entwicklung" wurde erstellt von pemko, 29.09.2010.

  1. pemko, 29.09.2010 #1
    pemko

    pemko Threadstarter Erfahrener Benutzer

    Beiträge:
    166
    Erhaltene Danke:
    3
    Registriert seit:
    26.08.2010
    Phone:
    Sony Xperia Z1 Compact
    Weiss hier jemand wie ich mit einem Handy den Debugger aufrufen kann?

    App geht und schreibt auch auf den Logcat vom Handy aus, aber ich kann nicht debuggen
     
  2. enrem, 29.09.2010 #2
    enrem

    enrem Erfahrener Benutzer

    Beiträge:
    188
    Erhaltene Danke:
    13
    Registriert seit:
    17.01.2010
    Hast du im Handy unter Einstellungen, Anwendungen, Entwicklung, USB-Debugging aktiviert?
     
    Zuletzt bearbeitet: 29.09.2010
  3. pemko, 29.09.2010 #3
    pemko

    pemko Threadstarter Erfahrener Benutzer

    Beiträge:
    166
    Erhaltene Danke:
    3
    Registriert seit:
    26.08.2010
    Phone:
    Sony Xperia Z1 Compact
    hehe hätte schwören können das es aktiviert ist... gibt es eine entwicklungsfaq? wäre ein kandidat dafür ^^

    *kopf-gegen-wand-schlag*
     
  4. pemko, 29.09.2010 #4
    pemko

    pemko Threadstarter Erfahrener Benutzer

    Beiträge:
    166
    Erhaltene Danke:
    3
    Registriert seit:
    26.08.2010
    Phone:
    Sony Xperia Z1 Compact
    geht trotzdem nicht :(
     
  5. enrem, 29.09.2010 #5
    enrem

    enrem Erfahrener Benutzer

    Beiträge:
    188
    Erhaltene Danke:
    13
    Registriert seit:
    17.01.2010
  6. enrem, 29.09.2010 #6
    enrem

    enrem Erfahrener Benutzer

    Beiträge:
    188
    Erhaltene Danke:
    13
    Registriert seit:
    17.01.2010
    Manchmal geht es bei mir auch nicht. Dann muss ich eclipse neu starten und das Handy booten. Ist aber eher selten.

    Versuch es trotzdem mal.

    Wie ist es mit den Treibern? Das schon gesehen?
    http://www.android-hilfe.de/android-app-entwicklung/8097-android-usb-debugging.html

    Der Link geht nicht suche hier im Forum mal nach "Android usb debugging"


     
    Zuletzt bearbeitet: 29.09.2010
  7. pemko, 29.09.2010 #7
    pemko

    pemko Threadstarter Erfahrener Benutzer

    Beiträge:
    166
    Erhaltene Danke:
    3
    Registriert seit:
    26.08.2010
    Phone:
    Sony Xperia Z1 Compact
    was hat das mit anfänger zu tun, wenn der debugger nicht geht?

    okey... boote ich mal das desire neu :)
     
  8. enrem, 29.09.2010 #8
    enrem

    enrem Erfahrener Benutzer

    Beiträge:
    188
    Erhaltene Danke:
    13
    Registriert seit:
    17.01.2010
    Dachte du suchst im allgemeinen was für Anfänger...

    Das habe ich falsch verstanden. Nee debuggen tun auch die Profis :razz:
     
  9. pemko, 29.09.2010 #9
    pemko

    pemko Threadstarter Erfahrener Benutzer

    Beiträge:
    166
    Erhaltene Danke:
    3
    Registriert seit:
    26.08.2010
    Phone:
    Sony Xperia Z1 Compact
    ja sollte nach 4 jahren lehre zu den halbprofis gehören ;-)
    und jetzt seit paar monaten an android ;-) die faq wäre mehr für hier gedacht dass so blödel fragen, wo die lösung theoretisch ienfach wäre abgehandelt werden können :)

    naja habe desire neugestartet und auch eclipse, aber will irgendwie nicht, naja egal syso tuts auch für dies problem
     
  10. Fr4gg0r, 29.09.2010 #10
    Fr4gg0r

    Fr4gg0r App-Anbieter (Werbung)

    Beiträge:
    2,506
    Erhaltene Danke:
    447
    Registriert seit:
    21.12.2009
    bist du verantwortlich für die Schnipsel Wiki?
    Wenn ja, wäre es schön, wenn du dafür sorgen könntest, dass die Textgröße in den Codefeldern nicht viel kleiner als der restliche Text ist.
     
  11. BenOtto, 30.09.2010 #11
    BenOtto

    BenOtto Android-Hilfe.de Mitglied

    Beiträge:
    141
    Erhaltene Danke:
    15
    Registriert seit:
    30.08.2010
    Guck mal was die Console sagt. Meistens stehen da Fehlermeldungen wie bspw.

    Device '#######' requires that applications explicitely declare themselves as debuggable in their manifest.

    Genau das könnte bei dir das Problem sein. Füge mal im application-Tag das Attribut debuggable="true" hinzu.
     
  12. pemko, 30.09.2010 #12
    pemko

    pemko Threadstarter Erfahrener Benutzer

    Beiträge:
    166
    Erhaltene Danke:
    3
    Registriert seit:
    26.08.2010
    Phone:
    Sony Xperia Z1 Compact
    werde ich mal hinzufügen, melde mich heute abend wieder... danke
     

Diese Seite empfehlen