1. Nimm jetzt an unserem 2. ADVENT-Gewinnspiel teil - Alle Informationen findest Du hier!

[How-To] MM/Saturn Geräte - offizielle Firmware flashen - Anleitung für Newbies

Dieses Thema im Forum "Anleitungen für Galaxy Nexus" wurde erstellt von KlausWuschel, 13.12.2011.

  1. KlausWuschel, 13.12.2011 #1
    KlausWuschel

    KlausWuschel Threadstarter Fortgeschrittenes Mitglied

    Beiträge:
    364
    Erhaltene Danke:
    50
    Registriert seit:
    14.09.2010
    Tablet:
    Nexus 7 (2013)
    Hallo Leute,

    da Samsung bei der ersten Charge scheinbar eine falsch signierte Version geflasht hat, gehen bei einigen die GAPPS-Updates nicht. Betroffen sind nur die Geräte mit der Build-Nummer: ITL41F.I9250XWKK8.
    siehe dazu folgender Link: http://www.android-hilfe.de/galaxy-nexus-forum/172493-updatefehler-google-apps.html
    Da einige große Probleme haben die original ITL41F von Google zu flashen, habe ich einfach mal eine Anleitung, die für jeden verständlich sein sollte, geschrieben.
    Vornweg, ihr könnt euer Telefon dabei zerstören. Ich oder die Community übernimmt keinerlei Haftung für eventuelle Schäden am Gerät.

    Das wird benötigt:
    ITL41F von Google – gibt’s hier: https://dl.google.com/dl/android/aosp/yakju-itl41f-factory-192e5c67.tgz
    PDAnet Treiber – gibt’s hier: Download PdaNet
    SDK Tools – gibt’s hier: http://dl.dropbox.com/u/20471345/SUroot/Tools/PC/sdktools-toolsonly.rar
    Ein offener Bootloader (die betroffenen Geräte haben den aber von Hause aus)

    Los geht’s:

    1. SDK Tools entpacken (z.B. nach D:\SDK-Tools\)
    2. ITL41F in das Verzeichnis “tools” im SDK-Tools Ordner entpacken (die Imagedateien aus dem ITL41F-Archiv müssen im gleichen Ordner liegen, wie die fastboot.exe)
    3. PDAnet installieren (wegen des korrekten Treibers des GN, kann danach wieder deinstalliert werden – aber nicht die Treiber :D)
    4. GN im Fastboot-Modus starten (Volume up + Volume down + Power-Taste gedrückt halten)
    5. GN mit dem PC/Notebook verbinden (ACHTUNG: Dabei versucht Win7 erneut den Treiber über Windows Update zu laden und überschreibt den richtigen Treiber. Unten rechts, neben der Uhr, läuft der Hardware-Assistent durch. Diesen dabei unbedingt abbrechen.)
    6. Startet am PC eine Kommandozeile (Start – Ausführen – cmd – Enter oder Windows-Taste + R – cmd – Enter)
    7. Wechselt in den Ordner Tools des SDK-Tools Ordners
    8. Nun geht es ans flashen, nur keine Angst
    9. fastboot flash bootloader bootloader-maguro-primekj10.img
    10. fastboot reboot-bootloader
    11. fastboot flash radio radio-maguro-i9250xxkk1.img
    12. fastboot reboot-bootloader
    13. fastboot -w update image-yakju-itl41f.zip

    Geschafft, euer Telefon bootet nun neu und ihr habt die offizielle Google ITL41F drauf und könnt wieder GAPPS Updates machen.
    Wenn noch Fragen auftreten, einfach hier stellen.

    Ich hoffe ich konnte einigen damit die Scheu des Flashvorgangs nehmen.

    Diese Anleitung funktioniert auch mit der neuen Version 4.0.2. Dafür muss bei den Punkten 9, 11 und 13 nur der Dateiname angepasst werden.

    Hier gibt es immer die neuen Versionen: http://code.google.com/intl/de-DE/android/nexus/images.html

    Sollte euer Bootloader noch zu sein, müsst ihr diesen mit folgendem Befehl unlocken:

    fastboot oem unlock



    MfG Klaus
     
    Zuletzt bearbeitet: 20.12.2011
    Nudelsieb, KaRa2, Luigi_Tirol und 13 andere haben sich bedankt.
  2. masch1, 13.12.2011 #2
    masch1

    masch1 Junior Mitglied

    Beiträge:
    35
    Erhaltene Danke:
    4
    Registriert seit:
    13.12.2011
    Ist in der Firmware der Volume-Bug behoben?
     
  3. KlausWuschel, 13.12.2011 #3
    KlausWuschel

    KlausWuschel Threadstarter Fortgeschrittenes Mitglied

    Beiträge:
    364
    Erhaltene Danke:
    50
    Registriert seit:
    14.09.2010
    Tablet:
    Nexus 7 (2013)
    Ja ist er.

    MfG Klaus
     
  4. Brausepaul, 13.12.2011 #4
    Brausepaul

    Brausepaul Erfahrener Benutzer

    Beiträge:
    233
    Erhaltene Danke:
    4
    Registriert seit:
    14.12.2010
    Gehen dabei Apps und Einstellungen verloren?
     
  5. KlausWuschel, 14.12.2011 #5
    KlausWuschel

    KlausWuschel Threadstarter Fortgeschrittenes Mitglied

    Beiträge:
    364
    Erhaltene Danke:
    50
    Registriert seit:
    14.09.2010
    Tablet:
    Nexus 7 (2013)
    Ja, das Gerät ist danach auf Werkszustand.
     
  6. Brausepaul, 14.12.2011 #6
    Brausepaul

    Brausepaul Erfahrener Benutzer

    Beiträge:
    233
    Erhaltene Danke:
    4
    Registriert seit:
    14.12.2010
    Ich habe eine Frage zu 3 und 4: bei 3 bin ich an einem Punkt, bei dem ich das USB-Debugging einschalten (gemacht) und das Handy mit dem PC verbinden soll. Nach dem Verbinden kommt nur eine Meldung, dass kein Android-Gerät gefunden wurde, es gab auch keine Meldung über neue Hardware am PC. Ich hatte bei der Installation die Frage nach dem Hersteller übrigens mit Samsung beantwortet, war das richtig (vorausgewählt war "others")?

    Zu 4: was heißt das genau? Es kommt dann dieser Bildschirm mit dem grünen "Start"-Schriftzug. Soll man weiter starten oder auf dem Bildschirm bleiben während man alles weitere macht?
     
  7. KlausWuschel, 14.12.2011 #7
    KlausWuschel

    KlausWuschel Threadstarter Fortgeschrittenes Mitglied

    Beiträge:
    364
    Erhaltene Danke:
    50
    Registriert seit:
    14.09.2010
    Tablet:
    Nexus 7 (2013)
    Also wegen des USB-Problems könnte dir nach der Treiberinstallation ein Reboot des PCs helfen. Oder ein anderer USB-Port. Wenn er sagt er findet kein Gerät, spricht das dafür das er keine USB-Verbindung zustande bringt und eigentlich nicht für den Treiber. Samsung auswählen war richtig.

    Genau das Telefon einfach auf diesen Bildschirm stehen lassen.
     
  8. Brausepaul, 14.12.2011 #8
    Brausepaul

    Brausepaul Erfahrener Benutzer

    Beiträge:
    233
    Erhaltene Danke:
    4
    Registriert seit:
    14.12.2010
    Es lag anscheinend am Por, aber so ganz klappt es noch nicht. Ich kann den Hardware-Assistenten von Windows 7 nicht so richtig abbrechen, er rödelt da irgendwie herum und danach bekommt PDAnet keine Verbindung zum Nexus mehr. Führe ich dann etwas an der Kommandozeile aus schlägt das fehl.
     
  9. escrivel, 14.12.2011 #9
    escrivel

    escrivel Android-Experte

    Beiträge:
    894
    Erhaltene Danke:
    293
    Registriert seit:
    23.06.2011
    Phone:
    Nexus 6
    Hab gerade erst gesehen das mein GNx auch diese Version hat. Woran merk ich das die Gapps nicht aktualisiert werden können? Wird das Update nicht angezeigt oder schlägt das Update fehl?
     
  10. KlausWuschel, 14.12.2011 #10
    KlausWuschel

    KlausWuschel Threadstarter Fortgeschrittenes Mitglied

    Beiträge:
    364
    Erhaltene Danke:
    50
    Registriert seit:
    14.09.2010
    Tablet:
    Nexus 7 (2013)

    Wenn das Symbol unten neben der Uhr kommt, drauf klicken und dann steht dort (ich glaub in blauer Schrift, habs grad nicht im Kopf) etwas mit abbrechen. Das unbedingt tun. Danach geht es.

    Wenn das nicht hilft, die automatische Treiberinstallation vorerst ausschalten:

    Arbeitsplatz -> rechte Maustaste -> Eigenschaften -> Erweiterte Systemeinstellungen -> Hardware -> Geräteinstallationseinstellungen (was ein dämliches Wort :D) -> Nein, zu installierende Software selbst auswählen

    Versuch das Update im Market zu machen. Es schlägt mit der Meldung fehl, dass die Paketdatei nicht richtig signiert ist.
     
    Zuletzt bearbeitet: 14.12.2011
  11. escrivel, 14.12.2011 #11
    escrivel

    escrivel Android-Experte

    Beiträge:
    894
    Erhaltene Danke:
    293
    Registriert seit:
    23.06.2011
    Phone:
    Nexus 6
    Was für ein Update? Bei mir wird da nix angezeigt?
     
  12. KlausWuschel, 14.12.2011 #12
    KlausWuschel

    KlausWuschel Threadstarter Fortgeschrittenes Mitglied

    Beiträge:
    364
    Erhaltene Danke:
    50
    Registriert seit:
    14.09.2010
    Tablet:
    Nexus 7 (2013)
    Einfach in den Market gehen, z.B. nach Google Maps suchen und das öffnen. Dort kannst du dann Update anklicken. Es wird dummerweise auch nicht angezeigt, dass kein Update da ist.
     
  13. escrivel, 14.12.2011 #13
    escrivel

    escrivel Android-Experte

    Beiträge:
    894
    Erhaltene Danke:
    293
    Registriert seit:
    23.06.2011
    Phone:
    Nexus 6
    Tatsache du hast recht! Wird das offiziell auch behoben per OTA? Hab ehrlich gesagt keine Lust die stock nochmal zu flashen :(
     
  14. rookie, 14.12.2011 #14
    rookie

    rookie Android-Lexikon

    Beiträge:
    1,729
    Erhaltene Danke:
    455
    Registriert seit:
    01.01.2010
    Phone:
    LG G4
    Scroll im Markt unter "Meine Apps" ganz nach unten

    Es lädt herunter, aber Installation schlägt fehl
     
  15. Brausepaul, 14.12.2011 #15
    Brausepaul

    Brausepaul Erfahrener Benutzer

    Beiträge:
    233
    Erhaltene Danke:
    4
    Registriert seit:
    14.12.2010
    So, hab mich bis zu 5. durchgefriemelt, aber jetzt habe ich ein weiteres Problem. Nach Fastboot und anschließen der USB erscheint auf dem Handy ganz unten eine Zeile in blau:"FASTBOOT STATUS - FAILinvalid id Command". PDAnet zeigt an, dass es verbunden sei. Führe ich dann den ersten Befehl auf der Konsole aus erscheint nur:

    D:\Neuer Ordner\android-sdk-windows\tools>fastboot flash bootloader bootloader-m
    aguro-primekj10.img
    sending 'bootloader' (2308 KB)... FAILED (remote: Invalid Command)
    finished. total time: 0.001s

    Danach ändert die Zeile sich in:"FASTBOOT STATUS - download:00241000"

    Nochmal den ersten Konsolenbefehl senden, dann zeigt das Handy:"FASTBOOT STATUS - OKAY" und die Konsole steht bei

    sending 'bootloader' (2308 KB)...

    ohne das etwas passiert
     
  16. KlausWuschel, 14.12.2011 #16
    KlausWuschel

    KlausWuschel Threadstarter Fortgeschrittenes Mitglied

    Beiträge:
    364
    Erhaltene Danke:
    50
    Registriert seit:
    14.09.2010
    Tablet:
    Nexus 7 (2013)
    Tja da scheiden sich die Geister. Ich denke schon, da Samsung/Google nicht davon ausgehen kann, dass alle Leute flashen. Aber da die beiden sich dazu in Schweigen hüllen, weiß niemand was genaues.

    Ich wollte es, denn mir war es wichtiger ein sauberes Google System zu haben, als irgendeinen Samsung-Murks. Und da nehm ich die 1-2h erneute Einrichtung gern in Kauf.

    @Brausepaul: Ist dein Bootloader überhaupt offen? Das erkennst du an dem leicht geöffneten, weißen Schloss beim booten.
     
  17. Brausepaul, 14.12.2011 #17
    Brausepaul

    Brausepaul Erfahrener Benutzer

    Beiträge:
    233
    Erhaltene Danke:
    4
    Registriert seit:
    14.12.2010
    Ja, das Schloss ist leicht geöffnet.
     
  18. KlausWuschel, 14.12.2011 #18
    KlausWuschel

    KlausWuschel Threadstarter Fortgeschrittenes Mitglied

    Beiträge:
    364
    Erhaltene Danke:
    50
    Registriert seit:
    14.09.2010
    Tablet:
    Nexus 7 (2013)
    Geh bitte nochmal folgendermaßen vor:

    - Telefon vom PC trennen
    - Telefon neu in den fastboot-Modus booten (solltest du aus dem bisherigen nicht rauskommen, einfach Akku raus)
    - Telefon neu verbinden
    erneut flashen
     
  19. Brausepaul, 14.12.2011 #19
    Brausepaul

    Brausepaul Erfahrener Benutzer

    Beiträge:
    233
    Erhaltene Danke:
    4
    Registriert seit:
    14.12.2010
    Habe ich gemacht, direkt nach dem Verbinden des Nexus kommt auf dem Handy die Meldung :

    "FASTBOOT STATUS - FAILinvalid id Command"
     
  20. rookie, 14.12.2011 #20
    rookie

    rookie Android-Lexikon

    Beiträge:
    1,729
    Erhaltene Danke:
    455
    Registriert seit:
    01.01.2010
    Phone:
    LG G4
    Hat zufällig jemand versucht nach dem flashen der offiziellen Firmware ein Data Restore aus einem Nandroid Backup- vorherige offizielle Version - einzuspielen?
     

Diese Seite empfehlen