1. Nimm jetzt an unserem Uhans - 3. ADVENT - Gewinnspiel teil - Alle Informationen findest Du hier!

[How-To] Reines USB-Ladekabel basteln

Dieses Thema im Forum "Zubehör für Samsung Galaxy S" wurde erstellt von wannaberoot, 03.06.2011.

  1. wannaberoot, 03.06.2011 #1
    wannaberoot

    wannaberoot Threadstarter Neuer Benutzer

    Beiträge:
    4
    Erhaltene Danke:
    15
    Registriert seit:
    27.04.2011
    Hallo, zunächst einmal danke an dieses Forum und an den Nutzer Curon für seinen Beitrag http://www.android-hilfe.de/zubehoe...3-automodus-mit-ladekabel-dockingstation.html ohne Euch hätte ich mich wohl nicht an die Lötarbeiten gewagt. Ich verfasse den eventuell redundanten Beitrag hier nur, da ich die Fotos der anderen Beiträge manchmal etwas schwer zu erkennen finde und Lötanfängern (ich bin auch einer) hier etwas Hilfestellung geben möchte.

    Das PDF im Anhang enthält die Bilder in etwas höherer Auflösung und lässt sich gut ausdrucken, um es beim Löten daneben zu legen.

    Problematik:
    Im Auto entlädt sich das Handy bei der Navigation trotz angeschlossenem USB-Kabel. Das SGS meint bei einem normalen USB-Kabel an einem USB-Port zu hängen. Von daher zieht es max. 500mA für den Ladevorgang. Der Adapter im Zigarettenanzünder liefert allerdings mehr (bei mir sind es 700mA).


    Lösung:
    Das Kabel modifizieren. Laut USB-Standard gibt sich ein dediziertes Ladegerät durch einen Widerstand von unter 200 Ohm zwischen den Datenleitungen D+ und D- zu erkennen (siehe Kapitel 4.4.3 im USB.org - Approved Device Class Document Download). Man könnte jetzt einfach D+ und D- kurzschließen oder sicherheitshalber einen 100 Ohm Widerstand dazwischen anbringen (das machen wir).


    Einige schneiden nun den Micro USB-Stecker ab und löten einen Widerstand sowie + und - direkt an einen neuen Stecker an. Ich habe mich dagegen entschieden, da zum einen die Stecker, die ich mir bei Conrad bestellt hatte, alle (4 verschiedene) sehr schwergängig waren (ich dachte beim Einstecken ich komme gleich durch das Gehäuse meines SGS unten wieder raus) und ich zum anderen das Löten an einem abisolierten Kabel einfacher finde, als an einem der Mini-Pins des Steckers rumzufummeln.



    Benötigt werden:

    • Seitenschneider
    • Teppichmesser
    • Schrumpfschlauchset (z.B. von Conrad (Best-Nr. 607754) 1.33 €)
    • Plastikröhrchen (zur Stabilitätsverbesserung, z.B. von einem Filzstift, Kugelschreiber o.ä.)
    • Lötkolben (Meiner ist ein 6.99 € Lötkolben vom Discounter und wurde hier zum ersten Mal benutzt. Bin also wirklich Anfänger. Keine Angst, das schafft jeder, der nicht zu zitterige Hände hat).
    • Micro USB-Kabel (Ich habs in der Bucht für 1.79 € bestellt.)
    • 100 Ohm Widerstand (z.B. von Conrad (Best-Nr. 423246) 0.51 €)
    Zunächst einmal trennen wir das Kabel mit dem Seitenschneider auf (Nicht direkt hinter dem Stecker, eher in der Mitte. Dann hängt die Lötstelle im Auto gerade herunter.). [​IMG]

    Kurz etwas zu den Adern in den Kabeln. Rot=+5V, Schwarz=Masse, Grün=Daten+, Weiß=Daten-

    Achtung!
    Wenn sich der Kabelhersteller nicht an den Standard hält, kann es für Euer SGS gefährlich werden. Bitte überprüft das ev. mit einem Multimeter. Pin Belegung im Stecker A findet Ihr z.B. bei Universal Serial Bus ? Wikipedia

    Auf der Seite des USB-Steckers Typ A können wir D+/D- kürzen und z.B. mit Klebstoff oder Heißklebepistole isolieren. Auf der Seite des Micro USB-Steckers wird später der Widerstand angelötet.

    [​IMG] [​IMG]

    Schiebt jetzt schon mal die Schrumpfschläuche verschiedener Dicke und das Plastikröhrchen auf eins der Kabelenden. Nachher geht das nicht mehr :huh:
    [​IMG]

    Nehmt jetzt das Stück mit dem Micro USB-Stecker und gebt etwas Lötzinn auf die abisolierten D+/D- Kabel. Den Draht vom Widerstand mit dem Seitenschneider kürzen und erstmal an einem Ende anlöten, dann z.B. mit Tesa isolieren, das andere Bein umbiegen und ebenfalls anlöten. Zum Abschluss ein Stück Schrumpfschlauch drüber und mit dem Feuerzeug (nicht zu lange dranhalten) einschrumpfen.

    [​IMG] [​IMG] [​IMG]

    Jetzt können 5V und Masse wieder verbunden werden. Entweder isoliert Ihr jedes einzeln nach dem Löten wieder mit Tesa oder macht wie ich ein Stück Schrumpfschlauch vor dem Löten auf eines der Enden und schrumpft nachher ein (Ja, bei 5V habe ich es vergessen und habe dann auch Tesa genommen).

    [​IMG]

    Jetzt schieben wir Stück für Stück unsere vorher aufgeschobenen Schrumpfschläuche (und das Platiskröhrchen) über unsere Lötstelle und schrumpfen alles mit dem Feuerzeug ein. Das Plastikröhrchen sollte stramm auf dem ummantelten Kabel sitzen. Es schützt vor Bruch der Lötstellen und wenn noch ein Stück Schrumpfschlauch drüberkommt, habt ihr eine super Zugentlastung.

    [​IMG] [​IMG]

    Jetzt kommt der große Moment. Kabel an das Ladegerät und ans SGS. Ladestatus prüfen (Entweder über Einstellungen->Telefoninfo->Status, dann steht bei Akkustatus Laden(AC) oder über irgendeine Systemapp, die das kann (ich habe den OSMonitor genommen).

    [​IMG]

    Viel Spaß beim Basteln.

    Ich übernehme selbstverständlich keine Garantie für Eure Lötarbeiten. Wer also falsch Lötet, schlecht Isoliert o.ä. und sich sein SGS schrottet, ist selber schuld. Ich habe das hier alles nach bestem Wissen und Gewissen aufgeschrieben und hoffe es hilft Euch.

    wannaberoot

    PS:
    Auf die gleiche Art und Weise kann man sich auch das Autodock Kabel löten. Dann muss statt des 100 Ohm Widerstandes ein 620 kOhm Widerstand genommen werden (Conrad Best.-Nr. 421073).

    Oder man baut sich einen Download Mode Stecker. Hier einfach das Kabel mit dem Micro USB-Stecker abschneiden, Stecker Typ A wegwerfen, 5V und Masse isolieren und zwischen D+/D- (Grün/Weiß) einen 301 kOhm Widerstand (Conrad Best.-Nr. 421871) löten). Damit kann man das SGS auch im gebrickten Zustand so gut wie immer in den Download Modus bringen (Danke auch hier an Curon für seinen Post http://www.android-hilfe.de/anleitungen-fuer-samsung-galaxy-s/55922-download-mode-nach-brick.html
     

    Anhänge:

    blue8, Peter Griffin, Mais und 11 andere haben sich bedankt.
  2. omega333, 01.03.2012 #2
    omega333

    omega333 Neuer Benutzer

    Beiträge:
    2
    Erhaltene Danke:
    0
    Registriert seit:
    15.02.2012
    Habe ich heute probiert für ein GT I8150(Galaxy W).
    Funktioniert am Zigarettenanzünder-USB. Bringt 1000mA - ich denke mal das reicht für das W. Gibt auch Adapter die über 2000mA Leistung abgeben.
    Vielen Dank für die Anleitung. Und immer daran denken-der Widerstand gehört in Richtung Handy, also zum Micro-USB!
     
  3. sirnoname, 08.04.2012 #3
    sirnoname

    sirnoname Android-Hilfe.de Mitglied

    Beiträge:
    112
    Erhaltene Danke:
    23
    Registriert seit:
    11.08.2011
    Hi, sehr schöne Anleitung.
    Habe das Problem das ich nichts über das Thema gefunden hatte.
    Zum Spass habe ich mal alle meine Ladegeräte für 220V auf diesen Trick untersucht. Alle haben (LG, Simvalley, Huwei) zwischn D+ und D- einen 0 Ohm Wiederstand.
    Das mit 100Ohm erscheint mir daher etwas riskannt, da die Entwickler der Firmen schliesslich mit 0 Ohm die Elektronik aufgebaut haben.

    Grüße
    SirNoName
     
  4. wannaberoot, 10.04.2012 #4
    wannaberoot

    wannaberoot Threadstarter Neuer Benutzer

    Beiträge:
    4
    Erhaltene Danke:
    15
    Registriert seit:
    27.04.2011
    Hallo,
    riskant ist der 100Ohm Widerstand in keiner Weise. Laut Spezifikation muss ein reines Ladegerät einen Widerstand zwischen D+ und D- von unter 200Ohm haben. Ich habe den 100Ohm Widerstand also nur als Sicherheit vorgeschlagen. Man kann den auch weglassen (entspricht dann immer noch der Spezifikation). Ich bin aber kein Freund von Kurzschlüssen, daher der 100Ohm Widerstand. :D
     
    ChrisKey bedankt sich.
  5. nopaga, 22.04.2012 #5
    nopaga

    nopaga Erfahrener Benutzer

    Beiträge:
    153
    Erhaltene Danke:
    7
    Registriert seit:
    17.01.2011
    Phone:
    Moto G 2015
    was würde passieren, wenn man das umgelötete Usb Kabel nun an seinen PC Usb Anschluss hängt, um sein Handy von dort aus zu laden?

    Würde das Handy dann mehr als 500mA anfordern und den USB Port zerstören oder regelt das im Notfall die USB Buchse des PCs?
     
  6. sirnoname, 22.04.2012 #6
    sirnoname

    sirnoname Android-Hilfe.de Mitglied

    Beiträge:
    112
    Erhaltene Danke:
    23
    Registriert seit:
    11.08.2011
    Es würde mehr laden, dann würde dein PC sagen "Overcurrent an Port xy". Wenn er nix sagt, dann ist dein Board ein Billigboard aus China das keine USB Norm einhällt.
     
    nopaga bedankt sich.
  7. nopaga, 22.04.2012 #7
    nopaga

    nopaga Erfahrener Benutzer

    Beiträge:
    153
    Erhaltene Danke:
    7
    Registriert seit:
    17.01.2011
    Phone:
    Moto G 2015
    oh also besser nicht mit diesem kabel an den pc hängen ^^ schon jemand ausprobiert?
     
  8. wannaberoot, 03.05.2012 #8
    wannaberoot

    wannaberoot Threadstarter Neuer Benutzer

    Beiträge:
    4
    Erhaltene Danke:
    15
    Registriert seit:
    27.04.2011
    In der Regel passiert nichts, da der USB Port dann vom Controller abgeschaltet wird (siehe "Overcurrent an Port XY" Antwort von sirnoname).
    Mir persönlich ist noch kein Billigboard untergekommen, welches den Port nicht abschaltet, was aber nicht heißt, dass es das nicht gibt.

    Allerdings ist das Kabel ja auch nicht dafür gedacht, sondern für einen Anschluss an ein Netzteil oder den Zigarettenanzünder im Auto. :smile:
     
  9. dstockm, 01.07.2012 #9
    dstockm

    dstockm Neuer Benutzer

    Beiträge:
    2
    Erhaltene Danke:
    1
    Registriert seit:
    06.11.2010
    Nicht ganz:
    Für die echte Car Dock-Erkennung muss der 619k Widerstand aber zwischen die Pins 4 und 5 (und Pin 4 fehlt bei fast allen Kabeln).
    Die Datenleitungen sind die Pins 2 und 3. In Bezug auf den Ladestrom haben beide Varianten den gleichen Effekt, aber das Handy erkennt den Automodus nicht.

    Gruß
     
    Tim Sasdrich bedankt sich.
  10. wannaberoot, 19.07.2012 #10
    wannaberoot

    wannaberoot Threadstarter Neuer Benutzer

    Beiträge:
    4
    Erhaltene Danke:
    15
    Registriert seit:
    27.04.2011
    Alles klar, danke für den Hinweis. Da muss ich wohl das HowTo noch mal anpassen. Leider habe ich keine Fotos für ein Kabel mit Verbindung von PIN 4 und 5 aber den Zusatz nehme ich auf.
     
  11. edlover, 06.12.2012 #11
    edlover

    edlover Android-Guru

    Beiträge:
    2,639
    Erhaltene Danke:
    514
    Registriert seit:
    07.02.2011
    Funktioniert super!!!!!

    Man kann das Kabel dann nur nicht mehr als Datenkabel nehmen!!!
    Besser wäre es die Brücke im Ladegerät (mit USB Buchse) zu machen.
    So ist es auch bei meinem Note II Ladegarät.
    Dann kann man das Kabel für beides nutzen (wenn man ein voll belegtes hat).
    Mein 0815 Kabel (was ich jetzt auch umgelötet habe am Stecker) waren die Datenleitungen garnicht erst aufgelegt :thumbdn:
     
  12. Mustang80, 10.12.2012 #12
    Mustang80

    Mustang80 Erfahrener Benutzer

    Beiträge:
    233
    Erhaltene Danke:
    16
    Registriert seit:
    20.04.2011
    Habe mein Galaxy S auf induktives Laden vom Palm Pre umgebaut und dafür benötigt man auch ein reines Ladekabel.

    Das habe ich nun dank dem Tut hier gebaut. Das Ganze mit einem USB Y-Adapter (-> 1A) an den PC angeschlossen - funktioniert super. Das Ganze reicht dann locker für die Versorgung aus, denn das Original Samung Netzteil liefert nur 0,7A.

    Man sollte dann aber Fast Charge deaktivieren, sofern einstellbar!
     
  13. cappy0815, 14.12.2012 #13
    cappy0815

    cappy0815 Android-Experte

    Beiträge:
    509
    Erhaltene Danke:
    47
    Registriert seit:
    27.02.2011
    Phone:
    Xiaomi Redmi Note 3 pro (KENZO)
    Tablet:
    Asus Memo Pad FHD 10
    Wearable:
    Fossil Q Founder FTW20012
    Tach zusammen,

    ich habe folgendes Szenario:

    Mein Steckernetzteil (mit USB-Port) kann laut Aufschrift 1A bei 5V
    Nachgemessen gibt es auch 5V (5,1V) ab.
    Während des Ladens mag sich das Tel, aber nur gut 100mA nehmen.
    In den Einstellungen eines TWEAKers habe ich den Ladestrom in allen Situationen (Netz, Laptop, Andere) auf 650mA eingestellt. OSmonitor sagt USBpower ONline

    Wenn ich nun per LaborNetzteil die Spannung auf 6V (mehr traue ich mich nicht) schraube, lande ich bei etwa 200mA

    Nunhabe ich Daten +&- (gn und ws) mittels R100 verbunden.

    OSmonitor zeigt mir eine Lade-Verbindung AC an ... der Strom ist aber sogar nur bei 40mA (5V)
    Drehe ich wieder auf 6V werden wieder ~200mA gezogen!?

    Mein USB -> MicroUSB-Kabel hat keinen Widerstand auf den Datenleitungen. Also elektrisch ausgedrückt natürlich unendlich.

    Bahnhof.

    Cappy

    Der ursprüngliche Beitrag von 11:35 Uhr wurde um 11:51 Uhr ergänzt:

    Des weiteren Stelle ich gerade fest, daß mir ein WIDGET und eine APP jeweils einen Ladestrom von 300mA anzeigen ... das stimmt definitv nicht.

    Auf derartige Apps ist also offensichtlich kein Verlass
     
    Zuletzt bearbeitet: 14.12.2012
  14. edlover, 14.12.2012 #14
    edlover

    edlover Android-Guru

    Beiträge:
    2,639
    Erhaltene Danke:
    514
    Registriert seit:
    07.02.2011
    Ich versteh auch nur Bahnhof *Spaß* ;)

    Also 1. keinen Widerstand auf den Datenleitungen???
    Da solltest du aber die 100Ohm haben die du dazwischen gelötet hast..oder versteh ich was falsch.. Also erstmal müsste es richtig sein wenn dein Handy beim Laden AC anzeigt )kenne allerdings deine APP nicht).

    Des weiteren...wie voll war dein Akku bei den Tests???
    40ma...200ma...könnte alles richtig sein WENN dein Akku fast voll war...da die Ladekurve eine LioAkkus zum Ende hin abflacht...Heisst wenn du diese Tests bei 95% vollen AKku oder so gemacht hast,kann das möglich sein...
    AM besten testen wenn er unter 30...oder gar 20% ist...
    Da müsste er bei 1A Ladegerät um die 600-700ma nehmen wenn du nix weiter am Handy machst (Zocken etc)...

    Und mit den 6V vorsichtig....ist eig nicht so toll....
    Ausserdem regelt dann die Ladeelektronik meines wissens sowieso runter bis die SPannung stimmt und drosselt dabei auch die mA-Werte...
    Hier mein Screenshot mit 1A Ladegerät und gebrückten D+ und D-.
    Da siehst du wie er bei ca 700ma anfängt (Akku ca 25% glaub ich) und zum Ende hin (also wenn Akku voller wird) abflacht...
    Da wo er dann zum Ende in Minusbereich geht,hatte ich Netzteil schon abgezogen!!!
     

    Anhänge:

    Zuletzt bearbeitet: 14.12.2012
  15. cappy0815, 15.12.2012 #15
    cappy0815

    cappy0815 Android-Experte

    Beiträge:
    509
    Erhaltene Danke:
    47
    Registriert seit:
    27.02.2011
    Phone:
    Xiaomi Redmi Note 3 pro (KENZO)
    Tablet:
    Asus Memo Pad FHD 10
    Wearable:
    Fossil Q Founder FTW20012
    Moin,

    danke für die Antwort.

    Ja und nein ... etwas blöde ausgedrückt, ich gebe es ja zu.
    Mein Ladekabel habe ich nicht zerschnitten. Daher ist dort kein Widerstand zu messen. Also ... natürlich elektrisch gesehen schon, nämlich unendlich hoch.
    Damit will ich nur sagen, daß gn und ws 1zu1 vom USB zum mikro-usb verdrahtet sind. Den Widerstand hatte ich ein zerlegtes USB-Slotblech-Adapter von einem PC eingelötet. War auch im hinblick auf das Labornetzteil einfacher
    Nein ... im Gegenteil der Akku war unter 20% und gezockt oder sonstiges habe ich auch nicht.
    Hätte auch einen Festspannungsregler oder eine Strombegrenzer erwartet.
    Mehr als 6V habe ich mich auch wie gesagt nicht getraut.

    Ich werde bei gelegenheit auch mal einen screenshot machen.
    Inzwischen tippe ich, daß irgendwas am USB-Ladekabel faul ist.
    Zu Hause am Steckerladegerät ging es deutlich schneller ...

    Cappy
     
  16. edlover, 15.12.2012 #16
    edlover

    edlover Android-Guru

    Beiträge:
    2,639
    Erhaltene Danke:
    514
    Registriert seit:
    07.02.2011
    Wenn du das Kabel nicht zerlegen willst musst du es in Netzteil Brücken. So müsste es auch im originalem Netzteil sein. Ps. Wenn das Kabel zu lang ist lädt es auch sehr langsam. Irgendwo habe ich mal eine Tabelle gesehen. War auch sehr überrascht wie die Spannung abfällt pro zusätzliche zehn Zentimeter. Daran hapert es bei mir auch noch. Möchte gern ein längeres Kabel. Aber das ist wohl der Grund warum die immer so kurz sind.
     
  17. cappy0815, 15.12.2012 #17
    cappy0815

    cappy0815 Android-Experte

    Beiträge:
    509
    Erhaltene Danke:
    47
    Registriert seit:
    27.02.2011
    Phone:
    Xiaomi Redmi Note 3 pro (KENZO)
    Tablet:
    Asus Memo Pad FHD 10
    Wearable:
    Fossil Q Founder FTW20012
    Mahlzeit,

    vielleicht muss ich es doch nochmal erklären:

    Ich habe einen Adapter. Auf der einen Seite ist eine USB-Buchse.
    Auf der anderen Seite gehe ich per Fliegenbein an rt und sw als Spannungsversorgung.
    gn und ws sind mit 100 Ohm gebrückt.
    In die USB-Buchse-Seite stecke ich mein USB-microUSB-Kabel, welches dann wiederum im Tel steckt.

    Zum Thema Kabellänge wäre zu sagen, daß man ja theoretisch ausrechnen könte wie hoch der Spannungsfall bei 5V und xA auf der Kabellänge ist.

    Da ich aber eh auf 6V hochgedreht habe, wird es daran nicht liegen.

    Wie gesagt, ich schätze, daß mein USB-microUSB-Kabel irgendwie dran schuld ist.WIE, weiß ich noch nicht.

    Cappy
     
  18. flyyy, 22.01.2013 #18
    flyyy

    flyyy Android-Experte

    Beiträge:
    787
    Erhaltene Danke:
    52
    Registriert seit:
    09.06.2011
    Gibt es keine Kabel bei denen D+/D- direkt beim Kauf verbunden ist? Gibt es vielleicht Zwischenstecker? Oder darf so etwas nicht verkauft werden?

    Ich habe hier zwei USB-Netzteile, die nur 500mA liefern. Angenommen ich würde ein Galaxy Nexus mit so einem Kabel an ein solches NT anschließen, würde es sich mehr als die 500mA genehmigen (obwohl das natürlich eigentlich nicht gut wäre)?

    Würden sich alle Geräte, die mit so einem Ladekabel an ein Netzteil angeschlossen werden, ihren vollen Ladestrom gönnen? Auch zB Tablets, die mit 2A laden?
    Ich habe ein 4-fach-USB-Lader, der pro Buchse bis zu 2A liefern soll. Alle Handys laden daran langsam, mein Nexus lädt sogar überhaupt nicht.
    Eigentlich sollte bei so einem USB-Lader D+/D- doch im Gerät schon verbunden sein?
     
  19. sirnoname, 23.01.2013 #19
    sirnoname

    sirnoname Android-Hilfe.de Mitglied

    Beiträge:
    112
    Erhaltene Danke:
    23
    Registriert seit:
    11.08.2011
    Bis jetzt wwaren alle meine Kabel verbunden.
     
  20. Mustang80, 23.01.2013 #20
    Mustang80

    Mustang80 Erfahrener Benutzer

    Beiträge:
    233
    Erhaltene Danke:
    16
    Registriert seit:
    20.04.2011
    @flyyy: Wenn dein Netzteil nicht mehr als 500 mA hergibt, ist so ein reines Ladekabel auch Schwachsinn. Damit überlastest du nur das Netzteil. Wenn es gut ist, schaltet es sicherheitshalber ab, ansonsten raucht es ab.

    Ich habe mein reines USB Ladekabel am PC angeschlossen und lade damit mein Nexus, wenn der PC eh läuft. Dort hängt es an einem USB 3 Port, der bis zu 900 mA abdrückt.
     

Diese Seite empfehlen

Besucher kamen mit folgenden Begriffen auf unsere Seite:

  1. usb belegung ladekabel

    ,
  2. usb-ladekabel pinbelegung

    ,
  3. usb kabel an netzteil löten

    ,
  4. nur ladekabel usb auf mini usb,
  5. 2 adern kabel auf usb buchse,
  6. ladekabel am tablet löten,
  7. usb auf micro usb verdrahten,
  8. samsung galaxy usb belegung,
  9. usb netzteil zum löten,
  10. handyladekabel usb aufbau